TDSHT3
HDMI Compliance Test Software

Online Help

OO Tektronix
077-0024-06 /s






TDSHT3
HDMI Compliance Test Software

Online Help

www.tektronix.com
077-0024-06

Tektron/ix



Copyright © Tektronix. All rights reserved. Licensed software products are owned by Tektronix or its
subsidiaries or suppliers, and are protected by national copyright laws and international treaty provisions.

Tektronix products are covered by U.S. and foreign patents, issued and pending. Information in this
publication supersedes that in all previously published material. Specifications and price change privileges
reserved.

TEKTRONIX and TEK are registered trademarks of Tektronix, Inc.
MATLAB®. Copyright 1984 - 2007 The MathWorks, Inc.
TDSHT3 HDMI Compliance Test Software Online Help Part Number, 076-0062-06

Contacting Tektronix
Tektronix, Inc.

14150 SW Karl Braun Drive
P.O. Box 500

Beaverton, OR 97077

USA

For product information, sales, service, and technical support:
= In North America, call 1-800-833-9200.
= Worldwide, visit www.tektronix.com to find contacts in your area.



http://www.tektronix.com/contact

Warranty
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Introduction TDSHT3 HDMI Compliance Test Software

TDSHT3 HDMI Compliance Test Software

TDSHT3

HOMI Compliance
Test Software (1.4)

Copyright® Tebtronix, Inc. Al rights
reserved. TEKTROME and TEK are
registered trademades of Tektronix Inc.

The TDSHT3 HDMI Compliance Test Software is a High Definition Multimedia Interface (HDMI)
compliance test solution. This software helps the test, validation, and design engineers perform both
HDMI physical layer validation and compliance testing. The TDSHT3 HDMI Compliance Test Software
provides credible test results in conformance with the HDMI standards and test specifications.

TDSHT3 HDMI Compliance Test Software Online Help 1



Introduction

TDSHT3 HDMI Compliance Test Software

The TDSHT3 HDMI Compliance Test Software offers automated tests for:

Source

Differential Tests

Eye Diagram (see page 202) (Test ID 7-10)

Duty Cycle (see page 208) (Test ID 7-8)

Rise Time (see page 212) (Test ID 7-4)

Fall Time (see page 216) (Test ID 7-4)

Clock litter (see page 221) (Test ID 7-9)

Inter-Pair Skew (see page 228) (Test ID 7-6)

Single-Ended Tests

Intra-Pair Skew (see page 238) (Test ID 7-7)

Low Amplitude + (see page 242) (Test ID 7-2)

Low Amplitude - (see page 245) (Test ID 7-2)

TDSHT3 HDMI Compliance Test Software Online Help



Introduction

Sink

TDSHT3 HDMI Compliance Test Software

B Differential Tests

Min/Max-Diff Swing Tolerance (see page 248) (Test ID 8-5)

Jitter Tolerance (see page 256) (Test ID 8-7)

Deep Color (see page 268) (Test ID 8-25)

Audio Clock Regeneration (see page 273) (Test ID 8-21)

Audio Sample Packet Jitter (see page 279) (Test ID 8-22)

Audio Formats (see page 284) (Test ID 8-23)

One Bit Audio (see page 290) (Test ID 8-28)

DVI Interoperability (see page 296) (Test ID 8-24)

3D Video (see page 302) (Test ID 8-29)

4Kx2K Video (see page 308) (Test ID 8-30)

Extended Colors and Contents (see page 313) (Test ID 8-31)

®  Single-Ended Tests

Cable

Intra-Pair Skew (see page 319) (Test ID 8-6)

®  Differential Tests

Eye Diagram (see page 327) (Test ID 5-3)

Inter-Pair Skew (see page 339) (Test ID 5-5)

NOTE. This Cable Inter-Pair Skew test is performed only for repeater cable testing.

The software offers automatic “one-button” testing that ensures faster validation with higher reliability and
it supports only single-link HDMI device resolutions.

See Also

B (see page 7)Compatibility
H  (see page 9)Requirements and Restrictions

TDSHT3 HDMI Compliance Test Software Online Help 3



Introduction Conventions

®  (see page 7)Recommended Accessories

Conventions

The online help system serves as a reference on how to use the TDSHT3 HDMI Compliance Test Software.

The term “Exit” refers to exiting the application and not the oscilloscope unless otherwise stated.
The waveforms used are representative and change for different settings and resolutions.
The TDSHT3 HDMI Compliance Test Software is referred to as TDSHT3 software.

The screens used are representative and may not match exactly with what you see. However, the
functionality of the software is as described.

TDSHT3 HDMI Compliance Test Software Online Help



Introduction Feedback

Feedback

Tektronix values your feedback on our products. To help us serve you better, please send us your
suggestions, ideas, or comments on the TDSHT3 software.

Direct your feedback via e-mail to HDMIFeedback@tek.com or FAX at (503) 627-5695 and include the
following information:

General Information

®  [nstrument model number and hardware options, if any

B Probes used

B Your name, company, mailing address, phone number, FAX number, e-mail id

m  Please indicate if you would like to be contacted by Tektronix about your suggestions or comments

Program-Specific Information
B Software version number
m  Description of the problem such that technical support can duplicate the problem

B The instrument setup file of the oscilloscope and the application are also required to identify the
problem

B [fpossible, save the waveform on which you are performing the test as a .wfm file

NOTE. To find the software version number, click Help > About in the software.

Once you have gathered this information, you can contact technical support by e-mail. When you use
e-mail, be sure to type in the subject line “TDSHT3 HDMI Compliance Test Software Problem,” and then
attach the .wfm files.

TDSHT3 HDMI Compliance Test Software Online Help 5
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Getting Started Compatibility

Compatibility

For information on oscilloscope compatibility, refer to the Optional Applications Software on
Windows-Based Oscilloscopes Installation Manual, Tektronix Part Number, 077-0067-XX. The manual is
available as a PDF file.

Recommended Accessories

The following probes and test fixtures are recommended for the TDSHT3 software.

Supported Probes

®  P7313SMA — 13 GHz recommended differential probe
The following probes can be used with HDMI 1.2 test fixtures:
P7350 — 5 GHz differential probe

P7330 — 4 GHz differential probe

P6330 — 4 GHz differential probe

P7380 — 8 GHz differential probe
P7240 — 4 GHz single-ended probe
P7260 — 6 GHz single-ended probe

The P7350SMA — 5 GHz differential probe can only be used with the HDMI 1.2 TDR fixture and the 1.3
Efficere test fixtures (now available from Tektronix).

Supported 1.3/1.4 Test Fixtures
B ET-HDMI-TPA-R, available from Tektronix (also available as part of the kit ET-HDMI-TPA-S)

®  ET-HDMI-TPA-P, available from Tektronix (also available as part of the kit ET-HDMI-TPA-S or
ET-HDMI-TPA-STX)

®  TF-HDMID-TPA-P and TF-HDMID-TPA-R, available from Tektronix

®  TF-HDMIE-TPA-KIT, available from Tektronix

The following HDMI 1.2 test fixtures can only work for limited HDMI resolutions.
= HDMI-TPA-P-DI

= HDMI-TPA-P-SE

®  HDMI-TPA-P-TDR

TDSHT3 HDMI Compliance Test Software Online Help 7



Getting Started Recommended Accessories

HDMI-TPA-R-DI
HDMI-TPA-R-SE
HDMI-TPA-R-TDR

The fixtures are available under the Tektronix ordering system with the following part numbers:

ET-HDMI-TPA-S — HDMI Type A fixture set for Tx, Rx, and Cable testing. It includes the following:
= One HDMI-TPA-P plug board with SMA cables

= One HDMI-TPA-R receptacle board with SMA cables

= One HDMI-TPA-C calibration board with SMA cables

= One HDMI-TPA-CE, EDID board with EDID EEPROM

= 29 SMA to GPPO cables two inches long

ET-HDMI-TPA-STX — HDMI Type A fixture set for Tx testing only. It includes the following:

= One HDMI-TPA-P plug board, 10 GPPO to SMA cables two inches long

-~ One HDMI-TPA-CE, EDID board with EDID EEPROM

ET-HDMIC-TPA-S — HDMI Type C fixture set for Tx, Rx, and Cable testing. It includes the
following:

-~ One HDMI-TPA-P plug board with SMA cables

= One HDMI-TPA-R receptacle board with SMA cables

= One HDMI-TPA-C calibration board with SMA cables

= One HDMI-TPA-CE, EDID board with EDID EEPROM

= 29 SMA to GPPO cables two inches long

ET-HDMIC-TPA-STX — HDMI Type C fixture set for Tx testing only. It includes the following:
= One HDMI-TPA-P plug board, 10 GPPO to SMA cables two inches long

= One HDMI-TPA-CE, EDID board with EDID EEPROM

TF-HDMID-TPA-P and TF-HDMID-TPA-R — HDMI Type D fixture set for Tx, Rx, and Cable
testing. It includes the following:

= One HDMI-TPA-P plug board
= One HDMI-TPA-R receptacle board

TF-HDMIE-TPA-KIT — HDMI Type E fixture set for Tx, Rx, and Cable Testing. It includes the
following:

= One HDMI-TPA-P plug board with SMA cables
= Two HDMI-TPA-R receptacle boards with SMA cables
= One HDMI-TPA-EDID board

TDSHT3 HDMI Compliance Test Software Online Help



Getting Started Requirements and Restrictions

Connectivity

B GPIB (recommended for DPO/DSA70000/B series oscilloscope)
®  USB-GPIB (HS)

m  E-Net Switch

Requirements and Restrictions

m  TekVISA must be installed on the oscilloscope. If you do not have TekVISA, you can download it
from www.tektronix.com/software.

®  MATLAB Runtime must be installed on the oscilloscope. If you do not have MATLAB Runtime,
the TDSHT3 installer will install it.

NOTE. Do not change the oscilloscope settings while a test is running. If you do, the sofiware may give
abnormal test results.

For Better and Reliable Results

m  Before you run any test, calibrate the probes and oscilloscope for Signal Path Compensation. On the
oscilloscope menu bar, click Utilities > Instrument Calibration and then click Calibrate to calibrate
the oscilloscope.

m  [f the signal is not connected and the noise level is less than 50 mV, the software detects and gives
a message such as “Invalid Signal.”

TDSHT3 HDMI Compliance Test Software Online Help 9
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Getting Started How to Start the Software

How to Start the Software

10

When you start the software, a warning message box may appear.

Warning - TDSHT3

This happens due to the following reasons:

1.

Four channel feature is supported only on DPO/DSA70000/B series oscilloscopes having
bandwidth greater than or equal to 8 GHz. For TDS series oscilloscopes, only two channels are
available and the other two channels are displayed as Not Conn.

Oscilloscope bandwidth is less than 8 GHz. For higher resolution HDMI signals, you need at least
an 8 GHz oscilloscope. Your oscilloscope bandwidth is less than 8 GHz.

Maximum available record length for two channels is less than 16 M. For HDMI compliance
testing, you need at least a 16 M record length in two channels. This 16 M record length is installed in
the following oscilloscopes:

= Option 4M and above in TDS series oscilloscopes
= Option 2XL and above in DPO series oscilloscopes

If these options are not available (installed) in the oscilloscope, the software will run the Eye diagram
and Jitter measurements with the maximum available record length.

DDS method is supported only on DPO/DSA70000/B series oscilloscopes having bandwidth
greater than or equal to 8§ GHz.

TDSHT3 application and the DDS method option license keys are not installed. They are
running in trial mode.

TDSHT3 application is licensed but the DDS method option license key is not installed. The DDS
method is running in trial mode.

DDS method option is not available, trial has expired. The DDS method trial has expired and
this option will not appear in the application.

TDSHT3 HDMI Compliance Test Software Online Help



Getting Started How to Start the Software

Depending on the type of oscilloscope that you have, you can start the software in different ways.

1. For supported B-series oscilloscopes, select App > HDMI Compliance Test Software(1.4).

MyScope Utilities Help Button

Ethernet Compliance Test Software
Jitter Analysis - Advanced

Jitter Analysis - Essentials

Power Measurements 3

Protocol Trigger and Decode

RT-Eye Serial Compliance and Analysis
USB2.0 Test Package

2. For TDS7000-series oscilloscopes, select File > Run Application >HDMI Compliance Test
Software(1.4).

File Edit Vertical HorizfAcg  Trig  Display  Corsors  Measure  Masks  Math MyScope  Utilities

Reference Waveform Conkrols. .. 19 Oct 02 07:55:32

S L L LN R

Run Application CAN And LIM Timing and Protocol Decode Software
Save Chrles HDMI Cornp 4
gave 5 Sz Jitker Analysis - Advanced

= Jitker Analysis - Essentials
Recall... Power Measurements 3
Recall Default Setup USEZ,0 Test Package
Delete
Page Setup...
Print Prewview
Print... Ctrl+P

1 Ci\demosetuplrunttrigger . set

2 Ci\demosetuptsamplemode. set

3 Ci\demosetuptglitchsetup. set

4 Cildemaosetupl000101 120335, 5et

Minimize Chrl+M

Shutdawn, ..
Exik

TDSHT3 HDMI Compliance Test Software Online Help 1



Getting Started How to Start the Software

3. For DPO70000/B-series and DSA70000/B-series oscilloscopes, select Analyze > HDMI Compliance
Test Software(1.4).

hdark...

Jitter Analysizs

HOMI Compliance Test Softweare(1 41
Jitter and Eye Analysis

PCl-Express

COR Analysis

USB 3.0 Essertials

4. A splash screen indicates that the software is loading.

TDSHT3

HOMI Compliance
Test Software (1.4)

Copyright @ Tebktroniz, Ine. Al rights
rezenred. TEKTROMIX and TEK are - -
registered trademars of Tektronix Inc. Tekironix

5. The oscilloscope display resizes to fit in the upper part of the screen. The lower part of the oscilloscope
screen displays the TDSHT3 software.

File Tests Results Utilities Help TDSHT3 Lo X

Select - Source
Run
Single-Ended Tests Test

Select
Configure

Connect

Sy
el

frplitude -

RUE
WY EVETDI

fgda

i Select All b Select All

Source -> BEye Diagram Clock -= Ch1; Datal -> ChZ2; Datal -= Ch3; Data? -» Ch4d; Fec Lennth -= 8M; CRU -> PLL

12 TDSHT3 HDMI Compliance Test Software Online Help



Getting Started How to Minimize and Maximize the Software

6. The software is automatically set to its default settings (see page 355).

7. If you gain access to the oscilloscope functions, the oscilloscope display appears full screen and the
TDSHT?3 software recedes to the background.

How to Minimize and Maximize the Software

The software appears even when you minimize the oscilloscope display.

®  To minimize the software, click File > Minimize. The TDSHT3 software window minimizes to the
Windows taskbar. The upper part of the screen has the oscilloscope display and the lower part of
the screen has the desktop.

m  To restore the minimized window to its previous size, click its taskbar button.

B To hide the window, click Hide E on the top-right of the software window.

NOTE. If you click Hide, the TDSHT3 software window goes to the background and the oscilloscope
fills the display.

How to Return to the Software

When you gain access to the oscilloscope functions, the oscilloscope fills the display. To gain access to the
oscilloscope functions, do one of the following:

m  Choose ecither the menu bar or the toolbar mode on the oscilloscope, and then gain access to the menus.
®  Click App > Restore Application for B-series, click Analyze > Restore Application for

DPO/DSA70000/B series, or click APP o on the top right of the TDS7000 series oscilloscope
display to return to the software.

See Also
B (see page 14)Exit
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How to Exit the Software

To quit the software:
B On the menu bar, click File > Exit.

m  The Exit dialog box appears.

Do you want to restore the oscilloscope settings to
their state prior to starting this application?

m  Click Yes, No, or Cancel. Yes is seclected by default. When the software runs, it automatically changes
some oscilloscope settings. When you quit the software, you can choose whether to retain these
settings or restore the previous settings.

NOTE. Using other methods to quit the software may result in an abnormal termination of the software.

Software Folders and File Names

The TDSHT3 software uses file name extensions to identify the file type. The following table lists the
default folder names and their purpose:

Folder Purpose
C:\TekAppTlications\TDSHT3v1-3 This is the software data folder.
C:\TekAppTications\TDSHT3v1-3\Images This folder stores all the images.
C:\TekApplications\TDSHT3v1-3\Data This folder stores all the software data.
C:\TekApplications\TDSHT3v1-3\setup This folder stores all the save and recall files.
C:\TekAppTlications\TDSHT3v1-3\Demo This folder stores the demo waveforms.
Tools

C:\TekAppTications\TDSHT3v1-3\Reports This folder stores the reports.
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Shortcut Keys

Menu Shortcut key
File Alt+F
Tests Alt+T
Results Alt+R
Utilities Alt+U

Help Alt+H

File > Recall Compliance Default Alt+F+D
File > Recall Alt+F+R
File > Recall > First Recent Alt+F+E+1
File > Recall > Second Recent Alt+F+E+2
File > Recall > Third Recent Alt+F+E+3
File > Recall > Fourth Recent Alt+F+E+4
File > Save Alt+F+S
File > Recall Recent Alt+F+E
File > Preferences Alt+F+P
File > Preferences > Position Eye Mask in Center Alt+F+P+M
File > Preferences > Acquisition Alert Message Alt+F+P+A
File > Preferences > Jitter Tolerance (No calibration) Alt+F+P+J
File > Preferences > Single Ended (With 50ohm term) Alt+F+P+S
File > Preferences > Set the probe control to internal 3.3 V Alt+F+P+C
File > Minimize Alt+F+M
File > Exit Alt+F+X
Tests > Select Alt+T+S
Tests > Select > Source Alt+T+S+S
Tests > Select > Sink Alt+T+S+K
Tests > Select > Cable Alt+T+S+C
Tests > Configure Alt+T+C
Tests > Connect Alt+T+N
Tests > View Waveform Alt+T+V
Results > Summary Alt+R+S
Results > Details Alt+R+D
Utilities > Deskew Alt+U+D
Utilities > DTG Pattern List Alt+U+P
Help > Help Topics Alt+H+T
Help > About HDMI Alt+H+A
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Software Window

Software Window

The software window includes a menu bar, selection pane, test selection pane, execution pane, and status
bar. The client pane changes between the selection pane, configuration pane, connection pane, and view
waveform pane depending on what you have selected in the selection pane. After you run the test, the

client pane automatically changes to the result pane.

File Tests Results Utilities Help

TDSHT3 EI x|

Select - Source

ETC
eler
Differential Tests

Rise Time
VIS - Fall Time
W anefarm

Single-Ended Tests Test

Report—

SUMMmary

Select Al Select Al Defail

Source -= Eye Diagram Clock -= Ch1; Datal -= Ch2; Datal -= Ch3; Data2 -= Chd; Rec Length -» 8M; CRU -= PLL

Interface Controls

The software uses a Windows interface.

NOTE. The oscilloscope software shrinks to fit in the top part of the display when the TDSHT3 software

runs.

The software interface uses the following controls:

Control Description

Menu bar The Menu bar provides access to the software menus. It is
located at the top of the software window.

Area/Tab An Area/Tab control encloses visual frame with a set of

related options.

Option button

An Option button allows you to select either a command
or a task.

Drop-down list box

A Drop-down list box lists items from which you can select
one item.

Field

A Field is a box where you can enter text or values.

Check boxes

Select or clear check boxes to set preferences.

TDSHT3 HDMI Compliance Test Software Online Help
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Control Description
Scroll bar A Scroll bar is a vertical or horizontal bar at the side or
bottom of a display area that is used to move around that
area.
Browse Browse refers to the window where you can browse through

a list of folders and files.

Command button

A Command button refers to the usually rectangular button
that carries out a command and may initiate immediate
action.

Numeric keypad

Use a Numeric keypad to enter numeric values.

Text keypad

Use a Text keypad to enter text.

MP/GP knob A line between the knob icon and the field indicates which
knob you can turn on the oscilloscope to select a value.
F1 F1 help opens help on a topic associated with the currently
selected item in your software.
Menu Bar

18

The menu bar consists of the following menus:

File Tests Results LMilities Help

Click these links for information on each of the menus.

(see page 19)File menu
(see page 20)Tests menu
(see page 20)Results menu
(see page 21)Utilities menu
(see page 21)Help menu
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File Menu

‘File Tests Results LUiilities Help

Recall Default

Recall ..
Save.
Recall Recent » Eye Diagram - Clock Jitter
Preferences »

Differential Tests

Minimize
Exit

e
WY aveform

B Click File > Recall Default to recall the default settings for both the software and the oscilloscope.
m  Click File > Recall to recall the previously saved settings for the software from an .1in1 file.

B Click File > Save to save the software settings to an .in1 file.

®  Click File > Recall Recent to select among the recently saved and recalled setups.

m  Click File > Preferences to select one of the available options. Click here (see page 22) for more
details.

B Click File > Minimize to minimize the software window.

m  Click File > Exit to quit the software.
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Tests Menu

File ‘Tests Results Utilities Help

d +Source
Configure

Connect rrential Tests

Cable

- Clock Jitter

Fise Time

- Inter-Pa

Tests Menu

H  (Click Tests > Select to display or modify the test selection for Source, Sink, or Cable in the client pane.

®  Click Tests > Configure to display or modify the configuration parameters for the selected test(s).

B Click Tests > Connect to display the connection instructions for the selected test(s).

H  (Click Tests > View Waveform to display a sample waveform or waveforms based on the settings

for the selected test(s).

Results Menu

20

File Tests|HesuIts Liilities  Help

SUmmany

j Sink

‘k-Data Tests

Details

®  Click Results > Summary to display the result summary of the last test(s) that you conducted.

®  Click Results > Details to display the detailed results of the last test(s) that you conducted.
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Utilities Menu

File Tests Results | Utilities Help

Deaskewy

Select DTG Pattern List

Configure

®  Click Utilities > Deskew to open the deskew (see page 44) pane. The deskew pane allows you to
compensate the skew between the oscilloscope channels.

B (Click Utilities > DTG Pattern list to open the DTG Pattern list (see page 45) pane. The DTG pattern
list allows you to add and delete DTG pattern files.

Help Menu

File Tests Results Utilitie5|Help
Help Topics

[ sourcdR N S e
LANTETETILIAL 1 E9lY

Eye Diagram - Clock

®  Click Help > Help Topics to display the help for the TDSHT3 software.

m  Click Help > About TDSHT3 to display a dialog box with information about the current TDSHT3
software.
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Preferences

On the menu bar, click File > Preferences to select any of the options described in the following table.
Click an option again to clear the selection.

File Tests Results Utilities Help

Recall Default
Recall...
Save..

Source

Differential Tests

3 v Position Eye Mask in Center
Ilinimize Acquisition Alert Message
Exit Jitter Tolerance (Mo calibration)

Single Ended (With S0ohm term)
Wiew
Yyaverorm

v Setthe probe control to internal 3.3V

Source -= Eye Diadram Clock -= Ch1; Datal -> Ch2, Datal -> Ch
Option Description
Position Eye Mask in Center Select this option to position the mask at the center of the

eye diagram. Clear this option to position the mask to the
left of the eye diagram.

Acquisition Alert Message Select this option to receive an alert message that allows
the software to use the custom oscilloscope setup. Clear
this option to stop receiving the alert message.

Jitter Tolerance (No calibration) Select this option if you do not want to run the jitter
calibration tests for sink jitter tolerance measurements.
Single Ended (With 50 Q term) This option can be selected only when the negative input of

the probe is terminated with the 50 Q terminator. When this
option is selected, the single ended measurements will be
performed as though a 50 Q termination is connected.

Set the probe control to internal 3.3 V This option is applicable to Source measurements on
DPO/DSA/B oscilloscopes with P7313 probes. When this
option is selected, the application sets the probe control to
internal and voltage to 3.3 V.
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Selection Pane

The selection pane, which is located to the left of the software window, allows you to navigate through
the software.

Select

Canfigure

Wi e
iavetarm

Use the following buttons to do these tasks:

B Click Tests > Select to display or modify the test selection for Source, Sink, or Cable in the client pane.
B (Click Tests > Configure to display or modify the configuration parameters for the selected test(s).

B Click Tests > Connect to display the connection instructions for the selected test(s).

®m  Click Tests > View Waveform to display a sample waveform or waveforms based on the settings
for the selected test(s).
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Execution Pane

The execution pane, which is located to the right of the software window, displays the Run Test and Result
buttons. After you successfully run a test, the Summary and Detail buttons are available.

: Fun .
Test )

Fesult

nepori—

Summary

[retail

—]

Use the following buttons to do the following tasks:

m  Click Run Test to run the selected test or tests.

B Click Result to display the result pane that shows the test results.
®  Click Summary to generate a report summary as a csv file.

m  Click Detail to generate the HTML/MHT report. Plots and waveforms are displayed wherever
applicable.

Status Bar

At the bottom of the software window is the status bar, which displays the selected test and the important
configuration parameters.

Source -= Eye Diagram Clock-= Ch1; Datal -» Ch2; Datal -= Ch3; DataZ -» Ch4; Rec Length -» 32M; CRU -> PLL

Virtual Keyboard

Virtual Keyboard - Numeric

1. Click any number box to display the icon for the numeric keyboard.
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File Tests Results Utilities Help TDSHT3 %| X |

Configure - Source

HorizlAcq Reference Levels
# of Acqs r 3 High A Test

Rec Length iy i Report——

e ¢ A
SUrrany.

Source -> Eye Diagram Clock-= Ch1; Datal -= Ch2; Datal -»= Ch3; Data2 -> Chd, Rec Length -> 8M; CRU -> PLL

2. Click the icon to display the numeric keyboard.

Hysteresis

e ol W

-%

-- .
EX KN kN

]

3. Click the number keys to enter the desired value.

4. Select a unit of measure.

5. Click Enter to confirm your entry. Selections are not effective until you click Enter.

Virtual Keyboard - Text
1. Click New to display the virtual keyboard.
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File Tests Results Utilities Help TDSHT3 %| X

Configure-DTG Pattern List

Pattern Run
Select
Test

Available Patterns

Caonfigure i 60Hz BB

Report—

e
Detal
WY avETDrm

Selected

Utilities -= DTG Pattern Configure

2. Use the text keyboard to enter the required text (such as a file name).

DTG Pattern Path

astP atte s\ P CVIS20 X080 p BOHz SBit Gray REE PG W3-3.dig
! i # % - & ( ] +
Backs
{
I ny T N ]

EapSLDck n--
< = ?

3. Click Enter to confirm your entry. Selections are not effective until you click Enter.

General Purpose Knob

To use the General Purpose knob, follow these steps:
1. Click any number box to display the connection to one of the general purpose knobs.

2. Turn the corresponding knob on the oscilloscope front panel to adjust the value for the selected
parameter.

3. For better resolution, press the Fine button.
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Enable Remote Control of Test Equipment

Three methods are available to connect to an AWG, DTG, or AFG.
(recommended), GPIB-USB, and GPIB-ENET.

The methods are GPIB-GPIB

The following section will guide you through the process of connecting the AWG, DTG, AFG , and the

digital oscilloscope used for Sink and Cable tests.

You will need a Tektronix AWG7000/B series instrument, a Tektronix AFG3000, a Tektronix
DTGS5274/DTG5334, Tektronix supported oscilloscope, a National Instruments GPIB-USB-B with the
included software, an NI-GPIB-HS cable with the included software, and NI-488.2 for Windows.

NI-488.2 Software configuration for TDS series
1. Ensure that NI-VISA is NOT installed.
2. [Install NI-488.2 for Windows (version 2.1 or later).

Feature Tree
Selact tha festures to be installed.

=)

Fesaturs Descriphon

= =5 -] Ni-4B8 2
= | Driver and Applications
& +| GPE Analyzer
= 2 = Language Support

= | Microsoft C/Ces
& +| Borland C/C++
= +| Visual Basic
B2 o LebVIEW
& | LabWindows T

| Other
- wmreend 4 Automabon Explorer

Target Directony

I rEesE |

[end 2>

Diek Cost | <€ Hack

3. Install the Measurement & Automation Explorer software.

4. When prompted, enable the GPIB-USB interface.

TDSHT3 HDMI Compliance Test Software Online Help
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NOTE. If you already have NI-488.2 installed on your oscilloscope, ensure that you have the appropriate
version and installation parameters. Otherwise, remove NI-488.2, and then reinstall the appropriate
version.

5. Restart the oscilloscope.

NI-Software configuration for DPO70000/B series

NOTE. If you are using the NI-Drivers on the DPO70000/B series for the first time, perform steps 1
through 9. If not, perform steps 7 through 9.

1. In the oscilloscope menu, click Utilities > GPIB Configuration.

File | Edt | Vertcl | Horiziacq | Trig | Display | Cursors | Measure | bssk
Tek Securs Eraat.
Set Time & Date.
GPI Configuration
LAN Server Slabus
Estermal Sigrals ..
Touch Scresn
Wistrumert Calkestion,
Wstrument Dlagnossics...
E-mod on Exert
Mulipurposs Knobs
1| pemigmion Buttons
sy Prferences...

Cgtkn ntolation

| a=m_eov

2. In the GPIB Configuration, select Controller. A GPIB Mode Switch dialog box is displayed.

3. Press OK to restart the oscilloscope.
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Horizifiesy | Trig

Yeur oxiloscops's operating

Fysbem myusk reboct mn order ko
change GPTE modes.

Click: OK to reboot the syetem,

400ns  250.0MSls 4.0ns/pt
few  Sample
RL:1.0K

4. In the oscilloscope menu, click Utilities > GPIB Configuration.
5. Inthe GPIB Configuration, select Talk/Listen. A GPIB mode switch dialog box is displayed.

6. Press OK to restart the oscilloscope.

Edt | Vertical | Horiziey | Trig | Oisplay

Veur oxiloscope's operating
syshem must reboot i order ko
change PTG maodes,

Cliks OK b raboot the eystem,

¥ GPIB GPIB Confliguration 1
Talk i Listen Controlier Off Bus.
P
- (- i
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You cannot access the NI software from the Start > Program menu and will have to go to
C:\Program Files\National Instruments\NI-488.2\Bin location.

7. Double-click Add GPIB Hardware to display the Add GPIB Hardware Wizard.

37 Add GPIB Hardware Wizard =13

“Welzome to the Add GPIB Hardware ‘wfizard.

Select an interface to add.

GPIB-EMETA00

=) Plug and Flay Interface
PCI-GPIB
F=l-GPIB
PMC-GFIE

- ISE-B

GPIB-USE-HS

PCI-GRIE+

PCMCIA-GRIE —

PCMCIA-GPIB+

AT-GPIBATHNT [Plug and Play]

Ml PCle-GPIB

Ml ExpressCard-GFIB

[

B Software

P

NI-488.2

High Performance G

[

’ MHest » ] ’ Cancel

8. Select the appropriate NI hardware from the list (select GPIB-USB-B from the list if it is connected).

9. Press Next and finish the installation.

Configure and View Equipment Connections

This section helps you to configure the equipment and view the connections.
1. Configure the DTG GPIB primary address to 1 and the AWG/AFG GPIB primary address to 2.

2. Connect the USB-GPIB controller to the USB port on the oscilloscope. The oscilloscope operating
system will detect the USB-GPIB controller and install the appropriate driver for it.

3. Using GPIB cables, connect (stack) both the DTG and AWG/AFG GPIB ports to the GPIB port of
the GPIB controller.

30 TDSHT3 HDMI Compliance Test Software Online Help



Operating Basics Configure and View Equipment Connections

_ USB
Oscilloscope

=

AWG _ = nn-c"n

(= | | fr—1 HHEHEEHER
u a E:E(-%-E:El P
98 L1 a[ERIl e b -

aooQa

DTG GPIB (Stacked

{mnnenmrs}
[ =) ]
m Lo e | e— =L o1
T GPIB-USB-B
aeadesaaiha l A
L ERERAS L
B

4. Open the Measurement & Automation Explorer software that was installed with the NI-488.2 software.

fF

¥ ‘Measurement & Automation Explorer ] -0l x|

File Edit Yew Tools Help

J F'ru:-perties | %Scan For Inskruments | %‘ MI Spy ‘T& GPIE Analvzer

Configuration = - = @ Show Hide

:ﬁ My-System Marme: I Malue | Description

E E‘ E e nnil W9 PIE Interface Number 0

| . @ Eftfvzlrﬁen MERIEED s Instrumenttl F‘rimary Address ... TEKTROMNIX,DTESZ274,1300167

B g et Systains Instrumenk1 Primary dddress .., SOMNYTEK, AWiG710,0,5CP199
| | [ ]

1 |_’| B Athibutes I

5. In the configuration pane, look under Devices and Interfaces for the GPIB device.

6. Right-click the GPIB device and click Scan for Instruments.
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32

7. Note the GPIB Instrument Number and the Primary Address to configure the instrument connection in
the TDSHT3 Software.

8. Right-click the instrument, and then click Communicate with Instrument.

9. In the NI-488.2 Communicator dialog box, click Query and check that “*IDN?” displays a description
of the correct equipment.

10. Start the TDSHT3 Software.
11. Click Select.
12. Click the Sink tab.

13. Select one of the differential tests, such as Jitter Tolerance.

File Tests Results Utilities Help TDSHT3 %| X |
Select - Sink

[ Source f g Cable Run
Select . . A
Differential Tests Single-Ended Tests Test
_ i - - Jitter Tolerance - Intra-Pa
Configure Result

Report—

Deep Color
=
iew ;

Sink -= Min/Max-Diff Swing Tolera... Input-> Ch1; Test Method-= DTG Method

14. Click Connect.

15. Click Signal Sources. The Signal Sources Setup dialog box appears.

Signal Sources Setup

| DTG |

Select GPIB Setup

Board Type

GPIED ~
Address

Manual

1 =

Secondary

0 -

16. In the Signal Sources Setup dialog box, click the DTG tab.
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17. Configure the GPIB Board Type by using the GPIB Instrument Number that you noted in step 4.

18. Configure the Primary Address by using the address that you noted in step 4.

19. Leave the Secondary Address set to 0.

20. Click AWG tab and repeat steps 14 through 16 for the AWG.

21. Click AFG tab and repeat steps 14 through 16 for the AFG.

22. Click Test Conn and look for a message that the connection is successful.

Configure New IP Address for GPIB-ENET

There are two methods to connect to AWG/DTG. One is the GPIB-USB method and the other, the
GPIB-ENET method.

GPIB-ENET and GPIB-ENET/100 for Windows 3.1/95/98/ME/NT/2000/XP

1.
2.

Confirm that you have installed the latest NI-488.2 driver software for your device.

Connect your GPIB-ENET or GPIB-ENET/100 to an Ethernet network by using a category 5 Ethernet
cable to connect the RJ-45 port on your hardware to an Ethernet hub. You could also connect the
external hardware directly to your oscilloscope by using an Ethernet crossover cable.

Connect the power to your GPIB-ENET or GPIB-ENET/100 and turn it on. When you power on
your GPIB-ENET, the POWER LED comes on immediately. The READY LED flashes while it
completes its power-on self-test. When the test completes successfully and the IP address is assigned,
the READY LED remains steady, indicating that the unit is ready to operate. To assign your IP
address, continue to step 4.

Run the Measurement & Automation Explorer software from Programs > National Instruments.

Some devices are not Windows Plug and Play compatible, so they do not automatically appear in the
Devices and Interfaces list. Other devices may reside in another oscilloscope on your network. To add
non-Plug and Play or remote DAQ devices, right-click Devices and Interfaces in the configuration
tree, and then click Create New. Follow the instructions in the wizard. Select GPIB-ENET/100 or
GPIB-ENET interface according to the hardware.

How to Configure GPIB-ENET/100

1.

To configure an existing National Instruments device, right-click the device name in Devices and
Interfaces in the configuration tree, and then click Properties. You can also configure existing device
properties by clicking Properties in the toolbar.

To configure the network parameters of your GPIB-ENET/100, right-click your GPIB interface in the
configuration tree, and click Device Configuration.

Click Properties. Configure the IP address as shown in the following figure:
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MHetwark Settingz

Sernal number; OOC740FD
Ethernet address: 00:80: 2 0a:08:59
Firrnweare wersion: B.7

enet00-5

Hoztname:

" Obtain an IP address automatically [DHCP

—i% Uge the following IP settings;

IF addrezs: | 192 188 . 103 137
Subret mask: | 255 255 .25 . O
Gateway: | 192 158 . 103 . 1
DMS zerver: | 192 158 . 113 . A

LComment [optional]: I

| k. I Cancel

Configure New IP Address for GPIB-ENET

4. After entering the IP settings, click OK. A message box appears as follows:

GPIB-ENET /100 Properties : il

Device currently not in configuration mode,
Press and hold the CFG RESET button on
wour Ethernet device for three seconds to
enter configuration mode,

5. After you reset the CFG in the ENET card, click OK in the GPIB-ENET/100 Properties message box.
The software will configure and another message box appears.
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GPIB-ENET, 100 Properti x|

The Etherrnet device has been configured and is
in the process of rebooting, This device will nok
show up in the lisk of Ethernet devices unkil its
book process is complete and the Refresh button
iz pushed,

6. Click OK. The ENET card is configured.

7. Verify the configuration by pinging the IP address and through ICTA.

How to Configure GPIB-ENET (old card)
1. Right-click Devices and Interfaces. Click Assign IP Address. A message box appears.

Q IP&ssign is unable ko detect appropriate network prokocaol driver,

Steps ko inskall IPAssign Protocal:
1. Login as system administrator and close all the applications.,
2, Open the Metwork dialog box,
Skark = =Settings = =Metwork & Dial-Up Connections
. Double click on "Local Area Connection® icon,
. Click Properties Butkon.
» Click, Install button,
. Choose Protocol from "Select Metwork Component: Type" dialog.
. Click &dd button and then click Hawe Disk button,
. Enter the full path of your GPIE Software installation (e.q. c:igpib-nt) and press ok,

[ [ Ly R LS PN

NOTE. The GPIB sofiware installation is in the path C:\Program Files\National
Instruments\NI-488.2\GPIB-ENET on the oscilloscope.

2. Run the Measurement & Automation Explorer software. Click Assign IP Address. A message
box appears.
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& GPIB-ENET Assign IP Address 2 x|

&zsign |P &ddress for the GPIB-EMET

Metwark, [nterfaces

\Dievice\MIE netP_{542FEFCE-DCC2-4
IP Address [e.g. 154.160.70.2) Cancel |

2
|

Ethernet &ddress [e.g. 00:80:2F:FF:12:34) Help |
00:80:2F: |[FF:77:77

3. Enter the new IP Address and the Ethernet Address. Click Assign. A message box appears.

@ This ukility allows you ko assign an IP address to wour GPIB-EMET.

Prepare the GPIB-EMET to receive an IP address before continuing, as Follows:

. Power off the GPIB-EMET.

. Set DIP switch 5 on the GPIB-EMET to the OM position,

. &l other DIP switches shiould be sek to OFF,

. Power on the GPIB-EMET and wait 10 secands, This will allow the power-on self kests ko complete,

. Observe the READY LED on the GPIE-EMET. It should be flashing skeadily.
. Press Ok o continue,

Lm I B A B
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4. Follow the instructions in the Ipassign message box. Click OK. Another message box appears.

passign x|

The READY LED on your GPIB-EMET should now be steadily lic, IF nok,
the IP address was naot successfully assigned, Yerify that the IP and
ethernet addresses are correct and run this ukility again,

If the READY LED is skeadily lit, the IP Address was successFully assigned!
Lo the following in order to save the IP Address in the GPIE-EMET:

1. Set DIP switch 5 on the GPIB-EMET ko the OFF position,
2. Set DIP switch 6 an the GPIB-EMET ta the ON position.
3, Power off your GPIB-ENET, then power it back an.

4, After 10 seconds, the READY LED should be steadily lik.
5. four GPIB-EMET is now ready ko use,

5. Follow the instructions in the new Ipassign message box. Click OK.

Remote Control Caution

If you run the Sink or Cable tests, the GPIB Bus Timing dialog box appears.

GPIE Bus Timing

configuration, enzure
Timing parameter to

Zusec manually.

Fress F1 for more details.

. Lo not show this message again

Click OK to continue if you are sure that the Bus Timing parameter is already set to 2 psec. Otherwise,
click Cancel and follow the procedure in this section on how to change the Bus Timing parameter manually.

Once you have changed the parameter, select the check box if you do not want the dialog box to appear
again in the current session. However, if you click File > Recall Default or you quit the software, the
dialog box appears again when you run the test.
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When you install the remote control for the test equipment, the Measurement & Automation Explorer
software will be installed on the oscilloscope. Start the software by clicking Start > Program Files >
National Instruments > Measurement & Automation.

To change the Bus Timing parameter, perform the following steps:

1. Start the Measurement & Automation Explorer software.

In the configuration pane, look under Devices and Interfaces for the GPIB device.

Right-click the GPIB device and click Properties. The GPIB Configuration dialog box appears.
In the GPIB Configuration dialog box, click the Advanced tab.

RANEE S

In the Bus Timing list, select 2 psec.

%3 GPIB Configuration 2] x]

MI-488.2 Setings  Advanced

w GFIB-USB-B

Bus Timing: IEIIIIIInsec vl

Farallel FPoll Duration:

Cable Length for H=488; ot -

V¥ Automatic Serial Palling

[T Ascert BEMN when SC

(0];8 Cancel

6. Quit the TDSHT3 Software and restart the oscilloscope.
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Remote GPIB Commands

The Remote General Purpose Interface Bus (RGPIB) is essentially another way of interfacing with the
oscilloscope. It allows you to control much of the functionality of the oscilloscope as defined by the
software, from a Remote GPIB controller.

For more information on the RGIB commands, command syntax, arguments, and sample program, refer to
the TDSHT3 HDMI Compliance Test Software Programmer Online Help.
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How to ... Calculate Tbit

Calculate Thit

On the Menu bar, click Test > Configure after the measurement is selected from the Select screen.

Thit
Re- Hof Avgs #

calculate 100 -: L

Existing 3
Walue

Tbit is the time that is required to transmit one bit of data. Tbit is one bit time at the specified pixel
clock frequency (= Tpxs/10).

For all the tests that require clock, the software calculates Tbit. For all the other tests, you have an option
of either recalculating Tbit or using the previous Tbit value for the test.

If you click Re-calculate, the software computes the specified number of averages of Tpixz. and then
calculates Tbit. If you use the existing Tbit value, the software uses the previously calculated Tbit value or
you can again recalculate Tbit by using the Tbit pane.

To calculate Tbit for a test, use the Tbit pane. You can calculate Tbit for Rise Time, Fall Time, Inter-Pair
Skew, Source Intra-Pair Skew, Low Amplitude +, Low Amplitude —, and Sink Intra-Pair Skew test if the
clock is not connected.
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To Calculate Thit

1. Set up the connections as shown in the following diagram:

Setup 1: Connections to calculate Tbit

EDND Emulator

]

Digital Oscilloscope )
——r > J i
SEEN-] wr
oEF° I':_ll 2 = -
ass [0k souce
| aaao E=—¢ " '
- - CLOCK ™z,
. ¥ ..-l:..'. o
£ E S
DATAD . S
e %a
N Toam
ta
5 e f o
HOMI-TPA-P-DI o000

o I,I!@ ]
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Setup 2: Connections to calculate Tbit with the Efficere Test Fixture

Digital Osciloscope

IR T TR

Source DUT =

HIRday (WOH
+>¢ !

=TT = pull up
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DATRZ P §
———pullup
:&.’pulrup )
OATA1 P .
i pull up
DATAIN "
k = pull up
) = pullup
— Cpull up )
CLOCK_P
_CLOGK N

Conredd 1o bizsad 50 Ohm termnation
such 88 inpst port of unoccupled

differential SMA probes

Calculate Tbit
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How to ... Deskew

NOTE. You can also use the EDID PCB instead of the EDID Emulator.

= Connect a TPA-P-DI adapter to a Source DUT HDMI output connector.
- Connect a power supply to a TPA board.

= Configure the Source DUT to output a video format with the required supported pixel clock
frequency.

= Connect a TMDS Clock to the configured oscilloscope channel by using a differential probe.

2. In the Tbit pane, do the following:
= Enter the desired number of periods that are considered to calculate Tbit. The default value is 100.
= Click Re-calculate to recalculate the Tbit value.

= Click Existing Value to use the previously calculated Tbit value.

NOTE. Tbit value is used for oscilloscope setup and limit calculations. If the DUT s display resolution and
the refresh rate changes, you have to recalculate Tbhit.

Deskew

44

Deskew is recommended before you conduct any skew test. To ensure accurate results, deskew the test
setup before you conduct the tests from your device under test.

1. On the menu bar, click Utilities > Deskew.

File Tests Results Utiities Help TDSHT3 m| x|

Deskew
Source From Input Setup

Inpurt Hysteresis %  Ref Level

Connect To Input Setup

Select

Canfigure

SUmimany

Input Hysteresis ®  RefLevel #of Slopes #

Yiem Chz 10% L S0% 1 b

i avefarm

Utilities - = Creshew Click Fun Test to Deskew the probes.
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2. In the source pane, do the following:
= Click External if you will use an external signal source (such as the clock signal of DUT).
= Click Internal to probe the compensation signal on an oscilloscope.

3. Select the input channels between which you want to perform the deskew operation. Hysteresis and
Ref Level are available only for an external source.

4. In the slope pane, do the following:
= Click Rise to calculate the average of the number of slopes and then set the skew for a rising pulse.

= Click Fall to calculate the average of the number of slopes and then set the skew for a falling
pulse. You do not have to calculate the average of the number of slopes for a falling pulse for an
internal source.

= Enter the required number of slopes to enable to set the skew for either a rising pulse or a falling
pulse. Ensure that the required number of slopes is present in the acquisition.

5. Set up the oscilloscope as follows:

= Set the acquisition rate so that there are two or more samples on the deskew edge using the
horizontal scale knob.

- Adjust the signals and display them on the screen using the vertical scale and position knobs.
= Set the record length so that there are more samples for the edges in the acquisition.

6. Click Run Test to deskew the probes.

Configure-DTG Pattern List

1. On the menu bar, click Utilities > DTG Pattern List.

File Tests Results Utilities Help TDSHT3 E| X |
Configure-DTG Pattern List

Pattern Run
Select
Test

Available Patterns

Canfigure i 30p 60Hz BBt Gray ...

Report—

Connect Delete

e

YWaverorm

Utilities -> DTG Pattern Configure
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2. In the Pattern pane, the Available Patterns drop-down list displays all the available patterns (including
the newly added ones). The DTG pattern selected from the Configure screen is displayed as the default
pattern in the Available Patterns list.

3. Click New to add a new DTG pattern. Type the name of the pattern and click Enter to save the pattern.
All the newly added patterns will be available in Cable Eye Diagram, Sink Min/Max Diff, and Sink
Jitter Tolerance measurements. The newly added pattern files should have a . dtg extension.

DTG Pattern Path

- estP atterns\P Y1920 1080 G0Hz SBit Gray RGBE PC W3-2.dg
{
I ny T N ]

EapSLDCk n---
Z > 7

4. To delete an added pattern, select the pattern from the Available Patterns list. Click Selected to delete
the selected pattern. The default patterns installed by the application cannot be deleted.

NOTE. All the folders of the application should have unique DTG pattern names.
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View the Results

B On the menu bar, click Results > Summary to display the result summary of the last test(s) that

you conducted.

m  Click Results > Details to display the detailed results of the last test(s) that was conducted.

The result pane, which is located at the center of the software window, appears as shown in the following
figure:

File Tests Results Utlities Help TDSHT3 %| bl |
Result Summary: Source Report Configuration

Select 25t Marme Device Details HOMI

]| 7-10 : Source Eye Diagram : CK - D1 Resolution
LAfl7-10 : Source Eye Diagram : CK- D2

Configure

Refresh Rate
Connect
Report File
WIEW
YW averorm

Data Lane p Y
CH 0 ils & Auto Increment

Source -= Eye Diagram Clock -= Ch1; Datal -» Ch2; Datal -» Ch3; Data2 -> Chd; Rec Length -> 32M; CREU -= PLL

The result pane includes the result summary pane and the report configuration pane.

View the Result Summary

The result summary pane displays the test results.

Result Summary: Source

7-10: Source Eye Diagram
7-10: Source Eye Diagram
7-10: Source Eye Diagram

Data Lane

0w

This icon indicates that the test has passed.
E This icon indicates that the test has failed.

i This icon indicates that the test could not be run due to an error.
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View the Results

Status (displays the status of the test as Pass, Fail, or Error)
Test Name (displays the test id, test name, and selected lanes)
Data Lane (displays the eye diagram plot of the selected data lane pair)

View lJitter Plot (displays the jitter plot). This option is available if you have successfully run the
clock jitter test.

View Eye Plot (displays the eye plot). This option is available if you have successfully run the eye
diagram test.

Result Details (displays the Result Details (see page 48) dialog box that shows the details of test results
categorized as test name, specification range, measured value, result, and remarks.)

Configure the Report

48

Set the report details to identify and generate the report automatically. You can also set a default report file.

Report Configuration

Device Details HOMI Device

Resolution 1920%1080i

Refresh Rate E0HZ

Report File

=@ Auto Increment

In the report configuration pane, you can configure the following parameters:

The Device Details box allows you to specify the device-related information on which the test is
conducted.

The Resolution box allows you to specify the resolution on which the test is conducted.
The Refresh Rate box allows you to specify the refresh rate at which the test is conducted.

The Report File box allows you to specify the path and the file where the generated report will be
saved. However, a default file name and path already exists.

Select the Auto Increment check box to generate a new report. Selecting this option does not overwrite
the existing report. However, it adds the date and time to the existing file name.

Click Save As to save the generated reports. The Save File dialog box is displayed.Enter a file name
and save the report.

Click Clear Report to clear all the results and records of the earlier tests.
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View the Result Details

In the Result Summary pane, click Result Details. The result details pane displays the following fields.

Result Details

Test Name Spec Range LIE 5
7-10: Source Eye Diagram : CK - D0 Data Jitter < 0.3*Thit; 2 b F Ops gin = 0.04*Thit;
0

7-10: Source Eye Diagram : CK - D1 Data Jitter < 0.3*Thit; 028 Thit

7-10: Source Eye Diagram : CK- D2 Data Jitter < 0.3*Thit; 0.26*Thit

m  Test Name (displays the test id, test name, and selected lanes)

B Spec Range (displays the HDMI standards and test specifications limit for the test)
B Meas Value (displays the measured value)
m  Result (displays the status of the test as Pass, Fail, or Error)

®  Remarks/Comments (displays the results of Tbit, Vswing, and Margin). If the test could not be run,
an error code (see page 357) appears.

m  View lJitter Plot (displays the jitter plot). This option is available if you have successfully run the
clock jitter test.

B View Eye Plot (displays the eye plot). This option is available if you have successfully run the eye
diagram test.

B Result Statistics (displays statistics based on the tests)

NOTE. The parameters in the Result Details dialog box may change depending on the test that you run.

View the Result Statistics
Click Result Statistics to display statistics based on the tests in the Result Details dialog box.

The software calculates statistics for each selected test, and logs the statistics on a cycle-by-cycle basis in
a large waveform. The standard statistics are for the Maximum, Minimum, Mean, Standard Deviation,
and Population.

Options Description
Test Name The Test Name column displays the test id, test name, and selected lanes.
Population The software calculates this statistic by using the following equation:

Population (X) = N
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Options Description

Min The software calculates this statistic by using the following equation:
Min (X) = Lowest value of X

Max The software calculates this statistic by using the following equation:
Max (X) = Highest value of X

Mean The software calculates this statistic by using the following equation:

N
Mean (X) =f=leX,,

n=1

Std Dev The software calculates this statistic by using the following equation:

N
Standard Deviation (X) = @, = \/ -(J_I—_l); x,- X

Pk-Pk The software calculates this statistic by using the following equation:
Xppn = Max(X ) = Min(X )

NOTE. Result Statistics is not available for Source tests such as Duty Cycle, Inter-Pair Skew, Intra-Pair
Skew, Low Amplitude +, Low Amplitude —, and all Sink tests.

Select a Source Test

File Tests Results Utilities Help TDSHT3 L] X |

Select - Source

[ Source Sink Cahle Run
Select 5 o "
Differential Tests Single-Ended Tests Test

Eye Diagram - Clock Jitter - Intra-Pair Ske
- Dt e - Inter- - Low Amplitude + Report—

Connect
- - Rise Time - Low Arnplitude -

Wiew P .
- el Wiz Select Al Select Al

Source -= Eye Diagram Clock -> Ch1; Datal -> Ch2; Datal -= Ch3; DataZ -» Chd; Rec Length -= 8M; CRU -= PLL

1. Click Tests > Select > Source.
2. Select the differential test(s) or single-ended test(s) that you want to perform.

3. To select all of the Differential Tests or all of the Single-Ended Tests, click the associated Select All
button (which will change to Clear All).
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Select a Sink Test

File Tests Results Utilities Help TDSHT3 m, X |
Select - Sink

| Soiree p o
Select
- Differential Tests Single-Ended Tests
X To 1 - Jitter Tolerance - Ir S
Configure

WiE ;

Sink -» MinMdax-Diff Swing Tolera... Input -= Ch1; Test Method-> DTG Method

Report—
Dee r
I

1. Click Tests > Select > Sink.

2. Select the differential test(s) or single-ended test that you want to perform.

Select a Cable Test

File Tests Results Ultilities Help TDSHT3 m, x |
Select - Cable

| -
P

e
W averorm

Cahle -» Eye Diagram Clock -= Ch1; Datal -= Ch2; Datal -= Ch3; DataZ -= Chd; BEL -= 100, Test Method-= DTG kMethod; TP1 -= Trug;, TRP2 -= True

1. Click Tests > Select > Cable.

2. Select the differential test(s) that you want to perform.
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Configure Parameters for the Source Tests

On the menu bar, click Tests > Configure to configure the parameters for the selected test(s).

In the configure pane, you will see the factory default configuration for the test you selected. For most tests,
you can use the factory default configuration. However, you can change the values by using the virtual
keyboard (see page 24) or the general purpose knob (see page 26) on the oscilloscope front panel. Using the
File menu, you can also restore the factory defaults or save and recall your own configuration settings. It is
recommended that you save the configuration settings before you choose to select Recall Default or close
the application. For more information about configuration, refer to How to... Test and go to a specific test.

The following table shows the parameters that you can configure for source (differential tests):

Parameters available for each test

Inter-Pair
Parameters Eye Diagram Duty Cycle Rise Time Fall Time Clock Jitter Skew
Source Clock, Data0, Clock Clock, Data0, Clock, Data0, Clock Clock, Data0,
input Data1, and Data1, and Data1, and Data1, and
Data2 Data2 Data2 Data2
Clock Yes — — — Yes Yes
Hysteresis Yes — — — Yes Yes
Mid Ref Yes — — — Yes Yes
Level
Low Ref — — Yes Yes — —
Level
High Ref — — Yes Yes — —
Level
Record Yes — — — Yes —
Length
Thit — Yes Yes Yes — Yes
# of Acgs — Yes Yes Yes — —
Units Yes — Yes Yes Yes Yes
CRU Yes — — — Yes —
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Configure Parameters for the Sink Tests

The following table shows the parameters that you can configure for source (single-ended tests):

Parameters available for each test

Parameters Intra-Pair Skew Low Amplitude + Low Amplitude -

Source Input Clock+ and Clock- Clock+ and Clock- Clock+ and Clock-
Data(0/Data1/Data2 Data(O/Data1/Data2 Data0/Data1/Data2
and and and
Data0/Data1/Data2 Data0/Data1/Data2 Data0/Data1/Data2

Avce — Yes Yes

Thit Yes Yes Yes

# of Acqs Yes Yes Yes

Configure Parameters for the Sink Tests

On the menu bar, click Tests > Configure to configure the parameters for the selected test.

In the configure pane, you will see the factory default configuration for the test you selected. For most tests,
you can use the factory default configuration. However, you can change the values by using the virtual
keyboard (see page 24) or the general purpose knob (see page 26) on the oscilloscope front panel. Using the

File menu, you can also restore the factory defaults or save and recall your own configuration settings. It is
recommended that you save the configuration settings before you choose to select Recall Default or close
the application. For more information about configuration, refer to How to... Test and go to a specific test.

TDSHT3 HDMI Compliance Test Software Online Help
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Configure Parameters for the Sink Tests

The following table shows the parameters that you can configure for sink (differential tests):

Parameters available for each test

Min/Max-Diff Min/Max-Diff

Swing Swing Jitter Jitter

Tolerance Tolerance Tolerance Tolerance Deep Deep

(DTG (DDS (DTG (DDS Color (DTG Color (DDS
Parameters Method) Method) Method) Method) Method) Method)
Source Clock/Data Clock/Data Clock and Clock and — —
Input Data Data
Clock — — Yes Yes — —
Pattern List Yes Yes Yes Yes Yes Yes
DTG Output Yes — Yes — Yes —
Cable — — — Yes — —
Emulator
Markers — Yes — Yes — Yes
Frequency — — Yes Yes — —
Pair
DUT Freq — — Yes Yes — —
(MHz)
Jitter — — Yes Yes — —
Insertion
Type
Jitter — — Yes — — —
Amplitude
Resolution — — — — Yes Yes
Refresh — — — — Yes Yes
Rate
Deep Color — — — — Yes Yes
Bits
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Parameters

Configure Parameters for the Sink Tests

Parameters available for each test

Audio Clock
Regenera-
tion (DTG
Method)

Audio Clock
Regenera-
tion (DDS
Method)

Audio
Sample
Packet
Jitter (DTG
Method)

Audio
Sample
Packet
Jitter (DDS
Method)

Audio
Formats
(DTG
Method)

Audio
Formats
(DDS
Method)

Source
Input

Yes

Yes

Yes

Yes

Yes

Yes

Clock

Yes

Yes

Yes

Yes

Yes

Yes

Pattern List

Yes

Yes

Yes

Yes

Yes

Yes

DTG Output

Yes

Yes

Yes

Cable
Emulator

Markers

Frequency
Pair

DUT Freq
(MHz)

Jitter
Insertion

Type

Jitter
Amplitude

Resolution

Refresh
Rate

Deep Color
Bits
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Parameters

Configure Parameters for the Sink Tests

Parameters available for each test

One Bit
Audio (DTG
Method)

One Bit
Audio (DDS
Method)

DVI Inter- DVI Inter-

operabil- operabil- 3D Video 3D Video
ity (DTG ity (DDS (DTG (DDS
Method) Method) Method) Method)

Source
Input

Yes

Yes

Yes

Yes Yes Yes

Clock

Yes

Yes

Yes

Yes Yes Yes

Pattern List

Yes

Yes

Yes

Yes Yes Yes

DTG Output

Yes

Yes

— Yes —

Cable
Emulator

Markers

Frequency
Pair

DUT Freq
(MHz)

Jitter
Insertion

Type

Jitter
Amplitude

Resolution

Refresh
Rate

Deep Color
Bits
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Configure Parameters for the Sink Tests

Parameters available for each test

Extended Colors

Extended Colors

4Kx2K Video (DTG 4Kx2K Video (DDS and Contents (DTG and Contents
Parameters Method) Method) Method) (DDS Method)
Source Input Yes Yes Yes Yes
Clock Yes Yes Yes Yes
Pattern List Yes Yes Yes Yes
DTG Output Yes — Yes —
Cable Emulator — — — —
Markers — Yes — Yes

Frequency Pair

DUT Freq (MHz)

Jitter Insertion
Type

Jitter Amplitude

Resolution

Refresh Rate

Deep Color Bits

The following table shows the parameters that you can configure for sink (single-ended tests):

Parameters available for each test

Parameters Intra-Pair Skew (DTG Method) Intra-Pair Skew (DDS Method)
Source Input Clock Clock

Thit Yes Yes

Skew Channel Yes Yes

Pattern List Yes Yes

DTG Output Yes —

Analog — Yes

Skew on one channel Yes Yes

Skew on all Channels Yes Yes

TDSHT3 HDMI Compliance Test Software Online Help

57



How to ... Configure Parameters for the Cable Tests

Configure Parameters for the Cable Tests

On the menu bar, click Tests > Configure to configure the parameters for the selected test.

In the configure pane, you will see the factory default configuration for the test you selected. For most
tests, you can use the factory default configuration. However, you can change the values by using the
virtual keyboard (see page 24) or the general purpose knob (see page 26) on the oscilloscope front panel.
Using the File menu, you can also restore the factory defaults or save and recall your own configuration
settings. It is recommended that you save the configuration settings before you choose to select Recall
Default or close the application. For more information about configuration, click the How to...Test help
topic, and then go to the specific test.

The following table shows the parameters that you can configure for cable (differential tests):

Parameters available for each test

Eye Diagram (DTG Eye Diagram (DDS Inter-Pair Skew (DDS
Parameters Method) Method) Method)
Source Input Clock, Data0, Data1, and Clock, Data0, Data1, and Clock, Data0, Data1, and
Data2 Data2 Data2
Clock Yes Yes Yes
Hysteresis Yes Yes Yes
High Ref Level Yes Yes Yes
Mid Ref Level Yes Yes Yes
Low Ref Level Yes Yes Yes
Record Length Yes Yes -
Ref Level Units Yes Yes Yes
TP1, TP2, TP5 TP1 and TP2 TP1, TP2, and TP5 —
Pattern List Yes — —
Cable Frequency — Yes Yes
DTG Output Yes — —
Cable Equalizer Yes Yes —
Rise Time Filter Yes — -
CRU Yes Yes —
Jitter Insertion Yes Yes -
# of Avgs — — Yes
Thit — — Yes
Markers — — Yes

NOTE. This Cable Inter-Pair Skew test is performed only for repeater cable testing.
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Connect the EDID Emulator for Source Tests

Connect the EDID Emulator for Source Tests

The EDID-PCB or EDID Emulator can be used in the following Source connection diagrams.

Pini Dafiritiors at J2
[1] Grourd

2] C=C

1] Resereed

4] ODC_Ciock {5CL)
5] O0C_Dats (208)
161 F_Gnd

IF1F 3y

[B] Hat_Prag
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How to ... Connect the Type-D Fixture for Mobile Application

Connect the Type-D Fixture for Mobile Application

Type-D fixture is required for the new mobile application as per the CTS 1.4a. For all the Source and Sink
test measurements, use the Type-D fixture in place of Type-A, Type-C, and Type-E (see page 60) fixtures
while making connections. For setup details, refer to the appropriate connection diagrams in this manual.

The following figure shows a graphical representation of the Type-D Plug and Receptacle fixtures.

TPA-P TPA-R

The following figure shows the Type-E fixture:
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Make Connections for Source Eye Diagram

Make Connections for Source Eye Diagram

On the menu bar, click Tests > Connect and make the connection as follows. Refer to EDID Emulator for

Source Tests (see page 59) for EDID emulator connections.

Method 1: Connections for Source Eye Diagram

Digital Oscilloscope

3
B
33 © "
PR =[] Ba
(ol ¥l # e &
(o le We We
TPA-P-TDR oo
Source DUT | B | & ‘_"__,::::hPTE}(){ SMA Probes
& H/K -
LA
S aE
o erLPE T Probe
B L wnasE I rj:‘—n DC Power Supply
bt P = o (| "
c};‘f«:v._\r — Probe li
T %%, o0 fo e\ |
O [l |
EQI0 Emulaior —
E 3
] ‘F‘ ? N
| J

NOTE. You can also use the EDID PCB instead of the EDID Emulator.
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Method 2: Connections for Source Eye Diagram with the Efficere Test Fixture

Digital Ogeibestops

Dl 3341ty St

HOMI-TPA- P

(OATRRP pull up
JORTAZN pull up
— ] M—prullun:
Iz ) E— T
o paTeap T

ajzepdeay |NOH

) ]
= s AT
Fg S i

.eﬁ-ﬂm..hl

Cannect o bissed 50 Ohm temination
= pullup ' guch a&s irput port of unoccupisd
diffarerdal SMA probes

NOTE. You can also use the EDID PCB instead of the EDID Emulator.
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For 4-Channel

.{j

(] D' DT_

Make Connections for Source Eye Diagram

External Powsar Supphy! & ,\.—E o

Intamal from DPOVDGA Osclloscope
03.30

Q000

HOMI- TPA-F

ejreleey IWOH

EDID EmudatorEQID PCE

[’ d

=,

[

NOTE. You can also use the EDID PCB instead of the EDID Emulator.
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1. Connect the HDMI output of the source DUT to the TPA-P-TDR/ET-TPA-P adapter.

2. Connect a power supply to the TPA adapter and set the power supply to 3.3 V. For DPO/DSA/B
oscilloscopes, this is not required if the internal power supply is used. See the Preferences (see
page 22) menu for details.

3. Connect the EDID emulator to the TPA adapter and set the emulator for the required resolution (refer
to the EDID emulator user manual).

4. Connect a TMDS Clock to the configured oscilloscope channel by using a SMA differential probe.

5. Connect the TMDS Data pair(s) on which you will conduct the test to the configured oscilloscope
channel by using a SMA differential probe.

6. Configure the Source DUT to output the required video format.

Make Connections for Duty Cycle

On the menu bar, click Tests > Connect and make the connection as follows. Refer to EDID Emulator for
Source Tests (see page 59) for EDID emulator connections.
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Method 1: Connections for Source Duty Cycle
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Method 2: Connections for Source Duty Cycle with the Efficere Test Fixture
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NOTE. You can also use the EDID PCB instead of the EDID Emulator.

1. Connect the HDMI output of the source DUT to the TPA-P-DI/ET-TPA-P adapter.

2. Connect a power supply to the TPA adapter and set the power supply to 3.3 V. For DPO/DSA/B
oscilloscopes, this is not required if the internal power supply is used. See the Preferences (see
page 22) menu for details.

3. Connect the EDID emulator to the TPA adapter and set the emulator for the required resolution (refer
to the EDID emulator user manual).

66 TDSHT3 HDMI Compliance Test Software Online Help



How to ... Make Connections for Rise Time

4. Configure the Source DUT to output a video format with the required supported pixel clock frequency.

5. Connect a TMDS Clock to the configured oscilloscope channel by using a differential probe.

Make Connections for Rise Time

On the menu bar, click Tests > Connect and make the connection as follows. Refer to EDID Emulator for
Source Tests (see page 59) for EDID emulator connections.

Method 1: Connections for Source Rise Time
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Method 2: Connections for Source Rise Time with the Efficere Test Fixture
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NOTE. You can also use the EDID PCB instead of the EDID Emulator.
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For 4-Channel
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NOTE. You can also use the EDID PCB instead of the EDID Emulator.
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1. Connect the HDMI output of the source DUT to the TPA-P-DI/ET-TPA-P adapter.

2. Connect a power supply to the TPA adapter and set the power supply to 3.3 V. For DPO/DSA/B
oscilloscopes, this is not required if the internal power supply is used. See the Preferences (see
page 22) menu for details.

3. Connect the EDID emulator to the TPA adapter and set the emulator for the required resolution (refer
to the EDID emulator user manual).

4. Configure the Source DUT to output a video format with the required supported pixel clock frequency.
5. Connect a differential probe(s) to a TMDS DATA/CLOCK.

6. If you have selected Re-calculate Thit in the configuration pane, connect the Clock channel to the
configured oscilloscope channel by using a second differential probe(s).

Make Connections for Fall Time

On the menu bar, click Tests > Connect and make the connection as follows. Refer to EDID Emulator for
Source Tests (see page 59) for EDID emulator connections.
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Method 1: Connections for Source Fall Time
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Method 2: Connections for Source Fall Time with the Efficere Test Fixture
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NOTE. You can also use the EDID PCB instead of the EDID Emulator.
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For 4-Channel
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NOTE. You can also use the EDID PCB instead of the EDID Emulator.
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1. Connect the HDMI output of the source DUT to the TPA-P-DI/ET-TPA-P adapter.

2. Connect a power supply to the TPA adapter and set the power supply to 3.3 V. For DPO/DSA/B
oscilloscopes, this is not required if the internal power supply is used. See the Preferences (see
page 22) menu for details.

3. Connect the EDID emulator to the TPA adapter and set the emulator for the required resolution (refer
to the EDID emulator user manual).

4. Configure the Source DUT to output a video format with the highest supported pixel clock frequency.
5. Connect a differential probe(s) to TMDS DATA/CLOCK.

6. If you have selected Re-calculate Thit in the configuration pane, connect the Clock channel to the
configured oscilloscope channel by using a second differential probe(s).

Make Connections for Clock Jitter

On the menu bar, click Tests > Connect and make the connection as follows. Refer to EDID Emulator for
Source Tests (see page 59) for EDID emulator connections.
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Method 1: Connections for Source Clock Jitter
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Method 2: Connections for Source Clock Jitter with the Efficere Test Fixture
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NOTE. You can also use the EDID PCB instead of the EDID Emulator.

1. Connect the HDMI output of the source DUT to the TPA-P-DI/ET-TPA-P adapter.

2. Connect a power supply to the TPA adapter and set the power supply to 3.3 V. For DPO/DSA/B
oscilloscopes, this is not required if the internal power supply is used. See the Preferences (see
page 22) menu for details.

3. Connect the EDID emulator to the TPA adapter and set the emulator for the required resolution (refer
to the EDID emulator user manual).
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4. Configure the Source DUT to output a video format with the required supported pixel clock frequency.

5. Connect a TMDS Clock to the configured oscilloscope channel by using a differential probe.

Make Connections for Inter-Pair Skew

On the menu bar, click Tests > Connect. Refer to EDID Emulator for Source Tests (see page 59) for
EDID emulator connections.

Setup 1
Use this setup if you selected Re-calculate Thit in the configuration pane.

Make the connections as follows:
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Method 1: Connections for Inter-Pair Skew (Re-calculate Thit option selected).
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Method 2: Connections for Inter-Pair Skew with the Efficere Test Fixture (Re-calculate Thit option

selected)
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NOTE. You can also use the EDID PCB instead of the EDID Emulator.

1. Connect the HDMI output of the source DUT to the TPA-P-DI/ET-TPA-P adapter.

2. Connect a power supply to the TPA adapter and set the power supply to 3.3 V. For DPO/DSA/B
oscilloscopes, this is not required if the internal power supply is used. See the Preferences (see
page 22) menu for details.
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80

Make Connections for Inter-Pair Skew

3. Connect the EDID emulator to the TPA adapter and set the emulator for the required resolution (refer
to the EDID emulator user manual).

4. Configure the Source DUT to output a video format with the required supported pixel clock frequency.

5. Connect a TMDS Clock to the configured oscilloscope channel by using a differential probe.

Setup 2

Use this setup if you selected Existing Tbit value or if you are calculating the inter-pair skew.

Make the connections as follows:

Method 1: Connections for Source Inter-Pair Skew (Existing Thit option selected)
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Method 2: Connections for Source Inter-Pair Skew with the Efficere Test Fixture (Existing Thit

option selected)
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NOTE. You can also use the EDID PCB instead of the EDID Emulator.
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For 4-Channel
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NOTE. You can also use the EDID PCB instead of the EDID Emulator.
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1. Connect the HDMI output of the source DUT to the TPA-P-DI/ET-TPA-P adapter.

2. Connect a power supply to the TPA adapter and set the power supply to 3.3 V. For DPO/DSA/B
oscilloscopes, this is not required if the internal power supply is used. See the Preferences (see
page 22) menu for details.

3. Connect the EDID emulator to the TPA adapter and set the emulator for the required resolution (refer
to the EDID emulator user manual).

4. Connect the TMDS CLOCK to the configured oscilloscope channel by using a differential probe.

5. Connect a TMDS DATA<X> to the configured oscilloscope channel by using a second differential
probe.

6. Connect the TMDS DATA<Y> pair on which you will conduct the test to the configured oscilloscope
channel by using a third differential probe.

7. Connect the TMDS DATA<Z> pair on which you will conduct the test to the configured oscilloscope
channel by using a fourth differential probe.

8. Configure the Source DUT to output the required video format.

Make Connections for Differential Tests Select All

On the menu bar, click Tests > Connect and make the connection as follows. Refer to EDID Emulator for
Source Tests (see page 59) for EDID emulator connections.
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How to ... Make Connections for Differential Tests Select All

Method 1: Connections for Source Differential tests (with Select All option)
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Method 2: Connections for Source Differential tests with the Efficere Test Fixture (Select All option)
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NOTE. You can also use the EDID PCB instead of the EDID Emulator.
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For 4-Channel
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NOTE. You can also use the EDID PCB instead of the EDID Emulator.
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1. Connect the HDMI output of the source DUT to the TPA-P-DI/ET-TPA-P adapter.

2. Connect a power supply to the TPA adapter and set the power supply to 3.3 V. For DPO/DSA/B
oscilloscopes, this is not required if the internal power supply is used. See the Preferences (see
page 22) menu for details.

3. Connect the EDID emulator to the TPA adapter and set the emulator for the required resolution (refer
to the EDID emulator user manual).

4. Connect a TMDS Clock to the configured oscilloscope channel by using a differential probe.

5. Connect the TMDS Data pair(s) on which you will conduct the test to the configured oscilloscope
channel by using a second differential probe(s).

6. Configure the Source DUT to output the required video format.

Make Connections for Source Intra-Pair Skew

On the menu bar, click Tests > Connect. Refer to EDID Emulator for Source Tests (see page 59) for
EDID emulator connections.

Setup 1
Use this setup if you have selected Re-calculate Thbit in the configuration pane.

Make the connections as follows:
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Method 1: Connections for Source Intra-Pair Skew test (Re-calculate Thit option selected).
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Method 2: Connections for Source Intra-Pair Skew test with the Efficere Test Fixture (Re-calculate Thit
option selected).
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NOTE. You can also use the EDID PCB instead of the EDID Emulator.

1. Connect the HDMI output of the source DUT to the TPA-P-DI/ET-TPA-P adapter.

2. Connect a power supply to the TPA adapter and set the power supply to 3.3 V. For DPO/DSA/B
oscilloscopes, this is not required if the internal power supply is used. See the Preferences (see
page 22) menu for details.
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Make Connections for Source Intra-Pair Skew

Connect the EDID emulator to the TPA adapter and set the emulator for the required resolution (refer
to the EDID emulator user manual).

Configure the Source DUT to output a video format with the required supported pixel clock frequency.

Connect a TMDS Clock to the configured oscilloscope channel by using a differential probe.

Setup 2

Use this setup if you have selected the Existing Thit value or if you are calculating the intra-pair skew.

Make the connections as follows:

Method 1: Connections for Source Intra-Pair Skew test (Existing Thit option selected).

90

Digital Oscilloscopea

HOMI-TPA-P-SE

EDID Emulator

L]

Source DUT

Powar Supply

00-00

7

TDSHT3 HDMI Compliance Test Software Online Help



How to ... Make Connections for Source Intra-Pair Skew

Method 2: Connections for Source Intra-Pair Skew test with the Efficere Test Fixture (Existing Thit option

selected).
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NOTE. For single-ended tests, the default setup is that the —ve input of the probe is configured to be kept
open. To perform the single-ended tests with the -ve input terminated with a 50 ohm terminator, ensure that
the single-ended (With 50 ohm term) option is selected in the Preferences (see page 22) menu.

NOTE. You can also use the EDID PCB instead of the EDID Emulator.
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For 4-Channel.
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NOTE. For single-ended tests, the default setup is that the —ve input of the probe is configured to be kept
open. 1o perform the single-ended tests with the -ve input terminated with a 50 ohm terminator, ensure that
the single-ended (With 50 ohm term) option is selected in the Preferences (see page 22) menu.

NOTE. You can also use the EDID PCB instead of the EDID Emulator.
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1. Connect the HDMI output of the source DUT to the TPA-P-SE/ET-TPA-P adapter.

2. Connect a power supply to the TPA adapter and set the power supply to 3.3 V. For DPO/DSA/B
oscilloscopes, this is not required if the internal power supply is used. See the Preferences (see
page 22) menu for details.

3. Connect the EDID emulator to the TPA adapter and set the emulator for the required resolution (refer
to the EDID emulator user manual).

Connect the first single-ended probe to TMDS DATA<X>+/TMDS CLOCK+.
Connect the second single-ended probe to TMDS DATA<X>-/TMDS_CLOCK-.
Connect the third single-ended probe to TMDS DATA<X>+/TMDS_CLOCK+.
Connect the fourth single-ended probe to TMDS DATA<X>-/TMDS_CLOCK-.

® XN

Configure the Source DUT to output a video format with the required supported pixel clock frequency.

Make Connections for Low Amplitude +

On the menu bar, click Tests > Connect. Refer to EDID Emulator for Source Tests (see page 59) for
EDID emulator connections.

Setup 1
Use this setup if you have selected Re-calculate Tbit in the configuration pane.

Make the connections as follows:
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Method 1: Connections for Low Amplitude + (Re-calculate Thit option selected).
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Method 2: Connections for Low Amplitude + with the Efficere Test Fixture (Re-calculate Thit option selected).
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NOTE. You can also use the EDID PCB instead of the EDID Emulator.

1. Connect the HDMI output of the source DUT to the TPA-P-DI/ET-TPA-P adapter.

2. Connect a power supply to the TPA adapter and set the power supply to 3.3 V. For DPO/DSA/B
oscilloscopes, this is not required if the internal power supply is used. See the Preferences (see
page 22) menu for details.

3. Connect the EDID emulator to the TPA adapter and set the emulator for the required resolution (refer
to the EDID emulator user manual).
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4. Configure the Source DUT to output a video format with the required supported pixel clock frequency.

5. Connect a TMDS Clock to the configured oscilloscope channel by using a differential probe.

Setup 2
Use this setup if you have selected Existing Thit value or if you are calculating low amplitude.

Make the connections as follows:

Method 1: Connections for Low Amplitude + (Existing Thit option selected).
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Method 2: Connections for Low Amplitude + with the Efficere Test Fixture (Existing Tbit option selected).
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NOTE. For single-ended tests, the default setup is that the —ve input of the probe is configured to be kept
open. To perform the single-ended tests with the -ve input terminated with a 50 ohm terminator, ensure that
the single-ended (With 50 ohm term) option is selected in the Preferences (see page 22) menu.

NOTE. You can also use the EDID PCB instead of the EDID Emulator.
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98

For 4-Channel.
Digital Oscilloscope
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NOTE. For single-ended tests, the default setup is that the —ve input of the probe is configured to be kept
open. To perform the single-ended tests with the -ve input terminated with a 50 ohm terminator, ensure that
the single-ended (With 50 ohm term) option is selected in the Preferences (see page 22) menu.

NOTE. You can also use the EDID PCB instead of the EDID Emulator.

NOTE. Connecting CH2 and Ch4 is not a must for this measurement.

TDSHT3 HDMI Compliance Test Software Online Help



How to ... Make Connections for Low Amplitude -

1. Connect the HDMI output of the source DUT to the TPA-P-SE/ET-TPA-P adapter.

2. Connect a power supply to the TPA adapter and set the power supply to 3.3 V. For DPO/DSA/B
oscilloscopes, this is not required if the internal power supply is used. See the Preferences (see
page 22) menu for details.

3. Connect the EDID emulator to the TPA adapter and set the emulator for the required resolution (refer
to the EDID emulator user manual).

4. Connect the first single-ended probe to TMDS DATA<X>+/TMDS_CLOCK+.
5. Connect the second single-ended probe to TMDS DATA<X>+/TMDS_CLOCK+.

6. Configure the Source DUT to output a video format with the required supported pixel clock frequency.

Make Connections for Low Amplitude -

On the menu bar, click Tests > Connect. Refer to EDID Emulator for Source Tests (see page 59) for
EDID emulator connections.

Setup 1
Use this setup if you have selected Re-calculate Tbit in the configuration pane.

Make the connections as follows:
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Method 1: Connections for Low Amplitude — (Re-calculate Thit option selected).
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Make Connections for Low Amplitude -

Method 2: Connections for Low Amplitude — with the Efficere Test Fixture (Re-calculate Thit option selected).
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NOTE. You can also use the EDID PCB instead of the EDID Emulator.

1. Connect the HDMI output of the source DUT to the TPA-P-DI/ET-TPA-P adapter.

2. Connect a power supply to the TPA adapter and set the power supply to 3.3 V. For DPO/DSA/B
oscilloscopes, this is not required if the internal power supply is used. See the Preferences (see

page 22) menu for details.

3. Connect the EDID emulator to the TPA adapter and set the emulator for the required resolution (refer
to the EDID emulator user manual).
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4. Configure the Source DUT to output a video format with the required supported pixel clock frequency.

5. Connect a TMDS Clock to the configured oscilloscope channel by using a differential probe.

Setup 2
Use this setup if you have selected Existing Thit value or if you are calculating low amplitude.

Make the connections as follows:

Method 1: Connections for Low Amplitude - (Existing Thit option selected).
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Method 2: Connections for Low Amplitude - with the Efficere Test Fixture (Existing Thit option selected).
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NOTE. For single-ended tests, the default setup is that the —ve input of the probe is configured to be kept
open. To perform the single-ended tests with the -ve input terminated with a 50 ohm terminator, ensure that
the single-ended (With 50 ohm term) option is selected in the Preferences (see page 22) menu.

NOTE. You can also use the EDID PCB instead of the EDID Emulator.
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For 4-Channel.
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Make Connections for Low Amplitude -

Digital Oscilloscope
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NOTE. For single-ended tests, the default setup is that the —ve input of the probe is configured to be kept
open. To perform the single-ended tests with the -ve input terminated with a 50 ohm terminator, ensure that
the single-ended (With 50 ohm term) option is selected in the Preferences (see page 22) menu.

NOTE. You can also use the EDID PCB instead of the EDID Emulator.

NOTE. Connecting Chl and Ch3 is not a must for this measurement.
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1. Connect the HDMI output of the source DUT to the TPA-P-SE/ET-TPA-P adapter.

2. Connect a power supply to the TPA adapter and set the power supply to 0 V. For DPO/DSA/B
oscilloscopes, this is not required if the internal power supply is used. See the Preferences (see
page 22) menu for details.

3. Connect the EDID emulator to the TPA adapter and set the emulator for the required resolution (refer
to the EDID emulator user manual).

4. Connect the first single-ended probe to TMDS DATA<X>+/TMDS_CLOCK+.
5. Connect the second single-ended probe to TMDS DATA<X>-/TMDS CLOCK-.

6. Configure the Source DUT to output a video format with the required supported pixel clock frequency.

Make Connections for Min/Max-Diff Swing Tolerance

NOTE. For all the HDMI 1.2 test fixture connections, connect a TTC filter between the DTG and the
test fixture.

On the menu bar, click Tests > Connect.

Method 1: Using HDMI 1.2 test fixtures

Setup 1. To find the minimum swing voltage of the Sink DUT

Make the connections as follows:
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LAN
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1. Connect the DTG to the TPA-R-TDR by using eight one-meter or one-and-a-half meter SMA cables:
= Module A, Channel 1+, 1—: Connect to CLOCK_P, and CLOCK_N
= Module A, Channel 2+, 2— No Connection
= Module B, Channel 1+, 1—: Connect to DATAO0 P and DATAO N
= Module B, Channel 2+, 2—: Connect to DATA1 P and DATA1 N
= Module C, Channel 1+, 1—: Connect to DATA2 P and DATA2 N
= Module C, Channel 2+, 2—: No Connection
2. Connect the Cable Emulator from the TPA-R-TDR to the Sink DUT.

3. Connect and configure the DC power supply to drive +5 V between +5 V Power (P_5V) and DDC
/CEC Ground ( P_GND) on the TPA-R-TDR.
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Setup 2. To measure the minimum differential swing voltage by using an oscilloscope

Make the connections as follows:

LaN

E-Het
E-Met to GFIE comertar E-Het

44 | Digiral Oscillosca pe

Powrer Supply e — e

Eaals :Té
BaomEs

DTS

L&

= (gl el el

[—|| HOMFTRRR-TOR

1. Remove the Sink DUT from the Cable Emulator.
2. Connect the TPA-R-DI test fixture at the end of the Cable Emulator.

3. Connect a TMDS Clock/Data channel to the configured oscilloscope channel by using a differential
probe.
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Setup 3. To find the maximum swing voltage of the Sink DUT
1. Remove the TPA-R-DI text fixture at the end of the Cable Emulator.

2. Connect the Sink DUT to the Cable Emulator.
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Method 2: Using Efficere test fixtures
Setup 1. To find the Min/Max differential swing voltage of the Sink DUT with the Efficere Test Fixture
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Make Connections for Min/Max-Diff Swing Tolerance

Setup 2. To measure the min/max differential swing voltage of the Sink DUT with the Efficere Test Fixture
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For the DDS Method

Setup 1. To test the Sink DUT for Min/Max-Diff Swing Tolerance test compliance
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Perform the following steps for each TMDS clock rate supported by the Sink DUT.
1. Ensure that the Sink DUT port on which you perform the test is selected.
2. Connect the test equipment and DUT.

3. Connect the two AWGs, Bias-Tees, AFG, DPO/DSA70804/B, and TPA-P as shown in the setup
diagram. One AWG is used as the MASTER and the other AWG is used as the SLAVE (called AWG1
and AWG?2 respectively).

= AWGI Markerl+ output to oscilloscope Ch3 input

= AWG2 Markerl+ output to oscilloscope Ch4 input

= AWGTI Chl+ output to 120 PS TTC filter
= 120 PS TTC filter output to Bias-Tee #1 signal input (RF)
- Bias-Tee #1 signal output (RF and DC) to TMDS CLOCK+
= AWGI DC_OUT (1) to Bias-Tee #1 DC-level input (DC)
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Make Connections for Min/Max-Diff Swing Tolerance

AWG]1 Chl- output to 120 PS TTC filter

= 120 PS TTC filter output to Bias-Tee #2 signal input (RF)

= Bias-Tee #2 signal output (RF and DC) output to TMDS CLOCK-
= AWGI DC _OUT (2) to Bias-Tee #2 DC-level input (DC)
AWG1 Ch2+ output to 120 PS TTC filter

- 120 PS TTC filter output to Bias-Tee #3 signal input (RF)

= Bias-Tee #3 signal output (RF and DC) to TMDS DATAO0+
= AWGI DC OUT (3) to Bias-Tee #3 DC-level input (DC)
AWGI1 Ch2- output to 120 PS TTC filter

= 120 PS TTC filter output to Bias-Tee #4 signal input (RF)
- Bias-Tee #4 signal output (RF and DC) to TMDS_DATAO—
= AWGI DC_OUT (4) to Bias-Tee #4 DC-level input (DC)
AWG?2 Chl+ output to 120 PS TTC filter

= 120 PS TTC filter output to Bias-Tee #5 signal input (RF)
= Bias-Tee #5 signal output (RF and DC) to TMDS_ DATA1+
= AWG2 DC OUT (1) to Bias-Tee #5 DC-level input (DC)
AWG?2 Chl- output to 120 PS TTC filter

= 120 PS TTC filter output to Bias-Tee #6 signal input (RF)
= Bias-Tee #6 signal output (RF and DC) to TMDS DATAI1-
= AWG2 DC _OUT (2) to Bias-Tee #6 DC-level input (DC)
AWG2 Ch2+ output to 120 PS TTC filter

= 120 PS TTC filter output to Bias-Tee #7 signal input (RF)
= Bias-Tee #7 signal output (RF and DC) to TMDS DATA2+
= AWG2 DC _OUT (3) to Bias-Tee #7 DC-level input (DC)
AWG2 Ch2- output to 120 PS TTC filter

- 120 PS TTC filter output to Bias-Tee #8 signal input (RF)
- Bias-Tee #8 signal output (RF and DC) to TMDS DATA2—
= AWG2 DC_OUT (4) to Bias-Tee #8 DC-level input (DC)
AFG3102 Chl using BNC-T adapter to trigger input of AWG1 and AWG2
AFG3102 Ch2 to be connected to Ext Ref input of AWG?2
AWG1 10 MHz Ref output to be connected to AFG3102 Ext Ref input
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4. Connect TPA-P to Sink DUT.

5. Connect and configure the DC power supply to drive +5 V between +5 V Power (P_5V) and
DDC/CEC Ground (P_GND) on the TPA-R-TDR.

6. Configure the application as follows:

= Run the TDSHT3 software (version with the Direct Synthesis capability) on the digital
oscilloscope.

= Select the DDS method in the configuration panel of the Sink Min/Max Diff Swing Tolerance Test.

= Select the resolution of the DUT to be tested.

NOTE. The software automatically reduces the amplitude of the signal in steps of 10 mV from 170 mV
to 90 mV.

= Confirm the gray bars on the DUT.
= Connect the Clock channel to the oscilloscope to measure the differential swing voltage.

= In the Signal Source dialog box, check the GPIB connection of the two AWGs and the AFG to
ensure proper connection.

= Go to the setup 2 (see page 114).
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Make Connections for Min/Max-Diff Swing Tolerance

Setup 2. To measure the Min/Max differential swing voltage

Digital Oscilloscope
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NOTE. Terminate the lanes that are not connected with a 50 ohm terminator using a Bias-T which is
pulled up to 3.3 V.

Connect the two AWGs, Bias-Tees, AFG, DPO/DSA70804/B, and TPA-P as shown in the setup

diagram. One AWG is used as the MASTER and the other AWG is used as the SLAVE (called AWGI
and AWG2 respectively). For connection details, refer to step 3.

probe.

Connect TPA-P to TPA-R.

DDC/CEC Ground (P_GND) on the TPA-R-TDR.

14

Once the test completes, you can view the result.

Connect the Clock output of the TPA-R to the configured oscilloscope channel by using a differential

Connect and configure the DC power supply to drive +5 V between +5 V Power (P_5V) and
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Make Connections for Jitter Tolerance

Make Connections for Jitter Tolerance

NOTE. For all the HDMI 1.2 test fixture connections, connect a TTC filter between the DTG and the

test fixture.

On the menu bar, click Tests > Connect.

Method 1: Using HDMI 1.2 test fixtures

Setup 1. To find the device tolerance limit for frequencies < 148.5 MHz make the connections as follows:
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Make Connections for Jitter Tolerance

Connect the DTG, AWG, Bias-Tees, and the TPA-R-TDR.

AWG Marker 1+ output to DTG External Clock input

AWG Marker 2+ output to DTG Trigger In

AWG Ch. 1+ output to Bias-Tee signal input (RF)

Bias-Tee signal output (RF and DC) to CLOCK_P

DTG DC_OUT (1) to Bias-Tee DC-level input (DC)

AWG Ch. 1- output to Bias-Tee signal input (RF)

Bias-Tee signal output (RF and DC) to CLOCK_N

DTG DC_OUT (2) to Bias-Tee DC-level input (DC)

DTG Module A, Channel 1+, 1-: No Connection

DTG Module A, Channel 2+, 2—: No Connection

DTG Module B, Channel 1+, 1—: Connect to DATAO P and DATAO0 N
DTG Module B, Channel 2+, 2—: Connect to DATA1 P and DATA1 N
DTG Module C, Channel 1+, 1—: Connect to DATA2 P and DATA2 N
DTG Module C, Channel 2+, 2—: No Connection

Connect the TPA-R-TDR to the Sink DUT by using a Cable Emulator specified for the tested pixel
clock rate.

Connect and configure the DC power supply to drive +5 V between +5 V Power (P_5V) and
DDC/CEC Ground (P_GND) on the TPA-R-TDR.
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Setup 2. To measure the parameters for frequencies < 148.5 MHz,

LAN

Make Connections for Jitter Tolerance

make the connections as follows:

E-Nat
E-Met to GPIB convertor E-Med
1
I
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— | @ EEREE Digital Oscilloscope
e : Q g p
I - 1] C ————— }
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= o o =N
3] 2 rE:.': k- /'_..f o,
C M = Ry s
i IR W D EE
I
L= HOMI-TPA&.R-O1
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=
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Remove the Sink DUT.

Connect the TPA-R-DI test adapter to a cable emulator.

L

by using a second differential probe.
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Connect a Clock to the configured oscilloscope channel by using a differential probe.

Connect the Data pair on which you will conduct the test to the configured oscilloscope channel
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Method 2: Using Efficere test fixtures

Connections for jitter calibration (common to all jitter insertion setups).

oTG
i AFG
i - — . = .
|4 : == EE
]| . | (==Lt =]
- ; =T =
"/y‘u.ua anlfas ns]” ! -';"ff.. =il
d | e . 15|k = =
| Ja , o ; =
i — - | I.
wm T eH | ||::H ’
_HOMI-TPA-R
=
e
|
b
|
TTC Modules &
L P 8 T
L1 o — N ama- T
L H— pr— T U
L7 g — .—“.- T | B
S s r,_1 T e M
[ e — - M o o Y =
T ook o — =1 S—
- - T T cwooe - - | _——

Gonnect v blesed 50 Ohm termination
Cpellup 7 osuch a8 mpul porl of wnoccupisd
differesiial SMA probes

1. Use Jitter Generation block to generate a known amount of jitter (Clock jitter: 0.25 Ul, Data jitter:
0.30 UI).

2. Connect the test fixture to the oscilloscope for calibration. The oscilloscope calculates data and clock
jitter inserted due to the cables and the test fixtures along with the known amount of jitter.
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Connections to adjust the clock jitter at TP2.

Jittar Ganaration
L | Digital Oszill
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______________________ 4
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|
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- . _| ab M oy - DRI H M
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Connect to biessd 5007 terrminabon such
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Setup 1a. DTG-AWG710/AWG710B for testing resolutions < 74.25MHz

DTG
__..JG.]| | Eetgiockin AWG T10 | AWGT 108
-y - 4 ] ik
s ==—iEEEO
= |2===ml | & o
z |zmm=m | - ]
- _”“|“'* = [
L . I = n
"l‘«*/:hn-... AT | = |_ 1 i cH .. X .
L# | oTaman diERD :riwn 4 : I i i
L
4 M1
H
[ ua
TIC: Wacubi
Clabl P lidze

DoCM | |CLCEP

HEMITRAP Sink DUT
_—
e G |
Motk Emulaior —
Lt T h— ¥ . L
A R I — I
g S ] — - T
e T T '—_H
-
s D - W,

1. Connect the test equipment for the DTG and AWG connection as shown in the setup diagram.

2. When connecting the test fixture to the DUT, use a cable emulator specified for the pixel clock rate
being tested.

3. Connect the DTG, AWG, and the oscilloscope according to the Enable Remote Control of Test
Equipment (see page 27) procedure.

4. Configure the DUT to receive the HDMI input signal.
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Setup 1b. DTG-AWG710/AWG710B for testing resolutions > 74.25MHz

oTE
== :'E';@ NG 7D | AWETIOR
7 - fl° 2mz 2 e
_: . lll_l.J:: ] O D = (BEE
: \-\\ % N e e 2 8 B o
e CH1
Pawer Supgly
Rl i+
TTC Modules Cable Emulator HOMI-TRAP
. v P Sink DUT
L 2 :
LH B = —5
| m_ i
H— : il
L B .
&
o

1. Connect the test equipment for the DTG and AWG connection as shown in the setup diagram.

2. Connect the DTG, AWG, and the oscilloscope according to the Enable Remote Control of Test
Equipment procedure.

3. Configure the DUT to receive the HDMI input signal.

NOTE. Some of the DUTs work with test fixtures that are not connected to a power supply.
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Setup 2. DTG-AFG3000 jitter tolerance

0TG

AFG

Pawer Supply

RelaiRlsLel

HOM-TPA.P

TTC Modules Cable Emulator Sink DUT

b

LI7T

aflial] o HIEIEI'E =1

1. Connect the test equipment for the DTG and AFG connection as shown in the setup diagram.

2. When connecting the test fixture to the DUT, use a cable emulator specified for the pixel clock rate
being tested.

3. Connect the DTG, AFG, and the oscilloscope according to the Enable Remote Control of Test
Equipment procedure.

4. Configure the DUT to receive the HDMI input signal.
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Setup 3. DTG-AWG7102 composite jitter tolerance for all frequencies

oTG AWGETI0Z
— Exl Sloch in
- 0
- T
- | o o
AT - | - -
] == =4
[ saiizg ) -
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e T —_ 8
L ] —_
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1. Connect the test equipment for the DTG and AWG7102 connection as shown in the setup diagram.

2. When connecting the test fixture to the DUT, use a cable emulator specified for the pixel clock rate
being tested.

3. Connect the DTG, AWG7102, and the oscilloscope according to the Enable Remote Control of Test
Equipment procedure.

4. Configure the DUT to receive the HDMI input signal.

NOTE. Mkr2 does not need to be connected to the trigger input of the DTG.
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Setup 4. DTG-AWG7102 with separate jitter tolerance for all frequencies

oTG AWGTI0Z
-
-
gz
—EEmmm —
PREEEEST
==
= mmm=s [t ST
====S
- =
\'/ L T | o
L® | oTamn dipls drovs » . I [
L
—i
TG adides
Coable Ervieiod | | |

Sink DUT

LC

1. Connect the test equipment for the DTG and AWG7102 connection as shown in the setup diagram.

2. When connecting the test fixture to the DUT, use a cable emulator specified for the pixel clock rate
being tested.

3. Connect the DTG, AWG7102, and the oscilloscope according to the Enable Remote Control of Test
Equipment procedure.

4. Configure the DUT to receive the HDMI input signal.

124 TDSHT3 HDMI Compliance Test Software Online Help



How to ... Make Connections for Jitter Tolerance

For the DDS Method

Setup 1: To test the Sink DUT for Sink Jitter Tolerance test compliance

Sink Jitter Tolerance

LAN
GPIB/E-Net
GPIB/E-Net to GPIB converter Ext Reference Input (50, 3 Vp-p Max)
I
I
cPiB oPB
10 MHz Ext. Ref »

Reference Output X[ Input AFG GPIB
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DATAO N <I
DATAQ_P g j L
cookn T
CLOCK P g
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Power supply

NOTE. The DDS method does not need different hardware TTC filters (for each resolution) and cable
emulators because their effects are emulated by the software.

Perform the following steps for each TMDS clock rate supported by the Sink DUT. You do not need to test
a particular rate if another rate within +/~10% of that rate has already been tested.

1. Ensure that the Sink DUT port on which you perform the test is selected.
2. Connect the test equipment and DUT.

3. Connect the two AWGs, Bias-Tees, AFG, DPO/DSA70804/B, and TPA-P as shown in the setup
diagram. One AWG is used as the MASTER and the other AWG is used as the SLAVE (called AWG1
and AWG?2 respectively).

= AWGI1 Markerl+ output to oscilloscope Ch3 input
= AWG2 Markerl+ output to oscilloscope Ch4 input
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= AWGI Chl+ output to 120 PS TTC filter
= 120 PS TTC filter output to Bias-Tee #1 signal input (RF)
= Bias-Tee #1 signal output (RF and DC) to TMDS CLOCK+
= AWGI DC _OUT (1) to Bias-Tee #1 DC-level input (DC)

= AWGI Chl- output to 120 PS TTC filter
- 120 PS TTC filter output to Bias-Tee #2 signal input (RF)
= Bias-Tee #2 signal output (RF and DC) output to TMDS CLOCK-
= AWGI DC_OUT (2) to Bias-Tee #2 DC-level input (DC)

= AWGI1 Ch2+ output to 120 PS TTC filter
= 120 PS TTC filter output to Bias-Tee #3 signal input (RF)
= Bias-Tee #3 signal output (RF and DC) to TMDS DATA0+
= AWGI DC OUT (3) to Bias-Tee #3 DC-level input (DC)

= AWGI Ch2- output to 120 PS TTC filter
= 120 PS TTC filter output to Bias-Tee #4 signal input (RF)
- Bias-Tee #4 signal output (RF and DC) to TMDS DATAO0-
= AWGI DC OUT (4) to Bias-Tee #4 DC-level input (DC)

= AWG?2 Chl+ output to 120 PS TTC filter
= 120 PS TTC filter output to Bias-Tee #5 signal input (RF)
= Bias-Tee #5 signal output (RF and DC) to TMDS DATAI1+
= AWG2 DC _OUT (1) to Bias-Tee #5 DC-level input (DC)

= AWG?2 Chl- output to 120 PS TTC filter
= 120 PS TTC filter output to Bias-Tee #6 signal input (RF)
= Bias-Tee #6 signal output (RF and DC) to TMDS DATA1-
= AWG2 DC _OUT (2) to Bias-Tee #6 DC-level input (DC)

= AWG?2 Ch2+ output to 120 PS TTC filter
- 120 PS TTC filter output to Bias-Tee #7 signal input (RF)
- Bias-Tee #7 signal output (RF and DC) to TMDS DATA2+
= AWG2 DC OUT (3) to Bias-Tee #7 DC-level input (DC)

=  AWG2 Ch2- output to 120 PS TTC filter
= 120 PS TTC filter output to Bias-Tee #8 signal input (RF)
- Bias-Tee #8 signal output (RF and DC) to TMDS_DATA2—-
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= AWG2 DC_OUT (4) to Bias-Tee #8 DC-level input (DC)
= AFG3102 Chl using BNC-T adapter to trigger input of AWG1 and AWG2
= AFG3102 Ch2 to be connected to Ext Ref input of AWG2
= AWGI 10 MHz Ref output to be connected to AFG3102 Ext Ref input
4. Connect TPA-P to Sink DUT.

5. Connect and configure the DC power supply to drive +5 V between +5 V Power (P_5V) and
DDC/CEC Ground (P_GND) on the TPA-R-TDR.

6. Configure the application as follows:

= Run the TDSHT3 software (version with the Direct Synthesis capability) on the digital
oscilloscope.

= Select the DDS method in the configuration panel of the Sink Jitter Tolerance Test.
= Select the resolution of the DUT to be tested.

- Select the cable emulator to be used for the test (Direct Synthesis method emulates the TTC
filters and cable emulators).

= In the Signal Source dialog box, check the GPIB connection of the two AWGs and the AFG to
ensure proper connection.

- The TDSHTS3 software will also change the skew in 0.1 TBit steps automatically, for example,
0.0TBIT, 0.1TBIT, until OTBIT. In each step, you will be prompted to confirm if the DUT
adequately supports the signal.

= Once the test completes, you can view the result.
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Setup 2: To test the automotive Sink DUT for Sink Jitter Tolerance test using Type-E fixture

Sink Jitter Tolerence
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Setup 3: To calibrate the jitter values

Sink Jitter Tolerance

LAN
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NOTE. Terminate the lanes that are not connected with a 50 ohm terminator using a Bias-T which is
pulled up to 3.3 V.

1. Connect the two AWGs, Bias-Tees, AFG, DPO/DSA70804/B, and TPA-P as shown in the setup
diagram. One AWG is used as the MASTER and the other AWG is used as the SLAVE (called AWG1
and AWG2 respectively). For connection details, refer to step 3.

2. Connect TPA-P to TPA-R.

3. Connect the Clock and Data0 output of the TPA-R to the configured oscilloscope channel by using a
differential probe.

4. Connect and configure the DC power supply to drive +5 V between +5 V Power (P_5V) and
DDC/CEC Ground (P_GND) on the TPA-R-TDR.

5. Once the calibration is complete, connect the TPA-P to Sink DUT to continue with the test. Refer
Setup 1 (see page 125).
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Setup 4: To calibrate the jitter values using Type-E fixture

Sink Jitter Tolerance - Calibration

LAN
GPIB/E-Net
GPIB/E-Net to GPIB converter Ext Reference Input (50 £, 3 Vp-p Max)
1
I
GPIB GPIB
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NOTE. Terminate the lanes that are not connected with a 50 ohm terminator using a Bias-T which is
pulled up to 3.3 V.

Make Connections for Deep Color

On the menu bar, click Tests > Connect.
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For the DTG Method

Make the connections as follows:

DTG Digital oscilloscope
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= 222230
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For the DDS Method

To test the Sink DUT for Deep Color test compliance.

Sink Deep Color LAN
GPIB/E-Net
GPIB/E-Net to GPIB converter Ext Reference Input (504, 3 Vp-p Max)
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Perform the following steps for each TMDS clock rate supported by the Sink DUT.
1. Ensure that the Sink DUT port on which you perform the test is selected.
2. Connect the test equipment and DUT.

3. Connect the two AWGs, Bias-Tees, AFG, DPO/DSA70804/B, and TPA-P as shown in the setup
diagram. One AWG is used as the MASTER and the other AWG is used as the SLAVE (called AWGI
and AWG?2 respectively).

= AWGI Markerl+ output to oscilloscope Ch3 input

= AWG2 Markerl+ output to oscilloscope Ch4 input

= AWGI Chl+ output to 120 PS TTC filter
= 120 PS TTC filter output to Bias-Tee #1 signal input (RF)
- Bias-Tee #1 signal output (RF and DC) to TMDS CLOCK+
= AWGI DC_OUT (1) to Bias-Tee #1 DC-level input (DC)
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Make Connections for Deep Color

AWGI1 Chl- output to 120 PS TTC filter

= 120 PS TTC filter output to Bias-Tee #2 signal input (RF)

= Bias-Tee #2 signal output (RF and DC) output to TMDS CLOCK-
= AWGI1 DC OUT (2) to Bias-Tee #2 DC-level input (DC)
AWGTI1 Ch2+ output to 120 PS TTC filter

= 120 PS TTC filter output to Bias-Tee #3 signal input (RF)

= Bias-Tee #3 signal output (RF and DC) to TMDS DATAO+
= AWGI DC _OUT (3) to Bias-Tee #3 DC-level input (DC)
AWGTI Ch2- output to 120 PS TTC filter

= 120 PS TTC filter output to Bias-Tee #4 signal input (RF)

- Bias-Tee #4 signal output (RF and DC) to TMDS_ DATAO0-
= AWGI DC_OUT (4) to Bias-Tee #4 DC-level input (DC)
AWG2 Chl+ output to 120 PS TTC filter

= 120 PS TTC filter output to Bias-Tee #5 signal input (RF)

= Bias-Tee #5 signal output (RF and DC) to TMDS DATAI1+
= AWG2 DC OUT (1) to Bias-Tee #5 DC-level input (DC)
AWG2 Chl- output to 120 PS TTC filter

= 120 PS TTC filter output to Bias-Tee #6 signal input (RF)
= Bias-Tee #6 signal output (RF and DC) to TMDS DATA1-
= AWG2 DC _OUT (2) to Bias-Tee #6 DC-level input (DC)
AWG2 Ch2+ output to 120 PS TTC filter

= 120 PS TTC filter output to Bias-Tee #7 signal input (RF)
= Bias-Tee #7 signal output (RF and DC) to TMDS DATA2+
= AWG2 DC OUT (3) to Bias-Tee #7 DC-level input (DC)
AWG?2 Ch2- output to 120 PS TTC filter

- 120 PS TTC filter output to Bias-Tee #8 signal input (RF)

- Bias-Tee #8 signal output (RF and DC) to TMDS DATA2—
= AWG2 DC_OUT (4) to Bias-Tee #8 DC-level input (DC)
AFG3102 Chl using BNC-T adapter to trigger input of AWG1 and AWG2
AFG3102 Ch2 to be connected to Ext Ref input of AWG2
AWG1 10 MHz Ref output to be connected to AFG3102 Ext Ref input
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4. Connect TPA-P to Sink DUT.

5. Connect and configure the DC power supply to drive +5 V between +5 V Power (P_5V) and
DDC/CEC Ground (P_GND) on the TPA-R-TDR.

6. Configure the application as follows:

= Run the TDSHT3 software (version with the Direct Synthesis capability) on the digital
oscilloscope.

= Select the DDS method in the configuration panel of the Sink Deep Color Test.
= Select the resolution, refresh rate, and bits of the DUT to be tested.

= Select the particular pattern(s).

= Run the measurement.

= Check if the gray/color bar is visible on the DUT.

Make Connections for Audio Clock Regeneration

On the menu bar, click Tests > Connect.

For the DTG Method

Make the connections as follows:

Digital oscilloscope
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For the DDS Method

To test the Sink DUT for Audio Clock Regeneration test compliance.

Sink Deep Color LAN
GPIB/E-Net
GPIB/E-Net to GPIB converter Ext Reference Input (504, 3 Vp-p Max)
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Perform the following steps for each TMDS clock rate supported by the Sink DUT.
1. Ensure that the Sink DUT port on which you perform the test is selected.
2. Connect the test equipment and DUT.

3. Connect the two AWGs, Bias-Tees, AFG, DPO/DSA70804/B, and TPA-P as shown in the setup
diagram. One AWG is used as the MASTER and the other AWG is used as the SLAVE (called AWG]1
and AWG?2 respectively).

= AWGI1 Markerl+ output to oscilloscope Ch3 input

= AWG2 Markerl+ output to oscilloscope Ch4 input

= AWGI1 Chl+ output to 120 PS TTC filter
= 120 PS TTC filter output to Bias-Tee #1 signal input (RF)
- Bias-Tee #1 signal output (RF and DC) to TMDS CLOCK+
= AWGI DC_OUT (1) to Bias-Tee #1 DC-level input (DC)
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Make Connections for Audio Clock Regeneration

AWG]1 Chl- output to 120 PS TTC filter

= 120 PS TTC filter output to Bias-Tee #2 signal input (RF)

= Bias-Tee #2 signal output (RF and DC) output to TMDS CLOCK-
= AWGI DC _OUT (2) to Bias-Tee #2 DC-level input (DC)
AWG1 Ch2+ output to 120 PS TTC filter

- 120 PS TTC filter output to Bias-Tee #3 signal input (RF)

= Bias-Tee #3 signal output (RF and DC) to TMDS DATAO0+
= AWGI DC OUT (3) to Bias-Tee #3 DC-level input (DC)
AWGI1 Ch2- output to 120 PS TTC filter

= 120 PS TTC filter output to Bias-Tee #4 signal input (RF)
- Bias-Tee #4 signal output (RF and DC) to TMDS_DATAO—
= AWGI DC_OUT (4) to Bias-Tee #4 DC-level input (DC)
AWG?2 Chl+ output to 120 PS TTC filter

= 120 PS TTC filter output to Bias-Tee #5 signal input (RF)
= Bias-Tee #5 signal output (RF and DC) to TMDS_ DATA1+
= AWG2 DC OUT (1) to Bias-Tee #5 DC-level input (DC)
AWG?2 Chl- output to 120 PS TTC filter

= 120 PS TTC filter output to Bias-Tee #6 signal input (RF)
= Bias-Tee #6 signal output (RF and DC) to TMDS DATAI1-
= AWG2 DC _OUT (2) to Bias-Tee #6 DC-level input (DC)
AWG2 Ch2+ output to 120 PS TTC filter

= 120 PS TTC filter output to Bias-Tee #7 signal input (RF)
= Bias-Tee #7 signal output (RF and DC) to TMDS DATA2+
= AWG2 DC _OUT (3) to Bias-Tee #7 DC-level input (DC)
AWG2 Ch2- output to 120 PS TTC filter

- 120 PS TTC filter output to Bias-Tee #8 signal input (RF)
- Bias-Tee #8 signal output (RF and DC) to TMDS DATA2—
= AWG2 DC_OUT (4) to Bias-Tee #8 DC-level input (DC)
AFG3102 Chl using BNC-T adapter to trigger input of AWG1 and AWG2
AFG3102 Ch2 to be connected to Ext Ref input of AWG?2
AWG1 10 MHz Ref output to be connected to AFG3102 Ext Ref input
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4. Connect TPA-P to Sink DUT.

5. Connect and configure the DC power supply to drive +5 V between +5 V Power (P_5V) and
DDC/CEC Ground (P_GND) on the TPA-R-TDR.

6. Configure the application as follows:

= Run the TDSHT3 software (version with the Direct Synthesis capability) on the digital
oscilloscope.

= Select the DDS method in the configuration panel of the Audio Clock Regeneration Test.
= Select the resolution, refresh rate, and bits of the DUT to be tested.

= Select the particular pattern(s).

= Run the measurement.

= Check if the gray/color bar is visible on the DUT.

Make Connections for Audio Sample Packet Jitter

On the menu bar, click Tests > Connect.

For the DTG Method
Make the connections as follows:

Digital oscilloscope
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For the DDS Method

To test the Sink DUT for Audio Sample Packet Jitter test compliance.

Sink Deep Color LAN
GPIB/E-Net
GPIB/E-Net to GPIB converter Ext Reference Input (504, 3 Vp-p Max)
I
{ r
GPiB GPIB
10 MHz Ext. Ref >
Reference Output x| Input GPiB
AWGT102/AWGT122B | (MASTER) . = — (SLAVE)  AWGT102/AWGT1228
Je €
Digital Oscilloscope = = > &=
i = 9 =0
RS ol T EEEEEEE]
o =4 - o—0© ISR
IS - L - =) gg;g
] ==
al I | i
) ) (e® eege® ePPPPOOEPPOOEOQPE® 1| @ 4«—DC out
- i - T
&) | Analog (CH1""| ly] Trigger ' Trigger H
© 000 § B § § o | mmcH) Input : Input '
- — Digital \ '
Marker i ' !
outto ! Digital H
' Marker H
" Bias outto 1 Bias
Mkr1 ( CH1) E voltage Oscilloscope I 120 PSTTC filters 1 voltage
' E [ I | & H
| N || | & k(64
. Ele Sink DUT
EFF- HDMI- TPA- P
DATA2 N ©|
D2 pata2P
DATAT_N 4 """w—u,ﬁ@ ®
D1 DATA1_P Z‘J -
o1 0P o
DATAO_N ) ID
A —— o= %9 ©

CLOCK_N —
CK CLOCK_P. Py e
S—

o

Power supply

[05.00

[OO;:OO

R

Perform the following steps for each TMDS clock rate supported by the Sink DUT.
1. Ensure that the Sink DUT port on which you perform the test is selected.
2. Connect the test equipment and DUT.

3. Connect the two AWGs, Bias-Tees, AFG, DPO/DSA70804/B, and TPA-P as shown in the setup
diagram. One AWG is used as the MASTER and the other AWG is used as the SLAVE (called AWGI
and AWG?2 respectively).

= AWGI Markerl+ output to oscilloscope Ch3 input

= AWG2 Markerl+ output to oscilloscope Ch4 input

= AWGI Chl+ output to 120 PS TTC filter
= 120 PS TTC filter output to Bias-Tee #1 signal input (RF)
- Bias-Tee #1 signal output (RF and DC) to TMDS CLOCK+
= AWGI DC_OUT (1) to Bias-Tee #1 DC-level input (DC)
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Make Connections for Audio Sample Packet Jitter

AWGI1 Chl- output to 120 PS TTC filter

= 120 PS TTC filter output to Bias-Tee #2 signal input (RF)

= Bias-Tee #2 signal output (RF and DC) output to TMDS CLOCK-
= AWGI1 DC OUT (2) to Bias-Tee #2 DC-level input (DC)
AWGTI1 Ch2+ output to 120 PS TTC filter

= 120 PS TTC filter output to Bias-Tee #3 signal input (RF)

= Bias-Tee #3 signal output (RF and DC) to TMDS DATAO+
= AWGI DC _OUT (3) to Bias-Tee #3 DC-level input (DC)
AWGTI Ch2- output to 120 PS TTC filter

= 120 PS TTC filter output to Bias-Tee #4 signal input (RF)

- Bias-Tee #4 signal output (RF and DC) to TMDS_ DATAO0-
= AWGI DC_OUT (4) to Bias-Tee #4 DC-level input (DC)
AWG2 Chl+ output to 120 PS TTC filter

= 120 PS TTC filter output to Bias-Tee #5 signal input (RF)

= Bias-Tee #5 signal output (RF and DC) to TMDS DATAI1+
= AWG2 DC OUT (1) to Bias-Tee #5 DC-level input (DC)
AWG2 Chl- output to 120 PS TTC filter

= 120 PS TTC filter output to Bias-Tee #6 signal input (RF)
= Bias-Tee #6 signal output (RF and DC) to TMDS DATA1-
= AWG2 DC _OUT (2) to Bias-Tee #6 DC-level input (DC)
AWG2 Ch2+ output to 120 PS TTC filter

= 120 PS TTC filter output to Bias-Tee #7 signal input (RF)
= Bias-Tee #7 signal output (RF and DC) to TMDS DATA2+
= AWG2 DC OUT (3) to Bias-Tee #7 DC-level input (DC)
AWG?2 Ch2- output to 120 PS TTC filter

- 120 PS TTC filter output to Bias-Tee #8 signal input (RF)

- Bias-Tee #8 signal output (RF and DC) to TMDS DATA2—
= AWG2 DC_OUT (4) to Bias-Tee #8 DC-level input (DC)
AFG3102 Chl using BNC-T adapter to trigger input of AWG1 and AWG2
AFG3102 Ch2 to be connected to Ext Ref input of AWG2
AWG1 10 MHz Ref output to be connected to AFG3102 Ext Ref input
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4. Connect TPA-P to Sink DUT.

5. Connect and configure the DC power supply to drive +5 V between +5 V Power (P_5V) and
DDC/CEC Ground (P_GND) on the TPA-R-TDR.

6. Configure the application as follows:

= Run the TDSHT3 software (version with the Direct Synthesis capability) on the digital
oscilloscope.

= Select the DDS method in the configuration panel of the Sink Audio Sample Packet Jitter test.
= Select the resolution, refresh rate, and bits of the DUT to be tested.

= Select the particular pattern(s).

= Run the measurement.

= Check if the gray/color bar is visible on the DUT.

Make Connections for Audio Formats

On the menu bar, click Tests > Connect.

For the DTG Method

Make the connections as follows:

Digital oscilloscope
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For the DDS Method

To test the Sink DUT for Audio Formats test compliance.

Sink Deep Color LAN
GPIB/E-Net
GPIB/E-Net to GPIB converter Ext Reference Input (504, 3 Vp-p Max)
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Perform the following steps for each TMDS clock rate supported by the Sink DUT.
1. Ensure that the Sink DUT port on which you perform the test is selected.
2. Connect the test equipment and DUT.

3. Connect the two AWGs, Bias-Tees, AFG, DPO/DSA70804/B, and TPA-P as shown in the setup
diagram. One AWG is used as the MASTER and the other AWG is used as the SLAVE (called AWGI
and AWG?2 respectively).

= AWGI1 Markerl+ output to oscilloscope Ch3 input

= AWG2 Markerl+ output to oscilloscope Ch4 input

= AWGI1 Chl+ output to 120 PS TTC filter
= 120 PS TTC filter output to Bias-Tee #1 signal input (RF)
= Bias-Tee #1 signal output (RF and DC) to TMDS CLOCK+
= AWGI DC_OUT (1) to Bias-Tee #1 DC-level input (DC)
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Make Connections for Audio Formats

AWG]1 Chl- output to 120 PS TTC filter

= 120 PS TTC filter output to Bias-Tee #2 signal input (RF)

= Bias-Tee #2 signal output (RF and DC) output to TMDS CLOCK-
= AWGI DC _OUT (2) to Bias-Tee #2 DC-level input (DC)
AWG1 Ch2+ output to 120 PS TTC filter

- 120 PS TTC filter output to Bias-Tee #3 signal input (RF)

= Bias-Tee #3 signal output (RF and DC) to TMDS DATAO0+
= AWGI DC OUT (3) to Bias-Tee #3 DC-level input (DC)
AWGI1 Ch2- output to 120 PS TTC filter

= 120 PS TTC filter output to Bias-Tee #4 signal input (RF)
- Bias-Tee #4 signal output (RF and DC) to TMDS_DATAO—
= AWGI DC_OUT (4) to Bias-Tee #4 DC-level input (DC)
AWG?2 Chl+ output to 120 PS TTC filter

= 120 PS TTC filter output to Bias-Tee #5 signal input (RF)
= Bias-Tee #5 signal output (RF and DC) to TMDS_ DATA1+
= AWG2 DC OUT (1) to Bias-Tee #5 DC-level input (DC)
AWG?2 Chl- output to 120 PS TTC filter

= 120 PS TTC filter output to Bias-Tee #6 signal input (RF)
= Bias-Tee #6 signal output (RF and DC) to TMDS DATAI1-
= AWG2 DC _OUT (2) to Bias-Tee #6 DC-level input (DC)
AWG2 Ch2+ output to 120 PS TTC filter

= 120 PS TTC filter output to Bias-Tee #7 signal input (RF)
= Bias-Tee #7 signal output (RF and DC) to TMDS DATA2+
= AWG2 DC _OUT (3) to Bias-Tee #7 DC-level input (DC)
AWG2 Ch2- output to 120 PS TTC filter

- 120 PS TTC filter output to Bias-Tee #8 signal input (RF)
- Bias-Tee #8 signal output (RF and DC) to TMDS DATA2—
= AWG2 DC_OUT (4) to Bias-Tee #8 DC-level input (DC)
AFG3102 Chl using BNC-T adapter to trigger input of AWG1 and AWG2
AFG3102 Ch2 to be connected to Ext Ref input of AWG?2
AWG1 10 MHz Ref output to be connected to AFG3102 Ext Ref input
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4. Connect TPA-P to Sink DUT.

5. Connect and configure the DC power supply to drive +5 V between +5 V Power (P_5V) and
DDC/CEC Ground (P_GND) on the TPA-R-TDR.

6. Configure the application as follows:

= Run the TDSHT3 software (version with the Direct Synthesis capability) on the digital
oscilloscope.

= Select the DDS method in the configuration panel of the Sink Audio Formats Test.
= Select the resolution, refresh rate, and bits of the DUT to be tested.

= Select the particular pattern(s).

= Run the measurement.

= Check if the gray/color bar is visible on the DUT.

Make Connections for One Bit Audio

On the menu bar, click Tests > Connect.

For the DTG Method
Make the connections as follows:

Digital oscilloscope
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For the DDS Method

To test the Sink DUT for One Bit Audio test compliance.

Sink Deep Color LAN
GPIB/E-Net
GPIB/E-Net to GPIB converter Ext Reference Input (504, 3 Vp-p Max)
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Perform the following steps for each TMDS clock rate supported by the Sink DUT.
1. Ensure that the Sink DUT port on which you perform the test is selected.
2. Connect the test equipment and DUT.

3. Connect the two AWGs, Bias-Tees, AFG, DPO/DSA70804/B, and TPA-P as shown in the setup
diagram. One AWG is used as the MASTER and the other AWG is used as the SLAVE (called AWGI
and AWG?2 respectively).

= AWGI Markerl+ output to oscilloscope Ch3 input

= AWG2 Markerl+ output to oscilloscope Ch4 input

= AWGI Chl+ output to 120 PS TTC filter
= 120 PS TTC filter output to Bias-Tee #1 signal input (RF)
- Bias-Tee #1 signal output (RF and DC) to TMDS CLOCK+
= AWGI DC_OUT (1) to Bias-Tee #1 DC-level input (DC)
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AWGI1 Chl- output to 120 PS TTC filter

= 120 PS TTC filter output to Bias-Tee #2 signal input (RF)

= Bias-Tee #2 signal output (RF and DC) output to TMDS CLOCK-
= AWGI1 DC OUT (2) to Bias-Tee #2 DC-level input (DC)
AWGTI1 Ch2+ output to 120 PS TTC filter

= 120 PS TTC filter output to Bias-Tee #3 signal input (RF)

= Bias-Tee #3 signal output (RF and DC) to TMDS DATAO+
= AWGI DC _OUT (3) to Bias-Tee #3 DC-level input (DC)
AWGTI Ch2- output to 120 PS TTC filter

= 120 PS TTC filter output to Bias-Tee #4 signal input (RF)

- Bias-Tee #4 signal output (RF and DC) to TMDS_ DATAO0-
= AWGI DC_OUT (4) to Bias-Tee #4 DC-level input (DC)
AWG2 Chl+ output to 120 PS TTC filter

= 120 PS TTC filter output to Bias-Tee #5 signal input (RF)

= Bias-Tee #5 signal output (RF and DC) to TMDS DATAI1+
= AWG2 DC OUT (1) to Bias-Tee #5 DC-level input (DC)
AWG2 Chl- output to 120 PS TTC filter

= 120 PS TTC filter output to Bias-Tee #6 signal input (RF)
= Bias-Tee #6 signal output (RF and DC) to TMDS DATA1-
= AWG2 DC _OUT (2) to Bias-Tee #6 DC-level input (DC)
AWG2 Ch2+ output to 120 PS TTC filter

= 120 PS TTC filter output to Bias-Tee #7 signal input (RF)
= Bias-Tee #7 signal output (RF and DC) to TMDS DATA2+
= AWG2 DC OUT (3) to Bias-Tee #7 DC-level input (DC)
AWG?2 Ch2- output to 120 PS TTC filter

- 120 PS TTC filter output to Bias-Tee #8 signal input (RF)

- Bias-Tee #8 signal output (RF and DC) to TMDS DATA2—
= AWG2 DC_OUT (4) to Bias-Tee #8 DC-level input (DC)
AFG3102 Chl using BNC-T adapter to trigger input of AWG1 and AWG2
AFG3102 Ch2 to be connected to Ext Ref input of AWG2
AWG1 10 MHz Ref output to be connected to AFG3102 Ext Ref input
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4. Connect TPA-P to Sink DUT.

5. Connect and configure the DC power supply to drive +5 V between +5 V Power (P_5V) and
DDC/CEC Ground (P_GND) on the TPA-R-TDR.

6. Configure the application as follows:

= Run the TDSHT3 software (version with the Direct Synthesis capability) on the digital
oscilloscope.

= Select the DDS method in the configuration panel of the Sink One Bit Audio Test.
= Select the resolution, refresh rate, and bits of the DUT to be tested.

= Select the particular pattern(s).

= Run the measurement.

= Check if the gray/color bar is visible on the DUT.

Make Connections for DVI Interoperability

On the menu bar, click Tests > Connect.

For the DTG Method

Make the connections as follows:

Digital oscilloscope
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For the DDS Method

To test the Sink DUT for DVI Interoperability compliance.

Sink Deep Color LAN
GPIB/E-Net
GPIB/E-Net to GPIB converter Ext Reference Input (504, 3 Vp-p Max)
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Perform the following steps for each TMDS clock rate supported by the Sink DUT.
1. Ensure that the Sink DUT port on which you perform the test is selected.
2. Connect the test equipment and DUT.

3. Connect the two AWGs, Bias-Tees, AFG, DPO/DSA70804/B, and TPA-P as shown in the setup
diagram. One AWG is used as the MASTER and the other AWG is used as the SLAVE (called AWG]1
and AWG?2 respectively).

= AWGI1 Markerl+ output to oscilloscope Ch3 input

= AWG2 Markerl+ output to oscilloscope Ch4 input

= AWGI1 Chl+ output to 120 PS TTC filter
= 120 PS TTC filter output to Bias-Tee #1 signal input (RF)
- Bias-Tee #1 signal output (RF and DC) to TMDS CLOCK+
= AWGI DC_OUT (1) to Bias-Tee #1 DC-level input (DC)
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Make Connections for DVI Interoperability

AWG]1 Chl- output to 120 PS TTC filter

= 120 PS TTC filter output to Bias-Tee #2 signal input (RF)

= Bias-Tee #2 signal output (RF and DC) output to TMDS CLOCK-
= AWGI DC _OUT (2) to Bias-Tee #2 DC-level input (DC)
AWG1 Ch2+ output to 120 PS TTC filter

- 120 PS TTC filter output to Bias-Tee #3 signal input (RF)

= Bias-Tee #3 signal output (RF and DC) to TMDS DATAO0+
= AWGI DC OUT (3) to Bias-Tee #3 DC-level input (DC)
AWGI1 Ch2- output to 120 PS TTC filter

= 120 PS TTC filter output to Bias-Tee #4 signal input (RF)
- Bias-Tee #4 signal output (RF and DC) to TMDS_DATAO—
= AWGI DC_OUT (4) to Bias-Tee #4 DC-level input (DC)
AWG?2 Chl+ output to 120 PS TTC filter

= 120 PS TTC filter output to Bias-Tee #5 signal input (RF)
= Bias-Tee #5 signal output (RF and DC) to TMDS_ DATA1+
= AWG2 DC OUT (1) to Bias-Tee #5 DC-level input (DC)
AWG?2 Chl- output to 120 PS TTC filter

= 120 PS TTC filter output to Bias-Tee #6 signal input (RF)
= Bias-Tee #6 signal output (RF and DC) to TMDS DATAI1-
= AWG2 DC _OUT (2) to Bias-Tee #6 DC-level input (DC)
AWG2 Ch2+ output to 120 PS TTC filter

= 120 PS TTC filter output to Bias-Tee #7 signal input (RF)
= Bias-Tee #7 signal output (RF and DC) to TMDS DATA2+
= AWG2 DC _OUT (3) to Bias-Tee #7 DC-level input (DC)
AWG2 Ch2- output to 120 PS TTC filter

- 120 PS TTC filter output to Bias-Tee #8 signal input (RF)
- Bias-Tee #8 signal output (RF and DC) to TMDS DATA2—
= AWG2 DC_OUT (4) to Bias-Tee #8 DC-level input (DC)
AFG3102 Chl using BNC-T adapter to trigger input of AWG1 and AWG2
AFG3102 Ch2 to be connected to Ext Ref input of AWG?2
AWG1 10 MHz Ref output to be connected to AFG3102 Ext Ref input
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4. Connect TPA-P to Sink DUT.

5. Connect and configure the DC power supply to drive +5 V between +5 V Power (P_5V) and
DDC/CEC Ground (P_GND) on the TPA-R-TDR.

6. Configure the application as follows:

= Run the TDSHT3 software (version with the Direct Synthesis capability) on the digital
oscilloscope.

= Select the DDS method in the configuration panel of the Sink DVI Interoperability Test.
= Select the resolution, refresh rate, and bits of the DUT to be tested.

= Select the particular pattern(s).

= Run the measurement.

= Check if the gray/color bar is visible on the DUT.

Make Connections for 3D Video

On the menu bar, click Tests > Connect.

For the DTG Method
Make the connections as follows:

Digital oscilloscope
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For the DDS Method

To test the Sink DUT for 3D Video test compliance.

Sink Deep Color LAN
GPIB/E-Net
GPIB/E-Net to GPIB converter Ext Reference Input (504, 3 Vp-p Max)
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Perform the following steps for each TMDS clock rate supported by the Sink DUT.
1. Ensure that the Sink DUT port on which you perform the test is selected.
2. Connect the test equipment and DUT.

3. Connect the two AWGs, Bias-Tees, AFG, DPO/DSA70804/B, and TPA-P as shown in the setup
diagram. One AWG is used as the MASTER and the other AWG is used as the SLAVE (called AWGI
and AWG?2 respectively).

= AWGI Markerl+ output to oscilloscope Ch3 input

= AWG2 Markerl+ output to oscilloscope Ch4 input

= AWGI Chl+ output to 120 PS TTC filter
= 120 PS TTC filter output to Bias-Tee #1 signal input (RF)
- Bias-Tee #1 signal output (RF and DC) to TMDS CLOCK+
= AWGI DC_OUT (1) to Bias-Tee #1 DC-level input (DC)
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Make Connections for 3D Video

AWGI1 Chl- output to 120 PS TTC filter

= 120 PS TTC filter output to Bias-Tee #2 signal input (RF)

= Bias-Tee #2 signal output (RF and DC) output to TMDS CLOCK-
= AWGI1 DC OUT (2) to Bias-Tee #2 DC-level input (DC)
AWGTI1 Ch2+ output to 120 PS TTC filter

= 120 PS TTC filter output to Bias-Tee #3 signal input (RF)

= Bias-Tee #3 signal output (RF and DC) to TMDS DATAO+
= AWGI DC _OUT (3) to Bias-Tee #3 DC-level input (DC)
AWGTI Ch2- output to 120 PS TTC filter

= 120 PS TTC filter output to Bias-Tee #4 signal input (RF)

- Bias-Tee #4 signal output (RF and DC) to TMDS_ DATAO0-
= AWGI DC_OUT (4) to Bias-Tee #4 DC-level input (DC)
AWG2 Chl+ output to 120 PS TTC filter

= 120 PS TTC filter output to Bias-Tee #5 signal input (RF)

= Bias-Tee #5 signal output (RF and DC) to TMDS DATAI1+
= AWG2 DC OUT (1) to Bias-Tee #5 DC-level input (DC)
AWG2 Chl- output to 120 PS TTC filter

= 120 PS TTC filter output to Bias-Tee #6 signal input (RF)
= Bias-Tee #6 signal output (RF and DC) to TMDS DATA1-
= AWG2 DC _OUT (2) to Bias-Tee #6 DC-level input (DC)
AWG2 Ch2+ output to 120 PS TTC filter

= 120 PS TTC filter output to Bias-Tee #7 signal input (RF)
= Bias-Tee #7 signal output (RF and DC) to TMDS DATA2+
= AWG2 DC OUT (3) to Bias-Tee #7 DC-level input (DC)
AWG?2 Ch2- output to 120 PS TTC filter

- 120 PS TTC filter output to Bias-Tee #8 signal input (RF)

- Bias-Tee #8 signal output (RF and DC) to TMDS DATA2—
= AWG2 DC_OUT (4) to Bias-Tee #8 DC-level input (DC)
AFG3102 Chl using BNC-T adapter to trigger input of AWG1 and AWG2
AFG3102 Ch2 to be connected to Ext Ref input of AWG2
AWG1 10 MHz Ref output to be connected to AFG3102 Ext Ref input
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4. Connect TPA-P to Sink DUT.

5. Connect and configure the DC power supply to drive +5 V between +5 V Power (P_5V) and
DDC/CEC Ground (P_GND) on the TPA-R-TDR.

6. Configure the application as follows:

= Run the TDSHT3 software (version with the Direct Synthesis capability) on the digital
oscilloscope.

= Select the DDS method in the configuration panel of the Sink 3D Video Test.
= Select the resolution, refresh rate, and bits of the DUT to be tested.

= Select the particular pattern(s).

= Run the measurement.

= Check if the gray/color bar is visible on the DUT.

Make Connections for 4Kx2K Video

On the menu bar, click Tests > Connect.

For the DTG Method

Make the connections as follows:

Digital oscilloscope
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For the DDS Method

To test the Sink DUT for 4Kx2K Video test compliance.

Sink Deep Color LAN
GPIB/E-Net
GPIB/E-Net to GPIB converter Ext Reference Input (504, 3 Vp-p Max)
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Perform the following steps for each TMDS clock rate supported by the Sink DUT.
1. Ensure that the Sink DUT port on which you perform the test is selected.
2. Connect the test equipment and DUT.

3. Connect the two AWGs, Bias-Tees, AFG, DPO/DSA70804/B, and TPA-P as shown in the setup

diagram. One AWG is used as the MASTER and the other AWG is used as the SLAVE (called AWGI
and AWG?2 respectively).

= AWGI1 Markerl+ output to oscilloscope Ch3 input

= AWG2 Markerl+ output to oscilloscope Ch4 input

= AWGI1 Chl+ output to 120 PS TTC filter
= 120 PS TTC filter output to Bias-Tee #1 signal input (RF)
= Bias-Tee #1 signal output (RF and DC) to TMDS CLOCK+
= AWGI DC_OUT (1) to Bias-Tee #1 DC-level input (DC)
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Make Connections for 4Kx2K Video

AWG]1 Chl- output to 120 PS TTC filter

= 120 PS TTC filter output to Bias-Tee #2 signal input (RF)

= Bias-Tee #2 signal output (RF and DC) output to TMDS CLOCK-
= AWGI DC _OUT (2) to Bias-Tee #2 DC-level input (DC)
AWG1 Ch2+ output to 120 PS TTC filter

- 120 PS TTC filter output to Bias-Tee #3 signal input (RF)

= Bias-Tee #3 signal output (RF and DC) to TMDS DATAO0+
= AWGI DC OUT (3) to Bias-Tee #3 DC-level input (DC)
AWGI1 Ch2- output to 120 PS TTC filter

= 120 PS TTC filter output to Bias-Tee #4 signal input (RF)
- Bias-Tee #4 signal output (RF and DC) to TMDS_DATAO—
= AWGI DC_OUT (4) to Bias-Tee #4 DC-level input (DC)
AWG?2 Chl+ output to 120 PS TTC filter

= 120 PS TTC filter output to Bias-Tee #5 signal input (RF)
= Bias-Tee #5 signal output (RF and DC) to TMDS_ DATA1+
= AWG2 DC OUT (1) to Bias-Tee #5 DC-level input (DC)
AWG?2 Chl- output to 120 PS TTC filter

= 120 PS TTC filter output to Bias-Tee #6 signal input (RF)
= Bias-Tee #6 signal output (RF and DC) to TMDS DATAI1-
= AWG2 DC _OUT (2) to Bias-Tee #6 DC-level input (DC)
AWG2 Ch2+ output to 120 PS TTC filter

= 120 PS TTC filter output to Bias-Tee #7 signal input (RF)
= Bias-Tee #7 signal output (RF and DC) to TMDS DATA2+
= AWG2 DC _OUT (3) to Bias-Tee #7 DC-level input (DC)
AWG2 Ch2- output to 120 PS TTC filter

- 120 PS TTC filter output to Bias-Tee #8 signal input (RF)
- Bias-Tee #8 signal output (RF and DC) to TMDS DATA2—
= AWG2 DC_OUT (4) to Bias-Tee #8 DC-level input (DC)
AFG3102 Chl using BNC-T adapter to trigger input of AWG1 and AWG2
AFG3102 Ch2 to be connected to Ext Ref input of AWG?2
AWG1 10 MHz Ref output to be connected to AFG3102 Ext Ref input
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4. Connect TPA-P to Sink DUT.

5. Connect and configure the DC power supply to drive +5 V between +5 V Power (P_5V) and
DDC/CEC Ground (P_GND) on the TPA-R-TDR.

6. Configure the application as follows:

= Run the TDSHT3 software (version with the Direct Synthesis capability) on the digital
oscilloscope.

= Select the DDS method in the configuration panel of the Sink 4Kx2K Video Test.
= Select the resolution, refresh rate, and bits of the DUT to be tested.

= Select the particular pattern(s).

= Run the measurement.

= Check if the gray/color bar is visible on the DUT.

Make Connections for Extended Colors and Contents

On the menu bar, click Tests > Connect.

For the DTG Method
Make the connections as follows:

Digital oscilloscope
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For the DDS Method

To test the Sink DUT for Extended Colors and Contents test compliance.

Sink Deep Color LAN
GPIB/E-Net
GPIB/E-Net to GPIB converter Ext Reference Input (504, 3 Vp-p Max)
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Perform the following steps for each TMDS clock rate supported by the Sink DUT.
1. Ensure that the Sink DUT port on which you perform the test is selected.
2. Connect the test equipment and DUT.

3. Connect the two AWGs, Bias-Tees, AFG, DPO/DSA70804/B, and TPA-P as shown in the setup
diagram. One AWG is used as the MASTER and the other AWG is used as the SLAVE (called AWGI
and AWG?2 respectively).

= AWGI Markerl+ output to oscilloscope Ch3 input

= AWG2 Markerl+ output to oscilloscope Ch4 input

= AWGI Chl+ output to 120 PS TTC filter
= 120 PS TTC filter output to Bias-Tee #1 signal input (RF)
- Bias-Tee #1 signal output (RF and DC) to TMDS CLOCK+
= AWGI DC_OUT (1) to Bias-Tee #1 DC-level input (DC)
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Make Connections for Extended Colors and Contents

AWGI1 Chl- output to 120 PS TTC filter

= 120 PS TTC filter output to Bias-Tee #2 signal input (RF)

= Bias-Tee #2 signal output (RF and DC) output to TMDS CLOCK-
= AWGI1 DC OUT (2) to Bias-Tee #2 DC-level input (DC)
AWGTI1 Ch2+ output to 120 PS TTC filter

= 120 PS TTC filter output to Bias-Tee #3 signal input (RF)

= Bias-Tee #3 signal output (RF and DC) to TMDS DATAO+
= AWGI DC _OUT (3) to Bias-Tee #3 DC-level input (DC)
AWGTI Ch2- output to 120 PS TTC filter

= 120 PS TTC filter output to Bias-Tee #4 signal input (RF)

- Bias-Tee #4 signal output (RF and DC) to TMDS_ DATAO0-
= AWGI DC_OUT (4) to Bias-Tee #4 DC-level input (DC)
AWG2 Chl+ output to 120 PS TTC filter

= 120 PS TTC filter output to Bias-Tee #5 signal input (RF)

= Bias-Tee #5 signal output (RF and DC) to TMDS DATAI1+
= AWG2 DC OUT (1) to Bias-Tee #5 DC-level input (DC)
AWG2 Chl- output to 120 PS TTC filter

= 120 PS TTC filter output to Bias-Tee #6 signal input (RF)
= Bias-Tee #6 signal output (RF and DC) to TMDS DATA1-
= AWG2 DC _OUT (2) to Bias-Tee #6 DC-level input (DC)
AWG2 Ch2+ output to 120 PS TTC filter

= 120 PS TTC filter output to Bias-Tee #7 signal input (RF)
= Bias-Tee #7 signal output (RF and DC) to TMDS DATA2+
= AWG2 DC OUT (3) to Bias-Tee #7 DC-level input (DC)
AWG?2 Ch2- output to 120 PS TTC filter

- 120 PS TTC filter output to Bias-Tee #8 signal input (RF)

- Bias-Tee #8 signal output (RF and DC) to TMDS DATA2—
= AWG2 DC_OUT (4) to Bias-Tee #8 DC-level input (DC)
AFG3102 Chl using BNC-T adapter to trigger input of AWG1 and AWG2
AFG3102 Ch2 to be connected to Ext Ref input of AWG2
AWG1 10 MHz Ref output to be connected to AFG3102 Ext Ref input
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4. Connect TPA-P to Sink DUT.

5. Connect and configure the DC power supply to drive +5 V between +5 V Power (P_5V) and
DDC/CEC Ground (P_GND) on the TPA-R-TDR.

6. Configure the application as follows:

= Run the TDSHT3 software (version with the Direct Synthesis capability) on the digital
oscilloscope.

= Select the DDS method in the configuration panel of the Sink Extended Colors and Contents Test.
= Select the resolution, refresh rate, and bits of the DUT to be tested.

= Select the particular pattern(s).

= Run the measurement.

= Check if the gray/color bar is visible on the DUT.

Make Connections for Sink Intra-Pair Skew

158

On the menu bar, click Tests > Connect.

NOTE. The following procedure is for the clock intra-pair skew test. For other pairs, interchange
the connection of DATA <X> P with CLOCK P and DATA <X> N with CLOCK N. Changes the
configuration of the DTG Outputs accordingly.

For example, to calculate the intra-pair skew of Data0:

Connect DATAO P to Module A1+, DATAO N to DTG Module A2+, CLOCK P to Module Bl+, and
CLOCK N to module Bl-.

Method 1: Using HDMI 1.2 test fixtures

Setup 1. To measure Tbit

Make the connections as follows:

NOTE. Use channel Al of the DTG instead of channel A2 (shown in figure) to make connections for
Tbit measurements.
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LAN
E-Net
E-Met to GPIB convertor [T
Digial Oscilloscope
Power Supply ——— -
oTG it ] B =0
l . . oFi%a
SO PEcE
= o= o=a=e=
= Z==== ] o e o We
g |= o000 — —
; it XL B
\f » & L F 1) . :
. w
Al o
= g
w1 E .
“, g e
T E o ™ =
r . :
i Sx D I mTE ey
g £5 ° L
i L
= -
. ok
T HOMITEA- R0
Cabla E

NOTE. Using the Cable Emulator/Cable is not mandatory. You can connect a TPA-P-TDR fixture directly
to the DUT. If you find this inconvenient, use the Cable Emulator/Cable to connect the DUT conveniently.

TDSHT3 HDMI Compliance Test Software Online Help 159



How to ... Make Connections for Sink Intra-Pair Skew

1. Connect the DTG to the TPA-R-TDR by using eight one-meter (preferable) or one-and-a-half meter
SMA cables:

= Module A, Channel 1+: Connect to CLOCK P
= Module A, Channel 1—: No Connection
= Module A, Channel 2+: Connect to CLOCK N
= Module A, Channel 2-: No Connection
- Module B, Channel 1+, 1-: Connect to DATAO P and DATAO N
= Module B, Channel 2+, 2—: Connect to DATA1 P and DATA1 N
= Module C, Channel 1+, 1—: Connect to DATA1 P and DATA1 N
= Module C, Channel 2+, 2—: No Connection

2. Connect the TPA-R-TDR to the Cable Emulator.

3. Connect the TPA-R-DI to the Cable Emulator.

4. Connect a Clock to the configured oscilloscope channel by using a differential probe.
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Setup 2. To find intra-pair skew of the Sink DUT

Make the connections as follows:

Livn
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E-Met to GPIB convertor

orG

Pawer Supply
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- || HDMI-TPA-R-TDR

E-Net

Digital Oscilloscope

et e ey

Sink DUT

Cable

NOTE. Using the Cable Emulator/Cable is not mandatory. You can connect a TPA-P-TDR fixture directly
to the DUT. If you find this inconvenient, use the Cable Emulator/Cable to connect the DUT conveniently.

1. Remove the TPA-R-DI test fixture from the Cable Emulator.
2. Connect the Sink DUT to the Cable Emulator.

3. Connect and configure the DC power supply to drive +5 V between +5 V Power (P_5V) and

DDC/CEC Ground (P_GND) on the TPA-R-TDR.
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Method 2: Using Efficere test fixtures

Setup 1. To find intra-pair skew of the Sink DUT with the Efficere Test Fixture

Make the connections as follows:

oTE

Sink DUT

Lz

|

EEIIE B (==

m  Connect and configure the DC power supply to drive +5 V between +5 V Power (P_5V) and
DDC/CEC Ground (P_GND) on the HDMI-TPA-P.

B Configure the DUT to receive the HDMI input signal.
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For 4-Channel.

Make the connections as follows:

Digital Ceciloscope
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Sink DUT
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m  Connect and configure the DC power supply to drive +5 V between +5 V Power (P_5V) and
DDC/CEC Ground (P_GND) on the HDMI-TPA-P.

m  Configure the DUT to receive the HDMI input signal.

®m  Run the Sink Intra-Pair skew test using TDSHT3 software to execute the 4-channel intra-pair skew
measurement.

B Once the test completes, you can view the result.
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For the DDS Method

Step 1: To measure Thit

Make the connections as follows:
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NOTE. Terminate the lanes that are not connected with a 50 ohm terminator using a Bias-T which is
pulled up to 3.3 V.

1. Ensure that the Sink DUT port on which you perform the test is selected.
2. Connect the test equipment and DUT.

3. Connect the two AWGs, Bias-Tees, AFG, DPO/DSA70804/B, and TPA-P as shown in the setup

diagram. One AWG is used as the MASTER and the other AWG is used as the SLAVE (called AWGI
and AWG?2 respectively).

= AWGI Channell+ output to oscilloscope Ch3 input
= AWG2 Channell+ output to oscilloscope Ch4 input
= AWGI Markerl (Chl) output to 6 dB attenuator
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6 dB attenuator to 0-6400 MHz low pass filter

0-6400 MHz low pass filter output to Bias-Tee #1 signal input (RF)
Bias-Tee #1 signal output (RF and DC) to TMDS CLOCK+
AWGI1 DC _OUT (1) to Bias-Tee #1 DC-level input (DC)

= AWGI Marker2 (Chl) output to 6 dB attenuator

6 dB attenuator to 0-6400 MHz low pass filter

0-6400 MHz low pass filter output to Bias-Tee #3 signal input (RF)
Bias-Tee #3 signal output (RF and DC) to TMDS DATAO0+

AWGI1 DC_OUT (3) to Bias-Tee #3 DC-level input (DC)

= AWGI Markerl (Ch2) output to 6 dB attenuator

6 dB attenuator to 0-6400 MHz low pass filter

0-6400 MHz low pass filter output to Bias-Tee #5 signal input (RF)
Bias-Tee #5 signal output (RF and DC) to TMDS DATA1+
AWG2 DC_OUT (1) to Bias-Tee #5 DC-level input (DC)

= AWGI Marker2 (Ch2) output to 6 dB attenuator

6 dB attenuator to 0-6400 MHz low pass filter

0-6400 MHz low pass filter output to Bias-Tee #7 signal input (RF)
Bias-Tee #7 signal output (RF and DC) to TMDS DATA2+
AWG2 DC_OUT (3) to Bias-Tee #7 DC-level input (DC)

= AWG2 Markerl (Chl) output to 6 dB attenuator

6 dB attenuator to 0-6400 MHz low pass filter

0-6400 MHz low pass filter output to Bias-Tee #2 signal input (RF)
Bias-Tee #2 signal output (RF and DC) output to TMDS CLOCK-—
AWGI1 DC _OUT (2) to Bias-Tee #2 DC-level input (DC)

= AWG2 Marker2 (Chl) output to 6 dB attenuator

6 dB attenuator to 0-6400 MHz low pass filter

0-6400 MHz low pass filter output to Bias-Tee #4 signal input (RF)
Bias-Tee #4 signal output (RF and DC) to TMDS DATAO0-

AWGI DC_OUT (4) to Bias-Tee #4 DC-level input (DC)

= AWG2 Markerl (Ch2) output to 6 dB attenuator

6 dB attenuator to 0-6400 MHz low pass filter
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Make Connections for Sink Intra-Pair Skew

= 0-6400 MHz low pass filter output to Bias-Tee #6 signal input (RF)
= Bias-Tee #6 signal output (RF and DC) to TMDS DATAI1-

= AWG2 DC _OUT (2) to Bias-Tee #6 DC-level input (DC)

AWG?2 Marker2 (Ch2) output to 6 dB attenuator

= 6 dB attenuator to 0-6400 MHz low pass filter

= 0-6400 MHz low pass filter output to Bias-Tee #8 signal input (RF)
= Bias-Tee #8 signal output (RF and DC) to TMDS_ DATA2—-

= AWG2 DC OUT (4) to Bias-Tee #8 DC-level input (DC)
AFG3102 Chl using BNC-T adapter to trigger input of AWG1 and AWG2
AFG3102 Ch2 to be connected to Ext Ref input of AWG?2

AWGI 10 MHz Ref output to be connected to AFG3102 Ext Ref input

Connect TPA-P to TPA-R.

Connect the Clock output of the TPA-R to the configured oscilloscope channel by using a differential
probe.

Connect and configure the DC power supply to drive +5 V between +5 V Power (P_5V) and
DDC/CEC Ground (P_GND) on the TPA-R-TDR.

Configure the application as follows:

Run the TDSHT3 software (version with the Direct Synthesis capability) on the digital
oscilloscope.

Select the DDS method in the configuration panel of the Sink Intra-Pair Skew Test.
Select the resolution of the DUT to be tested.
Run the measurement to calculate T-bit.

Determine the skew to be applied on the channels using the calculated T-bit.
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Step 2: To perform Intra-Pair Skew test on the Sink DUT using skew on one channel
Make the connections as follows:
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1. Ensure that the Sink DUT port on which you perform the test is selected.

2. Connect the test equipment and DUT.

3. Connect the two AWGs, Bias-Tees, AFG, DPO/DSA70804/B, and TPA-P as shown in the setup
diagram. One AWG is used as the MASTER and the other AWG is used as the SLAVE (called AWGl1
and AWG?2 respectively).

= AWGTI Channell+ output to oscilloscope Ch3 input
= AWG2 Channell+ output to oscilloscope Ch4 input
= AWGI1 Markerl (Chl) output to 6 dB attenuator
= 6 dB attenuator to 0-6400 MHz low pass filter
= 0-6400 MHz low pass filter output to Bias-Tee #1 signal input (RF)
- Bias-Tee #1 signal output (RF and DC) to TMDS CLOCK+
= AWGI DC OUT (1) to Bias-Tee #1 DC-level input (DC)
- AWGI Markerl (Chl) output to 6 dB attenuator
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6 dB attenuator to 0-6400 MHz low pass filter

0-6400 MHz low pass filter output to Bias-Tee #2 signal input (RF)
Bias-Tee #2 signal output (RF and DC) output to TMDS CLOCK-—
AWGI1 DC OUT (2) to Bias-Tee #2 DC-level input (DC)

= AWGI Marker2 (Chl) output to 6 dB attenuator

6 dB attenuator to 0-6400 MHz low pass filter

0-6400 MHz low pass filter output to Bias-Tee #3 signal input (RF)
Bias-Tee #3 signal output (RF and DC) to TMDS DATAO+

AWGI1 DC _OUT (3) to Bias-Tee #3 DC-level input (DC)

= AWGI Marker2 (Chl) output to 6 dB attenuator

6 dB attenuator to 0-6400 MHz low pass filter

0-6400 MHz low pass filter output to Bias-Tee #4 signal input (RF)
Bias-Tee #4 signal output (RF and DC) to TMDS DATAO0-—

AWG1 DC _OUT (4) to Bias-Tee #4 DC-level input (DC)

= AWGI Markerl (Ch2) output to 6 dB attenuator

6 dB attenuator to 0-6400 MHz low pass filter

0-6400 MHz low pass filter output to Bias-Tee #5 signal input (RF)
Bias-Tee #5 signal output (RF and DC) to TMDS_ DATA1+
AWG2 DC_OUT (1) to Bias-Tee #5 DC-level input (DC)

= AWG2 Markerl (Ch2) output to 6 dB attenuator

6 dB attenuator to 0-6400 MHz low pass filter

0-6400 MHz low pass filter output to Bias-Tee #6 signal input (RF)
Bias-Tee #6 signal output (RF and DC) to TMDS DATA1-
AWG2 DC _OUT (2) to Bias-Tee #6 DC-level input (DC)

= AWGI Marker2 (Ch2) output to 6 dB attenuator

6 dB attenuator to 0-6400 MHz low pass filter

0-6400 MHz low pass filter output to Bias-Tee #7 signal input (RF)
Bias-Tee #7 signal output (RF and DC) to TMDS DATA2+
AWG2 DC _OUT (3) to Bias-Tee #7 DC-level input (DC)

= AWGI Marker2 (Ch2) output to 6 dB attenuator

168

6 dB attenuator to 0-6400 MHz low pass filter
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= 0-6400 MHz low pass filter output to Bias-Tee #8 signal input (RF)
= Bias-Tee #8 signal output (RF and DC) to TMDS DATA2—
= AWG2 DC _OUT (4) to Bias-Tee #8 DC-level input (DC)
= AFG3102 Chl using BNC-T adapter to trigger input of AWG1 and AWG2
= AFG3102 Ch2 to be connected to Ext Ref input of AWG2
= AWGI 10 MHz Ref output to be connected to AFG3102 Ext Ref input
4. Connect TPA-P to Sink DUT.

5. Connect and configure the DC power supply to drive +5 V between +5 V Power (P_5V) and
DDC/CEC Ground (P_GND) on the TPA-R-TDR.

6. Configure the application as follows:

= Run the TDSHT3 software (version with the Direct Synthesis capability) on the digital
oscilloscope.

= Select the DDS method in the configuration panel of the Sink Intra-Pair Skew Test.
= Select the resolution of the DUT to be tested.

= In the Signal Source dialog box, check the GPIB connection of the two AWGs and the AFG to
ensure proper connection.

= The TDSHTS3 software will also change the skew in 0.1 TBit steps automatically, for example,
0.0TBIT, 0.1TBIT, until 0.6TBIT. In each step, you will be prompted to confirm if the DUT
adequately supports the signal.

= Once the test completes, you can view the result.
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Step 3: To perform Intra-Pair Skew test on the Sink DUT using skew on all channels

Make the connections as follows:

Sink Itra-Pair Skew
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1. Ensure that the Sink DUT port on which you perform the test is selected.
2. Connect the test equipment and DUT.

3. Connect the two AWGs, Bias-Tees, AFG, DPO/DSA70804/B, and TPA-P as shown in the setup
diagram. One AWG is used as the MASTER and the other AWG is used as the SLAVE (called AWGI
and AWG?2 respectively).

= AWGI Channell+ output to oscilloscope Ch3 input
= AWG?2 Channell+ output to oscilloscope Ch4 input
= AWGI1 Markerl (Chl) output to 6 dB attenuator
- 6 dB attenuator to 0-6400 MHz low pass filter
= 0-6400 MHz low pass filter output to Bias-Tee #1 signal input (RF)
- Bias-Tee #1 signal output (RF and DC) to TMDS CLOCK+
= AWGI DC_OUT (1) to Bias-Tee #1 DC-level input (DC)
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AWG]1 Marker2 (Chl) output to 6 dB attenuator

- 6 dB attenuator to 0-6400 MHz low pass filter

= 0-6400 MHz low pass filter output to Bias-Tee #3 signal input (RF)
= Bias-Tee #3 signal output (RF and DC) to TMDS DATAO+

= AWGI1 DC OUT (3) to Bias-Tee #3 DC-level input (DC)

AWGT1 Markerl (Ch2) output to 6 dB attenuator

= 6 dB attenuator to 0-6400 MHz low pass filter

= 0-6400 MHz low pass filter output to Bias-Tee #5 signal input (RF)
= Bias-Tee #5 signal output (RF and DC) to TMDS_DATAI1+

= AWG2 DC_OUT (1) to Bias-Tee #5 DC-level input (DC)

AWG1 Marker2 (Ch2) output to 6 dB attenuator

= 6 dB attenuator to 0-6400 MHz low pass filter

- 0-6400 MHz low pass filter output to Bias-Tee #7 signal input (RF)
= Bias-Tee #7 signal output (RF and DC) to TMDS DATA2+

= AWG2 DC _OUT (3) to Bias-Tee #7 DC-level input (DC)

AWG2 Markerl (Chl) output to 6 dB attenuator

6 dB attenuator to 0-6400 MHz low pass filter

0-6400 MHz low pass filter output to Bias-Tee #2 signal input (RF)
Bias-Tee #2 signal output (RF and DC) output to TMDS CLOCK-
AWG1 DC_OUT (2) to Bias-Tee #2 DC-level input (DC)

AWG2 Marker2 (Chl) output to 6 dB attenuator

- 6 dB attenuator to 0-6400 MHz low pass filter

= 0-6400 MHz low pass filter output to Bias-Tee #4 signal input (RF)
= Bias-Tee #4 signal output (RF and DC) to TMDS DATAO0-

= AWGI1 DC OUT (4) to Bias-Tee #4 DC-level input (DC)

AWG?2 Markerl (Ch2) output to 6 dB attenuator

6 dB attenuator to 0-6400 MHz low pass filter

= 0-6400 MHz low pass filter output to Bias-Tee #6 signal input (RF)
= Bias-Tee #6 signal output (RF and DC) to TMDS DATA1-

= AWG2 DC_OUT (2) to Bias-Tee #6 DC-level input (DC)

AWG?2 Marker2 (Ch2) output to 6 dB attenuator
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- 6 dB attenuator to 0-6400 MHz low pass filter

= 0-6400 MHz low pass filter output to Bias-Tee #8 signal input (RF)

= Bias-Tee #8 signal output (RF and DC) to TMDS DATA2-

= AWG2 DC _OUT (4) to Bias-Tee #8 DC-level input (DC)
= AFG3102 Chl using BNC-T adapter to trigger input of AWG1 and AWG2
= AFG3102 Ch2 to be connected to Ext Ref input of AWG2
= AWGI 10 MHz Ref output to be connected to AFG3102 Ext Ref input

4. Connect TPA-P to Sink DUT.
5. Connect and configure the DC power supply to drive +5 V between +5 V Power (P_5V) and

DDC/CEC Ground (P_GND) on the TPA-R-TDR.

6. Configure the application as follows:

= Run the TDSHT3 software (version with the Direct Synthesis capability) on the digital
oscilloscope.

= Select the DDS method in the configuration panel of the Sink Intra-Pair Skew Test.
= Select the resolution of the DUT to be tested.

- In the Signal Source dialog box, check the GPIB connection of the two AWGs and the AFG to
ensure proper connection.

= The TDSHT3 software will also change the skew in 0.1 TBit steps automatically, for example,
0.0TBIT, 0.1TBIT, until 0.6TBIT. In each step, you will be prompted to confirm if the DUT
adequately supports the signal.

= Once the test completes, you can view the result.

Make Connections for Cable Eye Diagram

On the menu bar, click Tests > Connect.

For the DTG Method

172

Setup diagram for TP1

Make the connections as follows:
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Method 1: Using HDMI 1.2 test fixtures

Make Connections for Cable Eye Diagram

E-Hat

E-Met 12 GPIE corverar
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Method 2: Using Efficere test fixtures
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For 4-Channel

0TG

Make Connections for Cable Eye Diagram
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For 4-Channel with AFG Jitter Insertion
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1. Connect the DTG to the “input” TPA-P-TDR/ET-TPA-P adapter by using eight one-meter (preferable)
or one-and-a-half meter SMA cables:

= Module A, Channel 1+, 1—: Connect to CLOCK P and CLOCK N
= Module A, Channel 2+, 2—: No Connection

- Module B, Channel 1+, 1—: Connect to DATAO P and DATAO0 N
= Module B, Channel 2+, 2—: Connect to DATA1 P and DATA1 N
= Module C, Channel 1+, 1—: Connect to DATA2 P and DATA2 N
= Module C, Channel 2+, 2—: No Connection

2. Connect the oscilloscope to the “output” TPA-R-DI adapter by using two/four differential probes, and
supply 3.3 V power.
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3. Connect a TMDS Clock to the configured oscilloscope channel by using a differential probe.

4. Connect the TMDS Data pair(s) on which you will conduct the test to the configured oscilloscope
channel by using a second differential probe(s).

Setup diagram for TP2

Make the connections as follows:
Method 1: Using HDMI 1.2 test fixtures
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Method 2: Using Efficere test fixtures

Make Connections for Cable Eye Diagram
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For 4-Channel
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For 4-Channel with AFG Jitter Insertion
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Cable DUT

Remove the TPA-P-DI/ET-TPA-P test adapter.
Connect the Cable DUT.
Connect the TPA-R-DI test adapter.

Connect a TMDS Clock to the configured oscilloscope channel by using a differential probe.

ho s Wb

Connect the TMDS Data pair(s) on which you will conduct the test to the configured oscilloscope
channel by using a second differential probe(s).
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For the DDS Method

Setup 1: To confirm worst case TP1 signal

Cable Eye Diagram
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Perform the following steps for each TMDS clock rate supported by the HDMI Cable DUT.

1. Connect the two AWGs, Bias-Tees, AFG, DPO/DSA70804/B, TPA-P, and TPA-R as shown in the
setup diagram. One AWG is used as the MASTER and the other AWG is used as the SLAVE (called

AWGI1 and AWG?2 respectively).
= AWGI1 Chl+ output to 120 PS TTC filter
= 120 PS TTC filter output to Bias-Tee #1 signal input (RF)
= Bias-Tee #1 signal output (RF and DC) to TMDS CLOCK+
= AWGI DC_OUT (1) to Bias-Tee #1 DC-level input (DC)
= AWGTI Chl- output to 120 PS TTC filter
= 120 PS TTC filter output to Bias-Tee #2 signal input (RF)
= Bias-Tee #2 signal output (RF and DC) output to TMDS CLOCK-
= AWGI DC_OUT (2) to Bias-Tee #2 DC-level input (DC)
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Make Connections for Cable Eye Diagram

AWG1 Ch2+ output to 120 PS TTC filter

= 120 PS TTC filter output to Bias-Tee #3 signal input (RF)

= Bias-Tee #3 signal output (RF and DC) to TMDS DATA(O+
= AWGI DC_OUT (3) to Bias-Tee #3 DC-level input (DC)
AWGI1 Ch2- output to 120 PS TTC filter

= 120 PS TTC filter output to Bias-Tee #4 signal input (RF)

- Bias-Tee #4 signal output (RF and DC) to TMDS DATAO0-
= AWGI DC OUT (4) to Bias-Tee #4 DC-level input (DC)
AWG?2 Chl+ output to 120 PS TTC filter

= 120 PS TTC filter output to Bias-Tee #5 signal input (RF)
- Bias-Tee #5 signal output (RF and DC) to TMDS DATA1+
= AWG2 DC_OUT (1) to Bias-Tee #5 DC-level input (DC)
AWG?2 Chl- output to 120 PS TTC filter

= 120 PS TTC filter output to Bias-Tee #6 signal input (RF)
= Bias-Tee #6 signal output (RF and DC) to TMDS_DATA1-
- AWG2 DC_OUT (2) to Bias-Tee #6 DC-level input (DC)
AWG2 Ch2+ output to 120 PS TTC filter

= 120 PS TTC filter output to Bias-Tee #7 signal input (RF)
= Bias-Tee #7 signal output (RF and DC) to TMDS DATA2+
= AWG2 DC _OUT (3) to Bias-Tee #7 DC-level input (DC)
AWG2 Ch2- output to 120 PS TTC filter

= 120 PS TTC filter output to Bias-Tee #8 signal input (RF)
= Bias-Tee #8 signal output (RF and DC) to TMDS DATA2—
= AWG2 DC _OUT (4) to Bias-Tee #8 DC-level input (DC)
AFG3102 Chl using BNC-T adapter to trigger input of AWG1 and AWG2
AFG3102 Ch2 to be connected to Ext Ref input of AWG?2
AWGI1 10 MHz Ref output to be connected to AFG3102 Ext Ref input

Connect TPA-P to TPA-R.
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3. Configure the application as follows:

= Run the TDSHT3 software (version with the Direct Synthesis capability) on the digital
oscilloscope.

= Select the DDS method in the configuration panel of the Cable Eye Diagram Test.

= Select the cable frequency based on the category of the cable (74 MHz, 165 MHz, 340 MHz,
74 MHz Type-E).

= In the Signal Source dialog box, check the GPIB connection of the two AWGs and the AFG to
ensure proper connection.

= Once the test completes, you can verify the TP1/TP5 worst case eye diagram.

Setup 2: To confirm worst case TP1 signal using Type-E fixture

Cable Eye Diagram
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Make Connections for Cable Eye Diagram

Setup 3: To test the Cable DUT
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Perform the following steps for each TMDS clock rate supported by the HDMI Cable DUT.

1.

Connect the two AWGs, Bias-Tees, AFG, DPO/DSA70804/B, and TPA-Rs as shown in the setup
diagram. One AWG is used as the MASTER and the other AWG is used as the SLAVE (called AWG]I
and AWG2 respectively). For connection details, refer to step 3 of the TP1 procedure.

Connect TPA-R to two ends of HDMI Cable DUT.

Configure the application as follows:

Run the TDSHT3 software (version with the Direct Synthesis capability) on the digital
oscilloscope.

Select the DDS method in the configuration panel of the Cable Eye Diagram Test.

Select the cable frequency based on the category of the cable (74 MHz, 165 MHz, 340 MHz,
74 MHz Type-E).

In the Signal Source dialog box, check the GPIB connection of the two AWGs and the AFG to
ensure proper connection.

Once the test completes, you can view the result.
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Setup 4: To test the Cable DUT using Type-E fixture

Cable Eye Diagram
LAN
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Make Connections for Cable Inter-Pair Skew

NOTE. This Cable Inter-Pair Skew test is performed only for repeater cable testing.

Setup 1: To synchronize both the AWGs

Make the connections as follows:
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g"a\ug[w]/" Hriggarlnpﬂ i Analng (CH1) o JTngger
A (CH) L !

186

GPIB [
101 Ext.Ref GFIR
Referance Outpt X Input AFG
ANGFIOE /ANGHZZE | MASTER) - = (SLAVE)  ANGTI02 ZANGTIZ2B

Make Connections for Cable Inter-Pair Skew

Cable Inter Pair Skew
LAM

GPIBVE-Net

GPIBJE-Net to GFIE corwerter Ext Reference Input (50 11,3 V< Max)

] #

k4

[XTg
b oo

= -e - o= Digital Dscilloscope
= = 2 ] == —
-
Ses Slamen == SEE Slame =<
- [ — =) == e EEEEET)
e Oz = Y S
0 =e == === oH e == == SE ]
- = 5=% o
e e O m______ == 15
HEH RO RIS @GS |:||m DCout |:||o &
i
] o

Inaloq (CH1)

=
Input ! | )
“nalog (CH2) T

T
|
[Q—ﬂ] Mpalog [CH2) i
120 P TTC fiters !
| Bias
] ______________,'m:lrlage

EFF- HDMI TRA - R

uuuu ooy

f HDM

T
EFF- HOMI- TPA- R =

Y

HOMI Cable DUT

Connect the two AWGs, Bias-Tees, AFG, DPO/DSA70804/B, and TPA-P as shown in the setup

diagram. One AWG is used as the MASTER and the other AWG is used as the SLAVE (called AWGI
and AWG?2 respectively).

= AWGI Markerl+ output to oscilloscope Ch3 input

= AWG?2 Markerl+ output to oscilloscope Ch4 input

= AWGI Chl+ output to 120 PS TTC filter
= 120 PS TTC filter output to Bias-Tee #1 signal input (RF)
= Bias-Tee #1 signal output (RF and DC) to TMDS CLOCK+
= AWGI DC _OUT (1) to Bias-Tee #1 DC-level input (DC)

= AWGI Chl- output to 120 PS TTC filter
= 120 PS TTC filter output to Bias-Tee #2 signal input (RF)
= Bias-Tee #2 signal output (RF and DC) output to TMDS CLOCK-
= AWGI DC _OUT (2) to Bias-Tee #2 DC-level input (DC)

= AWGI Ch2+ output to 120 PS TTC filter
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2. Connect the Chl and Ch2 inputs of the oscilloscope to Clock and Data0 channels of the TPA-R.

Make Connections for Cable Inter-Pair Skew

= 120 PS TTC filter output to Bias-Tee #3 signal input (RF)

= Bias-Tee #3 signal output (RF and DC) to TMDS DATAO+
= AWGI DC _OUT (3) to Bias-Tee #3 DC-level input (DC)
AWG]1 Ch2- output to 120 PS TTC filter

= 120 PS TTC filter output to Bias-Tee #4 signal input (RF)

= Bias-Tee #4 signal output (RF and DC) to TMDS DATAO-
= AWGI DC OUT (4) to Bias-Tee #4 DC-level input (DC)
AWG2 Chl+ output to 120 PS TTC filter

= 120 PS TTC filter output to Bias-Tee #5 signal input (RF)

= Bias-Tee #5 signal output (RF and DC) to TMDS DATAI1+
= AWG2 DC _OUT (1) to Bias-Tee #5 DC-level input (DC)
AWG2 Chl- output to 120 PS TTC filter

= 120 PS TTC filter output to Bias-Tee #6 signal input (RF)

- Bias-Tee #6 signal output (RF and DC) to TMDS DATA1-
= AWG2 DC_OUT (2) to Bias-Tee #6 DC-level input (DC)
AWG?2 Ch2+ output to 120 PS TTC filter

= 120 PS TTC filter output to Bias-Tee #7 signal input (RF)
= Bias-Tee #7 signal output (RF and DC) to TMDS DATA2+
= AWG2 DC OUT (3) to Bias-Tee #7 DC-level input (DC)
AWG?2 Ch2- output to 120 PS TTC filter

= 120 PS TTC filter output to Bias-Tee #8 signal input (RF)

= Bias-Tee #8 signal output (RF and DC) to TMDS DATA2—
= AWG2 DC OUT (4) to Bias-Tee #8 DC-level input (DC)
AFG3102 Chl using BNC-T adapter to trigger input of AWG1 and AWG2
AFG3102 Ch2 to be connected to Ext Ref input of AWG2
AWGI1 10 MHz Ref output to be connected to AFG3102 Ext Ref input
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How to ... Make Connections for Cable Inter-Pair Skew

3. Connect TPA-R to two ends of HDMI Cable DUT.
4. Configure the application as follows:

= Run the TDSHT3 software (version with the Direct Synthesis capability) on the digital
oscilloscope.

= Select the DDS method in the configuration panel of the Cable Inter-Pair Skew Test.
= Select the frequency of the cable to be tested.

= In the Signal Source dialog box, check the GPIB connection of the two AWGs and the AFG to
ensure proper connection.

= Run the test to load the patterns on both the AWGs.

= Once the synchronization of the two AWGs is complete, go to the setup 2 (see page 188).

Setup 2: To calculate inter-pair skew

Make the connections as follows:

Cable Inter-Pair Skew

LAN
GPIB/E-Net
GPIB/E-Net to GPIB converter Ext Reference Input (509, 3 Vp-p Max)
1
| .
GPIB GPIB
10 MHz Ext. Ref »

Reference Output [ Input AFG GPiB
AWGT102/AWG71228 | (MASTER) — - 3 CUVE: TG G

Digital Oscilloscope

a

POPPEEEOPPOO®

Al
! Analog (CH1) v
Analog (g:y/’ E . R nalog (CH1) Input ® ¢ °
e B D " Analog (CH2) ] S
i " DCout !
: :
' 1
' |
' B |
I : voltage 120 PS TTC filters | Bias
! B 1voltage
i T | - I
... R |
[
]
=
1 d“”“ “" EFF- HDMI- TPA-R
DATA2 N — ‘
L oamaN
D2 DATA2_ P j%-: . HOMI L
DATATN pu
D1 DATA1_P.
DATAON
DATAQ P HDMI
LOCK N
CK CLOCK P

HDMI Cab\e DUT

1. Remove the marker channel connections from the oscilloscope inputs.

2. Connect the Ch3 and Ch4 inputs of the oscilloscope to Datal and Data2 channels of the TPA-R
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How to ... Make Connections for Cable Inter-Pair Skew

3. Run the test to measure the inter-pair skew.

4. Once the test completes, you can view the results.
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How to ... View the Source Eye Diagram Sample Waveform

View the Source Eye Diagram Sample Waveform

Click View Waveform to display the input signals Clock and Data as follows:

File | Edit | * Trig | | htath |

/ R AR e Rt i, o A At o A

1
4 |
PO Y Y A PP T

/
L‘l-“"“\;"ww\m\n-‘\-rul‘”\h‘.ﬁ.ﬂ.-._;\;‘r.ld.J*L-‘J

e, J\r»\l"-b.ﬂl
|
o

&I 1.0Vidiv |mm J40.0mv || #0ns  25.0GS/s IT 8.0psipt
@D 1.0vidiv 8. Single Seq

T 1.0Vidiv " 1 acqgs

D 1.0Vidiv w8

Man  April 28, 2008

TDSHT3 B x|

Yiew Waveform
Select Waveform should look like the signal(s) as shown. Click More for details.

Configure
Connect
WiEw
Waveform

Source - Eye Diagram

Clock-> Ch1, Datal -> Ch2, Datal -» Ch3; Data2 -> Ch4d, Rec Length -> 320, CRU -> PLL
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View the Duty Cycle Sample Waveform

Click View Waveform to display the Clock signal as follows:

Fie | Edit | ¥

U -.r'-._.--F-"-.-...J_.,.l'.~\,..\..f"_-j

| T 200mvidiv

| Math | h
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5002 B,:8.0G

File Tests Results Utilities Help

Select

Configure

Connect

WiEw
Wyaveform

200

Source -» Duby Cycle

View Waveform

Waveform shouid look like the sighal(s) as shown. Click More for details.

Clock -= Ch1, ACgs -= 10k, Thit: Recalc; Avgs -= 100

| Utilties | Help 'n

L PN AN

(@e® 35.0mv

View the Duty Cycle Sample Waveform
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T
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View the Rise Time Sample Waveform

Click View Waveform to display the input signals Clock or Data as follows:
File | Edit | % Of | v IE] ) y | Math
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«©» 1.0vidiv 500 By:8.0G |@e=® / 20.0mv || 40ns  25.0Gsis 1T 8.0psipt
= 1.0vidiv 500 By:8.0G

T 1.0Vidiv 500 B,:8.0G
D 1.0Vidiv 500 By:8.0G

Single Seq

1 acqgs

Man  April 28, 2008

TDSHT3 B x|

File Tests Results Utilities Help

Yiew Waveform
Select Waveform should look like the signal(s) as shown. Click More for details.

Configure
Connect
WiEw
Waveform

Source -= Fise Time Clock -= Ch1; Datal -» Ch2; Datal -» Ch3;, DataZ -» Chd; Acgs -= 10k; High - 80%,; Low -= 20%; Thit: Recalc; Avgs -= 100
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View the Fall Time Sample Waveform

Click View Waveform to display the input signals Clock or Data as follows:
Fie | Edit |
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File Tests Results Utilities Help TDSHT3 o, X
View Waveform

Select Waveform shouid look like the sighal(s) as shown. Click More for details.

Configure

Connect

WiEw
Wyaveform

200

Source -» Fall Time

Clock -= Ch1, Datal -» Ch2; Datal -» Ch3; DataZ -» Chd; Acgs -» 10k, High -> 80%,; Low -> 20%, Thit Fecalc; Avgs -» 100
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View the Clock Jitter Sample Waveform

View the Clock Jitter Sample Waveform

Click View Waveform to display the Clock signal as follows:
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File Tests Results Utilities Help TDSHT3 o, X

Select

Configure

Connect

WiEw
Waveform

AN

Source -> Clock Jitter

Waveform should look like the signal(s) as shown. Click More for details.

View Waveform

Clock-> Ch1, Eec Length -> 320, CRU -> PLL
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View the Source Inter-Pair Skew Sample Waveform

Click View Waveform to display the input signals Data+ and Data— , and Clock as follows:
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File Tests Results Utilities Help TDSHT3 o, X
View Waveform

Select Waveform shouid look like the sighal(s) as shown. Click More for details.

Configure

Connect

WiEw
Wyaveform

200

Source - Inter-Pair Skew(D, D) Clock -= Ch1, Datal -» Ch2; Datal -» Ch3; Data2 -» Chd; Thit Fecalc; Avgs -» 100
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View the Differential Tests Select All Sample Waveform

Click View Waveform to display the input signals Clock and Data as follows:
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File Tests Results Utilities Help

Yiew Waveform
Select Waveform should look like the signal(s) as shown. Click More for details.

Configure
Connect
WiEw
Waveform

Source -= Multiple Tests

Clock-> Ch1, Datal -> Ch2, Datal -> Ch3, Dataz -> Ch4d, Rec Length -> 32h; CRU-> PLL, High -> 80%, Low -> 20%

NOTE. Similarly, click View Waveform to display a waveform for Single-Ended Tests Select All.
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View the Source Intra-Pair Skew Sample Waveform

Click View Waveform to display the input signals Data+ or Data—/Clock as follows:
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] View Waveform
Select Waveform shouid look like the sighal(s) as shown. Click More for details.

Configure

Connect ; 3
WiEw . i
Wa_vefu_rm th o : : : Detail

Source -z Intra-FPair Skew Inputt; Clock, +Ch1, -Ch2 Input2; Datal, +Ch3, -ChdAcg -= 10k; Thit 1.3481ns

Summary
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View the Low Amplitude + Sample Waveform

Click View Waveform to display the input signals Data+ or Data—/Clock as follows:
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Source -= Low Amplitude + Inputl: Clock +Ch1 Input2: Datal,+Ch3Acg -= 10k, AVCC -» 3.3%,; Thit 1.3481ns
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View the Low Amplitude - Sample Waveform

View the Low Amplitude - Sample Waveform

Click View Waveform to display the input signals Data+ or Data—/Clock as follows:
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Summary

Detal

Input?: Clock, -Ch2 Input2: Datal, -ChdAcg -> 10k; Avoo -> 3.3V, Thit 1.3481ns

View the Min/Max-Diff Swing Tolerance Sample Waveform

Because no signal is connected to the oscilloscope, you cannot view the waveform for the Min/Max-Diff

Swing Tolerance test.

TDSHT3 HDMI Compliance Test Software Online Help

199



How to ... View the Jitter Tolerance Waveform

View the Jitter Tolerance Waveform

Because no signal is connected to the oscilloscope, you cannot view the waveform for the Jitter Tolerance
test.

View the Deep Color Waveform

Because no signal is connected to the oscilloscope, you cannot view the waveform for the Deep Color test.

View the Audio Clock Regeneration Waveform

Because no signal is connected to the oscilloscope, you cannot view the waveform for the Audio Clock
Regeneration test.

View the Audio Sample Packet Jitter Waveform

Because no signal is connected to the oscilloscope, you cannot view the waveform for the Audio Sample
Packet Jitter test.

View the Audio Formats Waveform

Because no signal is connected to the oscilloscope, you cannot view the waveform for the Audio Formats
test.

View the One Bit Audio Waveform

Because no signal is connected to the oscilloscope, you cannot view the waveform for the One Bit
Audio test.
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View the DVI Interoperability Waveform

Because no signal is connected to the oscilloscope, you cannot view the waveform for the DVI
Interoperability test.

View the 3D Video Waveform

Because no signal is connected to the oscilloscope, you cannot view the waveform for the 3D Video test.

View the 4Kx2K Video Waveform

Because no signal is connected to the oscilloscope, you cannot view the waveform for the 4Kx2K
Video test.

View the Extended Colors and Contents Waveform

Because no signal is connected to the oscilloscope, you cannot view the waveform for the Extended
Colors and Contents test.

View the Sink Intra-Pair Skew Sample Waveform

Because no signal is connected to the oscilloscope, you cannot view the waveform for the Intra-Pair
Skew test.

View the Cable Eye Diagram Sample Waveform

Because no signal is connected to the oscilloscope, you cannot view the waveform for the Eye Diagram test.

View the Cable Inter-Pair Skew Sample Waveform

Because no signal is connected to the oscilloscope, you cannot view the waveform for the Cable Inter-Pair
Skew test.
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Test the Source Eye Diagram

This test allows you to confirm that the differential signal on each TMDS differential data pair has an “eye
opening” (region of valid data) which meets or exceeds the limits on eye opening in the specification.

You will need a supported oscilloscope, two/four differential probes, one DC power supply 3.3 V, one
EDID emulator, and one TPA-P fixture. For DPO/DSA/B oscilloscopes, an external power supply is not
required if the internal power supply is used. See the Preferences (see page 22) menu for details.

1. On the menu bar, click Tests > Select > Source.

2. In the differential tests pane, select the Eye Diagram check box.

File Tests Results Utilities Help TDSHT3 Lo X |

Select - Source

Select SEUTEE C -Run
Single-Ended Tests Test

configure - : Result

LIt B ter-Pai i oo Armplitude Report—
WS all Time Detail
Waveronm = = Select All Select All

Source -= Eye Diagram Clock -> Ch1; Datal -> Ch2; Datal -= Ch3; DataZ -» Chd; Rec Length -= 8M; CRU -= PLL

3. To change the configuration settings, click Tests > Configure. For most tests, you can use the factory
default configuration. However, you can change the values by using the virtual keyboard (see page 24)
or the general purpose knob (see page 26) on the oscilloscope front panel. Using the File menu,
you can also restore the factory defaults or save and recall your own configuration settings. It is
recommended that you save the configuration settings before you choose to select Recall Default or
close the application.

File Tests Results Utilities Help TDSHT3 %| X

Configure - Source

HoriziAcq Reference Levels Bun
Select . . - -
# of Acqgs [ High , Test

Configure . _
ch Hysteresis L3 i L3

Rec Length = o Report—

10%

BO0M ' Skl -

CRU

VLT g DeLal
Waverom Che PLL ¥

Source -= Eye Diagram Clock -= Ch1; Datal -= Ch2; Datal -= Ch3; Data2 -» Ch4d, Rec Length -» 8M; CRLU -= PLL
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Test the Source Eye Diagram

In the input pane, do the following:

= Set the Input Clock to the channel that you will use for the HDMI clock input. Select from the
available choices (Chl, Ch2, Ch3, Ch4, Refl, Ref2, Ref3, and Ref4).

= Set the Input Data0, Datal, and Data2 to the channel that you will use for the corresponding
HDMI data inputs. Select from the available choices (Chl, Ch2, Ch3, Ch4, Refl, Ref2, Ref3,
Ref4 and Not Conn).

In the horiz/acq pane, the required number of acquisitions are set for the test. The default value is 10 K.

Set the desired record length value for the eye tests in the Rec Length box. Select from the available
choices (8.00k, 16.0k, 40.0k, 80.0k, 200k, 400k, 800k, 2.00M, 4.00M, 8.00M, 20.0M, 32.0M). The
default value is 32.0M.

In the CRU pane, configure the Clock Recovery Unit. Select from the available choices (PLL, Raw,
and Ideal). The default value is first order PLL and is used for compliance testing. Raw and Ideal
are used for analysis.

In the reference levels pane, do the following:

= Set the reference level units to either Per (%) or Abs.
Per (%) indicates that the reference levels are a percentage of the Vswing value.
Abs indicates that the reference levels are absolute voltage values.
The default selection is Per (%).

- In the Hysteresis box, enter the desired hysteresis percent value. The range is from 0% to 25%
and default is 10%.

= In the High box, the required high reference voltage value is set for the test. The default value is
80%.

= In the Mid box, enter the desired mid reference voltage value. The range is from 25% to 75%
and default is 50%.

- In the Low box, the required low reference voltage value is set for the test. The default value is
20%.

To connect the DUT, click Tests > Connect. Click here (see page 61) for information on how
to make connections.

File Tests Results Utilities Help TDSHT3 %| X |

Connect

Select Follow these instructions to set up the connections.

Click More for detalls. Mare

L
1. Set up the DUT.

Report—

Connect 2. Connect the test fixtures and probes. Summary

R

Detail
Wyaverarm

3. To view the signal, click View Waveform.

Source -= Eye Diagram Clock -= Ch1; Datal -= Ch2; Datal -= Ch3; DataZ -= Chd; Rec Length -= 8M; CRU -> PLL
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How to ... Test the Source Eye Diagram

9. Ensure that your signal in the oscilloscope display is similar to the sample signal. Click View
Waveform (see page 190) to display a sample of the expected signal. If the displays are not similar, go
back and check your configuration and connections.

10. Click Run Test to perform the test. The TDSHT3 Software sets up the oscilloscope and the test
runs, displaying a progress indicator.

11. If you have run the eye diagram test successfully, the software makes the results available
automatically and displays the eye diagram plot.

Mask Manual Fit
Mask Movement

. Fine
Coarse

Reset *
Mask
Results

Mask Test F

Mask Hits 0

Vswing 803.84mV

=
o
S
>
£
Lo
~
~—
—
1]
o
[y
)
(=]
=

Thit 1.3468ns

Data Jitter 76.2ps

-

HistPk-Pk  76.2ps

Time [ 269ps / div ]

NOTE. In the full screen mode, the histogram disappears if you click anywhere within the plot.
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Test the Source Eye Diagram

Features on the Clock Jitter display include:

Save: Click Save Image to save the eye diagram plot.

Zoom: You can zoom in on an area of interest, up to five times the normal view. Either drag the
mouse or click to define the area of interest.

Reset Plot: Click Reset Plot to reset the plot.

Histogram: Click Hist to draw the histogram on the eye diagram plot. Click Hist Limits to draw
the histogram box, and Hist Save to save the histogram. Double-click the buttons next to the
Ymax, Ymin, Xmin, and Xmax labels to type the X and Y histogram limits.

Scale: Click Fix Scale to type in a new scale value, or click Enter Scale to type in a new vertical
scale value.

Mark Hits: Click Mark Hits to mark the hits in the eye diagram plot.

Mask: Click Mask Marg to display the margins on the eye diagram plot. Click Mask Fit
to enable to move the mask either in the left or the right direction. Mask Marg and Mask Fit
are mutually exclusive of each other.

Mask Manual Fit pane: Use this pane to move the mask either in the left or the right direction.
Select either a fine or a coarse movement.

Results display: The results pane displays the result of the mask test result (pass or fail), mask hits
(number of mask hits), Vswing value (voltage swing of the signal), and the Tbit value (time period
of each bit). The Data Jitter and the Hist Pk-Pk values are also shown near the results pane. If
there is no value for data jitter, it implies the absence of data points in the histogram window. In
this case, increase the record length value and run the test again.
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Resulis
Mask Test
Mask Hits 0
952.00mV

Y=wing

Thit 1.3482ns

Data Jitter 18¥ps

Hist Pk-Pk  187ps

Test the Source Eye Diagram

12. Click Half Screen to view the eye diagram plot in half screen. You can also view both the result
summary of the test and the report configuration in the result pane as shown in the following figure.

= ‘oltage(V)

T 179mV/div
T 500mV div
T 500mV/idiv

I|| Select

Soyrce Eye Diagram :_CK - DO

-
i

{I7-10 : Source Eye Diagram : CK - D1

Configure

Connect

==

Wiaveform |

b

Source -= Eye Diagram

-10 : Source Eye Diagram : CK - D2

Device Details

Resolution

Refresh Rate

Report File

& Auto Increment

Results

Mask Test F PASS

Mask Hits 0
Vswing 803.84mY

Thit 1.3468ns

Data Jitter 76.2ps

Full Screen

Single Seq
1 acgs RL:25.0M

Man  April 28, 2008

Result

Summary]

Detail

Report

Clock -> Ch1; Data0 -> Ch2; Datal -> Ch3; Data2 -> Ch4; Rec Length -> 32M; CRU -> PLL

The result pane displays the result summary pane and the report configuration pane.

The result summary pane displays the test results. Click here (see page 47) for more information.

Set the report details to identify and generate the report automatically. You can set a default report file.
Click here (see page 48) for more information.
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13. In the result summary pane, click Result Details to display the details of the result. Click here (see
page 48) for more information.

14. In the Result Details dialog box, click Result Statistics to display statistics based on the tests. Click
here (see page 49) for more information.

Result Statistics

Test Name _ Fapulation
Source Eye Diagram : Tx Clock TIE 47 4
Source Eye Diagram : Recovered Clock. | el

Test Method

This sequence explains the actions that the software takes while it performs an eye diagram test. For the
procedure on how to make this test, see eye diagram test procedure (see page 202).

1. Refer to Eye Diagram (see page 61) for information on how to make connections for Source Eye
Diagram test.

2. Set up the oscilloscope as follows:
= Set the memory length to at least 25 M points.
= Set the single-shot trigger at the rising edge of TMDS Clock (50 percent).
= Set the sample rate to > 10 GS/s based on the oscilloscope.
= Adjust the vertical scale to accommodate the waveform in six vertical divisions.

3. Capture the waveforms on the oscilloscope.

NOTE. Do not transfer the waveforms.

4. Perform software clock recovery as follows:
= Find Vy and V. of both clock and data.
= Find 50 percent reference level of the clock.

= Calculate the Software CRU filter as follows.
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H(s) = 1/(1+st), where t = 40 nsec.

= Pass the TIE values through the filter (FFT and IFFT) H(s) = 1/(1+st), where t = 40 nsec.

= Reconstruct the clock, and then create a bit clock (x10 clock) by using even up sampling.
5. Draw the eye diagram.

= x10 clock is used for slicing.

= Draw the eye diagram with 2 UI+UI+% Ul method. This ensures that all Uls are overlapped.
6. Create eye mask.

= Calculate Vswing by using Vy and V| of the data.

= Construct the mask co-ordinate by using Tgir and Vswing.
7. Position the mask in such a way that one of its left corners just touches the waveform.
8. If any other part of the waveform either touches or crosses the data eye, it implies Fail.
9. Calculate the data jitter by using the histogram technique. The histogram co-ordinates are Vc+/-5 mV.
10. If data jitter is more than (0.3*Tgr), it implies Fail.
11. Repeat the test for all the remaining TMDS_DATA pairs.

12. Repeat the test for all supported pixel clock rates. Only one video format is required per pixel
clock rate.

Test the Duty Cycle

This test allows you to confirm that the duty cycle of the differential TMDS clock does not exceed the
limits allowed by the specification.

You will need a supported oscilloscope, one differential probe, one DC power supply 3.3 V, one EDID
emulator, and one TPA-P fixture. For DPO/DSA/B oscilloscopes, an external power supply is not required
if the internal power supply is used. See the Preferences (see page 22) menu for details.

1. On the menu bar, click Tests > Select > Source.

2. In the differential tests pane, select the Duty Cycle check box.
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File Tests Results Utilities Help TDSHT3 %| X |

Select - Source

[ Source {
Select
- Differential Tests Single-Ended Tests
e Diagram Clock Jitter - Intra-p
Configure

= ter-Pa Report—
(o t
- Rise Time ow Amplitude -
Wiew PP .
- Fall Time Select Al Select Al

Source -> Duty Cytle Clock-= Cht; Acgs -= 10k; Thit: Recalc; Avgs -> 100

3. To change the configuration settings, click Tests > Configure. For most tests, you can use the factory
default configuration. However, you can change the values by using the virtual keyboard (see page 24)
or the general purpose knob (see page 26) on the oscilloscope front panel. Using the File menu,
you can also restore the factory defaults or save and recall your own configuration settings. It is
recommended that you save the configuration settings before you choose to select Recall Default or
close the application.

File Tests Results Utlities Help TDSHT3 %| X |

Configure - Source
HorizlAcy
# of Acqs [ Test
10k ..
Configure

Thit Report—

# of Avgs L
Connect Re- by
calculate 100 SIS,

View Evistifi
YWyavefarm AlLE

Source -> Duty Cytle Clock -= Ch1; Acgs -= 10k, Thit: Recalc; Avgs -= 100

4. In the input pane, set the Input Clock to the channel that you will use for the HDMI clock input. Select
from the available choices (Chl, Ch2, Ch3, and Ch4).

5. In the horiz/acq pane, enter the desired number of acquisitions that are required for the test. The
range is from 10 K to 1 M and default is 10 K.

6. In the tbit pane, do the following:

= Enter the desired number of periods that are considered to calculate Tbit. The range is from 2
to 1 K and default is 100.

= Click Re-calculate to recalculate the Tbit value.
= If you want to use the previously calculated Tbit value, click Existing Value.

7. To connect the DUT, click Tests > Connect. Click here (see page 64) for information on how
to make connections.
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File Tests Results Llilities Help TDSHT3 %| X |

Connect
Select Follow these instructions to set up the connections.

Click More for dotails. More

cont oHre
1. Set up the DUT.

Report—

Connect 2. Connect the test fixtures and probes. Summary

3. To view the signal, click View Waveform.
Wiew ;
Detail
‘Wavefarm -

Source -> Duty Cytle Clock-= Ch1; Acgs -= 10k; Thit: Recalc; Avgs -> 100

8. Ensure that your signal in the oscilloscope display is similar to the sample signal. Click View
Waveform (see page 191) to display a sample of the expected signal. If the displays are not similar, go
back and check your configuration and connections.

9. Click Run Test. The TDSHT3 Software sets up the oscilloscope and the test runs, displaying a
progress indicator.

10. The software makes the results available automatically and displays the result summary. You can also
view the report configuration details in the result pane.

File Tests Results Ltlities Help TDSHT3 v @1] X |
. Result Summary: Source Report Conguration ' :

Select e Device Details HDMI Device e i
LAl 7-8  Max Duty Cycle

] LA4|7-8 | Min Duty Cycle : CK Resolution 1920*1080i T
Configure . Result

Refresh Rate

Report File C SHT |
10 Data Lane = o ;
. - | et B Auto Increment | B |

Source -» DUty Cycle Clock-> Ch1; Acos -» 10K Thit 1.3481ns

The results summary lists the test name and their status (pass, fail, or error). To view the details
of the results, click Results Details.

11. Set the report details to identify and generate the report automatically. You can set a default report file.
Click here (see page 48) for more information.

12. In the result summary pane, click Result Details. The result details pane displays the following fields.
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Result Details i

Test Mame Spec Range

7-8: Max Duty Cycle: Tk Max Duty Cyele < 60.0%; [0
7-2: Min Duby Cyele: CK

= Test Name (displays the test id, test name, and lane)

= Spec Range (displays the HDMI standards and test specifications limit for the test)
= Meas Value (displays the measured value)

= Result (displays the status of the test as Pass, Fail, or Error)

= Remarks/Comments (displays the relevant details, such as Tbit and Margin). If the test could not
be run, the field displays an error code (see page 357).

Test Method

This sequence explains the actions that the software takes while it performs a duty cycle test. For the
procedure on how to make this test, see duty cycle test procedure (see page 208).

1. Refer to Duty Cycle (see page 64) for information on how to make connections for Duty Cycle test.

2. Display the waveform of one clock period.

3. Set up the oscilloscope as follows:
- Adjust the vertical scale to accommodate the waveform in six vertical divisions
= Trigger: Edge trigger
= Acquire at least 10,000 waveforms in FastAcq

4. Find the minimum and maximum duty cycle by using the following method:
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TMDS AC Clock Duty

5. Compare with the limit value.
= If minimum duty cycle is more than 40 percent, it implies Pass.

- If maximum duty cycle is less than 60 percent, it implies Pass.

Test the Rise Time

This test allows you to confirm that the rise times on the TMDS differential signals fall within the limits of
the specification.

You will need a supported oscilloscope, one differential probe, one DC power supply 3.3 V, one EDID
emulator, and one TPA-P fixture. For DPO/DSA/B oscilloscopes, an external power supply is not required
if the internal power supply is used. See the Preferences (see page 22) menu for details.

1. On the menu bar, click Tests > Select > Source.

2. In the differential tests pane, select the Rise Time check box.

File Tests Results Utilities Help TDSHT3 %| X |

Select - Source

Source Cable
Differential Tests Single-Ended Tests Test
Canfigure D : :

Report—
Wiew ol T Detail
Wavefarm “ = Select All Select All

Source -= Rise Time Clock -= Ch1; Datal -» Ch2; Datal -> Ch3; Data2 -> Chd; Acgs -= 10k; High -= 80%,; Low -> 20%; Thit: Recalc; Avgs -» 100

3. To change the configuration settings, click Tests > Configure. For most tests, you can use the factory
default configuration. However, you can change the values by using the virtual keyboard (see page 24)
or the general purpose knob (see page 26) on the oscilloscope front panel. Using the File menu,
you can also restore the factory defaults or save and recall your own configuration settings. It is
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Test the Rise Time

recommended that you save the configuration settings before you choose to select Recall Default or
close the application.

File Tests Results Utilities Help TDSHT3 %| X |

Configure - Source

HorizlAcy Reference Levels Run
Select _ r -
# of Acqs igh *, Test
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Connect Re- P SUmma
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Source -» Rise Time Clock -= Ch1; Datal -» Ch2; Datal -> Ch3; Data2 -> Chd,; Acgs -> 10k; High -= 80%,; Low -> 20%, Thit: Recalt; Avgs -= 100

4. In the input pane, do the following:

Set the Input Clock to the channel that you will use for the HDMI clock input. Select from the
available choices (Ch1, Ch2, Ch3, Ch4, and Not Conn).

Set the Input Data0, Datal, and Data2 to the channel that you will use for the corresponding
HDMI data inputs. Select from the available choices (Chl, Ch2, Ch3, Ch4, and Not Conn).

5. In the horiz/acq pane, enter the desired number of acquisitions that are required for the test. The
range is from 10 K to 1 M and default is 10 K.

6. In the tbit pane, do the following:

Enter the desired number of averages (periods) that are considered to calculate Tbit. The range
is from 2 to 1 K and default is 100.

Click Re-calculate to recalculate the Tbit value.

Click Existing Value to use the previously calculated Tbit value.

7. In the reference levels pane, do the following:

Set the reference level units to either Per (%) or Abs.

Per (%) indicates that the reference levels are a percentage of the Vswing value.

Abs indicates that the reference levels are absolute voltage values.

The default setting is Per (%).

In the Hysteresis box, the required hysteresis value is set for the test. The default value is 10%.

In the High box, enter the desired high reference voltage value. The range is from 50% to 100%
and the default is 80%.

In the Mid box, the required mid reference voltage value is set. The default value is 50%.

In the Low box, enter the desired low reference voltage value. The range is from 1% to 50%
and the default is 20%.
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8. To connect the DUT, click Tests > Connect. Click here (see page 67) for information on how
to make connections.

File Tests Results Utilities Help TDSHT3

Connect

Follow these instructions to set up the connections.

Click More for dotalls.

1. Set up the DUT.

Report—

connect 2. Connect the test fixtures and probes.

3. To view the signal, click View Waveform.

e )
Detal
Waveform -

Source -> Rise Time Clock-= Ch1; Datal ->= Ch2; Datal -= Ch3; Data2 ->= Ch4; Acgs -= 10k; High -= 80%,; Low -> 20%; Thit Fecalc; Avgs -= 100

9. Ensure that your signal in the oscilloscope display is similar to the sample signal. Click View
Waveform (see page 192) to display a sample of the expected signal. If the displays are not similar, go
back and check your configuration and connections.

10. Click Run Test to perform the test. The TDSHT3 Software sets up the oscilloscope and the test
runs, displaying a progress indicator.

11. The software makes the results available automatically and displays the result summary. You can also
view the report configuration details in the result pane.

File Tests Results Liilities Help TDSHT3 v El X |

Result Summary: Source Report Conguration

HE Device Details HOMI D

. source Rise Time

| i : Source Rise Time : Resolution ; : =
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" | : Source Rise Time : .
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Summary
Report File
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Clock -= Ch1; Datal -» Ch2;, Datal -» Ch3; Data2 -» Chd; Acgs -» 10k, High -» 80%; Low -> 20%; Thit: 1.3481ns

Source -= Rise Time

The results summary lists the test name and their status (pass, fail, or error). To view the details
of the results, click Results Details.

12. Set the report details to identify and generate the report automatically. You can set a default report file.
Click here (see page 48) for more information.

13. In the result summary pane, click Result Details. The result details pane displays the following fields.
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Result Details

Test Name
7-4 : Source Rise Time : CK

75.00ps < TR

7-4 : Source Rise Time : DO 75.00ps = TRISE;
7-4 : Source Rise Time : D1 75.00ps < TRISE;
7-4 : Source Rise Time : D2 75.00ps = TRISE;

- Test Name (displays the test id, test name, and selected lanes)

= Spec Range (displays the lower limit and upper limit of the rise time test)
= Meas Value (displays the measured value)
= Result (displays the status of the test as Pass, Fail, or Error)

= Remarks/Comments (displays the relevant details, such as Tbit, Vswing, Upper Margin, and
Lower Margin). If the test could not be run, the field displays an error code (see page 357).

= Result Statistics (displays statistics based on the tests)

14. In the Result Details dialog box, click Result Statistics to display statistics based on the tests. Click
here (see page 49) for more information.

Result Statistics

AlMe
?—4":_ SOuUrce :-_R_PsE’:j_F'rm_e T CK
7-4 : Source Rise Time ; |

7-4 © Source Rise Time : D1
7-4 : Source Rise Time : D2

Test Method

This sequence explains the actions that the software takes while it performs a rise time test. For the
procedure on how to make this test, see rise time test procedure (see page 212).
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1. Refer to Rise Time (see page 67) for information on how to make connections for Rise Time test.

2. Set the trigger position at the center of the screen.

3. Set up the oscilloscope as follows:
= Calculate Tgr by using differential clock.
= Set the vertical scale to accommodate the waveform in at least six divisions.
= Set the horizontal scale to more than 2*Tgy.

= If pulse width trigger is selected, Trigger with pulse width trigger with (4*Tgr) pulse or trigger
with edge trigger.

4. Accumulate at least 10,000 triggered waveforms by acquiring the waveform in FastAcq mode of
acquisition.

5. Calculate Vswing of the signal (Vswing = Va—V1), and then find the 20 percent and 80 percent of the
level.

6. Measure the rise time and fall time.

= Enable the oscilloscope rise time measurement. Set the reference level to 20 percent and 80
percent.

= Acquire at least 10 K waveforms (RUN and STOP).
= Calculate the rise time.
= Set the trigger to negative pulse.
= Enable the oscilloscope rise time measurement.
= Acquire at least 10 K waveforms (RUN and STOP).
= Calculate the fall time.
7. Compare with the limit.
= If Trisg is less than 75 ps or Trisg is more than (0.4*Tg7), it implies Fail.
= If Trarp is less than 75 ps or Tgarr is more than (0.4*Tgr), it implies Fail.

8. Repeat the test for all the remaining TMDS clock and data pairs.

Test the Fall Time

This test allows you to confirm that the fall times on the TMDS differential signals fall within the limits of
the specification.

You will need a supported oscilloscope, one differential probe, one DC power supply 3.3 V, one EDID
emulator, and one TPA-P fixture. For DPO/DSA/B oscilloscopes, an external power supply is not required
if the internal power supply is used. See the Preferences (see page 22) menu for details.
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1. On the menu bar, click Tests > Select > Source.

2. In the differential tests pane, select the Fall Time check box.

File Tests Results Utilities Help TDSHT3 %| X |

Single-Ended Tests Test

Select - Source
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SUrrmany.

Select All Select All -
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3. To change the configuration settings, click Tests > Configure. For most tests, you can use the factory
default configuration. However, you can change the values by using the virtual keyboard (see page 24)
or the general purpose knob (see page 26) on the oscilloscope front panel. Using the File menu,
you can also restore the factory defaults or save and recall your own configuration settings. It is
recommended that you save the configuration settings before you choose to select Recall Default or
close the application.

File Tests Results Utilities Help TDSHT3 %| X |

Configure - Source
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4. In the input pane, you have the following options:

= Set the Input Clock to the channel that you will use for the HDMI clock input. Select from the
available choices (Chl, Ch2, Ch3, Ch4, and Not Conn).

= Set the Input Data0, Datal, and Data2 to the channel that you will use for the corresponding
HDMI data inputs. Select from the available choices (Chl, Ch2, Ch3, Ch4, and Not Conn).

5. In the horiz/acq pane, enter the desired number of acquisitions that are required for the test. The
range is from 10 K to 1 M and default is 10 K.
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6. In the tbit pane, do the following:

= Enter the desired number of averages (periods) that are considered to calculate Tbit. The range is
from 2 to 1 K. The default value is 100.

= Click Re-calculate to recalculate the Tbit value.
= Click Existing Value to use the previously calculated Tbit value.
7. In the reference levels pane, do the following:
= Set the reference level units to either Per (%) or Abs.
Per (%) indicates that the reference levels are a percentage of the Vswing value.
Abs indicates that the reference levels are absolute voltage values.
The default setting is Per (%).
= In the Hysteresis box, the required hysteresis value is set for the test. The default value is 10%.

= In the High box, enter the desired high reference voltage value. The range is from 50% to 100%
and the default is 80%.

= In the Mid box, the required mid reference voltage value is set. The default value is 50%.

= In the Low box, enter the desired low reference voltage value. The range is from 1% to 50%
and the default is 20%.

8. To connect the DUT, click Tests > Connect. Click here (see page 70) for information on how
to make connections.

File Tests Results LUltilities Help TDSHT3 %| X |

Connect
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3. To view the signal, click Yiew Waveform.
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9. Ensure that your signal in the oscilloscope display is similar to the sample signal. Click View
Waveform (see page 193) to display a sample of the expected signal. If the displays are not similar, go
back and check your configuration and connections.

10. Click Run Test to perform the test. The TDSHT3 Software sets up the oscilloscope and the test
runs, displaying a progress indicator.

11. The software makes the results available automatically and displays the result summary. You can also
view the report configuration details in the result pane.
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The results summary lists the test name and their status (pass, fail, or error). To view the details
of the results, click Results Details.

12. Set the report details to identify and generate the report automatically. You can set a default report file.
Click here (see page 48) for more information.

13. In the result summary pane, click Result Details. The result details pane displays the following fields.

Result Details

75.00ps <

7-4 Snurce Fall Time - DO 75.00ps < TFALL;
7-4 : Source Fall Time : 01 75.00ps < TRALL;
7-4 Snurce Fall Time - D2 75.00ps < TFALL;

- Test Name (displays the test id, test name, and selected lanes)

= Spec Range (displays the lower limit and upper limit of the rise time test)
= Meas Value (displays the measured value)
= Result (displays the status of the test as Pass, Fail, or Error)

= Remarks/Comments (displays the relevant details, such as Tbit, Vswing, Upper Margin, and
Lower Margin). If the test could not be run, the field displays an error code (see page 357).

= Result Statistics (displays statistics based on the tests)

14. In the Result Details dialog box, click Result Statistics to display statistics based on the tests. Click
here (see page 49) for more information.
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Result Statistics

Test Name
- Bource Fall Time
o Source Fall Time :

- Source Fall Time

o Bource Fall Time :

Test Method

This sequence explains the actions that the software takes while it performs a fall time test. For the
procedure on how to make this test, see fall time test procedure (see page 216).

1. Refer to Fall Time (see page 70) for information on how to make connections for Fall Time test.

2. Set the trigger position at the center of the screen.

3. Set up the oscilloscope as follows:

Calculate Tgr by using differential clock.
= Set the vertical scale to accommodate the waveform in at least six divisions.
= Set the horizontal scale to more than 2*Tg;r.

- If pulse width trigger is selected, Trigger with pulse width trigger with (4*Tgr) pulse or trigger
with edge trigger.

4. Accumulate at least 10,000 triggered waveforms by acquiring the waveform in FastAcq mode of
acquisition.

5. Calculate Vswing of the signal (Vswing = Va—V1), and then find the 20 percent and 80 percent of the
level.
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6. Measure the rise time and fall time.

Enable the oscilloscope rise time measurement. Set the reference level to 20 percent and 80
percent.

Acquire at least 10 K waveforms (RUN and STOP).
Calculate the rise time.

Set the trigger to negative pulse.

Enable the oscilloscope rise time measurement.
Acquire at least 10 K waveforms (RUN and STOP).

Calculate the fall time.

7. Compare with the limit.

If Trise is less than 75 ps or Trisg is more than (0.4*Tgr), it implies Fail.

If Trarr is less than 75 ps or Trarr is more than (0.4*Tg;r), it implies Fail.

8. Repeat the test for all the remaining TMDS clock and data pairs.

Test the Clock Jitter

This test allows you to confirm that the TMDS clock does not carry excessive jitter.

You will need a supported oscilloscope, one differential probe, one DC power supply 3.3 V, one EDID
emulator, and one TPA-P fixture. For DPO/DSA/B oscilloscopes, an external power supply is not required
if the internal power supply is used. See the Preferences (see page 22) menu for details.

1. On the menu bar, click Tests > Select > Source.

2. In the differential tests pane, select the Clock Jitter check box.
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3. To change the configuration settings, click Tests > Configure. For most tests, you can use the factory
default configuration. However, you can change the values by using the virtual keyboard (see page 24)
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Test the Clock Jitter

or the general purpose knob (see page 26) on the oscilloscope front panel. Using the File menu,
you can also restore the factory defaults or save and recall your own configuration settings. It is
recommended that you save the configuration settings before you choose to select Recall Default or
close the application.

File Tests Results Utilities Help TDSHT3 %| X |

Configure - Source

HorizlAcy Reference Levels Fun
Select _ o -
# of Acqs igh *, Test

Hysteresis L i [

Rec Length — = p Report—

| A

CRU

View L .
Waveform PLL ¥ el

Source -= Clock Jitter Clock -= Ch1; Rec Length -> 8M; CRU -> PLL
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In the input pane, set the Input Clock to the channel that you will use for the HDMI clock input.
In the horiz/acq pane, the required number of acquisitions are set for the test. The default value is 10 K.

Set the desired record length value for the clock jitter tests in the Rec Length box. Select from the
available choices (8.00k, 16.0k, 40.0k, 80.0k, 200k, 400k, 800k, 2.00M, 4.00M, 8.00M, 20.0M,
32.0M). The default value is 32.0M.

In the CRU pane, configure the Clock Recovery Unit. The available choices are PLL, Raw, and
Ideal. The default value is first order PLL and is used for compliance testing. Raw and Ideal are
used for analysis.

In the reference levels pane, do the following:

= Set the reference level units to either Per (%) or Abs.
Per (%) indicates that the reference levels are a percentage of the Vswing value.
Abs indicates that the reference levels are absolute voltage values.
The default setting is Per (%).

= In the Hysteresis box, enter the desired hysteresis percent value. The range is from 0% to 25%
and default is 10%.

- In the High box, the required high reference voltage value is set for the test. The default value is
80%.

= In the Mid box, enter the desired mid reference voltage value. The range is from 25% to 75%
and default is 50%.

= In the Low box, the required low reference voltage value is set for the test. The default value is
20%.

To connect the DUT, click Tests > Connect. Click here (see page 74) for information on how
to make connections.

TDSHT3 HDMI Compliance Test Software Online Help



How to ... Test the Clock Jitter

File Tests Results Utilities Help TDSHT3 %| X |

Connect

Select Follow these instructions to set up the connections.

Click Moroe for dotails. More

co nﬁg o
1. Set up the DUT.

Report—

Connect 2. Connect the test fixtures and probes.

3. Toview the signal, click View Waveform.

e )
Detal
‘Waverorm -

Source -> Clock Jitter Clock -= Ch1; Rec Length -= M, CRU -= PLL

9. Ensure that your signal in the oscilloscope display is similar to the sample signal. Click View
Waveform (see page 194) to display a sample of the expected signal. If the displays are not similar, go
back and check your configuration and connections.

10. Click Run Test to perform the test. The TDSHT3 Software sets up the oscilloscope and the test
runs, displaying a progress indicator.

11. If you have run the clock jitter test successfully, the software makes the results available automatically
and displays the clock jitter plot.

The clock jitter plot is as follows:
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4 Clock Jitter o |mf B4

Clock Jitter

Results
Result

=
=
—_
=

E
Ll
-
—

Pk-Pk I3r.2ps
Vewing  908.80mw

Woltage

Thit 3.703Tns

IT Pk-Pk  32151ps

-

Hist Pk-Pk 37.2ps

= Time [370ps/ div]
- | CGreen

NOTE. In the full screen mode, the histogram disappears if you click anywhere within the plot.

Features on the Clock Jitter display include:
= Save: Click Save Image to save the clock jitter plot.

= Zoom: You can zoom in on an area of interest, up to five times the normal view. Either drag the
mouse or click to define the area of interest.

= Reset Plot: Click Reset Plot to reset the plot.

= Histogram: Click Hist to draw the histogram on the eye diagram plot. Click Hist Limits to draw
the histogram box, and Hist Save to save the histogram. Double-click the buttons next to the
Ymax, Ymin, Xmin, and Xmax labels to type the X and Y histogram limits.
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Ymax

+ 29.8mY 8 L

=200

= Scale: Click Fix Scale to type in a new scale value, or click Enter Scale to type in a new vertical
scale value.

= Results display: The results pane displays the result of the mask test result (pass or fail), mask hits
(number of mask hits), Vswing value (voltage swing of the signal), and the Tbit value (time period
of each bit). The IT Pk-Pk and the Hist Pk-Pk values are also shown near the results pane. If there
is no value for IT Pk-Pk, it implies the absence of data points in the histogram window. In this
case, increase the record length value and run the test again.

Results
Mazsk Test

Mask Hitz 0
Yswing 952.00mV

Tbit 1.3482ns

Data Jitter 187p=

Hist Pk-Pk 187ps

12. Click Half Screen to view the clock jitter plot in half screen. You can also view both the result
summary of the test and the report configuration in the result pane as shown in the following figure.
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Clock Jitter

Results

Result r

Pk-Pk 116ps
Vswing 947 .52mVY

Thit 1.3481ns

)
)
o
Ay
o
=
1

File Tests Results LUtliies Help TDSHT3

epor‘t onguration

Device Details HOh
Resolution

Refresh Rate
Report File

DatalLane | . i . ' -
i 1 [ Auto Increment | i B

|Jitter Plot

Source -+ Clock Jitter Clock -= Chi; Rec Lendgth -= 25M; CRU-> PLL

The result pane displays the result summary pane and the report configuration pane.

The result summary pane displays the test results. It lists the test name, status of the test (pass, fail or
error), and jitter plot. To view the details of the results, click Results Details.

Result Summary: Source

Data Lane

| Jitter Plot

NOTE. The View Jitter Plot option is available if you have successfully run the clock jitter test.
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Set the report details to identify and generate the report automatically. You can set a default report file.
Click here (see page 48) for more information.

13. In the result summary pane, click Result Details. The result details pane displays the following fields.

Result Details

= Test Name (displays the test id, test name, and selected lanes)

= Spec Range (displays the HDMI standards and test specifications limit for the test)
= Meas Value (displays the measured value)

= Result (displays the status of the test as Pass, Fail, or Error)

= Remarks/Comments (displays the results of Tbit, Vswing, and Margin). If the test could not be
run, this field displays an error code (see page 357).

14. In the Result Details dialog box, click Result Statistics to display statistics based on the tests. Click
here (see page 49) for more information.

Result Statistics B

Test HMame Fapulatian i
7-9: Clock Jitter Tx Clock TIE: Cl
7-9: Clock Jitter Recowverad Cloc... [
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Test Method

This sequence explains the actions that the software takes while it performs a clock jitter test. For the
procedure on how to make this test, see clock jitter test procedure (see page 221).

1. Refer to Clock lJitter (see page 74) for information on how to make connections for Clock Jitter test.

2. Set up the oscilloscope as follows:
= Adjust the vertical scale to accommodate the waveform in six vertical divisions
= Set the record length to 25 M
= Set the sample rate to > 10 GS/s based on the oscilloscope
= Trigger with the rising edge of the clock (50 percent level)

3. Capture the waveforms on the oscilloscope.

NOTE. Do not transfer the waveforms.

4. Perform software clock recovery as follows:
= Set the reference level to 50 percent of the clock and hysteresis to 10 percent of Vswine.
= Calculate the Software CRU filter as follows.
H(s) = 1/(1+st), where t = 40 nsec.
5. Draw the TMDS waveform with positive edge trigger.
6. Measure the clock jitter as follows:
= Calculate Vswing by using Vy and V. of the clock.
= Calculate the center voltage as follows:
= Ve=(VytVyp)2
= Draw the histogram at Vc+ /-20 mV.
= Calculate Pk-Pk jitter and ‘Interpolated’ Pk-pk jitter.
7. [If clock jitter exceeds (0.25*Tgr), it implies Fail.

Test the Source Inter-Pair Skew

This test allows you to confirm that any skew between the differential pairs in the TMDS portion of the
HDMI link does not exceed the limits in the specification.

You will need a supported oscilloscope, two/four differential probes, one DC power supply 3.3 V, one
EDID emulator, and one TPA-P fixture. For DPO/DSA/B oscilloscopes, an external power supply is not
required if the internal power supply is used. See the Preferences (see page 22) menu for details.
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NOTE. Deskew (see page 44) is recommended before you conduct any skew test.

1. On the menu bar, click Tests > Select > Source.

2. In the differential tests pane, select the Inter-Pair Skew check box.

File Tests Results Utilities Help TDSHT3 %| X |

Select - Source

| ce . Cah -Run
Single-Ended Tests Test

Report—

Connect " T Eo—
o - ; M i
Fall Time
Waveform 2 e Select Al Select Al Detail

Source -= Inter-Pair Skew(D,D) Clock -= Ch1; Datal -» Ch2; Datal -> Ch3; Data2 -> Chd,; Thit: Recalc; Avis -= 100

3. To change the configuration settings, click Tests > Configure. For most tests, you can use the factory
default configuration. However, you can change the values by using the virtual keyboard (see page 24)
or the general purpose knob (see page 26) on the oscilloscope front panel. Using the File menu,
you can also restore the factory defaults or save and recall your own configuration settings. It is
recommended that you save the configuration settings before you choose to select Recall Default or
close the application.

File Tests Results Utilities Help TDSHT3 E| X |

Configure - Source

HoriziAcq Reference Levels Bun
# of Acqs L High -Test

Thit € e Report—

Re- # of Avgs L3
calculate 100 L o
S/ AlLE

Source -= Inter-Pair Skew(D D) Clack -= Ch1; Datal -> Ch2; Datal -= Ch3; DataZ ->= Ch4, Thit: Recalc; Avgs -= 100

For 2-Channel setup, the configuration is as follows:
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File Tests Results Utilities Help TDSHT3 %| X

Configure - Source

Input HoriziAcq Reference Levels Bun
Select Clock ¥ of Acqs % High Test

Ch1 &7

Configure Data0 _ :
- Hysteresis L3 i L3

Chz Thit & & Report—;

10%

N Data1l R # of Avgs L3 a0%
NotC.. ¥ 100 e o
g : _thaz Existing , ) Detai
Wavefarm Mot * [~

Source -= Inter-Pair Skew(D D) Clock -= Ch1; Datal -> Ch2; Thit: Recalc; Avgs -= 100

Inter Pair Skew Configuration...
Connect
Follow these instructions to set up the connections.

Click Iforo for dotaiis. More

1. Make sure Deskew(Lkilities) is performed before running the test.

2. Set up the DUT.

Thit

Continue 4. To view the signal, click vView Waveform.

’—Calculated— 3. Connect the test fixtures and probes.

Remove the clock signal connection and connect the data pair between which you want to calculate
the skew.

4. In the input pane, do the following:

= Set the Input Clock to the channel that you will use for the HDMI clock input. Select from the
available choices (Chl, Ch2, Ch3, and Ch4).

= Set the Input Data0, Datal, and Data2 to the channel that you will use for the corresponding
HDMI data inputs. Select from the available choices (Chl, Ch2, Ch3, Ch4, and Not Conn).

5. In the tbit pane, do the following:

= Enter the desired number of averages (periods) that are considered to calculate Tbit. The range
is from 2 to 1 K and default is 100.

= Click Re-calculate to recalculate the Tbit value.
= Click Existing Value to use the previously calculated Tbit value.
6. In the reference levels pane, do the following:
= Set the reference level units to either Per (%) or Abs.
Per (%) indicates that the reference levels are a percentage of the Vswing value.

Abs indicates that the reference levels are absolute voltage values.
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The default setting is Per (%).

= In the Hysteresis box, enter the desired hysteresis percent value. The range is from 0% to 25%
and default is 10%.

= In the High box, the required high reference voltage value is set for the test. The default value is
80%.

= In the Mid box, enter the desired mid reference voltage value. The range is from 25% to 75%
and default is 50%.

= In the Low box, the required low reference voltage value is set for the test. The default value is
20%.

7. To connect the DUT, click Tests > Connect. Click here (see page 77) for information on how
to make connections.

File Tests Results Utilities Help TDSHT3 %| X |

Connect

Follow these instructions to set up the connections.
=5

Click More for details. More

Configure
1. Set up the DUT.

Report—

Connect 2. Connect the test fixtures and probes.

3. Toview the signal, click View Waveform.
Wiew ;
Detail
‘aveform -

Source -= Inter-Pair Skew(D,0) Clock -= Ch1; Datal -> ChZ; Datal -> Ch3; Data2 ->= Chd, Thit: Recalc, Avgs -= 100

8. Ensure that your signal in the oscilloscope display is similar to the sample signal. Click View
Waveform (see page 195) to display a sample of the expected signal. If the displays are not similar, go
back and check your configuration and connections. The waveform shown here is for the re-calculate
Tbit option. Click Run Test to run the test. The Confirm dialog box appears. Click Continue to
continue to run the test. Go to step 10.

9. Ifyou have selected existing the Tbit value, click View Waveform to get a different waveform on
your display. Ensure that your signal in the oscilloscope display is similar to the sample signal.

10. Click Run Test. The TDSHT3 Software sets up the oscilloscope and the test runs, displaying a
progress indicator.

11. The software makes the results available automatically and displays the result summary. You can also
view the report configuration details in the result pane.
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File Tests Results Utlities Help

Result Summary: Source
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‘ LAl 7-6 © Source Inter-Pair Skew : D2 - D0
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Test the Source Inter-Pair Skew

TDSHT3 ' E x|

Report Conﬁuration

Device Details HIOmAl
Resolution

Rep'brt%"

Refresh Rate AOHz FF

Report File

uto Increment

The results summary lists the test name, status of the test (pass, fail or error), and jitter plot. To view

the details of the results, click Results Details.

12. Set the report details to identify and generate the report automatically. You can set a default report file.
Click here (see page 48) for more information.

13. In the result summary pane, click Result Details. The result details pane displays the following fields.

Result Details

Test Name
7-G : Source Inter-Pair Skew : D0 - D1

|Skew < 200.0ms;

7-6; Source Inter-Pair Skew ; D1 - D2

Skew < 200.0ms;

7-6 ; Source Inter-Pair Skew : D2 - DO

Skew < 200.0ms;

- Test Name (displays the test id, test name, and selected lanes)

= Spec Range (displays the HDMI standards and test specifications limit for the test)

= Meas Value (displays the measured value)

= Result (displays the status of the test as Pass, Fail, or Error)

- Remarks/Comments (displays the relevant details, such as Tbit, Vswing, and Margin. If the test
could not be run, this field displays an error code (see page 357).

Test Method

This sequence explains the actions that the software takes while it performs an inter-pair skew test. For the
procedure on how to make this test, see inter-pair skew test procedure (see page 228).
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Test the Source Inter-Pair Skew

1. Refer to Inter-Pair Skew (see page 77) for information on how to make connections for Clock Jitter test.

2. Set up the oscilloscope and acquire the waveform.

Adjust the vertical scale to accommodate the waveform in six vertical divisions.
Calculate Tyt by using differential clock

Set the sample rate to > 10 GS/s based on the oscilloscope

Set the bit rate based on the Tgr value

Acquire the waveform in real-time single shot

3. Calculate the inter-pair skew as follows:

Find the CTL pattern in Data<X>
Find the CTL pattern in Data<Y>
Find the skew between the two channels in each transition

Calculate the average skew

4. If Tsgpw is greater than (0.2*TpxgL), it implies Fail.

5. Repeat the test for the remaining combinations of TMDS pairs.

CTL Patterns

Use the following patterns to perform the inter-pair skew measurement:

NOTE. The patterns vary based on the HDMI data lane input.

10-bit pattern.
0010101011 for Data0 , Datal, Data2

1101010100 for Data0 , Datal, Data2

0010101010 for Data0

1101010101 for Data0

20-bit pattern.
00101010110011001101 for Data0

11010101010011001101 for Data0

11010101001100110010 for Datal

00101010110011001101 for Data2
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Test the Differential Tests Select All

This option enables you to run the eye diagram, duty cycle, rise time, fall time, and clock jitter test
simultaneously.

You will need a supported oscilloscope, two/four differential probes, one DC power supply 3.3 V, one
EDID emulator, and one TPA-P fixture. For DPO/DSA/B oscilloscopes, an external power supply is not
required if the internal power supply is used. See the Preferences (see page 22) menu for details.

1. On the menu bar, click Tests > Select > Source.
2. In the differential tests pane, click Select All.

File Tests Results Lhilities Help TDSHT3 @| X |

Select - Source

i Single-Ended Tests Test

Report—

Connect _ )

- Rise Time ow Amplitude -
\View S _
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Source -= Multiple Tests Clock -= Ch1; Datal -»= Ch2; Datal -= Ch3; Data2 -> Ch4; Rec Length -= 8M; CRU -= PLL; High -= 80%,; Low -> 20%

3. To change the configuration settings, click Tests > Configure. For most tests, you can use the factory
default configuration. However, you can change the values by using the virtual keyboard (see page 24)
or the general purpose knob (see page 26) on the oscilloscope front panel. Using the File menu,
you can also restore the factory defaults or save and recall your own configuration settings. It is
recommended that you save the configuration settings before you choose to select Recall Default or
close the application.

File Tests Results Utilities Help TDSHT3 %| x

Configure - Source

HoriziAcq Refarence Levels
Select > : .
# of Acqs L High ® Test

10K ; ¢ -
configure . . _ Result
Hysteresis L i )

Rec Length P : = Report—

10%

BooM ' 2% '

CRU

Ve : “ Detail
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Source -= Multiple Tests Clock-= Ch1; Datal -» Ch2; Datal -> Ch3; Data2 -> Chd; Rec Length -= 8, CRU -> PLL; High -> §0%; Low -> 20%

For 2-Channel setup, the configuration is as follows:
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File Tests Results Ultilities Help TDSHT3 E1| X |
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Source -= Multiple Tests Clock -= Ch1; Datal -» Ch2; Rec Length -> 4M; CRU -= PLL; High -> 80%; Low -> 20%

Inter Pair Skew Configuration...

Input Test Connect
Data0 Follow these instructions to set up the connections
cha = Connect .
Click liore for details. Mare
Datal
Ch3 VIEY
i WWaverorm 1. Make sure Deskewilltilities) is performed before running the test.

Data2

Mot C 2. Set up the DUT.
Stop

3. Connect the test fixtures and probes.

Continue 4. To view the signal, click View Waveform.

Remove the clock signal connection and connect the data pair between which you want to calculate
the skew.

4. In the input pane, do the following:

= Set the Input Clock to the channel that you will use for the HDMI clock input. Select from the
available choices (Chl, Ch2, Ch3, and Ch4).

= Set the Input Data0, Datal, and Data2 to the channel that you will use for the corresponding
HDMI data inputs. Select from the available choices (Chl, Ch2, Ch3, Ch4, and Not Conn).

5. In the horiz/acq pane, do the following:

= In the horiz/acq pane, enter the desired number of acquisitions that are required for the test. The
range is from 10 K to 1 M and default is 10 K.

= In the Rec Length box, set the desired record length value for all the selected tests in the Rec
Length box. Select from the available choices (8.00k, 16.0k, 40.0k, 80.0k, 200k, 400k, 800k,
2.00M, 4.00M, 8.00M, 20.0M, 32.0M). The default value is 32.0M.
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6. In the CRU pane, do the following:

= Configure the Clock Recovery Unit. The available choices are PLL, Raw, and Ideal. The default
value is first order PLL and is used for compliance testing. Raw and Ideal are used for analysis.

7. In the reference levels pane, do the following:
= Set the reference level units to either Per (%) or Abs.
Per (%) indicates that the reference levels are a percentage of the Vswing value.
Abs indicates that the reference levels are absolute voltage values.
The default setting is Per (%).

- In the Hysteresis box, enter the desired hysteresis percent value. The range is from 0% to 25%
and default is 10%.

= In the High box, enter the desired high reference voltage value. The range is from 50% to 100%
and default is 80%.

= In the Mid box, enter the desired mid reference voltage value. The range is from 25% to 75%
and default is 50%.

= In the Low box, enter the desired low reference voltage value. The range is from 1% to 50%
and default is 20%.

8. To connect the DUT, click Tests > Connect. Click here (see page 83) for information on how
to make connections.

File Tests Results Utilities Help TDSHT3 E Ll
P 4 Connee
Select Follow these instructions to set up the connections.
Click Moroe for dotails. More

Configure
1. Set up the DUT.

Report—

Connect 2. Connect the test fixtures and probes.

3. Toview the signal, click View Waveform.

e .
Detail
‘Waverorm -

Source -> Multiple Tests Clock -= Ch1; Datal -= Ch2; Datal -» Ch3; Data2 -> Chd, Rec Length -> 8M; CRU -> PLL; High -> §0%, Low -> 20%

9. Ensure that your signal in the oscilloscope display is similar to the sample signal. Click View
Waveform (see page 196) to display a sample of the expected signal. If the displays are not similar, go
back and check your configuration and connections.

10. Click Run Test to perform the test. The TDSHT3 Software sets up the oscilloscope and the test
runs, displaying a progress indicator.

11. If you have run the tests successfully, the software makes the results available automatically and
displays the eye diagram plot and the clock jitter plot. For more information on the plots, refer to the
section on the eye diagram and the clock jitter tests. You can also view both the result summary of the
test and the report configuration in the result pane as shown in the following figure:
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File Tests Results Utilities Help TDSHT3 %I X |
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Clock -» Ch1; Datad -» Ch2; Datal -» Ch3; Data2 -> Chd: Rec Length -» 32M; CRU -> PLL; High -> 80%: Low -> 20%

Source -> Multiple Tests

The results summary lists the test name, status of the test (pass, fail or error), jitter plot for the clock
jitter test, and eye plot for the eye diagram test. To view the details of the results, click Results Details.

12. Set the report details to identify and generate the report automatically. You can set a default report file.
Click here (see page 48) for more information.

13. In the result summary pane, click Result Details. The result details pane displays the following fields.

Result Details

Te ame
7-6 : Source Inter-Pair Skew : DO - D1

7-6 | Source Inter-Pair Skew: D1- D2 |[Skew < 200.0ms;

6 : Source Inter-Pair Skew : D2 - D0 [Skew < 200 Oms;

- Test Name (displays the test id, test name, and selected lanes)

- Spec Range (displays the HDMI standards and test specifications limit for the test)
= Meas Value (displays the status of the test as Pass, Fail, or Error)

= Remarks/Comments (displays the results of Tbit, Vswing, and Margin). If the test could not be
run, this field displays an error code (see page 357).

= View lJitter Plot (displays the jitter plot for the clock jitter test)
= View Eye Plot (displays the eye plot for the eye diagram test)
= Result Statistics (displays statistics based on the tests)

14. In the Result Details dialog box, click Result Statistics to display statistics based on the tests. Click
here (see page 49) for more information.
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Result Statistics

Test Name
Source Clock Jitter : Tx Clock TIE
Source Clock Jitter : Recovered Clock ... | -
Source Eye Diagram : Tx Clock TIE
Source Eye Diagram : Recovered Cloc...| -
7-4 : Source Rise Time - CK
7-4 . Source Rise Time : DO
7-4 : Source Rise Time : D1

7-4 : Source Rise Time : D2

NOTE. Perform similar steps as mentioned in this procedure to test Single-Ended Select All.

Test the Source Intra-Pair Skew

This test allows you to confirm that any skew within any one differential pair in the TMDS portion of the
HDMI link does not exceed the limits in the specification.

You will need a supported oscilloscope, two single-ended probes, one DC power supply 3.3 V, one EDID
emulator, and one TPA-P fixture. For DPO/DSA/B oscilloscopes, an external power supply is not required
if the internal power supply is used. See the Preferences (see page 22) menu for details.

1. On the menu bar, click Tests > Select > Source.

2. In the single-ended tests pane, select the Intra-Pair Skew check box.

File Tests Results Utilities Help TDSHT3 %| X

Select - Source

l 2 - Run
Single-Ended Tests -Test
ye Liagram JItter “ Intra.
Configure Result

Report—

Connect ) .
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Source -= Intra-Pair Skew Inputt: Clock, +Ch1, -Ch2 Input2: Datal, +Chis, -ChdAct -= 10k, Thit: Recalc; Avis -> 100
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3. To change the configuration settings, click Tests > Configure. For most tests, you can use the factory
default configuration. However, you can change the values by using the virtual keyboard (see page 24)
or the general purpose knob (see page 26) on the oscilloscope front panel. Using the File menu,
you can also restore the factory defaults or save and recall your own configuration settings. It is
recommended that you save the configuration settings before you choose to select Recall Default or
close the application.

File Tests Results Utilities Help TDSHT3 %| X |
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4. In the input pane, do the following:
= Set the Inputl, Input+, and Input— to the channel that you will use for the HDMI inputs.

Inputl indicates the source channel to which you will connect the HDMI input. Select from the
available choices (Clock, Data0, Datal, and Data2).

Input+ indicates the source channel to which you will connect the positive input. Select from the
available choices (Chl, Ch2, Ch3, and Ch4).

Input- indicates the source channel to which you will connect the negative input. Select from the
available choices (Chl, Ch2, Ch3, and Ch4).

= Set the Input2, Input+, and Input— to the channel that you will use for the HDMI inputs.

Input2 indicates the source channel to which you will connect the HDMI input. Select from the
available choices (Clock, Data0, Datal, Data2, and Not Conn).

Input+ indicates the source channel to which you will connect the positive input. Select from the
available choices (Ch1, Ch2, Ch3, and Ch4).

Input- indicates the source channel to which you will connect the negative input. Select from the
available choices (Chl, Ch2, Ch3, and Ch4).

5. In the horiz/acq pane, enter the desired number of acquisitions that are required for the test. The
range is from 10 K to 1 M and default is 10 K.

6. In the input pane, set the Clock channel that you want to use. Select from the available choices
(Ch1, Ch2, Ch3, and Ch4).

7. In the voltage pane, the required voltage value is set for the test. The default value is 3.3 V.

TDSHT3 HDMI Compliance Test Software Online Help 239



How to ... Test the Source Intra-Pair Skew

240

8. In the tbit pane, do the following:

= Enter the desired number of averages (periods) that are considered to calculate Tbit. The range
is from 2 to 1 K and default is 100.

- Click Re-calculate to recalculate the Tbit value.
= Click Existing Value to use the previously calculated Tbit value.

9. To connect the DUT, click Tests > Connect. Click here (see page 87) for information on how
to make connections.

File Tests Results Utilities Help TDSHT3 %| X |

Connect

Follow these instructions to set up the connections.

Click Moro for dotails. Mare

1. Set up the DUT.
Report—

Connect 2. Connect the test fixtures and probes. summany

W
Waverorm

Detail

3. To view the signal, click View Waveform.

Source -= Intra-Pair Skew Input1: Clock, +Ch1, -Ch2 Input2: Datal, +Ch3, -ChdAcg -= 10k Thit: Recalc; Avgs -= 100

10. Ensure that your signal in the oscilloscope display is similar to the sample signal. Click View
Waveform (see page 197) to display a sample of the expected signal. If the displays are not similar, go
back and check your configuration and connections. The waveform shown here is for the re-calculate
Tbit option. Click Run Test to run the test. The Confirm dialog box appears. Click Continue to
continue to run the test. Go to step 12.

11. If you have selected existing the Tbit value, click View Waveform to get a different waveform on
your display. Ensure that your signal in the oscilloscope display is similar to the sample signal.

12. Click Run Test. The TDSHT3 Software sets up the oscilloscope and the test runs, displaying a
progress indicator.

13. The software makes the results available automatically and displays the result summary. You can also
view the report configuration details in the result pane.
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14.

15.

Test the Source Intra-Pair Skew

The results summary lists the test name and their status (pass, fail, or error). To view the details
of the results, click Results Details.

Set the report details to identify and generate the report automatically. You can set a default report file.
Click here (see page 48) for more information.

In the result summary pane, click Result Details. The result details pane displays the following fields.

Result Details

Skew < 0.156°Thit

7-7 . Source Intra-Pair Skew : Datal Skew < 0.15°Thit;

= Test Name (displays the test id, test name, and selected lanes)

= Spec Range (displays the HDMI standards and test specifications limit for the test)
= Meas Value (displays the measured value)

= Result (displays the status of the test as Pass, Fail, or Error)

= Remarks/Comments (displays the relevant details, such as Tbit, Vswing, and Margin). If the test
could not be run, this field displays an error code (see page 357).

Test Method

This sequence explains the actions that the software takes while it performs an intra-pair skew test. For the
procedure on how to make this test, see intra-pair skew test procedure (see page 238).

1.

Refer to Intra-Pair Skew (see page 87) for information on how to make connections for Intra-Pair
Skew test.

Set up the oscilloscope as follows:

= Calculate Tyt by using differential clock.

= Adjust the vertical scale to accommodate the waveform in six vertical divisions.
= Set the horizontal scale to (2*Tgr).

= Trigger with edge trigger of Data+ (Rising edge with 50 percent level).

Display the waveform of TMDS DATAO+ and DATAO-. Accumulate at least 10,000 triggers by
acquiring the waveform in FastAcq mode.

Determine the most common TMDS DATAO- 50 percent point by using the histogram method.
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5. Measure skew from most common TMDS DATAO+ point to 50 percent point of first edge of
TMDS_DATAO-.

6. If skew is greater than (0.15*Tgr), it implies Fail.

7. Repeat the test for all the remaining TMDS differential pairs.

Test the Low Amplitude +

This test allows you to confirm that DC voltage levels on the HDMI link are within specified limits
for each TMDS signal.

You will need a supported oscilloscope, one single-ended probe, one DC power supply 3.3 V, one EDID
emulator, and one TPA-P fixture. For DPO/DSA/B oscilloscopes, an external power supply is not required
if the internal power supply is used. See the Preferences (see page 22) menu for details.

1. On the menu bar, click Tests > Select > Source.

2. In the single-ended tests pane, select the Low Amplitude + check box.

File Tests Results Utilities Help TDSHT3 %| X |
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3. To change the configuration settings, click Tests > Configure. For most tests, you can use the factory
default configuration. However, you can change the values by using the virtual keyboard (see page 24)
or the general purpose knob (see page 26) on the oscilloscope front panel. Using the File menu,
you can also restore the factory defaults or save and recall your own configuration settings. It is
recommended that you save the configuration settings before you choose to select Recall Default or
close the application.
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File Tests Results Utilities Help TDSHT3 %| X |
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4. In the input pane, you have the following options:
= Set the Inputl and Input+ to the channel that you will use for the HDMI inputs.

Inputl indicates the source channel to which you will connect the HDMI input. Select from the
available choices ( Chl, Ch2, Ch3, and Ch4).

Input+ indicates the source channel to which you will connect the positive input. Select from the
available choices (Chl, Ch2, Ch3, and Ch4).

= Set the Input2 and Input+ to the channel that you will use for the HDMI inputs.

Input2 indicates the source channel to which you will connect the HDMI input. Select from the
available choices (Chl, Ch2, Ch3, Ch4, and Not Conn).

Input+ indicates the source channel to which you will connect the positive input. Select from the
available choices (Chl, Ch2, Ch3, and Ch4).

5. In the horiz/acq pane, enter the desired number of acquisitions that are required for the test. The
range is from 10 K to 1 M and default is 10 K.

6. In the input pane, set the Clock channel that you want to use. Select from the available choices
(Ch1, Ch2, Ch3, and Ch4).

7. In the voltage pane, enter the desired voltage value. The range is from 1 V to 5 V and default is 3.3 V.
8. In the tbit pane, do the following:

= Enter the desired number of averages (periods) that are considered to calculate Tbit. The range
is from 2 to 1 K and default is 100.

= Click Re-calculate to recalculate the Tbit value.
= Click Existing Value to use the previously calculated Tbit value.

9. To connect the DUT, click Tests > Connect. Click here (see page 93) for information on how
to make connections.
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File Tests Results Utilities Help TDSHT3 %| X

Connect

Follow these instructions to set up the connections.

Click \oro for dotails. Mare

1. Set up the DUT.
Report—

2. Connect the test fixtures and probes.

Connect SUmmany,

3. Toview the signal, click View Waveform.

W averorm

Source -= Low Amplitude + Inputl: Clock,+Ch1 Input2: Datald,+Ch3Aco -= 10k Avce -= 3.3%; Thit: Recalc; Avgs -= 100

10. Ensure that your signal in the oscilloscope display is similar to the sample signal. Click View
Waveform (see page 198) to display a sample of the expected signal. If the displays are not similar, go
back and check your configuration and connections. The waveform shown here is for the re-calculate
Tbit option. Click Run Test to run the test. The Confirm dialog box appears. Click Continue to
continue to run the test. Go to step 11.

11. If you have selected existing the Tbit value, click View Waveform to get a different waveform on
your display. Ensure that your signal in the oscilloscope display is similar to the sample signal.

12. Click Run Test. The TDSHT3 Software sets up the oscilloscope and the test runs, displaying a
progress indicator.

13. The software makes the results available automatically and displays the result summary. You can also
view the report configuration details in the result pane.

File Tests Results Utiliies Help TDSHT3 £, X

Result Summary: Source Report Configuration
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The results summary lists the test name and their status (pass, fail, or error). To view the details
of the results, click Results Details.

14. Set the report details to identify and generate the report automatically. You can set a default report file.
Click here (see page 48) for more information.

15. In the result summary pane, click Result Details. The result details pane displays the following fields.
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Result Details

7-2 Source Low Amplitude +: DO+ 2.700% < VL < 2.900V,

- Test Name (displays the test id, test name, and selected lanes)

= Spec Range (displays the HDMI standards and test specifications limit for the test)
= Meas Value (displays the measured value in volts)

= Result (displays the status of the test as Pass, Fail, or Error)

= Remarks/Comments (displays the relevant details of Tbit, Vswing, Upper Margin, and Lower
Margin). If the test could not be run, this field displays an error code (see page 357).

Test the Low Amplitude -

This test allows you to confirm that DC voltage levels on the HDMI link are within specified limits
for each TMDS signal.

You will need a supported oscilloscope, one single-ended probe, one DC power supply 3.3 V, one EDID
emulator, and one TPA-P fixture. For DPO/DSA/B oscilloscopes, an external power supply is not required
if the internal power supply is used. See the Preferences (see page 22) menu for details.

1. On the menu bar, click Tests > Select > Source.

2. In the single-ended tests pane, select the Low Amplitude - check box.

File Tests Results Utilities Help TDSHT3 @| X |
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Test the Low Amplitude -

To change the configuration settings, click Tests > Configure. For most tests, you can use the factory
default configuration. However, you can change the values by using the virtual keyboard (see page 24)
or the general purpose knob (see page 26) on the oscilloscope front panel. Using the File menu,

you can also restore the factory defaults or save and recall your own configuration settings. It is
recommended that you save the configuration settings before you choose to select Recall Default or
close the application.
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4.
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In the input pane, you have the following options:
= Set the Inputl and Input— to the channel that you will use for the HDMI inputs.

Inputl indicates the source channel to which you will connect the HDMI input. Select from the
available choices (Chl, Ch2, Ch3, and Ch4).

Input— indicates the source channel to which you will connect the negative input. Select from the
available choices (Chl, Ch2, Ch3, and Ch4).

= Set the Input2 and Input— to the channel that you will use for the HDMI inputs.

Input2 indicates the source channel to which you will connect the HDMI input. Select from the
available choices (Chl, Ch2, Ch3, Ch4, and Not Conn).

Input— indicates the source channel to which you will connect the input. Select from the available
choices (Chl, Ch2, Ch3, Ch4, and Not Conn).

In the horiz/acq pane, enter the desired number of acquisitions that are required for the test. The
range is from 10 K to 1 M and default is 10 K.

In the input pane, set the Clock channel that you want to use. Select from the available choices
(Ch1, Ch2, Ch3, and Ch4).

In the voltage pane, enter the desired voltage value. The range is from 1 V to 5 V and default is 3.3 V.
In the tbit pane, do the following:

= Enter the desired number of averages (periods) that are considered to calculate Tbit. The range
is from 2 to 1 K and default is 100.

= Click Re-calculate to recalculate the Tbit value.

= Click Existing Value to use the previously calculated Tbit value.
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9. To connect the DUT, click Tests > Connect. Click here (see page 99) for information on how
to make connections.

File Tests Results Utilities Help TDSHT3 E| X |

Connect

Select Follow these instructions to set up the connections.
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Configure
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10. Ensure that your signal in the oscilloscope display is similar to the sample signal. Click View
Waveform (see page 199) to display a sample of the expected signal. If the displays are not similar, go
back and check your configuration and connections. The waveform shown here is for the re-calculate
Tbit option. Click Run Test to run the test. The Confirm dialog box appears. Click Continue to
continue to run the test. Go to step 12.

11. If you have selected existing the Tbit value, click View Waveform to get a different waveform on
your display. Ensure that your signal in the oscilloscope display is similar to the sample signal.

12. Click Run Test. The TDSHT3 Software sets up the oscilloscope and the test runs, displaying a
progress indicator.

13. The software makes the results available automatically and displays the result summary. You can also
view the report configuration details in the result pane.
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Result Summary: Source Report Configuration
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The results summary lists the test name and their status (pass, fail, or error). To view the details
of the results, click Results Details.

14. In the result summary pane, click Result Details. The result details pane displays the following fields.
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Result Details

Test Name
7-2° Source Low Amplitude - @ Chk-

7-2: Source Low Amplitude - : DO- 2.700Y < VL < 2.900V,

= Test Name (displays the test id, test name, and selected lanes)

= Spec Range (displays the HDMI standards and test specifications limit for the test)
= Meas Value (displays the measured value in volts)

= Result (displays the status of the test as Pass, Fail, or Error)

= Remarks/Comments (displays the relevant details of Tbit, Vswing, Upper Margin, and Lower
Margin). If the test could not be run, this field displays an error code (see page 357).

Test the Min/Max-Diff Swing Tolerance

This test allows you to confirm that the Sink correctly supports TMDS differential voltages at minimum
levels.

To use the DTG test method, you will need a supported oscilloscope, one digital timing generator
(DTG), one differential probe, one DC power supply, eight SMA cables, one GPIB controller, and one
TPA-P-TDR fixture.

To use the DDS test method, you will need a supported oscilloscope, two arbitrary waveform generators
(AWG7102/AWG7122B), one arbitrary function generator (AFG3102/AFG3532), two differential probes,
one TPA-P, one TPA-R, two TCA SMA cables, and one accessory kit (consisting of seven matched
SMA cable pairs, eight bias-tees, eight 120 ps TTC filters, three GPIB-HS cables, four BNC cables, and
one BNC-T adapter).

1. On the menu bar, click Tests > Select > Sink.

2. In the differential tests pane, select the Min/Max-Diff Swing Tolerance check box.
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3. To change the configuration settings, click Tests > Configure. For most tests, you can use the factory
default configuration. However, you can change the values by using the virtual keyboard (see page 24)
or the general purpose knob (see page 26) on the oscilloscope front panel. Using the File menu,
you can also restore the factory defaults or save and recall your own configuration settings. It is
recommended that you save the configuration settings before you choose to select Recall Default or
close the application.
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4. In the Input pane, set the channel that you will use for the HDMI input. Select from the available
choices (Chl, Ch2, Ch3, and Ch4).

5. In the Setup pane, select the appropriate test method from the available choices (DTG Method and
DDS Method).

6. If the selected test method is DTG, do the following:
= Select the DTG pattern file from the drop-down list.

= Click Outputs to display a dialog box where you can set unique Clock, Data0, Datal, and
Data2 outputs.

If the selected test method is DDS, do the following:

TDSHT3 HDMI Compliance Test Software Online Help 249



How to ...

Test the Min/Max-Diff Swing Tolerance

File Tests Results Ltiliies Help TDSHT3 %| x |
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= In the Markers pane:

= Select the oscilloscope channel to use for routing the synchronization pulse from the AWGI.
The available choices are: Chl, Ch2, Ch3, and Ch4. The default value is Ch3.

= Select the oscilloscope channel to use for routing the synchronization pulse from the AWG?2.
The available choices are: Chl, Ch2, Ch3, and Ch4. The default value is Ch4.

= Select the DDS pattern file from the drop-down list for the selected DUT frequency.
= Click Outputs to display the AWG Output dialog box.

NOTE. You cannot configure the AWG Outputs dialog box.

The DTG Outputs dialog box has the following options:

DTG Outputs | %]

Outputs
Clock Data0

Al il B1 il

Data2

1 7

= Clock (allows you to configure the Clock output). Select from the available choices (A1, A2, B1,
B2, Cl1, C2, D1, and D2).

= Data0, Datal, and Data2 (allows you to configure the corresponding data output). Select from
the available choices (A1, A2, B1, B2, C1, C2, D1, and D2).

The AWG Outputs dialog box for the DDS method has following configurations:
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AWG Outputs

AWG Outputs
Clock Data0

NOTE. You cannot configure the AWG Outputs dialog box.

NOTE. You cannot exit the dialog box unless each of the clock and data selections are unique.

8. To connect the DUT, click Tests > Connect. Click here (see page 105) for information on how
to make connections.

File Tests Results Utilities Help TDSHT3 %| X |

Connect

Follow these instructions to set up the connections. Run
Select Test

Click Moro for dotails.

Configure Result
1. Set up the DUT, test fixtures and probes.

e
YWWaveform

3. To view the signal, click View Waveform. [Detail

Report—
Connect 2. Configure and test the signal sources.

Sink -= MinMdax-Diff Swing Tolera... Input -= Chi; Test Method-> DTG Method

9. To configure and test the GPIB connection to the DTG, click Signal Sources. The Signal Sources
Setup dialog box appears.
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Signal Sources Setup

Select GPIB Setup
Board Type

ZPIE GPIED

Address

Primary
1 -

Secondary

] 7

If you have selected the DDS test method, the AWG tab has options to configure the Primary and
Secondary Addresses of AWG1 and AWG2.

Signal Sources Setup

GPIB Setup
Board Type

GFIED
AWG1 Address AWGE2 Address
Primary Primary

3 - =3 -

Secondary Secondary

NOTE. You cannot exit the dialog box unless each of the primary and secondary address selections are
unique.

NOTE. The Manual test option is not available for the DDS method.

10. In the select pane, click GPIB. Configure the appropriate GPIB board number. Click here (see
page 27) for more information.

11. To test both the connection and the DTG GPIB configuration, click Test Conn.
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12. Because no signal is connected to the oscilloscope, you cannot view the waveform for the min-diff
sensitivity test.

NOTE. 70 run the test successfully, ensure that the Bus Timing parameter is set to 2 usec on your GPIB
board configuration. For more details, click here (see page 37).

13. Click Run Test. The TDSHT3 Software sets up the oscilloscope and conducts the test. Follow the
instructions in the dialog box. Depending on your answer, a series of dialog boxes may prompt
you for your input.

14. If you successfully run the test, the software makes the results available automatically and displays the

result summary. You can also view the report configuration details in the result pane.
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The result summary for the DDS test method is as follows:
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The results summary lists the test name and their status (pass, fail, or error). To view the details
of the results, click Results Details.

15. Set the report details to identify and generate the report automatically. You can set a default report file.
Click here (see page 48) for more information.

16. In the result summary pane, click Result Details. The result details pane displays the following fields.
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Result Details

-5 tage : vVicm2
85 Max-Diff Swing Voltage

Wit < 150.0m';
8-5 : Min - Diff Swing Yoltage : vicm2 Wiff < 150.0m,
B8-5 : May - DIff Swing Voltage

= Test Name (displays the test id, test name, VIcm, and lane)

= Spec Range (displays the HDMI standards and test specifications limit for the test)
= Meas Value (displays the measured value in mV)

= Result (displays the status of the test as Pass, Fail, or Error)

- Remarks/Comments (displays the relevant details, such as Vswing and Margin). If the test could
not be run, this field displays an error code (see page 357).

Test Method

This sequence explains the actions that the software takes while it performs a min/max-dift swing
tolerance test. For the procedure on how to make this test, refer to the min/max-diff swing tolerance
test procedure (see page 248).
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For the DTG Method

1.

Configure the DTG to output any sink-supported video format.

= Load the pattern that contains repeating RGB gray ramp 0, 1, 2...254, 255, 0, 1, 2... during
each video period.

= Map all the logical channels to physical channels.
= Run the DTG.
= Enable all the output channels.

Search for and record the minimum differential swing voltage that the Sink DUT supports without
error at Viem = 2.9 V (Frequency > 165 MHz) and 3.0 V (Frequency < 165 MHz).

= Set VICMI =3.029 V.

= Set Vpirr = 170 mV on all TMDS differential pairs. (Note that “Amplitude and Offset” mode in
the DTG “Level” window should be chosen. In this mode, set “Amplitude” to 0.085 Vpp to
correspond to a 170 mV differential swing.)

= Ifthe test passes at 170 mV, reduce Vpier in 10 mV steps (corresponding to 0.01 Vpp steps in the
“Amplitude” setting) on all pairs until the Sink DUT outputs errors or Vpr 0of 90 mV is reached.

- If the test fails at 170 mV, increase Vprr in 10 mV steps on all pairs until the Sink DUT outputs
pass or Vpir 0of 250 mV is reached.

= Record Vpr {minimum} at first voltage level where no error appears.
Repeat the test for Vicmp =3.3 V.

Set Vprrr = 1.2 V on all TMDS differential pairs. (Note that “Amplitude and Offset” mode in the DTG
“Level” window should be chosen. In this mode, “Amplitude” should be set to 0.6 Vpp to correspond
to a 1.2 V differential swing.)

Verify that the DUT continues to support the signal without errors.
If the DUT fails to support the signal, it implies a Fail.

For the DDS Method

1.
2.

Operate the Sink DUT to support the HDMI input signal.

For the procedure on how to make this test, refer to the min/max-diff swing tolerance test procedure

(see page 248).

Refer to the make connections for sink min-max differential swing test (see page 111) for information
on how to make connections.

Check the connection of the AWGs and AFG from TDSHTS3.

Run the test. The software loads the appropriate patterns with differential voltage of 170 mV. The
software prompts you to confirm the gray bars on the DUT.

If the gray bar does not appear, the differential voltage is increased to 250 mV in steps of 10 mV. You
are prompted to confirm for the gray bars on the DUT for each step.
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7. If the gray bar appears, the differential voltage is decreased to 90 mV in steps of 10 mV as per the
CTS. You are prompted to confirm for the gray bars on the DUT for each step.

8. You are promoted to connect the Clock channel to the oscilloscope to measure the voltage.

9. Once the test completes, the appropriate test results are generated.

NOTE. Using a manual DDS test method is not recommended because the software performs the
Min/Max-Diff Swing Tolerance test automatically and effectively.

Test the Jitter Tolerance

256

This test allows you to confirm that the maximum allowed TMDS clock jitter is supported by the Sink DUT.

The signal degradation of typical passive copper cables increases with the frequency and the length of the
cable. To recover data from such cables, the TDSHT3 software applies the reference cable equalizer (as
specified in the HDMI specifications 1.4a) automatically to the jitter tolerance measurement when the
clock frequency is more than 165 MHz.

To use the DTG test method, you will need a supported oscilloscope (which also acts as a GPIB
Controller), two differential probes, one digital timing generator (DTG), one arbitrary waveform generator
(AWG), one DC power supply, 12 SMA cables, two bias-tees, cable emulators, one TPA-R-DI, one
TPA-R-TDR, and TTC modules.

To use the DDS test method, you will need a supported oscilloscope, two arbitrary waveform generators
(AWG7102/AWGT122B), one arbitrary function generator (AFG3102/AFG3532), two differential probes,
one TPA-P, one TPA-R, and two TCA SMA cables, and one accessory kit (consisting of seven matched
SMA cable pairs, eight bias-tees, eight 120 ps TTC filters, three GPIB-HS cables, four BNC cables, and
one BNC-T adapter). For Type-E cable emulator, use the Type-E fixtures (one TF-HDMIE-TPA-P and
one TF-HDMIE-TPA-R) in place of Type-A and Type-C fixtures.

Jitter Calibration Steps.

To calibrate the jitter values of the Direct Synthesis signal, do the following:

B Connect a TPA-R fixture to the TPA-P fixture.

®  Connect the Clock and Data0 output of the TPA-R fixture to the oscilloscope using two P7313SMA
probes.

B The software measures the jitter values using two P7313SMA probes. If the measured values are not
within +£2.5% of the range specified in the CTS, the software regenerates the patterns.

This sequence is repeated until the measured values are within the specified range in the CTS.
1. On the menu bar, click Tests > Select > Sink.

2. In the differential tests pane, select the Jitter Tolerance check box.
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File Tests Results Ltilities Help TDSHT3 %| X |
Select - Sink

|'... source [ i ah Run
Select . g
Differential Tests Single-Ended Tests Test
g . Jitter Tolerance ) - .
B

Report—

en
- One Bit Audio vl Inter i ) o
View - nded C
—

Sink -» Jitter Tolerance Clock -»>Ch1; Data -> Ch2; Test Method-= DTG Method, Freq Pair-» D,CK: 500kHz, 10MHz, DUT freq (MHz)»> 74.25

3. To change the configuration settings, click Tests > Configure. For most tests, you can use the factory
default configuration. However, you can change the values by using the virtual keyboard (see page 24)
or the general purpose knob (see page 26) on the oscilloscope front panel. Using the File menu,
you can also restore the factory defaults or save and recall your own configuration settings. It is
recommended that you save the configuration settings before you choose to select Recall Default or
close the application.

File Tests Results Utilities Help TDSHT3 @| X |
Configure - Sink

Setup DTG Method Run
Select Test Method Jitter Insertion Jitter Amplitude : Test

Clock

DTG Wethod ' P e
Configure [ 3 I3 :

Report——

CDnnECt " . — I -

DUT Freg (MHz2)

WiEW
Waverform i 60HZ 8 . Outputs

Sink == Jitter Tolerance Clock ->Ch1; Data -> Ch2; Test Method-= DTG Method; Freg Pair-> 0,CK: S00kHz, 10MRHzZ, DUT freg-» 74 25MHZ

4. In the Input pane, do the following:

= Set the Input Clock to the channel that you will use for the HDMI clock input. Select from the
available choices (Chl, Ch2, Ch3, and Ch4).

= Set the Input Data to the channel that you will use for the HDMI data input. Select from the
available choices (Chl, Ch2, Ch3, and Ch4).

NOTE. For the DTG method, this connection is required only if you perform jitter calibration by selecting
Jitter Tolerance (No calibration) in the Preferences (see page 22) menu.

TDSHT3 HDMI Compliance Test Software Online Help 257



How to ...

258

Test the Jitter Tolerance

5. In the Setup pane, do the following:

In the Test Method pane, select the appropriate test method from the available choices (DTG
Method and DDS Method).

In the Frequency Pair list, click the desired value for the jitter tolerance tests. Select from the
available choices (D, Ck: 500 KHz, 10 MHz and D, Ck: 1 MHz, 7 MHz, and Both). If you select
Both, the test is run for both the frequency pairs.

In the DUT Freq (MHz) list, select the frequency to be tested for the DUT. The available choices
depend upon the selected test method.

For the DTG method, the available choices are 27.175, 27, 74.25, 148.5, 222.75, and 297.

For the DDS method, the available choices are 27, 74.25, 148.5, 222.75, 27 Type-E, and 74.25
Type-E.

6. If the selected test method is DTG, do the following:

In the Jitter Insertion pane:

= Select AWG to insert composite jitter using an AWG.

NOTE. In the composite jitter, both clock and data jitter frequency components are added to
the clock signal.

= Select AFG to insert composite jitter using an AFG.

NOTE. In the composite jitter, both clock and data jitter frequency components are added to
the clock signal.

= Select AWG to insert separate jitter.

NOTE. In separate jitter insertion, clock jitter is added to the clock signal and data jitter is added
to the data signal.

In the Jitter Amplitude pane:

= Set the amplitude of the clock jitter. By default, the value is set to the value specified in
the HDMI standards (CTS 1.4a).

The minimum and maximum value of clock are 150 mTbit and 500 mTbit respectively.

= Set the amplitude of the data jitter. By default, the value is set to the value specified in the
HDMI standards. Set the amplitude of the data jitter. By default the value is set to the value
specified in the HDMI standards.
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The minimum and maximum value of data are 150 mTbit and 500 mTbit respectively.
= Select the DTG pattern file from the drop-down list for the selected DUT frequency.

= In the DTG field, click Outputs to display a dialog box where you can set unique Clock, Data0,
Datal, and Data2 outputs.

If the selected test method is DDS, do the following:

File Tests Results Utilities Help TDSHT3 X |
Configure - Sink

Setup DDS Method Run
Sl Test Method Jitter Insertion Cable Emulator Test

DDS Method ¥ ! nosite Both 7
Configure ® Separate
Frequency Pair Markers

AWG1 AWG2 Report—

Connect . cChi Chd =
DUT Freq {(MHz)
VIEW 74.25 -

Pattern List AWG
Wavetorm [N —

Outputs

Sink -= Jitter Tolerance Clock -=Ch1; Data -» Ch2; Test Method-> DDE Method; Freg Pair-> D,CK. S00KHZ, 10MHZ; DUT freg-> 74 .258MHZ

= In the Jitter Insertion pane, select the composite jitter insertion technique to add jitter. In the
composite jitter insertion technique, clock jitter and data jitter are added to the clock signal.

NOTE. The Separate Jitter Insertion technique is not supported for the DDS method.

= Select the cable emulator type to use. The available choices are: 1st Cable Emulator, 2nd Cable
Emulator, and Both. The default is Both.

If you have selected 27 Type-E or 74.25 Type-E in the DUT Freq (MHz) list, only one cable
emulator type (Type-E Cable Emulator) is available.

- In the Markers pane:

= Select the oscilloscope channel to use for routing the synchronization pulse from the AWGI.
The available choices are: Chl, Ch2, Ch3, and Ch4. The default value is Ch3.

= Select the oscilloscope channel to use for routing the synchronization pulse from the AWG?2.
The available choices are: Chl, Ch2, Ch3, and Ch4. The default value is Ch4.

= Select the DDS pattern file from the drop-down list for the selected DUT frequency.
= In the AWG field, click Outputs to display a dialog box.
7. The DTG Outputs dialog box for the DTG method has the following options:
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OTG Outputs E

Outputs
Clock Datal

A B

Data1l Data2

e 1

Test the Jitter Tolerance

= Clock (allows you to configure the clock output). Select from the available choices (A1, A2, B1,

B2, C1, C2, D1, and D2).

= Data0, Datal, and Data2 (allows you to configure the corresponding data outputs). Select from
the available choices (A1, A2, B1, B2, C1, C2, D1, and D2).

The AWG Outputs dialog box for the DDS method has following configurations:

AWG Outputs

AWG Outputs
Clock Data0

NOTE. You cannot configure the AWG Outputs dialog box.

NOTE. You cannot exit the dialog box unless each of the clock and data selections are unique.

To connect the DUT, click Tests > Connect. Click here (see page 115) for information on how to

make connections.
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File Tests Results Lhtilities Help TDSHT3 @| X |

Connect
Follow these instructions to set up the connections. Run
Select Test

Click More for details. ore

1. Set up the DUT, test fixtures and probes.
C ! C Report—

Connect

2. Configure and test the signal sources.

e 3. Toview the signal, click View Waveform. Detail
YWaveform

Sink -= Jitter Tolerance Clock -=Ch1; Data -» Ch2; Test Method-> DTG Method; Freq Pair-> D,CK: 500kHz, 10MHz, DUT freg-= 74.28MHz

9. To configure and test the GPIB connection, click Signal Sources. The Signal Sources Setup dialog box
appears. The Signal Sources parameters are populated based on the selected test method: DTG or DDS.

Signal Sources Setup

GPIB Setup
Board Type

GPIED -
Address
Primary

1 =

Secondary

] -

If you have selected the DDS test method, the AWG tab has options to configure the Primary and
Secondary Addresses of AWG1 and AWG2.
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Signal Sources Setup

GPIB Setup
Board Type

GRIEBOD
AWG1 Address AWG2 Address
Primary Primary

- a3 -

Secondary Secondary

Test the Jitter Tolerance

NOTE. You cannot exit the dialog box unless each of the primary and secondary address selections are
unique.

NOTE. The Manual test option is not available for the DDS method.

10. In the select pane, click GPIB. Configure the appropriate GPIB board number. Click here (see
page 27) for more information.

11. To test the connection and the GPIB configuration, click Test Conn.

12. Because no signal is connected to the oscilloscope, you cannot view the waveform for the jitter
tolerance test.

NOTE. To run the test successfully, ensure that the Bus Timing parameter is set to 2 usec on your GPIB
board configuration. Click here (see page 37) for more information.

13. Click Run Test. The TDSHT3 Software sets up the oscilloscope and conducts the test.

14. Follow the instructions in the Sink Jitter Tolerance dialog box. Click OK. The Connect Sink Device
dialog box for low frequency appears as follows.
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‘Connect to the Sink

as follows

If you select the DDS test method, the Connect Sink Device dialog box appears as follows:

Connect to sink device

continue.

Press F1 for the detailed setup diagrarm.

15. Follow the instructions in the Connect Sink Device dialog box. Click OK. The test runs, displaying a
progress indicator. The Confirm Sink Device Support dialog box appears.
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File Tests Results Utilities Help TDSHT3 @| X |

Result Summary: Sink Danart Canfianuratiag

Select Confirm Sink Device Support

Configure

Report—

Wigw Data Lane ;
Waverorm - Detail

Sink -= Jitter Tolerance Clock -=Ch1; Data -> Chi3; Test Method-> DTG Method; Freq Pair-= D,CkK: 800kHz, 10MHz; DUT freg-> 27MHZ

If you select the DDS test method, the Confirm Sink Device Support dialog box appears as follows:

File Tests Results Utilities Help TDSHT3 L) X |

Result Summary: Sink Do nst © nnfiaieatiagg

Select Confirm Sink Device Support X] IR
Test
Configure Sl ! i
' ST . & Report—
Connect _ quency Pair :

Wiew -
Data Lane Detail
Waveform ’

Sink -= Jitter Tolerance Clock -»Ch1; Data -= Ch2; Test Method-= DDS Method: Freq Pair-= D, CK: 800kHz, 10MHz; DUT freq-» 74 25MHz

16. Follow the instructions in the dialog box. Depending on your answer, a series of dialog boxes may
prompt you for your input.

17. If you successfully run the test, the software calculates the jitter values and displays the results. The
software makes the results available automatically and displays the result summary. You can also view
the report configuration details in the result pane.

File Tests Results Utilities Help TDSHT3 %| X |
Result Summary: Sink Report Configuration

Select T Te
LAf|5-7 : Jitter Tolerance ; 27MHz ; D,CK 500kHZ,1..

Lf|5-7 : Jitter Tolerance : 27MHz ; D,CK: 1MHZ, 7MHZ Resolution 192 i
Configure Result

Device Details HOMI : I Test

Refresh Rate E0Hz Report—

Report File op b g
Vi
N2ty Data Lane g
W averorm W Auto Increment o

Sink -= Jitter Tolerance Clock -=Ch1; Data -> ChZ; Test Method-> DTG Method; Freg Pair-= Both; DUT freg-= 27MHzZ

The result summary for the DDS test method is as follows:
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File Tests Results Utilities Help TDSHT3 5, X |
BB ResutSummary:sink - Report Configuration

- . Run
g 3 Device Details HOMI
s Jitter Tolerance :© 148.5MHz ; Freg Pair: D..

o Jitter Tolerance © 148.5MHZ ; Freq Pair: D.. Resolution 3 i i
Configure Result

- Jitter Tolerance : 148.8MHz ; Freq Pair
- Jitter Tolerance © 148 GMHz ; Freq Pair Refresh Rate a0Hz e Report—

Report File 0451_ | 1 i
Vi
L) Data Lane - g Detail
wyaveform ) & Auto Incremen

Sink -= Jitter Tolerance Clock -=Ch1; Data -» Ch2; Test Method-= DDS hethod; Freq Pair-> Both; DUT freg-= 148 ShMHz

The results summary lists the test name and the status (pass, fail, or error). To view the details of the
results, click Results Details.

18. Set the report details to identify and generate the report automatically. Click here (see page 48)
for more information.

19. In the result summary pane, click Result Details. The result details pane displays the following fields.

Result Details

5-7 : Jitter Tolerance : D .CK: S00kHz, 1. [1.0°Thit <= Ck-D Skew,

B-7 ; Jitter Tolerance : D Ck: IMHz, ZMHz|1 0 Thit <= Ck-D Skew,

:Jitter Tolerance © 148.5MHz ; Freq Pair . D,CK: 500kHz, 10MHZ, Cable Emulator @ |1.0°Thit <= k—... 1.0%Thit
:Jitter Tolerance : 148.8MHZ ; Freq Pair : D,CK: S00kHz, 10MHZ Catle Emulator ;. [1.0°Thit €= Ck-... || 1)
: Jitter Tolerance : 148.5MHzZ ; Freq Pair . D ,CK: 1MHZ, 7MHZ, Cahble Emulator @ 15, |1.0%Thit <= Ck-... || 10
s Jitter Tolerance : 148.5MHz ; Freq Pair . D,CK: 1MHZ, 7MHE, Cable Emulator @ 2n..|1.0°Thit <= Ck-... |
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= Test Name (displays the test id, test name, and selected lanes)

= Spec Range (displays the HDMI standards and test specifications limit for the test)
= Meas Value (displays the measured value in mV)

= Result (displays the status of the test as Pass, Fail, or Error)

= Remarks/Comments (displays the relevant details, such as Vswing and Margin. If the test could
not be run, this field displays an error code (see page 357).

Test Method

266

This sequence explains the actions that the software takes while it performs a jitter tolerance test. For the
procedure on how to make this test, refer jitter tolerance test procedure (see page 256).

For the DTG Method
1. Operate the Sink DUT to support the HDMI input signal.
2. Configure the DTG as follows:
- Load the appropriate no-jitter pattern in the DTG
= Set the signal outputs to 3.0 V average
3. Configure the AWG as follows:
= In the “Vertical” menu, set the following:
= Filter-through
= Amplitude
= Offset=0V
= Marker 1 =0.00 V to 1.00 V
= Marker 2 =0.00 V to 2.00 V
= No jitter on output initially, with ability to add two simultaneous jitter components.

4. Connect the test fixture to the oscilloscope for jitter calibration. The oscilloscope calculates data and
clock jitter inserted due to the cables and the test fixtures along with the known amount of jitter.

5. Use the appropriate TTC module based on the recommended resolution.
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Measure jitter tolerance while verifying adequate support by sink.
= For each of the two test cases:

- D _JITTER =500 kHz, C JITTER = 10 MHz

- D JITTER =1 MHz, C JITTER =7 MHz

Increase the skew (Differential timing offset) in steps of 0.1 Tbit from 0.0 Tbit to 1.0 Tbit. The
test fails if the sink outputs errors at any time.

For the DDS Method

The DDS method does not require a DTG. The setup includes two AWGs to create synthesized patterns for
HDMI Sink Jitter Tolerance testing. It does not need different TTC filters for each resolution and cable
emulators because their effects are emulated by the software.

1.
2.
3.

Operate the Sink DUT to support the HDMI input signal.

To configure the parameters for this test, refer jitter tolerance test procedure (see page 256).

Refer to the sink jitter tolerance test connection (see page 124) for information on how to make
connections.

Check the connection of the AWGs and AFG from TDSHT3.

Run the test. The software loads the appropriate patterns with no-jitter waveforms. The software
prompts you to confirm the gray bars on the DUT. Once this is confirmed, the software loads the TP1
waveforms with jitter insertion as per the CTS.

If you have not selected Jitter Tolerance (No calibration) in the Preferences (see page 22) menu,
the software will measure the jitter values. If the measured values are not within +2.5% of the value
specified in the CTS, the software will regenerate the patterns to match the specified jitter values.

Confirm the gray bars on the DUT for TP1. Upon confirmation, the software loads the TP2 waveforms
with appropriate cable emulator and jitter insertion as per the CTS.

If you have not selected Jitter Tolerance (No calibration) in the Preferences (see page 22) menu,
the software will measure the jitter values. If the measured values are not within +2.5% of the value
specified in the CTS, the software will regenerate the patterns to match the specified jitter values.

Confirm the gray bars on the DUT for TP2. Upon confirmation, the software loads the skew patterns in
steps of 0.1 Tbit from 0.0 Tbit to 1.0 Tbit. The test fails if the sink outputs errors at any time.

NOTE. Using a manual DDS test method is not recommended because the software performs the Sink
Jitter Tolerance test automatically and effectively.
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Test the Deep Color

268

This test allows you to confirm that a particular resolution and color depth (bits) is supported by the
Sink DUT.

To use the DTG test method, you will need a supported oscilloscope, one digital timing generator
(DTG), one differential probe, one DC power supply, eight SMA cables, one GPIB controller, and one
TPA-P-TDR fixture.

To use the DDS test method, you will need a supported oscilloscope, two arbitrary waveform generators
(AWG7102/AWGT122B), one arbitrary function generator (AFG3102/AFG3532), two differential probes,
one TPA-P, one TPA-R, two TCA SMA cables, and one accessory kit (consisting of seven matched
SMA cable pairs, eight bias-tees, eight 120 ps TTC filters, three GPIB-HS cables, four BNC cables, and
one BNC-T adapter).

1. On the menu bar, click Tests > Select > Sink.

2. In the differential tests pane, select the Deep Color check box.

File Tests Results Ltilities Help TDSHT3 @1| X
Select - Sink

| =OUrce Sink r .
Select Cable
S""E'Elld Tests -est

hl

e Jitter Tolerance . Deep Colar - Intra-Pair i
i

Audio Formats Report—

— .
“igw - en 5
:

Sink -» Deep Color Test Method-> DTG Method, Resolution->= 480i; Bits-> 12 hit, Refresh Rate-> 60 Hz

3. To change the configuration settings, click Tests > Configure. For most tests, you can use the factory
default configuration. However, you can change the values by using the virtual keyboard (see page 24)
or the general purpose knob (see page 26) on the oscilloscope front panel. Using the File menu,
you can also restore the factory defaults or save and recall your own configuration settings. It is
recommended that you save the configuration settings before you choose to select Recall Default or
close the application.

File Tests Results Ltiliies Help TDSHT3 E| X |
Configure - Sink

Setup DDS Method Bun
Select Test Method Resolution Test

DDS Method ~ 480i 4
Configure Markers
Bits

AWG1 AWG2 Fepayenl

12 hit cha = Cchd =
Refresh Rate

Pattern List

iew &0 Hz 480 12 6 ar 444 i
WY averornm DEEl

Sink -= Deep Caolor Test Method-= DDE Method; Resolution-» 480i; Bits-= 12 hit; Refresh Rate-= 60 Hz
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4. In the Input pane, set the Input Clock to the channel that you will use for the HDMI clock input. Select
from the available choices (Chl, Ch2, Ch3, and Ch4).

5. In the Setup pane, select the appropriate test method from the available choices (DTG Method and
DDS Method).

6. In the DTG Method pane, do the following:

Select the resolution of the pattern to be loaded on the AWG. Select from the available choices
(4801, 480p, 480px640, 5761, 576p, 720p, 10801, 1080p, and VGA). The default value is 480i.

Select the color depth (Bits) of the deep color pattern. Select from the available choices (10 Bit,
12 Bit, and 16 Bit).

Select the refresh rate of the patterns. Select from the available choices (50 Hz and 60 Hz).
The default value is 60 Hz.

Select the pattern(s) from the available list for the selected resolution, refresh rate, and the bits.

In the DDS Method pane, do the following:

Select the resolution of the pattern to be loaded on the AWG. Select from the available choices
(4801, 480p, 480px640, 5761, 576p, 720p, 10801, 1080p, and VGA). The default value is 480i.

Select the color depth (Bits) of the deep color pattern. Select from the available choices (10 Bit,
12 Bit, and 16 Bit).

Select the refresh rate of the patterns. Select from the available choices (50 Hz and 60 Hz).
The default value is 60 Hz.

In the Markers pane:

= Select the oscilloscope channel to use for routing the synchronization pulse from the AWGI.
The available choices are: Chl, Ch2, Ch3, and Ch4. The default value is Ch3.

= Select the oscilloscope channel to use for routing the synchronization pulse from the AWG?2.
The available choices are: Chl, Ch2, Ch3, and Ch4. The default value is Ch4.

Select the pattern(s) from the available list for the selected resolution, refresh rate, and the bits.

7. To connect the DUT, click Tests > Connect. Click here (see page 130) for information on how
to make connections.
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File Tests Results Ltiliies Help TDSHT3 %| x |
Connect

Follow these instructions to set up the connhections.
Test

Click ifore for details. hare

1. Set up the DUT, test fixtures and probes.
L ! L Report—

Connect 2. Configure and test the signal sources. sumrmary
igw 3. To view the signal, click View YWaveform. Detail
Waverorm

Sink -= Deep Caolor Test Method-> DDS Method; Resolution-» 480i; Bits-= 12 hit; Refresh Rate-= 60 Hz

8. To configure and test the GPIB connection, click Signal Sources. The Signal Sources Setup dialog
box appears.

The AWG tab has options to configure the Primary and Secondary Addresses of AWG1 and AWG?2.

Signal Sources Setup

Select GPIB Setup
Board Type

GPRIE GPIBOD
AWG1 Address AWG2 Address

B o

Manual - -
@ - a -

Secondary Secondary
]

NOTE. You cannot exit the dialog box unless each of the primary and secondary address selections are
unique.

NOTE. The Manual test option is not available for the DDS method.

9. In the select pane, click GPIB. Configure the appropriate GPIB board number. Click here (see
page 27) for more information.

10. To test the connection and the GPIB configuration, click Test Conn.

11. Because no signal is connected to the oscilloscope, you cannot view the waveform for the jitter
tolerance test.
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NOTE. To run the test successfully, ensure that the Bus Timing parameter is set to 2 usec on your GPIB
board configuration. Click here (see page 37) for more information.

12. Click Run Test. The TDSHT3 Software sets up the oscilloscope and conducts the test.

13. Follow the instructions in the Sink Deep Color dialog box. Click OK. The Connect Sink Device
dialog box appears as follows:

Connect to sink device le

1, set up the connections as follows -

d TPA-P.

14. Follow the instructions in the Connect Sink Device dialog box. Click OK. The test runs, displaying a
progress indicator. The Confirm Sink Device Support dialog box appears.

Confirm Sink Device Support

| Pattern Mame : 480i 10 60 CBar RG

or Bar on the DUT ?

15. Follow the instructions in the dialog box.

16. If you successfully run the test, the software loads the deep color pattern(s). The software makes
the results available automatically and displays the result summary. You can also view the report
configuration details in the result pane.
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File Tests Results Ltiliies Help TDSHT3 %| x |

Result Summary: Sink Report Configuration

- _ Run
Device Details HOM ] i Tt

LAf|9-25: Deep Color 4800 10 60 CBar RGE PC169 ...

L A]|8-25: Deep Color 480i 10 60 CBar RGE PC43 v... Resolution 0i
Canfigure Result

LA)|5-29: Deep Color 4801 10 60 Gray RGEB PC169 ...
| ]|8-25: Deep Color 480i 10 60 Gray RGE PCA3 v Refresh Rate 50 Hz Report—

Report File alica 5
Vi
1Ew Data Lane g
W avefarm & Auto Increment

Sink -= Deep Caolor Test Method-> DDS Method; Resolution-» 480i; Bits-= 10 hit; Refresh Rate-= 60 Hz

The results summary lists the test name and the status (pass, fail, or error). To view the details of the
results, click Results Details.

17. Set the report details to identify and generate the report automatically. You can set a default report file.
Click here (see page 48) for more information.

18. In the result summary pane, click Result Details. The result details pane displays the following fields.

Result Details

Test Mame
8-25: Deep Color 450§ 10 60 CBar RG...
IB—ZS: Deep Color 480§ 10 60 CBar RG...
IB—ZS: Deep Color 480§ 10 60 Gray RG..

8-25: Deep Color 480i 10 60 Gray RG..

= Test Name (displays the test id, test name, and selected lanes)

= Meas Value (displays the deep color pattern supported by the DUT)

= Result (displays the status of the test as Pass, Fail, or Error)

Test Method

This sequence explains the actions that the software takes while it performs a deep color test. For the
procedure on how to make this test, refer deep color test procedure (see page 268).
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For the DTG Method

1. Configure the DTG to output any sink-supported video format.

= Load the pattern that contains repeating RGB gray ramp 0, 1, 2...254, 255, 0, 1, 2... during
each video period.

= Map all the logical channels to physical channels.
= Run the DTG.
- Enable all the output channels.
2. Verify that the DUT continues to support the signal without errors.

3. Ifthe DUT fails to support the signal, it implies a Fail.

For the DDS Method

The DDS method does not require a DTG. The set up includes two AWGs to create synthesized patterns
for HDMI Sink Deep Color testing.

1. Operate the Sink DUT to support the HDMI input signal.

2. To configure the parameters for this test, refer deep color test procedure (see page 268).

3. Refer to the make connections for deep color (see page 130) for information on how to make
connections.

4. Check the connection of the AWGs and AFG from TDSHT3.

5. Run the test. The software loads the appropriate pattern(s). The software prompts you to confirm the
gray bars on the DUT.

NOTE. Using a manual DDS test method is not recommended because the software performs the Sink
Deep Color test automatically and effectively.

Test the Audio Clock Regeneration

To use the DTG test method, you will need a supported oscilloscope, one digital timing generator
(DTG), one differential probe, one DC power supply, eight SMA cables, one GPIB controller, and one
TPA-P-TDR fixture.

To use the DDS test method, you will need a supported oscilloscope, two arbitrary waveform generators
(AWG7102/AWG7122B), one arbitrary function generator (AFG3102/AFG3532), two differential probes,
one TPA-P, one TPA-R, two TCA SMA cables, and one accessory kit (consisting of seven matched
SMA cable pairs, eight bias-tees, eight 120 ps TTC filters, three GPIB-HS cables, four BNC cables, and
one BNC-T adapter).
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1.
2.
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Test the Audio Clock Regeneration

On the menu bar, click Tests > Select > Sink.

In the differential tests pane, select the Audio Clock Regeneration check box.

File Tests Results Utilities Help TDSHT3 o] X
Select - Sink

[ source [ Sink [ Cahle
Differential Tests Single-Ended Tests Test
0] : - Jitter Tolerance . Deep Color - Intra-Pai
- e . Audio Formats o

. 30 viden

Sink -= Audio Clock Regeneration  Test Method-»= DTG Method; Pattern-= 480p 8 60Hz CBar RGE TV w33 ACrkiax

To change the configuration settings, click Tests > Configure. For most tests, you can use the factory
default configuration. However, you can change the values by using the virtual keyboard (see page 24)
or the general purpose knob (see page 26) on the oscilloscope front panel. Using the File menu,

you can also restore the factory defaults or save and recall your own configuration settings. It is
recommended that you save the configuration settings before you choose to select Recall Default or
close the application.

In the Input pane, set the Input Clock to the channel that you will use for the HDMI clock input. Select
from the available choices (Chl, Ch2, Ch3, and Ch4).

In the Setup pane, select the appropriate test method from the available choices (DTG Method and
DDS Method).

In the DTG Method pane, select the pattern(s) from the available list.

File Tests Results Ultilities Help TDSHT3 %| X |
Configure - Sink

Setup DTG Method Run
Select Test Method Test

DTG Method ¥ Pattern List bTe

Outputs

Configure Result

Wiew
Waverarm

Report—

Detail

Sink -» Audio Clock Regeneration  Test Method-= DTG Method; Pattern-> 480p 8 60Hz CBar RGB TY w23 ACriiax

The DTG Outputs dialog box for the DTG method has the following options:
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DTG Outputs E

Outputs

Clock

Al

Diatal

= Clock (allows you to configure the clock output). Select from the available choices (A1, A2, B1,
B2, Cl1, C2, DI, and D2).

= Data0, Datal, and Data2 (allows you to configure the corresponding data outputs). Select from
the available choices (A1, A2, B1, B2, C1, C2, D1, and D2).

NOTE. You cannot exit the dialog box unless each of the clock and data selections are unique.

In the DDS Method pane, do the following:

File Tests Results Utilities Help TDSHT3 %| X
Configure - Sink

Setup DDS Method Run
. Test Method Test
DDs Method ™
Configure Markers
AWG2

AWG1 Report

cha - cha

Connect Summary
Pattern List

Wiew 480p B 60Hz C B

W EVETDIT

Sink -= Audio Clock Regeneration  Test Method-= DTG Method; Pattern-= 4800 § 60Hz CBar RGE TY w33 ACridax

= Select the pattern(s) from the available list.
In the Markers pane:

= Select the oscilloscope channel to use for routing the synchronization pulse from the AWGI.
The available choices are: Chl, Ch2, Ch3, and Ch4. The default value is Ch3.

= Select the oscilloscope channel to use for routing the synchronization pulse from the AWG?2.
The available choices are: Chl, Ch2, Ch3, and Ch4. The default value is Ch4.

7. To connect the DUT, click Tests > Connect. Click here (see page 134) for information on how
to make connections.
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File Tests Results Ltilities Help TDSHT3 @1| X

Connect
Follow these instructions to set up the connections.
Test

Click \fore for details. hare

Configure

1. Set up the DUT, test fixtures and probes.
b ’ C Report—

Connect 2. Configure and test the signal sources.
Wiew 5 Pl T :
3. To view the signal, click View Waveform. Detail
Wyaveronm

Sink -» Audio Clock Regeneration  Test Method-=> DDS Method, Pattern-= 480p § 60Hz CBar RGEB T w53 Acriiax

8. To configure and test the GPIB connection, click Signal Sources. The Signal Sources Setup dialog
box appears.

The AWG tab has options to configure the Primary and Secondary Addresses of AWG1 and AWG2.

Signal Sources Setup

Select GPIB Setup
Board Type
SPIE GREBO ™
AWG1 Address AWG2 Address
Primary Primary

Secondary Secondary

NOTE. You cannot exit the dialog box unless each of the primary and secondary address selections are
unique.

NOTE. The Manual test option is not available for the DDS method.

9. In the select pane, click GPIB. Configure the appropriate GPIB board number. Click here (see
page 27) for more information.

10. To test the connection and the GPIB configuration, click Test Conn.

11. Because no signal is connected to the oscilloscope, you cannot view the waveform for the audio
clock regeneration test.

NOTE. To run the test successfully, ensure that the Bus Timing parameter is set to 2 usec on your GPIB
board configuration. Click here (see page 37) for more information.
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12. Click Run Test. The TDSHT3 Software sets up the oscilloscope and conducts the test.

13. Follow the instructions in the Sink dialog box. Click OK. The Connect Sink Device dialog box
appears as follows:

Connect to sink device

3. Click OK to continue

Press F1 for the detailed setup diagram.

14. Follow the instructions in the Connect Sink Device dialog box. Click OK. The test runs, displaying a
progress indicator. The Confirm Sink Device Support dialog box appears.

Confirm Sink Device Support

Fattern Mame : ar RGE

g the Gr or Bar on the DUT ?

15. Follow the instructions in the dialog box.

16. If you successfully run the test, the software makes the results available automatically and displays the
result summary. You can also view the report configuration details in the result pane.

File Tests Results Utilities Hslp TDSHT3

Configure

Cannect

e
WY averorm

Sink -= Audio Clock Regeneration

Result Summary: Sink
Te

|f|5-21; Audio Clock Regeneration 480p & 60Hz C..

LAf|5-21: Audio Clock Regeneration 450p & 60Hz C

L Af|5-21: Audio Clock Regeneration 576p & 50Hz C

| Afl3-21: Audio Clock Regeneration 576p 8 S0Hz C...

Data Lane
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Report Configuration

iz Run
Device Details ce et

Report—

Reselution

Refresh Rate

Report File

Auto Increment
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The results summary lists the test name and the status (pass, fail, or error). To view the details of the
results, click Results Details.

17. Set the report details to identify and generate the report automatically. You can set a default report file.
Click here (see page 48) for more information.

18. In the result summary pane, click Result Details. The result details pane displays the following fields.

Result Details
Test Mame
8-21: Audio Clock Regeneration 480p ... [ -
I8-21. Audio Clock Regeneration 480p ... [ -
I8-21. Audio Clock Regeneration 576p ... [ -

8-21: Audio Clock Regeneration 578p ... [ --

= Test Name (displays the test id, test name, and selected pattern)
= Spec Range (displays the HDMI standards and test specifications limit for the test)
= Meas Value (displays the pattern supported by the DUT)

= Result (displays the status of the test as Pass, Fail, or Error)

Test Method

This sequence explains the actions that the software takes while it performs an audio clock regeneration
test. For the procedure on how to make this test, refer to the audio clock regeneration test procedure

(see page 273).

For the DTG Method
1. Configure the DTG to output any sink-supported video format.

= Load the pattern that contains repeating RGB gray ramp 0, 1, 2...254, 255, 0, 1, 2... during
each video period.

= Map all the logical channels to physical channels.
= Run the DTG.
= Enable all the output channels.
2. Verify that the DUT continues to support the signal without errors.

3. Ifthe DUT fails to support the signal, it implies a Fail.
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For the DDS Method
The DDS method does not require a DTG. The set up includes two AWGs.
1. Operate the Sink DUT to support the HDMI input signal.

2. To configure the parameters for this test, refer audio clock regeneration test procedure (see page 273).

3. Refer to make connections for audio clock regeneration (see page 134) for information on how
to make connections.

4. Check the connection of the AWGs and AFG from TDSHT3.

5. Run the test. The software loads the appropriate pattern(s). The software prompts you to confirm the
gray bars on the DUT.

Test the Audio Sample Packet Jitter

To use the DTG test method, you will need a supported oscilloscope, one digital timing generator
(DTG), one differential probe, one DC power supply, eight SMA cables, one GPIB controller, and one
TPA-P-TDR fixture.

To use the DDS test method, you will need a supported oscilloscope, two arbitrary waveform generators
(AWG7102/AWG7122B), one arbitrary function generator (AFG3102/AFG3532), two differential probes,
one TPA-P, one TPA-R, two TCA SMA cables, and one accessory kit (consisting of seven matched
SMA cable pairs, eight bias-tees, eight 120 ps TTC filters, three GPIB-HS cables, four BNC cables, and
one BNC-T adapter).

1. On the menu bar, click Tests > Select > Sink.

2. In the differential tests pane, select the Audio Sample Packet Jitter check box.

File Tests Results Ltilities Help TDSHT3 %| X |
Select - Sink

| = =} [ Sink f 1 Fun

Report—

Egeneration <et Jitter

COne Bit Audio
deo ’

Waveform =

Sink -= Audio Sample Jitter Test Method-> DTG Method, Pattern-» 480p 8 60Hz CBar RGE T4 w53 AudioJitter

3. To change the configuration settings, click Tests > Configure. For most tests, you can use the factory
default configuration. However, you can change the values by using the virtual keyboard (see page 24)
or the general purpose knob (see page 26) on the oscilloscope front panel. Using the File menu,
you can also restore the factory defaults or save and recall your own configuration settings. It is
recommended that you save the configuration settings before you choose to select Recall Default or
close the application.
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4. In the Input pane, set the Input Clock to the channel that you will use for the HDMI clock input. Select
from the available choices (Chl, Ch2, Ch3, and Ch4).

5. 1In the Setup pane, select the appropriate test method from the available choices (DTG Method and
DDS Method).

6. Inthe DTG Method pane, select the pattern(s) from the available list.

File Tests Results Utilities Help TDSHT3 o] X |
Configure - Sink

Setup DTG Method Run
Test Method Test

Pattern List DTG

DTG Method —
Configure 480p 8 60Hz CB: dicJitter ¥ Outputs

Report—
Connect Summary

Wavetorm e

Sink -= Audio Sample Jitter Test Method-= DTG Method; Pattern-» 480p 8 60Hz CBar RGB T w53 AudioJitter

The DTG Outputs dialog box for the DTG method has the following options:

DTG Outputs E3

Outputs
Clock Data0

B1

Data?
1

= Clock (allows you to configure the clock output). Select from the available choices (A1, A2, B1,
B2, Cl1, C2, D1, and D2).

= Data0, Datal, and Data2 (allows you to configure the corresponding data outputs). Select from
the available choices (A1, A2, B1, B2, C1, C2, D1, and D2).

NOTE. You cannot exit the dialog box unless each of the clock and data selections are unique.

In the DDS Method pane, select the pattern(s) from the available list.
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TDSHT3 E x|

Configure - Sink
Setup DDS Method
Test

Select Test Method

File Tests Results Utilities Help

Configure
AWG1 AWG2 Report |

chi « Chd =
Pattern List

Wiew
Wyaveform

Sink -= Audio Sample Jitter Test Method-> DTG Method, Pattern-» 480p 8 60Hz CBar RGE T4 w53 AudioJitter

7. To connect the DUT, click Tests > Connect. Click here (see page 137) for information on how

to make connections.
m| x|

TDSHT3

File Tests Results Utilities Help

Connect
Follow these instructions te set up the connections.
Test

Select
Click Moro for detalls. ore

Configure
Report—

1. Set up the DUT, test fixtures and probes.
onnect 2. Configure and test the signal sources.

e 3. To view the signal, click View YWaveform.
Waverorm

Sink -= Audio Sample Jitter Test Method-= DTG Method: Pattern-» 480p & 60Hz CBar RGE T w53 AudinJitter

8. To configure and test the GPIB connection, click Signal Sources. The Signal Sources Setup dialog

box appears.
The AWG tab has options to configure the Primary and Secondary Addresses of AWG1 and AWG2.

Signal Sources Setup

Select GPIB Setup

Board Type
GPIED *
AWG1 Address AWG2 Address
Primary

GFIB

Primary
2
2 w7 a -

Secondary Secondary

A (I 4

NOTE. You cannot exit the dialog box unless each of the primary and secondary address selections are

unique.

TDSHT3 HDMI Compliance Test Software Online Help 281



How to ... Test the Audio Sample Packet Jitter

NOTE. The Manual test option is not available for the DDS method.

9. In the select pane, click GPIB. Configure the appropriate GPIB board number. Click here (see
page 27) for more information.

10. To test the connection and the GPIB configuration, click Test Conn.

11. Because no signal is connected to the oscilloscope, you cannot view the waveform for the audio
sample packet jitter test.

NOTE. To run the test successfully, ensure that the Bus Timing parameter is set to 2 usec on your GPIB
board configuration. Click here (see page 37) for more information.

12. Click Run Test. The TDSHT3 Software sets up the oscilloscope and conducts the test.

13. Follow the instructions in the Sink dialog box. Click OK. The Connect Sink Device dialog box
appears as follows:

Connect to sink device

set up the connectio
DT i TPA-P

3. Click OK to continue

Press F1 for the detailed setup diagram.

14. Follow the instructions in the Connect Sink Device dialog box. Click OK. The test runs, displaying a
progress indicator. The Confirm Sink Device Support dialog box appears.

Confirm Sink Device Support El

Pattern Mame ; 480 S0Hz CBar RGE T Ludioditter

>olor Bar an the DUT 2

15. Follow the instructions in the dialog box.
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16. If you successfully run the test, the software makes the results available automatically and displays the
result summary. You can also view the report configuration details in the result pane.

File Tests Results Utilities Help TDSHT3 | X
Result Summary: Sink Report Configuration

Run
Select Te e Device Details HOMI Device Test

L Afl3-22: Audio Sample Jitter 480p 6 60Hz CBar ...

i Resolution 480p
Configure Resut

Refresh Rate G0Hz Report—;

Report File 318
Wiew
Data Lane =yey _ g
W averfarm ) B Auto Increment 5 g

Sink -= Audio Sample Jitter Test Method-> DTG Method; Pattern-»= 480p 8 60Hz CBar RGB TY w33 AudioJitter

The results summary lists the test name and the status (pass, fail, or error). To view the details of the
results, click Results Details.

17. Set the report details to identify and generate the report automatically. You can set a default report file.
Click here (see page 48) for more information.

18. In the result summary pane, click Result Details. The result details pane displays the following fields.

Result Details

Test Name
8-22: Audio Sample Jitter 480p 8 60Hz .. |

= Test Name (displays the test id, test name, and selected lanes)

= Meas Value (displays the deep color pattern supported by the DUT)

= Result (displays the status of the test as Pass, Fail, or Error)

Test Method

This sequence explains the actions that the software takes while it performs a deep color test. For the
procedure on how to make this test, refer audio sample packet jitter test procedure (see page 279).
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Test the Audio Formats

For the DTG Method

1.

Configure the DTG to output any sink-supported video format.

= Load the pattern that contains repeating RGB gray ramp 0, 1, 2...254, 255, 0, 1, 2... during
each video period.

= Map all the logical channels to physical channels.

= Run the DTG.

- Enable all the output channels.

Verify that the DUT continues to support the signal without errors.

If the DUT fails to support the signal, it implies a Fail.

For the DDS Method
The DDS method does not require a DTG. The set up includes two AWGs.

1.
2.
3.

Operate the Sink DUT to support the HDMI input signal.

To configure the parameters for this test, refer audio sample packet jitter test procedure (see page 279).

Refer to make connections for audio sample packet jitter (see page 137) for information on how
to make connections.

Check the connection of the AWGs and AFG from TDSHT3.

Run the test. The software loads the appropriate pattern(s). The software prompts you to confirm the
gray bars on the DUT.

Test the Audio Formats

284

To use the DTG test method, you will need a supported oscilloscope, one digital timing generator
(DTG), one differential probe, one DC power supply, eight SMA cables, one GPIB controller, and one
TPA-P-TDR fixture.

To use the DDS test method, you will need a supported oscilloscope, two arbitrary waveform generators
(AWG7102/AWGT122B), one arbitrary function generator (AFG3102/AFG3532), two differential probes,
one TPA-P, one TPA-R, two TCA SMA cables, and one accessory kit (consisting of seven matched
SMA cable pairs, eight bias-tees, eight 120 ps TTC filters, three GPIB-HS cables, four BNC cables, and
one BNC-T adapter).

1.
2.

On the menu bar, click Tests > Select > Sink.

In the differential tests pane, select the Audio Formats check box.
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File Tests Results Ltilities Help TDSHT3 %| X |
Select - Sink

Sink i ) Fun
Differential Tests Single-Ended Tests
g . Jitter Tolerance - Deep Calor . Intra-

Audio Formats Report—

Sink - Audio Farmats Test Method-> DTG Method: Pattern-» V(GA 8 A0Hz CBar RGE T4 va3 48kAudio

3. To change the configuration settings, click Tests > Configure. For most tests, you can use the factory
default configuration. However, you can change the values by using the virtual keyboard (see page 24)
or the general purpose knob (see page 26) on the oscilloscope front panel. Using the File menu,
you can also restore the factory defaults or save and recall your own configuration settings. It is
recommended that you save the configuration settings before you choose to select Recall Default or
close the application.

4. In the Input pane, set the Input Clock to the channel that you will use for the HDMI clock input. Select
from the available choices (Chl, Ch2, Ch3, and Ch4).

5. In the Setup pane, select the appropriate test method from the available choices (DTG Method and
DDS Method).

6. In the DTG Method pane, select the pattern(s) from the available list.

File Tests Results Utilities Help TDSHT3 %| X |
Configure - Sink

Setup DTG Method RFun
SEER Test Method Test

DTG Method ¥ Pattern List DTG

Corfigure ! |Hz CBar a Outputs

Report—

Connect Summary

WY avETDrm DEED

Sink -= Audio Formats Test Method-> DTG Method; Pattern-= YGA 8 60Hz CBar RGB TV w53 48kAudio

The DTG Outputs dialog box for the DTG method has the following options:
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OTG Outputs E

Outputs
Clock Datal

A B

Data1l Data2

e 1

= Clock (allows you to configure the clock output). Select from the available choices (A1, A2, B1,
B2, Cl1, C2, D1, and D2).

= Data0, Datal, and Data2 (allows you to configure the corresponding data outputs). Select from
the available choices (A1, A2, B1, B2, C1, C2, D1, and D2).

NOTE. You cannot exit the dialog box unless each of the clock and data selections are unique.

In the DDS Method pane, do the following:

File Tests Results Utilities Help TDSHT3 @1| X
Configure - Sink

Setup DDS Method Run
e Test Method Test

DDS Method =
Markers Result
AWG1 AWG2

Configure

Pattern L

Wigw 80Hz CBar RGE i i
Waverorm petal

Report—
Cha - Chd4 =

Sink -= Audio Formats Test Method-= DTG Method; Pattern-= %GA 8 60Hz CBar RGE T v453 48kAudio

= In the Markers pane:

= Select the oscilloscope channel to use for routing the synchronization pulse from the AWGI.
The available choices are: Chl, Ch2, Ch3, and Ch4. The default value is Ch3.

= Select the oscilloscope channel to use for routing the synchronization pulse from the AWG?2.
The available choices are: Chl, Ch2, Ch3, and Ch4. The default value is Ch4.

= Select the pattern(s) from the available list.

7. To connect the DUT, click Tests > Connect. Click here (see page 140) for information on how
to make connections.
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File Tests Results Ltilities Help TDSHT3 B, | x |
Cennect
Follow these instructions to set up the connections. Run
Select Test

Click MMoreo for dotails. More

Configure

1. Set up the DUT, test fixtures and probes.
J ’ b Report—

Connect 2. Configure and test the signal Sources. .
iew 3. To view the signal, click View Waveform. Detail
Waverorm

Sink -= Audio Farmats Test Method-> DDS Method; Pattern-= %GA 8 60Hz CBar RGE T% v53 48kAudio

8. To configure and test the GPIB connection, click Signal Sources. The Signal Sources Setup dialog
box appears.

The AWG tab has options to configure the Primary and Secondary Addresses of AWGI1 and AWG2.

Signal Sources Setup

Select GPIB Setup
Board Type
=PRIE GFIBOD
AWG1 Address AWG2 Address
Primary Primary

Secondary Secondary

NOTE. You cannot exit the dialog box unless each of the primary and secondary address selections are
unique.

NOTE. The Manual test option is not available for the DDS method.

9. In the select pane, click GPIB. Configure the appropriate GPIB board number. Click here (see
page 27) for more information.

10. To test the connection and the GPIB configuration, click Test Conn.

11. Because no signal is connected to the oscilloscope, you cannot view the waveform for the audio
formats test.

NOTE. To run the test successfully, ensure that the Bus Timing parameter is set to 2 usec on your GPIB
board configuration. Click here (see page 37) for more information.
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12. Click Run Test. The TDSHT3 Software sets up the oscilloscope and conducts the test.

13. Follow the instructions in the Sink dialog box. Click OK. The Connect Sink Device dialog box
appears as follows:

Connect to sink device

14. Follow the instructions in the Connect Sink Device dialog box. Click OK. The test runs, displaying a
progress indicator. The Confirm Sink Device Support dialog box appears.

Confirm Sink Device Support

Pattern Mame

Can you see the

15. Follow the instructions in the dialog box.

16. If you successfully run the test, the software makes the results available automatically and displays the
result summary. You can also view the report configuration details in the result pane.

File Tests Results Utilities Help TDSHT3 %| x |
Result Summary: Sink Report Configuration

Run
Select Te me Device Details HOmMI 3 T
L)|B-23: AudioFormats WGEA B 60Hz CBar RGB T ..

) Resolution =
Configure Result

Refresh Rate GOHZ EE Report—

Report File 318 0100517_" e
Wiem
Data Lane
Vifaverorm Auto Increment e o

Sink -= Audio Formats Test Method-= DTG Method; Pattern-»= %GA 8§ 60Hz CBar RGE TV w53 48kAudio
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The results summary lists the test name and the status (pass, fail, or error). To view the details of the
results, click Results Details.

17. Set the report details to identify and generate the report automatically. You can set a default report file.
Click here (see page 48) for more information.

18. In the result summary pane, click Result Details. The result details pane displays the following fields.

Result Details

Test Name Spec Range
8-23: AudioFormats WGA § 60Hz CBar .. |

= Test Name (displays the test id, test name, and selected patterns)

= Spec Range (displays the HDMI standards and test specifications limit for the test)
= Meas Value (displays the pattern supported by the DUT)

= Result (displays the status of the test as Pass, Fail, or Error)

Test Method

This sequence explains the actions that the software takes while it performs an audio formats test. For the
procedure on how to make this test, refer to audio formats test procedure (see page 284).

For the DTG Method
1. Configure the DTG to output any sink-supported video format.

= Load the pattern that contains repeating RGB gray ramp 0, 1, 2...254, 255, 0, 1, 2... during
each video period.

= Map all the logical channels to physical channels.

= Run the DTG.

= Enable all the output channels.
2. Verify that the DUT continues to support the signal without errors.
3. [If the DUT fails to support the signal, it implies a Fail.

For the DDS Method
The DDS method does not require a DTG. The set up includes two AWGs.
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1. Operate the Sink DUT to support the HDMI input signal.

2. To configure the parameters for this test, refer audio formats test procedure (see page 284).

3. Refer to make connections for audio formats (see page 140) for information on how to make

connections.

4. Check the connection of the AWGs and AFG from TDSHTS3.

5. Run the test. The software loads the appropriate pattern(s). The software prompts you to confirm the
gray bars on the DUT.

Test the One Bit Audio
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To use the DTG test method, you will need a supported oscilloscope, one digital timing generator
(DTG), one differential probe, one DC power supply, eight SMA cables, one GPIB controller, and one
TPA-P-TDR fixture.

To use the DDS test method, you will need a supported oscilloscope, two arbitrary waveform generators
(AWG7102/AWG7122B), one arbitrary function generator (AFG3102/AFG3532), two differential probes,
one TPA-P, one TPA-R, two TCA SMA cables, and one accessory kit (consisting of seven matched
SMA cable pairs, eight bias-tees, eight 120 ps TTC filters, three GPIB-HS cables, four BNC cables, and
one BNC-T adapter).

1. On the menu bar, click Tests > Select > Sink.

2. In the differential tests pane, select the One Bit Audio check box.

File Tests Results Utilities Help TDSHT3 @| X
Select - Sink

Sink Run
Differential Tests Single-Ended Tests
9 - ditter Tolerance - Deep Color - Intra-Pair Skew
= . Audio Formats Report——

ility - 30 video

Sink -= One Bit Audio Test Method-> DTG Method; Resolution-» 480p 60 8 Gray RGE 1h

3. To change the configuration settings, click Tests > Configure. For most tests, you can use the factory
default configuration. However, you can change the values by using the virtual keyboard (see page 24)
or the general purpose knob (see page 26) on the oscilloscope front panel. Using the File menu,
you can also restore the factory defaults or save and recall your own configuration settings. It is
recommended that you save the configuration settings before you choose to select Recall Default or
close the application.

4. In the Input pane, set the Input Clock to the channel that you will use for the HDMI clock input. Select
from the available choices (Chl, Ch2, Ch3, and Ch4).
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5. In the Setup pane, select the appropriate test method from the available choices (DTG Method and
DDS Method).

6. In the DTG Method pane, select the pattern(s) from the available list.

File Tests Results Utilities Help TDSHT3 %| X |
Configure - Sink

Setup DTG Method Run
Select Test Method Test

DTG
DTG Method =

Configure =2 Outputs

Report—

WiEW

Wi aveform DEE]

Sink -= One Bit Audio Test Method-> DTG Method; Resolution-= 4800 60 8 Gray RGE 1h

The DTG Outputs dialog box for the DTG method has the following options:

DT COutputs
Outputs
Clock

Al

= Clock (allows you to configure the clock output). Select from the available choices (A1, A2, B1,
B2, Cl1, C2, D1, and D2).

= Data0, Datal, and Data2 (allows you to configure the corresponding data outputs). Select from
the available choices (A1, A2, B1, B2, C1, C2, D1, and D2).

NOTE. You cannot exit the dialog box unless each of the clock and data selections are unique.

In the DDS Method pane, do the following:
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File Tests Results Utilities Help TDSHT3 %' X

Configure - Sink

Setup DD$S Methed Run
il Test Method Test

DD od w7
Configure Markers

AWG1 AWG2

Report—

Chi ~ Chd =

Pattern List
e Op 5 i .
Wavetarm

Sink -> One Bit Audio Test Method-> DTG Method; Resolution-> 450p 60 8§ Gray RGE 1b

= In the Markers pane:

= Select the oscilloscope channel to use for routing the synchronization pulse from the AWGI.
The available choices are: Chl, Ch2, Ch3, and Ch4. The default value is Ch3.

= Select the oscilloscope channel to use for routing the synchronization pulse from the AWG?2.
The available choices are: Chl, Ch2, Ch3, and Ch4. The default value is Ch4.

= Select the pattern(s) from the available list.

7. To connect the DUT, click Tests > Connect. Click here (see page 143) for information on how
to make connections.

File Tests Results Utilities Help TDSHT3 @1| X

Connect
Eollow these instructions to set up the connections. Run
Select Test

Click More for dotails. More

Configure

1. Set up the DUT, test fixtures and probes.
E ’ C Report——

Connect 2. Configure and test the signal Sources. Summary
i 3. To view the signal, click View Waveform. Detail
Wyaverorm

Sink -» One Bit Audio Test Method-> DDS Wethod, Resolution-= 450p 60 § Gray RGE 1b

8. To configure and test the GPIB connection, click Signal Sources. The Signal Sources Setup dialog
box appears.

The AWG tab has options to configure the Primary and Secondary Addresses of AWG1 and AWG2.
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Signal Sources Setup

GPIB Setup
Board Type

GFIEOD
AWG1 Address AWG2 Address
Primary Primary

- a3 -

Secondary Secondary

0 b 0 -

Test

NOTE. You cannot exit the dialog box unless each of the primary and secondary address selections are
unique.

NOTE. The Manual test option is not available for the DDS method.

9. In the select pane, click GPIB. Configure the appropriate GPIB board number. Click here (see
page 27) for more information.

10. To test the connection and the GPIB configuration, click Test Conn.

11. Because no signal is connected to the oscilloscope, you cannot view the waveform for the one bit
audio test.

NOTE. 70 run the test successfully, ensure that the Bus Timing parameter is set to 2 usec on your GPIB
board configuration. Click here (see page 37) for more information.

12. Click Run Test. The TDSHT3 Software sets up the oscilloscope and conducts the test.

13. Follow the instructions in the Sink dialog box. Click OK. The Connect Sink Device dialog box
appears as follows:
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Connect to sink device

ck OK to continue

Press F1 for the detailed setup diagram.

14. Follow the instructions in the Connect Sink Device dialog box. Click OK. The test runs, displaying a
progress indicator. The Confirm Sink Device Support dialog box appears.

Confirm Sink Device Support

Pattern Mame ; 4 g0 5 GE 1hit

Can you see the G olor Bar on the DUT ?

15. Follow the instructions in the dialog box.

16. If you successfully run the test, the software makes the results available automatically and displays the
result summary. You can also view the report configuration details in the result pane.

File Tests Results Utilities Help TDSHT3 | X |

Result Summary: Sink

Select

Corfigure

Connect

WIEN Data Lane
Waverarm

LJ|5-28: One Bit Audio 480p 60 & Gray RGE 1hit

LJ|5-28: One Bit Audio 576p 50 & Gray RGE 1hit

Report Configuration

i Run
Device Details HOMI Device =
Resolution 480p Fe

Result

Refresh Rate e Report—

Report File 140_20 1 CEHE
-
Auto Increment ? e

Sink -= One Bit Audio Test Method-= DTG Method, Resolution-= Select A

The results summary lists the test name and the status (pass, fail, or error). To view the details of the

results, click Results Details.
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17. Set the report details to identify and generate the report automatically. You can set a default report file.
Click here (see page 48) for more information.

18. In the result summary pane, click Result Details. The result details pane displays the following fields.

Result Details

Test Name Spec Range
8-28: One Bit Audio 480p 60 8 Gray R... | --
8-28: One Bit Audio 576p 50 8 Gray R... | --

= Test Name (displays the test id, test name, and selected patterns)
= Spec Range (displays the HDMI standards and test specifications limit for the test)
= Meas Value (displays the patterns supported by the DUT)

= Result (displays the status of the test as Pass, Fail, or Error)

Test Method

This sequence explains the actions that the software takes while it performs a one bit audio test. For the
procedure on how to make this test, refer one bit audio test procedure (see page 290).

For the DTG Method
1. Configure the DTG to output any sink-supported video format.

- Load the pattern that contains repeating RGB gray ramp 0, 1, 2...254, 255, 0, 1, 2... during
each video period.

= Map all the logical channels to physical channels.
= Run the DTG.
- Enable all the output channels.
2. Verify that the DUT continues to support the signal without errors.

3. Ifthe DUT fails to support the signal, it implies a Fail.

For the DDS Method
The DDS method does not require a DTG. The set up includes two AWGs.
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Test the DVI Interoperability

Operate the Sink DUT to support the HDMI input signal.

To configure the parameters for this test, refer one bit audio test procedure (see page 313).

Refer to make connections for one bit audio (see page 143) for information on how to make
connections.

Check the connection of the AWGs and AFG from TDSHT3.

Run the test. The software loads the appropriate pattern(s). The software prompts you to confirm the
gray bars on the DUT.

Test the DVI Interoperability

296

To use the DTG test method, you will need a supported oscilloscope, one digital timing generator
(DTG), one differential probe, one DC power supply, eight SMA cables, one GPIB controller, and one
TPA-P-TDR fixture.

To use the DDS test method, you will need a supported oscilloscope, two arbitrary waveform generators
(AWG7102/AWGT122B), one arbitrary function generator (AFG3102/AFG3532), two differential probes,
one TPA-P, one TPA-R, two TCA SMA cables, and one accessory kit (consisting of seven matched
SMA cable pairs, eight bias-tees, eight 120 ps TTC filters, three GPIB-HS cables, four BNC cables, and
one BNC-T adapter).

1.
2.

On the menu bar, click Tests > Select > Sink.
In the differential tests pane, select the DVI Interoperability check box.

File Tests Results Utilities Help TDSHT3 B, x

Select - Sink
; [ Cable
Differential Tests Single-Ended Tests Test
g - Jitter Tolerance . Deep Colar . Intra-Pair 1y
. =} . Audio Formats Report——

le

Sink -= DYl Interoperatility Test Method-> DTG Method; Pattern-= 480p 8 60Hz CBar RGB PC &3 Dwvi

To change the configuration settings, click Tests > Configure. For most tests, you can use the factory
default configuration. However, you can change the values by using the virtual keyboard (see page 24)
or the general purpose knob (see page 26) on the oscilloscope front panel. Using the File menu,

you can also restore the factory defaults or save and recall your own configuration settings. It is
recommended that you save the configuration settings before you choose to select Recall Default or
close the application.

In the Input pane, set the Input Clock to the channel that you will use for the HDMI clock input. Select
from the available choices (Chl, Ch2, Ch3, and Ch4).

TDSHT3 HDMI Compliance Test Software Online Help



How to ... Test the DVI Interoperability

5. In the Setup pane, select the appropriate test method from the available choices (DTG Method and
DDS Method).

6. In the DTG Method pane, select the pattern(s) from the available list.

File Tests Results Ltilities Help TDSHT3 %| X |
Configure - Sink

Setup DTG Method Run
Test Method Test

DTG Method ™ Pattern List el

Configure A5 r CBar RGE P i Outputs

Report—

Connect Summary

=

Wy averorm DEEN

Sink -= DY Interoperability Test Method-> DTG Method, Pattern-» 480p 8 60Hz CBar RGE PC w53 Divi

The DTG Outputs dialog box for the DTG method has the following options:

DT COutputs
Outputs
Clock

Al

Diatal
B2

= Clock (allows you to configure the clock output). Select from the available choices (A1, A2, B1,
B2, Cl1, C2, DI, and D2).

= Data0, Datal, and Data2 (allows you to configure the corresponding data outputs). Select from
the available choices (A1, A2, B1, B2, C1, C2, D1, and D2).

NOTE. You cannot exit the dialog box unless each of the clock and data selections are unique.

In the DDS Method pane, do the following:
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File Tests Results Ltilities Help

Setup
Test Method

oo

Configure

Connect

Wi
Wyaveronm

Sink -» DY Interoperahbility

= In the Markers pane:

Test the DVI Interoperability

B, | X
Run
Test
Markers

BNG2 Repert—

Chd
Pattern List

TDSHT3

Configure - Sink

DDS Method

Test Method-> DTG hethod, Pattern-> 480p 8 60Hz CBar RGE PC w33 Dvi

Select the oscilloscope channel to use for routing the synchronization pulse from the AWGI.
The available choices are: Chl, Ch2, Ch3, and Ch4. The default value is Ch3.

Select the oscilloscope channel to use for routing the synchronization pulse from the AWG?2.
The available choices are: Chl, Ch2, Ch3, and Ch4. The default value is Ch4.

= Select the pattern(s) from the available list.

7. To connect the DUT, click Tests > Connect. Click here (see page 146) for information on how

to make connections.

File Tests Results Ltilities Help

Follow these instructions to set up the connections.

Click \fore for details. hare

Configure
1. Set up the DUT, test fixtures and probes.

Connect 2. Configure and test the signal sources.

igw 3. To view the signal, click View Waveform.
Wyaveronm

Sink -» DY Interoperahbility

= x|
Test

Report—

TDSHT3

Connect

Test Method-> DDS Method,; Pattern-> 480p § 60Hz CBar RGE PC wi3 Dvi

8. To configure and test the GPIB connection, click Signal Sources. The Signal Sources Setup dialog

box appears.

The AWG tab has options to configure the Primary and Secondary Addresses of AWG1 and AWG2.
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Signal Sources Setup

GPIB Setup
Board Type

GFIEOD
AWG1 Address AWG2 Address
Primary Primary

- a3 -

Secondary Secondary

0 b 0 -

Test

NOTE. You cannot exit the dialog box unless each of the primary and secondary address selections are
unique.

NOTE. The Manual test option is not available for the DDS method.

9. In the select pane, click GPIB. Configure the appropriate GPIB board number. Click here (see
page 27) for more information.

10. To test the connection and the GPIB configuration, click Test Conn.

11. Because no signal is connected to the oscilloscope, you cannot view the waveform for the DVI
interoperability test.

NOTE. 70 run the test successfully, ensure that the Bus Timing parameter is set to 2 usec on your GPIB
board configuration. Click here (see page 37) for more information.

12. Click Run Test. The TDSHT3 Software sets up the oscilloscope and conducts the test.

13. Follow the instructions in the Sink dialog box. Click OK. The Connect Sink Device dialog box
appears as follows:
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Connect to sink device

ck OK to continue

Press F1 for the detailed setup diagram.

14. Follow the instructions in the Connect Sink Device dialog box. Click OK. The test runs, displaying a
progress indicator. The Confirm Sink Device Support dialog box appears.

Confirm Sink Device Support

Fattern Mame : 450p 5 7 CBar RGE PC

or Bar on the DUT 2

15. Follow the instructions in the dialog box.

16. If you successfully run the test, the software makes the results available automatically and displays the
result summary. You can also view the report configuration details in the result pane.

File Tests Results Utilities Help TDSHT3 %| X |
Result Summary: Sink Report Configuration

Select Te : Device Details HDMI Device =
LAl5-24: D% Interoperability 480p 8 60Hz CBar RG...

) Resolution 4800 T
Configure Result

Refresh Rate GOHz o Report—

Report File i18 1 i
Wiew Data Lane )
Waverorm Auto INcCrement

Sink -= Dl Interoperability Test Method-= DTG Method; Pattern-» 480p 8 60Hz CBar RGB PC w53 Dwvi

The results summary lists the test name and the status (pass, fail, or error). To view the details of the
results, click Results Details.
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17. Set the report details to identify and generate the report automatically. You can set a default report file.
Click here (see page 48) for more information.

18. In the result summary pane, click Result Details. The result details pane displays the following fields.

Result Details

Test Name
B-24: DI Interoperability 480p 8 60Hz ..

= Test Name (displays the test id, test name, and selected pattern)
= Spec Range (displays the HDMI standards and test specifications limit for the test)
= Meas Value (displays the pattern supported by the DUT)

= Result (displays the status of the test as Pass, Fail, or Error)

Test Method

This sequence explains the actions that the software takes while it performs a DVI Interoperability test.
For the procedure on how to make this test, refer DVI interoperability test procedure (see page 313).

For the DTG Method
1. Configure the DTG to output any sink-supported video format.

= Load the pattern that contains repeating RGB gray ramp 0, 1, 2...254, 255, 0, 1, 2... during
each video period.

= Map all the logical channels to physical channels.
= Run the DTG.
= Enable all the output channels.
2. Verify that the DUT continues to support the signal without errors.

3. Ifthe DUT fails to support the signal, it implies a Fail.

For the DDS Method
The DDS method does not require a DTG. The set up includes two AWGs.
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1. Operate the Sink DUT to support the HDMI input signal.

2. To configure the parameters for this test, refer DVI interoperability test procedure (see page 313).

3. Refer to make connections for DVI interoperability (see page 146) for information on how to make

connections.

4. Check the connection of the AWGs and AFG from TDSHTS3.

5. Run the test. The software loads the appropriate pattern(s). The software prompts you to confirm the
gray bars on the DUT.

Test the 3D Video

302

To use the DTG test method, you will need a supported oscilloscope, one digital timing generator
(DTG), one differential probe, one DC power supply, eight SMA cables, one GPIB controller, and one
TPA-P-TDR fixture.

To use the DDS test method, You will need a supported oscilloscope, two arbitrary waveform generators
(AWG7102/AWGT122B), one arbitrary function generator (AFG3102/AFG3532), two differential probes,
one TPA-P, one TPA-R, two TCA SMA cables, and one accessory kit (consisting of seven matched
SMA cable pairs, eight bias-tees, eight 120 ps TTC filters, three GPIB-HS cables, four BNC cables, and
one BNC-T adapter).

1. On the menu bar, click Tests > Select > Sink.

2. In the differential tests pane, select the 3D Video check box.

File Tests Results Utilities Help TDSHT3 %l X
Select - Sink

Differential Tests Single-Ended Tests Test

lir! ] ¥ . Deep Caolor - Intra-Pair iy
o C e - Audio Formats Report—

jit Audio ility 3D video

Wigw ;

Sink -> 30 Video Test Method-> DTG Method; Pattern-= 10801 § S0Hz EGE T w38 30DFP

3. To change the configuration settings, click Tests > Configure. For most tests, you can use the factory
default configuration. However, you can change the values by using the virtual keyboard (see page 24)
or the general purpose knob (see page 26) on the oscilloscope front panel. Using the File menu,
you can also restore the factory defaults or save and recall your own configuration settings. It is
recommended that you save the configuration settings before you choose to select Recall Default or
close the application.

4. In the Input pane, set the Input Clock to the channel that you will use for the HDMI clock input. Select
from the available choices (Chl, Ch2, Ch3, and Ch4).
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5. In the Setup pane, select the appropriate test method from the available choices (DTG Method and
DDS Method).

6. In the DTG Method pane, do the following:

File Tests Results Utilities Help TDSHT3 %| X |

Configure - Sink
Setup DTG Method

Test Method
DTG Method ™

Select
Pattern
Outputs

Configure

WiEw

Wyaveform D

here' 3 Report—

Sink -= 30 Video Test Method-= DTG Method, Pattern-> 1080i § 50Hz RGE T w399 3DFFP

= Select the pattern(s) from the available list.

= Select one of the two: Custom ’Man with Sphere’ 3D, or Standard Graybars 3D.
= The DTG Outputs dialog box for the DTG method has the following options:

DTG Outputs E

Outputs
Clock

A1

Diatal

= Clock (allows you to configure the clock output). Select from the available choices (Al,
A2, B1, B2, Cl1, C2, D1, and D2).

- Data0, Datal, and Data2 (allows you to configure the corresponding data outputs). Select from
the available choices (A1, A2, B1, B2, C1, C2, D1, and D2).

NOTE. You cannot exit the dialog box unless each of the clock and data selections are unique.

In the DDS Method pane, do the following:
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TDSHT3 E x|

File Tests Results Utilities Help

Configure - Sink
Setup DDS Method Run
Select =i 30
0 3 Test

Test Method

oo s < ' )
Configure Markers

AWG1 AWG2

Report—

Ch4

Pattern List

Wy EVETDIT

Sink -» 3D Yideo Test Method-> DTG Method; Pattern-= 10801 8 50Hz RGB T% v39 30DFFP

Select one of the two: Custom *Man with Sphere’ 3D, or Standard Graybars 3D.

= In the Markers pane:

Select the oscilloscope channel to use for routing the synchronization pulse from the AWGI.
The available choices are: Chl, Ch2, Ch3, and Ch4. The default value is Ch3.

Select the oscilloscope channel to use for routing the synchronization pulse from the AWG?2.
The available choices are: Chl, Ch2, Ch3, and Ch4. The default value is Ch4.

= Select the pattern(s) from the available list.

7. To connect the DUT, click Tests > Connect. Click here (see page 149) for information on how

to make connections.
File Tests Results Utilities Help TDSHT3 @1| X

Connect
Follow these instructions to set up the connections. Run
Select Test

Click \iore for details. Mare
Configure

1. Set up the DUT, test fixtures and probes. Report—

onnect 2. Configure and test the signal sources. Summary
Vi 3. To view the signal, click View Waveform. Detail

Wyaveronm

Sink -> 30 Video Test Method-> DDS Method; Pattern-= 10801 8 50Hz RGE T w3858 30FP

8. To configure and test the GPIB connection, click Signal Sources. The Signal Sources Setup dialog
box appears.
The AWG tab has options to configure the Primary and Secondary Addresses of AWG1 and AWG?2.
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Signal Sources Setup

GPIB Setup
Board Type

GFIEOD
AWG1 Address AWG2 Address
Primary Primary

- a3 -

Secondary Secondary

0 b 0 -

Test

NOTE. You cannot exit the dialog box unless each of the primary and secondary address selections are
unique.

NOTE. The Manual test option is not available for the DDS method.

9. In the select pane, click GPIB. Configure the appropriate GPIB board number. Click here (see
page 27) for more information.

10. To test the connection and the GPIB configuration, click Test Conn.

11. Because no signal is connected to the oscilloscope, you cannot view the waveform for the jitter
tolerance test.

NOTE. 70 run the test successfully, ensure that the Bus Timing parameter is set to 2 usec on your GPIB
board configuration. Click here (see page 37) for more information.

12. Click Run Test. The TDSHT3 Software sets up the oscilloscope and conducts the test.

13. Follow the instructions in the Sink dialog box. Click OK. The Connect Sink Device dialog box
appears as follows:
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Connect to sink device

ck OK to continue

Press F1 for the detailed setup diagram.

14. Follow the instructions in the Connect Sink Device dialog box. Click OK. The test runs, displaying a
progress indicator. The Confirm Sink Device Support dialog box appears.

Confirm Sink Device Support b__<|

30FP

or Bar on the DUT ?

15. Follow the instructions in the dialog box.

16. If you successfully run the test, the software makes the results available automatically and displays the
result summary. You can also view the report configuration details in the result pane.

File Tests Results Utilities Help TDSHT3 %| X |
Result Summary: Sink Report Configuration

Select Te : Device Details HDMI Device =
L Af13-29: 3D ideo 1080i 8 S0Hz RGE T v39

) Resolution 1080 T
Configure Result

Refraesh Rate e Report—

Report File i18 1 i
Wiew Data Lane )
Waverorm Auto INcCrement

Sink-> 30 Yideo Test Method-»> DTG Method; Pattern-» 1080i 8 50Hz RGE T v99 3DFP

The results summary lists the test name and the status (pass, fail, or error). To view the details of the
results, click Results Details.
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17. Set the report details to identify and generate the report automatically. You can set a default report file.
Click here (see page 48) for more information.

18. In the result summary pane, click Result Details. The result details pane displays the following fields.

Result Details

Test Name Spec Range
8-29: 50 video 1080 8 50Hz RGB T

= Test Name (displays the test id, test name, and selected patterns)
= Spec Range (displays the HDMI standards and test specifications limit for the test)
= Meas Value (displays the patterns supported by the DUT)

= Result (displays the status of the test as Pass, Fail, or Error)

Test Method

This sequence explains the actions that the software takes while it performs a 3D Video test. For the
procedure on how to make this test, refer 3D Video test procedure (see page 313).

For the DTG Method
1. Configure the DTG to output any sink-supported video format.

- Load the pattern that contains repeating RGB gray ramp 0, 1, 2...254, 255, 0, 1, 2... during
each video period.

= Map all the logical channels to physical channels.
= Run the DTG.
- Enable all the output channels.
2. Verify that the DUT continues to support the signal without errors.

3. Ifthe DUT fails to support the signal, it implies a Fail.

For the DDS Method
The DDS method does not require a DTG. The set up includes two AWGs.
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Operate the Sink DUT to support the HDMI input signal.

To configure the parameters for this test, refer 3D Video test procedure (see page 313).

Refer to make connections for 3D Video (see page 149) for information on how to make connections.

Check the connection of the AWGs and AFG from TDSHT3.

A I O o

Run the test. The software loads the appropriate pattern(s). The software prompts you to confirm the
gray bars on the DUT.

Test the 4Kx2K Video

308

To use the DTG test method, you will need a supported oscilloscope, one digital timing generator
(DTG), one differential probe, one DC power supply, eight SMA cables, one GPIB controller, and one
TPA-P-TDR fixture.

To use the DDS test method, you will need a supported oscilloscope, two arbitrary waveform generators
(AWG7102/AWGT122B), one arbitrary function generator (AFG3102/AFG3532), two differential probes,
one TPA-P, one TPA-R, two TCA SMA cables, and one accessory kit (consisting of seven matched
SMA cable pairs, eight bias-tees, eight 120 ps TTC filters, three GPIB-HS cables, four BNC cables, and
one BNC-T adapter).

1. On the menu bar, click Tests > Select > Sink.

2. In the differential tests pane, select the 4Kx2K Video check box.

File Tests Results Utilities Help TDSHT3 | X
Select - Sink

elec
Differential Tests Single-Ended Tests Test
VI L g - Jitter Tolerance Jeep Colar - WP Sy

Report—

iew - Y eo i
€ Sl

Sink -> 30 Video Test Method-> DTG Method; Pattern-»= 10801 8 50Hz RGE T w35 30FP

3. To change the configuration settings, click Tests > Configure. For most tests, you can use the factory
default configuration. However, you can change the values by using the virtual keyboard (see page 24)
or the general purpose knob (see page 26) on the oscilloscope front panel. Using the File menu,
you can also restore the factory defaults or save and recall your own configuration settings. It is
recommended that you save the configuration settings before you choose to select Recall Default or
close the application.

4. In the Input pane, set the Input Clock to the channel that you will use for the HDMI clock input. Select
from the available choices (Chl, Ch2, Ch3, and Ch4).

5. In the Setup pane, select the appropriate test method from the available choices (DTG Method and
DDS Method).

TDSHT3 HDMI Compliance Test Software Online Help



How to ... Test the 4Kx2K Video

6. In the DTG Method pane, do the following:

File Tests Results Utilities Help TDSHT3 %| X |
Configure - Sink

Setup DTG Method Run
Test Method Test

Pattern List
DTG Method ™

Configure 7 Outputs

Report—

Connect Summary

=

Wy averorm DEEN

Sink -= 4Kx2K Video Test Method-> DTG Method, Pattern-» 4K21< 2160p 23 98Hz

= Select the pattern(s) from the available list.

= The DTG Outputs dialog box for the DTG method has the following options:

DT COutputs

Outputs
Clock

Al

Diatal
B2

= Clock (allows you to configure the clock output). Select from the available choices (Al,
A2, B1, B2, Cl1, C2, D1, and D2).

- Data0, Datal, and Data2 (allows you to configure the corresponding data outputs). Select from
the available choices (A1, A2, B1, B2, C1, C2, D1, and D2).

NOTE. You cannot exit the dialog box unless each of the clock and data selections are unique.

In the DDS Method pane, do the following:
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File Tests Results Utilities Help TDSHT3 @1| X
Configure - Sink

Setup DDS Method Run
e Test Method Test
D hod =
Configure Markers

AWG1 AWG2

Report—

( - Chda ~

Pattern List

Wi .

Waverorm

Sink -= dkx2K Video Test Method-= DTG Method; Pattern-= 42K 2160p 25 98Hz

= In the Markers pane:

Select the oscilloscope channel to use for routing the synchronization pulse from the AWGI.
The available choices are: Chl, Ch2, Ch3, and Ch4. The default value is Ch3.

Select the oscilloscope channel to use for routing the synchronization pulse from the AWG?2.
The available choices are: Chl, Ch2, Ch3, and Ch4. The default value is Ch4.

= Select the pattern(s) from the available list.

7. To connect the DUT, click Tests > Connect. Click here (see page 152) for information on how
to make connections.
File Tests Results Utilities Help TDSHT3 El Ll

Connect

Eollow these instructions to set up the connections. Run
Select Test

Click More for dotails. Waore
Configure

1. Set up the DUT, test fixtures and probes. Report—

onnect 2. Configure and test the signal sources.
WiEw o T i 2 i
3. To view the signal, click View Waveform. Detail

Wyaverorm

Sink -= dkx2K Video Test Method-> DDS Method; Pattern-= 42l 2160p 23 98Hz

8. To configure and test the GPIB connection, click Signal Sources. The Signal Sources Setup dialog
box appears.

The AWG tab has options to configure the Primary and Secondary Addresses of AWG1 and AWG2.
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Signal Sources Setup

GPIB Setup
Board Type

GFIEOD
AWG1 Address AWG2 Address
Primary Primary

- a3 -

Secondary Secondary

0 b 0 -

Test

NOTE. You cannot exit the dialog box unless each of the primary and secondary address selections are
unique.

NOTE. The Manual test option is not available for the DDS method.

9. In the select pane, click GPIB. Configure the appropriate GPIB board number. Click here (see
page 27) for more information.

10. To test the connection and the GPIB configuration, click Test Conn.

11. Because no signal is connected to the oscilloscope, you cannot view the waveform for the 4Kx2K
video test.

NOTE. 70 run the test successfully, ensure that the Bus Timing parameter is set to 2 usec on your GPIB
board configuration. Click here (see page 37) for more information.

12. Click Run Test. The TDSHT3 Software sets up the oscilloscope and conducts the test.

13. Follow the instructions in the Sink dialog box. Click OK. The Connect Sink Device dialog box
appears as follows:
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Test the 4Kx2K Video

Connect to sink device E|

s follows: -

3. Click OK to continue

Press F1 for the detailed setup diagram.

14. Follow the instructions in the Connect Sink Device dialog box. Click OK. The test runs, displaying a
progress indicator. The Confirm Sink Device Support dialog box appears.

Confirm Sink Device Support

B0p 24Hz

>olor Bar on the DUT 2

15. Follow the instructions in the dialog box.

16. If you successfully run the test, the software makes the results available automatically and displays the
result summary. You can also view the report configuration details in the result pane.

The results summary lists the test name and the status (pass, fail, or error). To view the details of the
results, click Results Details.

17. Set the report details to identify and generate the report automatically. You can set a default report file.
Click here (see page 48) for more information.

18. In the result summary pane, click Result Details. The result details pane displays the following fields.
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Test Name (displays the test id, test name, and selected patterns)
Spec Range
Meas Value (displays the patterns supported by the DUT)

Result (displays the status of the test as Pass, Fail, or Error)
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Test Method

This sequence explains the actions that the software takes while it performs a 4Kx2K Video test. For the
procedure on how to make this test, refer 4Kx2K Video test procedure (see page 313).

For the DTG Method
1. Configure the DTG to output any sink-supported video format.

= Load the pattern that contains repeating RGB gray ramp 0, 1, 2...254, 255, 0, 1, 2... during
each video period.

= Map all the logical channels to physical channels.
= Run the DTG.
= Enable all the output channels.
2. Verify that the DUT continues to support the signal without errors.

3. Ifthe DUT fails to support the signal, it implies a Fail.

For the DDS Method
The DDS method does not require a DTG. The set up includes two AWGs.
1. Operate the Sink DUT to support the HDMI input signal.

2. To configure the parameters for this test, refer 4Kx2K Video test procedure (see page 313).

3. Refer to make connections for 4Kx2K Video (see page 152) for information on how to make
connections.

4. Check the connection of the AWGs and AFG from TDSHT3.

5. Run the test. The software loads the appropriate pattern(s). The software prompts you to confirm the
gray bars on the DUT.

Test the Extended Colors and Contents

To use the DTG test method, you will need a supported oscilloscope, one digital timing generator
(DTG), one differential probe, one DC power supply, eight SMA cables, one GPIB controller, and one
TPA-P-TDR fixture.

To use the DDS test method, You will need a supported oscilloscope, two arbitrary waveform generators
(AWG7102/AWG7122B), one arbitrary function generator (AFG3102/AFG3532), two differential probes,
one TPA-P, one TPA-R, two TCA SMA cables, and one accessory kit (consisting of seven matched
SMA cable pairs, eight bias-tees, eight 120 ps TTC filters, three GPIB-HS cables, four BNC cables, and
one BNC-T adapter).
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1. On the menu bar, click Tests > Select > Sink.

2. In the differential tests pane, select the Extended Colors and Contents check box.

File Tests Results Utilities Help TDSHT3 @1| X
Select - Sink

Cable
Differential Tests Single-Ended Tests Test
- Jitter Tolerance . Deep Color - Intra-Pair ;

e - Audio Formats Report
. 30 widen

Sink -= Extended Colors Test Method-= DTG Method; Pattern-> AdobeRGE480p

3. To change the configuration settings, click Tests > Configure. For most tests, you can use the factory
default configuration. However, you can change the values by using the virtual keyboard (see page 24)
or the general purpose knob (see page 26) on the oscilloscope front panel. Using the File menu,
you can also restore the factory defaults or save and recall your own configuration settings. It is
recommended that you save the configuration settings before you choose to select Recall Default or
close the application.

4. In the Input pane, set the Input Clock to the channel that you will use for the HDMI clock input. Select
from the available choices (Chl, Ch2, Ch3, and Ch4).

5. In the Setup pane, select the appropriate test method from the available choices (DTG Method and
DDS Method).

6. In the DTG Method pane, do the following:

File Tests Results Utilities Help TDSHT3 %| x
Configure - Sink

Setup DTG Methed Run
Test Method Test

- Pattern List DTG
DTG Method ™

Corfigure Adobe 50p Qutputs

Report—

Connect Summary

Waverorm DL

Sink -» Extended Colors Test Method-= DTG Method; Pattern-> AdobeRGBE480p

= Select the pattern(s) from the available list.
= The DTG Outputs dialog box for the DTG method has the following options:
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DTG Outputs E

Outputs

Clock

Al

Diatal

= Clock (allows you to configure the clock output). Select from the available choices (Al,
A2, B1, B2, Cl1, C2, D1, and D2).

= Data0, Datal, and Data2 (allows you to configure the corresponding data outputs). Select from
the available choices (A1, A2, B1, B2, C1, C2, D1, and D2).

NOTE. You cannot exit the dialog box unless each of the clock and data selections are unique.

In the DDS Method pane, do the following:

File Tests Results Utilities Help TDSHT3 %| X |
Configure - Sink

Setup DDS Method Run
e Test Method Test
DOS Method  *
Configure Markers

AWG1 AWG2 Report—
chi = Ch4 ¥
Connect Summary

Wiew YCC_Full_Quanta7ep i
W EVETOT - Detal

Sink -= Extended Colors Test Method-> DTG Method; Pattern-» AdobeRGE4800

= In the Markers pane:

= Select the oscilloscope channel to use for routing the synchronization pulse from the AWGI.
The available choices are: Chl, Ch2, Ch3, and Ch4. The default value is Ch3.

= Select the oscilloscope channel to use for routing the synchronization pulse from the AWG?2.
The available choices are: Chl, Ch2, Ch3, and Ch4. The default value is Ch4.

= Select the pattern(s) from the available list.

7. To connect the DUT, click Tests > Connect. Click here (see page 155) for information on how
to make connections.
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File Tests Results Utilities Help TDSHT3 @| X
Connect

Follow these instructions to set up the connections. Run
Select Test

Click More for dotails. More

Configure

1. Set up the DUT, test fixtures and probes. Report—

Connect 2. Configure and test the signal sources. .
Wiew 5 Pl T : |
3. To view the signal, click View Waveform. Detail
Wyaverorm

Sink -» Extended Colors Test Method-> DDS Method; Pattern-= YCC Full Quanta7ap

8. To configure and test the GPIB connection, click Signal Sources. The Signal Sources Setup dialog
box appears.

The AWG tab has options to configure the Primary and Secondary Addresses of AWG1 and AWG2.

Signal Sources Setup

Select GPIB Setup
Board Type

GPED ~
AWG1 Address AWG2 Address

Manual . -
2 = 3 -

Secondary Secondary

NOTE. You cannot exit the dialog box unless each of the primary and secondary address selections are
unique.

NOTE. The Manual test option is not available for the DDS method.

9. In the select pane, click GPIB. Configure the appropriate GPIB board number. Click here (see
page 27) for more information.

10. To test the connection and the GPIB configuration, click Test Conn.

11. Because no signal is connected to the oscilloscope, you cannot view the waveform for the extended
colors and contents test.

NOTE. To run the test successfully, ensure that the Bus Timing parameter is set to 2 usec on your GPIB
board configuration. Click here (see page 37) for more information.
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12. Click Run Test. The TDSHT3 Software sets up the oscilloscope and conducts the test.

13. Follow the instructions in the Sink dialog box. Click OK. The Connect Sink Device dialog box
appears as follows:

Connect to sink device rz|

} Connect TPA-Pto S

k OK to continue

ess F1 for the detailed setup diagram.

14. Follow the instructions in the Connect Sink Device dialog box. Click OK. The test runs, displaying a
progress indicator. The Confirm Sink Device Support dialog box appears.

Confirm Sink Device Support

Pattern MName © Adab 0p

i Bar on the DUT ¢

15. Follow the instructions in the dialog box.

16. If you successfully run the test, the software makes the results available automatically and displays the
result summary. You can also view the report configuration details in the result pane.

File Tests Results Utilities Help TDSHT3 B, x

Result Summary: Sink Report Configuration

- - . . N Fun
Select Te e Device Details HDMI 3 Test

|.#]|5-31: Extended Colors AdobeRGE

| Resolution heRG
Configure Result

Refrash Rate Report—

Report File 3E_0 1
Wiew
Data Lane = - (
Wy aveform Auto Increment Ep0

Sink -> Extended Colors Test Method-= DTG Method; Pattern->= AdobeRGB480p
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The results summary lists the test name and the status (pass, fail, or error). To view the details of the
results, click Results Details.

17. Set the report details to identify and generate the report automatically. You can set a default report file.
Click here (see page 48) for more information.

18. In the result summary pane, click Result Details. The result details pane displays the following fields.

Result Details

Test Name
8-31: Extended Colors AdobeRGE

- Test Name (displays the test id, test name, and selected patterns)
= Spec Range (displays the HDMI standards and test specifications limit for the test)
= Meas Value (displays the pattern supported by the DUT)

= Result (displays the status of the test as Pass, Fail, or Error)

Test Method

318

This sequence explains the actions that the software takes while it performs a Extended Colors and
Contents test. For the procedure on how to make this test, refer Extended Colors and Contents test
procedure (see page 313).

For the DTG Method
1. Configure the DTG to output any sink-supported video format.

= Load the pattern that contains repeating RGB gray ramp 0, 1, 2...254, 255, 0, 1, 2... during
each video period.

- Map all the logical channels to physical channels.
= Run the DTG.
= Enable all the output channels.
2. Verify that the DUT continues to support the signal without errors.

3. Ifthe DUT fails to support the signal, it implies a Fail.
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For the DDS Method
The DDS method does not require a DTG. The set up includes two AWGs.
1. Operate the Sink DUT to support the HDMI input signal.

2. To configure the parameters for this test, refer Extended Colors and Contents test procedure (see
page 313).

3. Refer to make connections for Extended Colors and Contents (see page 155) for information on how
to make connections.

4. Check the connection of the AWGs and AFG from TDSHTS3.

5. Run the test. The software loads the appropriate pattern(s). The software prompts you to confirm the
gray bars on the DUT.

Test the Sink Intra-Pair Skew

This test allows you to confirm that the maximum allowed timing skew within each TMDS pair is
supported by the Sink DUT.

To use the DTG test method, you will need a supported oscilloscope, one differential probe, one cable
emulator, one TPA-P-DI fixture, one digital timing generator (DTG), one DC power supply, eight SMA
cables, one GPIB controller, and one TPA-P-TDR fixture.

To use the DDS test method, you will need a supported oscilloscope, two arbitrary waveform generators
(AWG7102/AWG7122B), one arbitrary function generator (AFG3102/AFG3532), one differential probe,
one TPA-P, one TPA-R, two TCA SMA cables, and one accessory kit (consisting of seven matched
SMA cable pairs, eight bias-tees, eight 0-6400 MHz low pass filters, three GPIB-HS cables, four BNC
cables, and one BNC-T adapter).

1. On the menu bar, click Tests > Select > Sink.
2. In the single-ended tests pane, select the Intra-Pair Skew check box.

File Tests Results Utilities Help TDSHT3 @1| x
Select - Sink

( Source Sink Cahle
Select
- Differential Tests Single-Ended Tests
it __--- . Jitter Tolerance - Deep Color Intra-Pz it

5 Audio Formats
- egeneration . Packet Jitter - Report—

- One Bit Audio . | Interoperahility - 30 wideo

iew - ideD - i
Detal

Sink -= Intra-Pair Skew Test Method-= DTG Method, Thit: Recalc; Avgs -= 100

3. To change the configuration settings, click Tests > Configure. For most tests, you can use the factory
default configuration. However, you can change the values by using the virtual keyboard (see page 24)
or the general purpose knob (see page 26) on the oscilloscope front panel. Using the File menu,
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you can also restore the factory defaults or save and recall your own configuration settings. It is
recommended that you save the configuration settings before you choose to select Recall Default or
close the application.

File Tests Results Utilities Help TDSHT3 %| X |

Configure - Sink
Setup Skew Configuration
Test Method on o el Skew Channel

15 Ck ™

Select

DTG Method =
Configure DTG Method

Thit

# of Avgs
Connect g
calculate 100
Pattern List
o 1 OHz 8Bt ... = Outputs
Wavetarm

Sink -> Intra-Pair Skew Test Method-> DTG Method, Thit: Recalc; Avgs -= 100

NOTE. The default configuration introduces skew on a single channel (Clock). If you want to calculate the
intra-pair skew for all channels, connect the desired channels to Al and A2. For example, to calculate
the intra-pair skew of Data0, assign Al to Data0 and Bl to Clock. Make appropriate changes in the

test connections.

4. In the Input pane, set the Input Clock to the channel that you will use for the HDMI clock input. Select
from the available choices (Chl, Ch2, Ch3, and Ch4).

5. Select the appropriate test method from the available choices (DTG Method and DDS Method).

6. In the Tbit pane, do the following:
- Enter the desired number of periods that are considered to calculate Tbit. The default value is 100.
= Click Re-calculate to recalculate the Tbit value.
= Click Existing Value to use the previously calculated Tbit value.

7. In the Skew Configuration pane, do the following:

- Select Skew On All Channels to set the skew on all the channels to introduce skew on Clock, DO,
D1, and D2. All the four DTGM30 modules are required for this option.

Select Skew On One Channel to set the skew on one channel.

NOTE. The four DTGM modules can be connected as follows: Clock +ve to A1 and Clock —ve to A2,
DO +ve to Bl and DO —ve to B2, DI +ve to CI and D1 —ve to C2, D2 +ve to D1 and D2 —ve to D2.

= Select the skew channel in which you want to introduce the skew. You can select from the
available choices (Chl, Ch2, Ch3, and Ch4).
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8. If the selected test method is DTG, do the following:
= Select the DTG pattern file from the drop-down list.
= Click Outputs to display a dialog box where you can set Clock, Data0, Datal, and Data2 outputs.

If the selected test method is DDS, do the following:

File Tests Results Utilities Help TDSHT3 B, X |

Configure - Sink
Setup Skew Configuration
Test Method nel Skew Channel

Ck ¥

Select

DDS Method ™ -
Configure DDS Method

Analog
Thit AWG1 AWG2

# of Avys L3 SE Chd
Connect 4 = cha = ch4
calculate 100

Pattern List DDS

=D 1 GOHZ BB Gr.. ¥ outputs
Wavetorm

Sink -= Intra-Pair Skew Test Method-= DDS Method; Thit: Recale; Avgs -= 100

= In the Analog pane:

= Select the oscilloscope channel to use for routing the synchronization pulse from the AWGH.
The available choices are: Chl, Ch2, Ch3, and Ch4. The default value is Ch3.

- Select the oscilloscope channel to use for routing the synchronization pulse from the AWG2.
The available choices are: Chl, Ch2, Ch3, and Ch4. The default value is Ch4.

= Select the DDS pattern file from the drop-down list.
= Click Outputs to display the AWG Output dialog box.

NOTE. You cannot configure the AWG Outputs dialog box.

9. Inthe DTG Method pane, the Outputs dialog box has the following options:

DTG Outputs | X

Outputs
Clock Datad

Al Bl ¥

Data2

C1 7
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= Clock (allows you to configure the clock output). Select from the available choices (A1, A2, B1,
B2, C1, C2, D1, and D2).

= Data0, Datal, and Data2 (allows you to configure the corresponding data outputs). Select from
the available choices (A1, A2, B1, B2, C1, C2, D1, and D2).

NOTE. You cannot exit the dialog box unless each of the clock and data values are unique.

In the DDS Method pane, the AWG Outputs dialog box has the following configurations:

AWG Outputs

AWG Outputs
Clock Data0

NOTE. You cannot configure the AWG Outputs dialog box.

10. To connect the DUT, click Tests > Connect. Click here (see page 158) for information on how
to make connections.

File Tests Results Utilities Help TDSHT3 %| X |
Connect
Follow these instructions to set up the cohhections. Run
Select Follow these Instructions to set Up the connections. St

Click More for dotails. More

1. Set up the DUT, test fixtures and probes. Report—

Connect

2. Configure and test the signal sources. : : SUMmmary

e
Wy averonm

3. To view the signal, click View Waveform. Detail

Sink -= Intra-Pair Skew Test Method-= DTG Method; Thit: Recalc; Avgs-> 100

11. To configure and test the GPIB connection, click Signal Sources. The Signal Sources Setup dialog
box appears.
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Signal Sources Setup

Select GPIB Setup
Board Type

=PIB GRIBO

Address

Primary
i -

Secondary

0 -

12. In the select pane, click GPIB. Configure the appropriate GPIB board number. Click here (see
page 27) for more information.

13. To test the connection and the GPIB configuration, click Test Conn.

14. Click Run Test to perform the test. The TDSHT3 Software sets up the oscilloscope and conducts
the test. Follow the instructions in the dialog box. Depending on your answer, a series of dialog
boxes may prompt you for your input.

15. If you successfully run the test, the software makes the results available automatically and displays the
result summary. You can also view the report configuration details in the result pane.

File Tests Results Utilities Help TDSHT3 %I X I
Result Summary: Sink Report Configuration = '

_ . B . -
T & Device Details g | iz

: Sink Intra-Pair Skew :

: a6 - Sink Intra-Pair Skew Resslution 19201080
Configure - —— - 4 Result
4|58-6 : Sink Intra-Pair Skew : :

-6 : Sink Intra-Pair Skew Refresh Rate

Connect | -
- . Report File C lic i
Wavefnrm : e e B Auto Increment 2 | Repo | ]

Sink -= Intra-Pair Skew Test Method-= DTG Method; Thit: Fecalc; Avgs -= 100

The result summary for the DDS test method is as follows:
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File Tests Results Utilities Help TDSHT3 @l X |
W ResultSummar:Sink 0 ReportConfiguration

Run
Select E Device Details HOMI Device
: Sink Intra-Pair Skew

: Sink Intra-Pair Skew : Resolution

Canfigure —— : :
: Sink Intra-Pair Skew

- Sink Intra-Pair Skew Refresh Rate 1] Report—

Report File Ca 5
e
Data Lane g
W aVETDrm = Auto Increment

Sink -= Intra-Pair Skew Test Method-> DDS Method; Thit: Recalc; Avds -= 100

The results summary lists the test name and their status (pass, fail, or error). To view the details
of the results, click Results Details.

16. Set the report details to identify and generate the report automatically. You can set a default report file.
Click here (see page 48) for more information.

17. In the result summary pane, click Result Details. The result details pane displays the following fields.
Result Details

e
ntra Pair Skew;
0.47Thit < Intra Pair Skew;
8-6 : Sink Intra-Pair Skew : D1 0.47Thit < Intra Pair Skew;
8-6 : Sink Intra-Pair Skew ; D2 D.4*Thit < Intra Pair Skew;

The result details for the DDS test method are as follows:
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Result Details

Test the Sink Intra-Pair Skew

Test Name =
Sink Intra-Pair Skew : CK 0.4*Thit « Intr:

10e |
Pair Skew - ... |1 oI it = 1 N = hod; Worst

8-6:
8-6 : Sink Intra-Pair Skew : DO 0.4*Thit < Intra - Pair Skew- ... | 3 Margin = 0.2° st skew supported by
8-6 : Bink Intra-Pair Skew : D1 0.4*Thit « Intra - Pair Skew - ... (1050000 'z i 27Thit; DDS Metht pparted oy

Test Method

8-6:

0.4*Thit < Intra -

Sink Intra-Pair Skew Pair Skew - ... 1= 3 i 0.2*Thit; DDS Methe pporte

Test Name (displays the test id, test name, and selected names)

Spec Range (displays the HDMI standards and test specifications limit for the test)
Meas Value (displays the measured value)
Result (displays the status of the test as Pass, Fail, or Error)

Remarks/Comments (displays the relevant details, such as Tbit, Vswing, and Margin. If the test
could not be run, this field displays an error code (see page 357).

For the DTG Method

This sequence explains the actions that the software takes while it performs an intra-pair skew test. For the
procedure on how to make this test, refer intra-pair skew test procedure (see page 319).

1. Configure the DTG to output any sink-supported video format that uses the maximum sink-supported
pixel clock frequency. If multiple formats are available, a native format is preferred.

2. Calculate Tbit by using the differential clock.

3. For each of the TMDS Clock and Data pairs that act as the tested pair:

Set the delay for all outputs to 0 ns . Disable “Differential Timing Offset” if it is previously
enabled.

Move the TMDS “+” signal of the tested pair to DTG output module A, 1+.
Move the TMDS “— signal of the tested pair to DTG output module A, 2+.
Change the DTG configuration to output the pattern for the tested TMDS channel on module A, 1.
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4. When Skew on all four channels option is selected, the skew on all the four channels will be calculated
based on the following conditions:

= All four modules of the DTG must be DTGM30 modules. The test checks for the modules and
throws an error if they are not from the DTGM30.

= The configuration to run the test are A1-Clock, B1-Data 0, C1-Data 1, and D1-Data 2. If the
test fails on any of the channels the skew will be inserted individually on the channels to find
the channel that has failed the test.

5. In the DTG “Timing”, set the tested channel (connected to 1A1) and enable “Differential Timing
Offset.”

6. Set the delay value in the differential timing offset to approximately (0.1*Tg;r). This corresponds to
the initial intra-pair skew value.

7. Increase the skew (Differential Timing Offset) by steps of less than or equal to (0.1*Tg7), until the
Sink DUT outputs errors or until reaching either (0.6*Tgr) or 1 nsec.

8. Iferrors are seen on DUT, then:
= Reduce the skew one step, so that the Sink DUT outputs no errors.

= If intra-pair skew is less than (0.4*Tgr), it implies Fail.

For the DDS Method
1. Operate the Sink DUT to support the HDMI input signal.

2. For the procedure on how to make this test, refer intra-pair skew test procedure (see page 319).

3. Refer to the make connections for sink intra-pair skew (see page 164) for information on how to
make connections.

4. Check the connection of the AWGs and AFG from TDSHT3.

5. Run the test. The software loads the appropriate patterns with zero skew patterns. The software
prompts you to confirm the gray bars on the DUT.

6. You are prompted to connect the Clock output of the TPA-R to the configured oscilloscope channel
to measure the T-bit.

7. Connect the TPA-P to the Sink DUT. The software prompts you to confirm the gray bars on the DUT.

8. Once this is confirmed, the appropriate skew signals are generated in steps of 0.1 Tbit from 0.0 Thbit as
per the CTS. You are prompted to confirm for the gray bar on the DUT for each step.

9. The test fails if the sink outputs errors at any time.

NOTE. Using a manual DDS test method is not recommended because the software performs the Sink
Intra-Pair Skew test automatically and effectively.
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Test the Cable Eye Diagram

This test allows you to confirm that the Cable assembly outputs a compliant data eye. Check the input test
signal at TP1 and verify the output of the cable for compliance at TP2.

The signal degradation of typical passive copper cables increases with the frequency and the length of the

cable. To recover data from such cables, the TDSHT3 applies the reference cable equalizer (as specified in
the HDMI specifications 1.4a) automatically to the eye diagram measurement when the clock frequency is
more than 165 MHz.

To use the DTG test method, you will need a supported oscilloscope, two/four differential probes, one
digital timing generator (DTQ), one arbitrary function generator (AFG), one GPIB controller, one DC
power supply 3.3 V, eight SMA cables, one TPA-R-DI fixture, and one TPA-R-TDR fixture.

To use the DDS test method, you will need a supported oscilloscope, two arbitrary waveform generators
(AWG7102/AWG7122B), one arbitrary function generator (AFG3102/AFG3532), two/four differential
probes, one TPA-P, two TPA-R, and one accessory kit (consisting of eight matched SMA cable pairs, eight
bias-tees, eight 120 ps TTC filters, three GPIB-HS cables, four BNC cables, and one BNC-T adapter). For
Type-E cable emulator, use the Type-E fixtures (one TF-HDMIE-TPA-P and two TF-HDMIE-TPA-R) in
place of Type-A and Type-C fixtures.

1. On the menu bar, click Tests > Select > Cable.

2. In the differential tests pane, select the Eye Diagram check box.

File Tests Results Utilities Help TDSHT3 o, X |
Select - Cable

Sink I Cahle
Differential Tests Test
Eye Diagram - Inter-Pai "

Report—

Wiew
WWaverarm

Cahle -> Eve Diagram Clock -= Ch1; Datal -» Ch2; Datal -» Ch3; Data2 -» Ch4; BL -> 106, Test Method-> DTG Method, TP1 -= True, TP2 -> True

3. To change the configuration settings, click Tests > Configure. For most tests, you can use the factory
default configuration. However, you can change the values by using the virtual keyboard or the
general purpose knob on the oscilloscope front panel. Using the File menu, you can also restore the
factory defaults or save and recall your own configuration settings. It is recommended that you save
the configuration settings before you choose to select Recall Default or close the application.
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File Tests Results Ltiliies Help TDSHT3 E| X |

Configure - Cable

R (setup | DTG Methon | " Cable Equalizer | Rise time filter Run
o Test

Test Method Ref Level Units High Ref

DTG Method - #
Configure 2 _
HoriziAcq Test Points

Rec Length Hysteresis . Mid Ref *, Report—

R e 10% i 0% -

CRU Low Ref L)
e . 20% L
Waverarm L —

Cahle -» Eye Diagram Clock -= Ch1; Datal -= Ch2; Datal -= Ch3; Data2 -> Chd, BL -= 25M; Test Method-» DTG Method; TP1 -= True; TP2 -= True

4. In the Input pane, do the following:

= Set the Input Clock to the channel that you will use for the HDMI clock input. Select from the
available choices (Chl, Ch2, Ch3, and Ch4).

= Set the Input Data0, Datal, and Data2 to the channels that you will use for the corresponding
HDMI data inputs. Select from the available choices (Ch1l, Ch2, Ch3, Ch4, and Not Conn).

5. In the Setup tab, do the following:
= Select the appropriate test method from the available choices (DTG Method and DDS Method).
In the Horiz/Acq pane:
- Enter the desired record length value for the eye tests in the Rec Length box.

= Configure the Clock Recovery Unit in the CRU pane. Select from the available choices (PLL,
Raw, and Ideal). The default value is first order PLL and is used for compliance testing. Raw and
Ideal are used for analysis.

In the Test Points pane (for the DTG and DDS methods):

= Feed the worst possible compliant signal at TP1. By default, the TP1 check box is selected.
TP1 represents the first test point.

= The worst possible compliant signal fed at TP1 is transmitted through the cable. The same signal
is tested at TP2 with the TP2 eye mask. By default, the TP2 check box is selected. TP2 represents
the second test point.
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6.

Test the Cable Eye Diagram

For the DDS Method using the Type-E cable emulator, you can select only two test points at a time
(TP1 and TP2, TP1 and TP5, or TP5 and TP2).

- Ifyou have selected TP1 and TP2, do the following:
= Feed the worst possible compliant signal at TP1.

= The worst possible compliant signal fed at TP1 is transmitted through the cable. Test the same
signal at TP2 with the TP2 eye mask. TP2 represents the second test point.

= Ifyou have selected TP1 and TP5 (applicable for 74 MHz Type-E), do the following:
- Feed the worst possible compliant signal at TP1.

= The worst possible compliant signal fed at TP1 is transmitted through the Type-E cable. Test
the same signal at TP5 with the TP5 eye mask.

= If you have selected TP5 and TP2 (applicable for 74 MHz Type-E), do the following:
= Feed the worst possible compliant signal at TPS5.

= The worst possible compliant signal fed at TP5 is transmitted through the cable. The same
signal is tested at TP2 with the TP2 eye mask.

= Set the reference level units to either Per (%) or Abs.
Per (%) indicates that the reference levels are a percentage of the Vswing value.
Abs indicates that the reference levels are absolute voltage values.
The default setting is Per (%).

= In the Hysteresis box, enter the desired hysteresis percent value. The range is from 0% to 25%
and default is 10%.

- In the High box, the required high reference voltage value is set for the test. The default value is
80%.

= In the Mid Ref box, enter the desired mid reference voltage value. The range is from 25% to 75%
and default is 50%.

= In the Low box, the required low reference voltage value is set for the test. The default value is
20%.

In the DTG Method tab, do the following:

File Tests Results Utlities Help TDSHT3 %| X |

Pattern List DTG Jitter Insertion
Configure = S . Dutputs Q Result

Configure - Cable

Select |'.. Setup DTG Metnod | “canie Equalizer | Rise time filter Run
Test

Report—

Connect

W aveform

Cahle -> Eve Diagram Clock -»= Ch1; Datal -= Ch3; Datal ->= Ch2; DataZ -> Chd; RL -> 25M; Test Method-> DTG Method; TP1 -= Trug; TP2 -= True
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= Select the DTG pattern file from the drop-down list.
= Click Outputs to display a dialog box where you can set Clock, Data0, Datal, and Data2 outputs.
= In the Jitter Insertion pane, do the following:

= Select DTG to insert jitter using a DTG.

= Select AFG to insert jitter using an AFG.

7. In the DTG Outputs dialog box, you have the following options:

DTG Outputs m

Cutputs

Clock

= Clock (allows you to configure the clock output). Select from the available choices (A1, A2, B1,
B2, Cl1, C2, D1, and D2).

- Data0, Datal, and Data2 (allows you to configure the corresponding data output). Select from
the available choices (A1, A2, B1, B2, C1, C2, D1, and D2).

NOTE. You cannot exit the dialog box unless each of the clock and data values are unique.

8. In the DDS Method tab, do the following:

File Tests Results Utilities Help TDSHT3 @| X

[ seup [ DS Method | Run
Test
) Cable Frequency AWG
Configure e Outputs Result

Report—

Connect

Ex

Waveform

Cahle - Eve Diagram Clock -= Ch1; Datal -= Ch2; Datal -» Ch3; Data2 -> Chd; RL -» 25M; Test Method-» DDS Method, TP1 - True; TRP2 -» True

= Select the cable frequency from the drop-down list.
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Depending on the selected cable frequency, the following check box is enabled in the Cable
Equalizer tab:

= For 74 MHz and 165 MHz cable frequencies, Do not apply equalizer for Clock and Data
check box is selected.

= For 340 MHz cable frequency, Use internal coefficients check box is selected.

= For 74 MHz Type-E cable frequency, Use internal coefficients check box is selected but
2.3 dB cable equalizer is used.

= Click Outputs to display the AWG dialog box.

9. Inthe AWG Outputs dialog box, you have the following configurations:

AWG Outputs

AWG Outputs
Clock Data0

NOTE. You cannot configure the AWG Outputs dialog box.

10. In the Cable Equalizer Configuration tab, do the following:

File Tests Results Ltilities Help TDSHT3 %| X |

Configure - Cable
Input
Select Clock

cht = Cable Equalizer Configuration

[ setup | DTG Method ["Cable Equalizer | Rise time filter

Configure Data0

ch2 «

Use internal coefficients
Cable Equalizer Path
Connect patal W Use coefficients from a file CihTe cations

Ch3 w7

Wi Data2 Do not apply equalizer for Clock and Data

Waveform chd4 ¥

Cahle -> Eye Diagram Clock-»= Ch1; Datal -= Ch3; Datal -> Ch2; Data2 -» Chd; RL -» 25M; Test Method-> DTG Method; TP1 -= True; TP2 -> True
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= Select the Use Internal coefficients check box to use the internal coefficients that are already
available (these coefficients are in accordance with the CTS). This is applicable for frequencies
above 165 MHz.

= Select the Use coefficients from a file check box to use the coefficients from a file. Browse the
cable equalizer file from the Cable Equalization Path option.

= Select Do not apply equalizer for Clock and Data check box if you do not want to apply cable
equalization. This is applicable for frequencies below 165 MHz.

11. In the Rise Time Filter Configuration tab, do the following.

File Tests Results Utilities Help TDSHT3 @1| X
Configure - Cable

Input ( setun [ D ethod —I qua m Run
Clock [Fsep — - Test
Rise Time Filter Configuration

Use internal coefficients
Rise Time Filter Path Report—

Use coefficients fram a file Summary

Do not app e Time Filter -

Detail

Cable -= Eye Diagram Clock -» Chi; Datal -»> Ch3, Datal -= Ch2, Data2 -= Ch4, BL -» 280, Test Method-> DTG Method, TP1 -> True; TP2 -= True

= Select the Use Internal coefficients check box to use the internal coefficients that are already
available (these coefficients are in accordance with the CTS).

= Select the Use coefficients from a file check box to use the coefficients from a file. Browse the rise
time filter file from the Rise Time Filter Path.

= Select Do not apply rise time filter for Clock and Data check box if you do not want to use the
rise time filter.

NOTE. You cannot configure the Rise Time Filter for the DDS method because the effect is emulated
by the software.

12. To connect the DUT, click Tests > Connect. Click here (see page 172) for information on how
to make connections.
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File Tests Results Utilities Help TDSHT3 m, X |

Connect

Follow these instructions to set up the connections. Run
Select Test

Click More for details. Iore

Configure

1. Set up the DUT, test fixtures and probes. Report—

Connect 2. Configure and test the signal sources.
iew 5 ignal. cli ? i
3. Toview the signal, click View Waveform. Detail
WY AVETDIT

Cahle -> Eye Diagram Clock -= Ch1; Datal -> Ch2; FL -= 25M; Test Method-= DTG Method; TP1 -> False; TP2 -= True

13. To configure and test the GPIB connection, click Signal Sources. The Signal Sources Setup dialog
box appears.

Signal Sources Setup

GPIB Setup

Board Type

- GPED
Address

Marnual

1 =

Secondary

] o

14. In the select pane, click GPIB. Configure the appropriate GPIB board number. Click here (see
page 27) for more information.

15. To test the connection and the GPIB configuration, click Test Conn.

16. Because no signal is connected to the oscilloscope, you cannot view the waveform for the eye
diagram test.

NOTE. 70 run the test successfully, ensure that the Bus Timing parameter is set to 2 usec on your GPIB
board configuration. Click here (see page 37) for more information.

17. Click Run Test to perform the test. The TDSHT3 Software sets up the oscilloscope and the test
runs, displaying a progress indicator.
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18. In the GPIB mode, the application automatically adjusts the jitter amplitude on DTG and displays the
measured jitter value. Follow the on-screen instructions to enable you to re-adjust the jitter value. The
software creates a worst eye and asks you to verify the worst eye. Follow the on-screen instructions.
Depending on your answer, a series of dialog boxes may prompt you for your input.

19. If you have run the test successfully, the software makes the results available automatically and
displays the eye diagram plot and the clock jitter plot for both TP1 and TP2. For more information
on the plots, refer the section on the source eye diagram test and the source clock jitter test. You
can also view both the result summary of the test and the report configuration in the result pane as
shown in the following figure:

File Tests Results Utlities Help TDSHT3 %| X |
Result Summary: Cable Report Configuration

Run
Test Mame A H I D = —
Select £ Device Details HOMI D

. Cable Eye Diagram TP1:

. Cable Eye Diagram TPZ2: Resolution 080i
Configure - Result
. Cable Eye Diagram TPZ2:

. Cable Eye Diagram TP2: Refresh Rate 60Hz Report—

Report File Ca 5

R Test Point Data Lane : -
Wyavefarm TP2 * 9w ) ) [ Auto Increment |

Cahle -= Eye Diagram Clock -» Ch1; Datal -» Ch3; Datal -» Ch2; DataZ -» Chd, RL -» 25M; Test Method-» DTG Method; TP1 -=» Trug; TP2 -= True

The result summary for the DDS test method is as follows:

File Tests Results Lltiliies Help TDSHT3 %| X |
Result Summary: Cable Report Configuration

Select Device Details HOM (=] 3T Test
: Cable Eye Diagram TP1:

. Cable Eye Diagram TF2 : Resolution
Configure = Result
. Cable Eye Diagram TR2:

: Cable Eye Diagram TP2 : Refrash Rate Report—

Report File 15
iew Test Point Data Lane 2 7
Wyaverorm 2 Auto Increment

Cahle -» Eye Diagram Clock -= Ch1; Datal -= Ch3; Datal -= Ch2; Data2 -» Ch4, BL -» 28M; Test Method-» DDS Method; TP1 -= True; TP2 -= True

The result summary pane lists the tests, status of the test (pass, fail, or error), test point, data lane, and
view eye plot. To view the details of the results, click Results Details.

20. Set the report details to identify and generate the report automatically. You can set a default report file.
Click here (see page 48) for more information.

21. In the result summary pane, click Result Details. The result details pane displays the following fields.
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Result Details

0 [TP2 Data Jitter < 0. 0.3°Thit

[7P2 o2t st <0 =

2 |TP2 Data Jiter < 0.6°

Test Paint DataLane
TRl ¥ g

Test Name
. Cahle Eye Diagram TRP1:

TF'1_ Data Jitter < 0.3*Thit; 0 i | i} I 2 0*Thit: Record

§-3: Cahle Eye Diagram TP2: CK - D0 |TPZ2 Data Jitter < 0.5*Thit; i i ; |Thi in hit: Recard

8-3: Capble Eye Diagram TPZ: CK- D1 [TP2 Data Jitter < 0.57ThHit, g } ] : ar Thit;

: Cahle Eye Diagram TP2: CK- D2 |TP2 Data Jitter < 0.5*Thit, 0 i b *Thit: Record

Test Point Data Lane

TRl ¥

- Test Name (displays the test id, test name, test point, and selected lanes)

= Spec Range (displays the HDMI standards and test specifications limit for the test)
= Meas Value (displays the measured value in mV)

= Result (displays the status of the test as Pass, Fail, or Error)

- Remarks/Comments (displays the relevant details, such as Vswing and Margin). If the test could
not be run, this field displays an error code (see page 357).

= Test Point (allows you to check the input test signal at TP1/TP5 and verify the output of the
cable for compliance at TP2/TP5. From the Test Point list, select either TP1/TP5 or TP2/TP5 to
view the respective details)

= Data Lane (displays the eye diagram plot of the selected data lane pair)
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NOTE. This option is applicable only for TP2/TPS5.

- View Eye Plot (allows you to view the eye plot for the selected test point and data lane for the
eye diagram test)

= Result Statistics (displays statistics based on the tests)

22. In the Result Details dialog box, click Result Statistics to display statistics based on the tests. Click
here (see page 49) for more information.

Result Statistics

The result statistics for the DDS method is as follows:

Result Statistics

Test Mame
Cable Eye Diagram : Tx Clock TIE B
Cahble Eye Diagram ; Recovered Clock ... |10 3 30 342 .00ps
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Test Method

This sequence explains the actions that the software takes while it performs an eye diagram test. For the
procedure on how to make this test, refer eye diagram test procedure (see page 327).

Cable Equalizer

The signal degradation of typical passive copper cables increases with the frequency and the length of
the cable. To recover data from such cables, TDSHT3 Software applies the reference cable equalizer (as
specified in the HDMI specification 1.4a) automatically to the cable eye diagram measurement when the
clock frequency is more than 165 MHz. For the Type-E cable, a 2.3 dB equalizer is applied at 74.25 MHz.

For the DTG Method

1. Configure the DTG to output a video format corresponding to the specified bandwidth of the cable.
If no bandwidth is specified, configure the DTG to output 1920 x 10801 @ 60 Hz (74.25 MHz pixel
clock).

= Load the appropriate pattern file.

= Set the logical channel to physical channel mapping.
= Run the pattern.

- Enable all the DTG outputs.

2. Configure the DTG to output worst-case eye as follows:

Adjust jitter on TMDS_CLOCK pair to output 0.4 ns at 500 KHz (worst jitter permitted at (TP1 =
0-3*TBIT) at 75 MHZ)

Adjust the output swing voltage to 500 mV for every TMDS single-ended signal.

Using jitter/eye analyzer, measure the TMDS CLOCK jitter and eye diagram of all the three
TMDS DATA pairs.

Repeat and readjust as necessary to create the worst-case eye diagram.

3. Set up the oscilloscope as follows:

Set the memory length to at least 25 M points.

= Set the single-shot trigger at the rising edge of TMDS Clock (50 percent).

Set the sample rate to > 10 GS/s based on the oscilloscope.

Adjust the vertical scale to accommodate the waveform in six vertical divisions.

4. Perform software clock recovery as follows:
= Set the reference level to 50 percent of the clock and hysteresis to 10 percent of Vswing.
= Calculate the Software CRU filter as follows.

H(s) = 1/(1+st), where t = 40 nsec.
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Test the Cable Eye Diagram

Connect the cable DUT between the TPA-R-TDR and TPA-R-DI adapters.
Measure jitter at TPA-R-DI (the procedure is the same as that for the source eye measurement).
= If the data jitter is greater than 0.67 ns (= 0.5*Tgr at 75 MHz), it implies a Fail.
= Calculate the measurement BOX vertical setting as follows:
= Vc=(VytVL)2 =45 mV

= Test the eye diagram with sink minimum eye mask. If any of the points violate the mask, it
implies Fail.

Adjust the DTG swing voltage to (Vy, Vi) = (3.3 V, 2.9 V) without jitter (clock jitter should remain at
the worst case input condition).

Measure the eye mask on all the TMDS DATA channels at CTP2.

If any of the measured eyes do not meet the sink minimum eye mask, it implies a Fail.

For the DDS Method

In the Cable Equalizer tab, select one of the cable frequencies (74 MHz, 165 MHz, 340 MHz, and 74 MHz
Type-E). When you select the cable frequency:

Appropriate test patterns are loaded.

Relevant cable equalizer is enabled as required.

Worst case TP1/TP5 patterns are loaded.

With the DUT connection, the test is performed depending on the selected data lane (TP2 or TPS).

To configure the parameters for this test, refer eye diagram test procedure (see page 327).

Refer to the make connections for cable eye diagram (see page 180) for information on how to make
connections.

Check the connection of the AWGs and AFG from TDSHT3.

Run the test. The software loads the appropriate patterns with TP1/TP5 waveforms and plots the
eye diagram.

Connect the cable DUT between AWG and oscilloscope.
The software will plot the eye diagram with TP5/TP2 eye mask.

NOTE. Using a manual DDS test method is not recommended because the software performs the Cable
Eye Diagram test automatically and effectively.
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Test the Cable Inter-Pair Skew

This test allows you to confirm that any skew between the differential pairs in the TMDS portion of the
HDMI link does not exceed the limits in the specification.

NOTE. This test is performed only for repeater cable testing.

You will need a supported oscilloscope, two arbitrary waveform generators (AWG7102/AWG7122B), one
arbitrary function generator (AFG3102/AFG3532), two differential probes, one TPA-P, two TPA-R, two
TCA SMA cables, and one accessory kit (consisting of seven matched SMA cable pairs, eight bias-tees,
eight 120 ps TTC filters, three GPIB-HS cables, four BNC cables, and one BNC-T adapter).

1. On the menu bar, click Tests > Cable > Inter-Pair Skew.

2. In the differential tests pane, select the Inter-Pair Skew check box.

File Tests Results Utilities Help TDSHT3 m, X |
Select - Cable

Select " sink C cabe
Differential Tests Test
- Eye Diagram . Inter-Pai i
Configure «

Report—

Connect Summary

Detail

e

Waverorm

Cable -» Cable Inter-Pair Skew(D,D) Clock -> Ch1; Datal -> Ch2; Acgs -» 10k; THit Recalc; Avis-= 100

3. To change the configuration settings, click Tests > Configure. For most tests, you can use the factory
default configuration. However, you can change the values by using the virtual keyboard (see page 24)
or the general purpose knob (see page 26) on the oscilloscope front panel. Using the File menu,
you can also restore the factory defaults or save and recall your own configuration settings. It is
recommended that you save the configuration settings before you choose to select Recall Default or
close the application.
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File Tests Results Ltiliies Help TDSHT3 %| x |
Configure - Cable

g‘lputk nal | Setup
92 Setup DDS Method Test

Test Method

Conigure Data0 DDS Method ¥ e
=
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Ch2

ANG1 AWG2 Report
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Wavefarm MNotC... ™ 24 MHz

Cahle -» Cahle Inter-Pair Skew{D, D Clock -= Ch1; Datal -= Ch2; Acgs -= 10k, Thit: Fecalc; Avgs -= 100

4. In the Signal tab, do the following:
- Select the appropriate test method from the available choices (DTG Method and DDS Method).

NOTE. The DTG method is not supported for the Cable Inter-Pair Skew test.

= In the DDS Method pane, do the following:

= In the Markers pane, select the oscilloscope channel to use for routing the synchronization
pulse from the AWGI. The available choices are: Chl, Ch2, Ch3, and Ch4. The default
value is Ch3.

= Select the oscilloscope channel to use for routing the synchronization pulse from the AWG2.
The available choices are: Chl, Ch2, Ch3, and Ch4. The default value is Ch4.

= Select the cable frequency from the drop-down list.
5. In the Setup tab, do the following:

File Tests Results Ltiliies Help TDSHT3 E| X |
Configure - Cable
BIEC Clock 2 - ; = Test
chi ~ HoriziAeq — Ref Level Units High Ref
# of Acqs 20% 3
Configure Data0 10k LA & — Result
Hysteresis L Mid Ref

Cchz «

Data2

PP NotC.. v ® Detail

Cahle -» Cahle Inter-Pair Skewi{D D Clock -= Ch1; Datal -= Ch2; Acgs -= 10k, Thit: Fecalc; Avgs -= 100

WIEW

Report—
© t Data T:it £ A o 10% .. ; ‘
onnec i ofAvgs ¥
calculate 100 i) 1.
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= In the input pane, do the following:

= Set the Input Clock to the channel that you will use for the HDMI clock input. Select from the
available choices (Ch1l, Ch2, Ch3, and Ch4).

= Set the Input Data0, Datal, and Data2 to the channel that you will use for the corresponding
HDMI data inputs. Select from the available choices (Ch1l, Ch2, Ch3, Ch4, and Not Conn).

= In the horiz/acq pane, enter the desired number of acquisitions that are required for the test. The
range is from 10 K to 1 M and default is 10 K.

= In the tbit pane, do the following:
= Click Re-calculate to recalculate the Tbit value.
= Click Existing Value to use the previously calculated Thbit value.

= Enter the number of averages (periods) that are required for the test. The range is from 2
to 1000 (1 K) and default is 100.

- In the Ref Level Units box, set the reference level units to either Per (%) or Abs.
Per (%) indicates that the reference levels are a percentage of the Vswing value.
Abs indicates that the reference levels are absolute voltage values.

The default setting is Per (%).

= In the Hysteresis box, enter the desired hysteresis percent value. The range is from 0% to 25%
and default is 10%.

- In the High box, the required high reference voltage value is set for the test. The default value is
80%.

= In the Mid box, enter the desired mid reference voltage value. The range is from 25% to 75%
and default is 50%.

= In the Low box, the required low reference voltage value is set for the test. The default value is
20%.

6. To connect the DUT, click Tests > Connect. Click here (see page 185) for information on how
to make connections.

File Tests Results Utilities Help TDSHT3 m, X |

Connect

Follow these instructions to set up the connections. Run
Select Test

Click Moro for dotails. More

Configure

1. Set up the DUT, test fixtures and probes.
J ’ C Report—

Connect 2. Configure and test the signal sources. ,:,' _
WIEW 5 AT i 2 i
3. To view the signal, click View Waveform. Detail
Wyaverorm

Cahle -» Cahle Inter-Pair Skew{D,D) Clock -= Ch1; Datal -» Ch2; Datal -= Ch3; Data2 -= Chd; Acgs -= 10k; Thit: Recalc; Avgs -= 100
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7. Click Run Test to run the test.
NOTE. To synchronize the two AWGs, connect the marker channels to the oscilloscope. Click here (see
page 185) for information on how to make connections.
8. Once the synchronization of the two AWGs completes, the Connect to Cable DUT dialog box appears
as follows:
Connect to Cable DUT
Follow the instructions in this dialog box to make connections to measure inter-pair skew. Click here
(see page 188) for information on how to make connections. The TDSHT3 Software sets up the
oscilloscope and the test runs, displaying a progress indicator.
9. The software makes the results available automatically and displays the result summary. You can also
view the report configuration details in the result pane.
File Tests Results Ltiliies Help TDSHT3 %| x |
Result Summary: Cable Report Configuration
Select Device Details HDM ice B ‘I'?;:t
LAf|5-5 : Cable Inter-Pair Skew : DO - D1
LA|5-5 : Ccablz Inter-Pair Skew : D1 - D2 Resolution 30 -
Configure - - Result
LA|5-5 © Cable Inter-Pair Skew . D2 - DO
Refresh Rate g0HZ Report—
Connect
Report File alica 5
iEw Data Lane -
Wavetorm AUta Increment oetal
Cahle -» Cahle Inter-Pair Skew{D D Clock -= Ch1; Datal -= Ch2; Datal -= Ch3; Data2 -> Chd, Acgs -= 10k; Thit Recalc; Avgs -= 100
The results summary lists the test name, status of the test (pass, fail or error), and jitter plot. To view
the details of the results, click Results Details.
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10. Set the report details to identify and generate the report automatically. You can set a default report file.
Click here (see page 48) for more information.

11. In the result summary pane, click Result Details. The result details pane displays the following fields.

Result Details

Test Name

5-5: Cable Inter-Pair Skew : DO - D1 Skew < 0.18*TPixel,

5-5: Cable Inter-Pair Skew: D1 - D2 [Skew < 0.18*TPixel;

Skew < 0.18*TPixel;

5-5: Cable Inter-Pair Skew : D2 - DO

- Test Name (displays the test id, test name, and selected lanes)

= Spec Range (displays the HDMI standards and test specifications limit for the test)
= Meas Value (displays the measured value)
= Result (displays the status of the test as Pass, Fail, or Error)

= Remarks/Comments (displays the relevant details, such as Tbit, Vswing, and Margin. If the test
could not be run, this field displays an error code (see page 357).
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Test Method

NOTE. This test is performed only for repeater cable testing.

®  To configure the parameters for this test, refer cable inter-pair skew procedure (see page 339).

m  Refer to the connection diagram for synchronizing (see page 185) for information on how to make
connections.

m  Check the connection of the AWGs and AFG from TDSHTS3.
B Run the test. The software loads the patterns on both the AWGs.

B Once the synchronization of both the AWGs is done, remove the marker channels from the
oscilloscope.

B Connect the Input Data0 and Data2 to the oscilloscope to calculate inter-pair skew. Click here (see
page 188) for information on how to make connections.

B Run the test to calculate inter-pair skew.

NOTE. Using a manual DDS test method is not recommended because the software performs the Cable
Inter-Pair Skew test automatically and effectively.
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Software CRU Technology

The HDMI specification mandates the Clock Recovery Unit (CRU) by using a Phase Locked Loop
(PLL) with first order transfer function characteristics, to test both the jitter and the eye diagram. A
PLL-based CRU implemented in hardware makes correlation of test results difficult due to differences in
vendor-specific implementations. Software PLL techniques can extract clock and timing data from a serial
data stream. The following method shows a practical and affordable way to satisfy the requirement:

PLL Characteristics

¢ Ol

kp

Divider
/N

(ris) = Ci'in

In )| (i('s) y Out

The diagram shows a simplified block diagram of generic phase-locked loop (PLL). A PLL consists of
the Phase Detector (PD), Low Pass Filter (LPF), Voltage Controlled Oscillator (VCO), and Frequency
Divider (FD).

The phase of the input signal is compared to the phase of FD output. The input of the FD is the output
of VCO, whose frequency is controlled by the LPF output. The LPF output is a filtered form of the PD
output. When the phase of FD output is leading compared to the input phase, the PD output changes to
decrease the VCO frequency. Thus, the FD output will lag. Due to the effect of this feedback mechanism,
the frequency of VCO is locked to N-times of the input frequency.
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The LPF restricts the quick variation of the incoming signal, so that high frequency changes in the input
phase are attenuated before they are transferred to consecutive functional blocks. Therefore, the VCO
output represents the average phase of input signal even if the input signal does not have the constant
phase rotation (frequency). Using this approach, the PLL circuitry recovers the clock information from
the modulated input signal.

The transfer function from the input phase to the output phase is represented by following equation:

Jl\:.n Ky a'lj'l[.\':'
- ) -\\ . hlf)" f.\\ |lr!.'l:.,!‘.+

N
\

(ils)=

§-

where Kp and Kv are the sensitivity coefficients of PD and VCO respectively, and N is the division factor
of FD. H(s) is the transfer function of LPF in the frequency domain.

Assuming that N, Kp, and Kv are constant, the function G(s) can be simplified as follows:

K, H(s)

Crls)= -
s+ K,-H(s)

Note that G(s) becomes the first order low-pass filter only when H(s) is constant, namely, when H(s) is
non-dependent on the frequency. This means that H(s) is not a low- pass filter in this case. On the contrary,
it is well known that the PLL is not stable without a low-pass filter in place of H(s). Therefore, the first
order transfer function that is required by CRU for HDMI may not be realized by the PLL circuitry as
shown in the earlier PLL Functional Block diagram.

Conventional Method

Weie) X{t):Raw TIE ¥it) : Recovered TIE
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The diagram shows a simple PLL design for CRU, measuring both the clock jitter and eye diagram within
a digital oscilloscope. The input signal is first converted to digital information with an A/D converter. The
phase of the input signal is extracted by finding the rising (or falling) edges of the digitized signal. A digital
simulation of an actual hardware PLL circuit may be realized because the input and output signals exist as
just digital information. In this case, the voltage values at several points in the PLL circuit are expressed in
the time domain, and are repetitively calculated to derive their time variation. The time interval of the
calculation must be sufficiently small to retain the high precision of the simulation. Hence, it requires
significant digital processing capability to simulate actual PLL within a reasonable amount of time.

In this method, the phase transfer function of the PLL is determined by the characteristics of the simulated
components. As long as the simulation observes the laws of physics, the resultant transfer function

does not differ from that of the actual hardware PLL circuit. Given the time to process the data in the
simulation, using this method is not advisable. The first order transfer function to be realized by this
method may not be useful either.

Another method to simulate a PLL in software is to use its time domain transfer function from the input
phase error to output timing information. The impulse response is used as the time domain transfer
function. In this case, given the input signal X(t), the integral operation shown next gives the output
signal Y(t).

x

Y(t)= [X(1)-G@ —t)dr

-

T ==

where G(t) is the time domain representation of G(s) mentioned in the previous section. This is called a
convolution integral. In this case, the input signal is represented as discrete-time samples. The integration
shown earlier should also be performed in discrete fashion as follows:

vin) = E g(m)-x(n—m)= Yg{t 1n—m)-x(m)
RP=—0 R=—1

There are two disadvantages in the time domain convolution method. One is that it still requires a huge
number of multiplications and additions to calculate the values of all time points, as easily seen from
the form of the equation above. Another is that it is not always practical to express the time domain
transfer function as an explicit mathematical representation. In many cases, the human interpretation of
the transfer function is made in frequency domain. Some means of conversion is required to derive the
time domain response from the frequency domain characteristics. This requirement will complicate the
design of the user interface.

It is important to mention that the first order transfer function characteristics can be realized by this
convolution method, even though it has the difficulties described earlier. This method is inherently stable
as far as an appropriate impulse response is adopted, because it does not include a feedback loop.
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Proposed Method
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The PLL circuitry acts as a low-pass filter for incoming time information. In the frequency domain,
the filter function is simply realized by multiplying of the frequency response coefficients to the input
spectrum. The convolution integral in the time domain is equivalent to simple multiplication between
frequency-domain functions derived by the Fourier Transform. If the time information and the PLL
characteristics are transformed to frequency domain, the PLL processing becomes much easier than in
the time domain.

Gis)

L &

Y(s)=G(s)- X(8)

As seen in this equation, the calculation becomes one multiplication (though between complex numbers)
per sample point. Hence, the demand for digital processing performance is very low.

After the filter function is performed, the time information of the output signal may be derived with
inverse transformation. Using an FFT algorithm, the forward and inverse transformation can be executed
in relatively short time compared to simulation in time domain. Thus, the total time to calculate the
recovered clock can be significantly reduced.

Jitter Test

The jitter of the incoming clock signal is measured by statistically analyzing the time difference between
the incoming and recovered clocks. The timing information of both signals is already retained in digital
form, so the jitter calculation is simple and straightforward. Usually, the peak-to-peak jitter value and the
standard deviation ( RMS) jitter value are used for evaluating the signal quality.

Jpp = AT max— AT min

¥ (A7, - AT
N

Jo
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Appropriate sample points should be chosen to measure the jitter for specific cases such as the
clock-to-data jitter at the first bit. Such a requirement is addressed by specifying a rectangular area with
time range of [-T..+T] and voltage range of [-V..+V].

To obtain an accurate test, a large number of samples are required. As the earlier area restriction reduces
the number of measured samples, the capability to process more and more samples is desired. Using
the proposed method, it becomes realistic to gather a huge amount of statistical information for a more
precise test.

Eye Diagram

An eye diagram is the incoming data waveform repeatedly drawn with the recovered clock used as the time
reference. The recovered clock is represented as time information. It may be used to derive the position
where the input data waveform should be drawn. The resulting diagram will precisely indicate the true
marginal area with which the reliability of data transmission is determined.

The vertical coordinate to draw the incoming waveform is determined by using the data value itself.
Determine the horizontal coordinate (x) by the following equation:

Xeoord=Tn—Tref

where Tn is the time of incoming waveform, and Tref is the time of the reference signal (the recovered
clock signal).

TDSHT3 HDMI Compliance Test Software Online Help 349



Measurement Algorithms Software CRU Technology

350 TDSHT3 HDMI Compliance Test Software Online Help



HTML/MHT Reports About HTML/MHT Reports

About HTML/MHT Reports

HTML/MHT Reports enhance the TDSHT3 Software capabilities by simplifying the process of creating
and maintaining results. It automates the process of compiling the test results and generating the reports.
The application generates an MHT file that can be opened in Internet Explorer.

Reports Formats

The generated reports (see page 352) are in .mht format and include the following configured set of
information:

m  Configuration: This section includes the following:
= Setup Configuration such as the oscilloscope information and application version.
- Device Configuration such as Device Details, Resolution, and Refresh Rate.
= Compliance Summary such as the total tests performed and Pass/Fail status.

B Test Summary: This section displays the Test Name, Lanes, Specification Range, Measurement
Value, and Results.

B Detailed Results: This section includes the following:

= Results such as Specification Range, Measurement Value, Tbit, Vswing, Margin, Record length,
Mask Hits, and Results.

= Waveform/Plot such as selected plots and/or oscilloscope waveforms.
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Sample Report

A sample report is as follows:

HDMI Compliance Test Software: Measurement Report

A Apr 01 131126 15T 2009
Cable Tests Report

+ Configuration

+ Setup Configuration
Oscilloscope Info DPOY0804 - 4.3.0 Build 95
TDSHT3v1-3 Version 5.0.0 Build 15

+ Device Configuration
Device Details HOMI Device
Clock Frequency(Mhz) 74253
Resolution
Refresh Rate

+ Compliance Summary

Total Tests (for all data lanes)
Tests Completed

Pass

Fail

SRS

b Test Summary

Index Test Hame Lanes Spec Range Meas Value | Result

1 5-3: Cahble Eye Diagram TP | CK -DO | TP1 Data Jiter < 0.3 Thit, 0.29°Thit
2 5-3: Cable Eye Diagram TPS | CK - DO | TPS Data Jiter = 0.35*Thit; 0 35*Thit
3 5-3: Cable Eve Disgram TPS | CK - D1 | TPS Data Jitter =< 0.38*Thit, 0.34*Thit
4 5-3: Cahble Eve Diagram TPS | CK - D2 | TPS Data Jiter =< 0.38°Thit, 034 Thit

+ Detailed Results

+ 5.3 : Cable Eye Diagram TP1: CK - DO

+ Results
Spec Range | Meas Value \ Thit | Vs | Margin | Record Length | Mask Hits \ Result \
| TP1 Data Jiter = 0.3*Thit, | 0.29°Thit | 1.3468ns | 789.12my | 0.01*Thit | 25000M | 0 | |

+ WaveformPlot

Cable TP1 Data Eye Diagram : CK - DO

875m
Results
Mask Test m
Mask Hits 0
< Vswing 793.60mY
<
@
> Thit 13468ns
S
Data Jitter 396ps
. Bl Mask
-875m _IFail

0.0 =+ Time(s) 2.69n

« Return to Test Summary
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+ 5.3 Cable Eye Diagram TP5 : CK - DD

+ Results
[ Spec Range [Meas value | Thit | Vs | Margin | Record Length | Mask Hits | Result |
| TP5 Data Jiter = 0.38*Thit, | 0.35'Thit | 1.3968ns | 793.60mY | 003 Tkt | 25.000M | 0 |

+ Waveform/Plot

Cable TP5 Data Eye Diagram : CK - DO
875m 3 ‘ ]
Results
Mask Test m
Mask Hits 0
< Vswing 793.60mY
;i’ Thit 1.3468ns
o
> Data Jitter 466ps
1
-875m e
= Time(s)

+ Return to Test Summary

+ 5-3: Cable Eye Diagram TP5 : CK - D1

+ Results
| Spec Range \ Meas Value \ Thit | Vs | Margin \ Record Length | Mask Hits | Result |
| TP5 Data Jiter < 0.38°Thit, | 0.34°Thit | 1.3468ns | 787.92mv | 004°Tkit | 25000M | i | |

+ Waveform/Plot

Cable TP5 Data Eye Diagram : CK - D1
875m S 3 :

Results

Mask Test m

Mask Hits 0

Vswing 787.92mV

Thit 1.3468ns

Data Jitter  461ps

« Return to Test Summany

+ 5.3 : Cable Eye Diagram TP5 : CK - D2

+ Results
[ Spet Range: [Measvalue | Tbit | Vs | Margin | Record Length | Mask Hits | Result |
| TPS Data Jiter = 0.38*Thit, | 0.34*Thit | 1.3968ns | 785.40mY | 0.04°Tkit | 25.000M | ] | |

+ Waveform/Plot

Cable TP5 Data Eye Diagram : CK - D2
875m : : :

Results

Mask Test m

Mask Hits 0

Vswing 788.40mY

Thit 1.3468ns

Data Jitter 452ps

-+ \oltage(V)

-875m

0.0 =+ Time(s)

+ Return to Test Summary

+ Return to top
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Default Settings

Parameter

Selection

Default Settings

Default setting

Select

Flow Controls

Select

Device Type Tab

Source (Differential Tests)

Source Test Eye Diagram
Sink Test Min/Max-Diff Swing Tolerance
(Differential)
Cable Test Eye Diagram
Source Configuration Clock Input Ch1
Data0 Input Ch2
Data1 Input Ch3
Data2 Input Chd
CRU Clock PLL
Others Ref Level Units Percentage
Sink Configuration DTG file path C:\TekApplications\TD-

SHT3v1-3\ComplianceTest-
Patterns\ PC\1920x1080i
50Hz 8 Bit Gray RGB PC
v3-3.dtg

Clock output from DTG A1
Data0 output from DTG B1
Data1 output from DTG B2
Data2 output from DTG C1
Signal Sources Signal Sources Tab DTG

AWG Unavailable
AFG Unavailable

Control Type GPIB
Board Type GPIBO
GPIB Address (Primary) 1
GPIB Address (Secondary) 0

View Waveform Clock/Data Waveforms

Result Summary View Jitter Plot Unavailable
View Eye Plot Unavailable
Data Lane Unavailable
Test Point Unavailable

Result Details View Jitter Plot Unavailable
View Eye Plot Unavailable
Result Statistics Unavailable
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Parameter

Selection

Default Settings

Default setting

Deskew

External

From Input Setup - Input - Ch1

From Input Setup - Hysteresis - 10%

From Input Setup - Ref Level - 50%

To Input Setup - Input - Ch2

To Input Setup - Hysteresis - 10%

To Input Setup - Ref Level - 50%

Slope - Rise

Slope - # of Slopes - 1

Internal

From Input Setup - Input - Ch1

To Input Setup - Input - Ch2

Slope - Rise
Report Configuration pane Device Details HDMI Device
Resolution 1920*1080i
Refresh Rate 60 Hz
Report File Disabled
Auto Increment Selected
Save As Disabled
Clear Report Enabled
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Error Codes

The following table lists the error codes, their descriptions, and the possible solutions:

Error code Error message Description Possible solution

101 Input is “Not Conn.” Both the selected sources are not Select valid channels (Ch1-Ch2,
connected. Ref1-Ref2) for at least clock/data

source/data source (differential
tests) or for input1/input2
(single-ended tests).
102 Conflict in the selection The sources that are selected Select different channel sources
of inputs. for the two inputs are the same. for input 1 and input 2 for
The inputs clock source and data single-ended tests and different
source for differential tests, input 1 channel sources for clock source
and input 2 for single-ended tests. and data source for differential
tests.

103 The combination of Ref The software supports both Ref Select both ref channels or both
and Live input signals is or both Live combinations of live channels for clock and data
not valid. channels. source.

104 Ref Wfm is not valid. The software cannot switch on ref Recall the required ref waveform
waveforms. Ref waveforms could from the appropriate file on the
be empty. oscilloscope.

105 Conflict in GPIB There is a conflict in the selection Ensure that no two GPIB

Selection. of GPIB address. One or more addresses are identical.
addresses are repeated.

106 Conflict in the selection There is a conflict in the selection Ensure that the combination of
of input types. of the inputs. One or more inputs the selected inputs are unique.

are repeated.

107 Four channel feature The four channel feature is not Reduce the number of channels
is supported only on supported in the oscilloscope. to two and proceed.
DPO/DSA70000/B
series oscilloscopes
with bandwidths greater
than or equal to 8 GHz.

110 Unable to acquire The oscilloscope is not able to Ensure that the software
waveform. acquire the signal and trigger. configurations are proper. Check

the probes and test fixture
connections. If the test uses
serial trigger, ensure that the
CTL pattern is present on the
waveform.

1M1 Not enough acquisitions The software expects to acquire a Ensure that the software

to perform the test.

minimum number of acquisitions
that are configured.

configurations are proper. Check
the probes and test fixture
connections.
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Error code Error message Description Possible solution
13 Error in importing the The software could not import Check the probes and test fixture
Wim. the waveform from acquisition. connections. Run the test again.
This happens when there is no
valid waveform in the acquisition
memory.
114 Improper Wfm. Signal is not probed at the proper Refer to the connections diagram
test points. and probe the proper signal.
115 Ref Wfms have different The ref waveforms have different Use waveforms that are acquired
Record Lengths/Sample sample rates and/or record simultaneously for ref waveforms.
Rates. lengths.
121 Ref Levels entered are Unable to locate the edges on Enter the Ref Level voltage value
outside the range of the the waveform at the transition where the transition occurs on
Wfm. because the levels configured do the waveform. Enter 50 percent
not fall within the transition of the of the level of the peak-to-peak
waveform. transition level for mid-ref levels,
80 percent of the peak-to-peak
for high-ref levels, and 20 percent
of the peak-to-peak for low ref
levels.
122 ((Hysteresis Level/2) ((Hysteresis Level/2) + Ref Level) Set both the ref and (Hysteresis
+ Ref Level) cannot has to be within 100 percent for Level/2) to be less than 100
be greater than 100 edge finding. percent.
percent.
123 High Level is less than The configured high level value is Configure the high level to be
or equal to Low Level. less than the low level value. greater than the low level.
131 Error in calculating Thit. Not a valid clock waveform. Supply a valid clock waveform
and run the test again.
132 Clock input is required The Tbit value has to be calculated 1. Select and run a test that
to calculate Thit. before you run a test that uses uses clock source for Thit
only data source(s). value.
2. Click Connect, select clock
source, and then click
Re-calculate Tbit before you
run the test.
152 Select any test to Configure, Connect, View Select at least one test before you
continue. Waveform, and Run Test need at click either Configure, Connect,
least one test to be selected. View Waveform, or Run Test.
161 Unable to recover clock. Improper waveform or the Supply the proper waveform.
software components are missing. Reinstall the software.
171 Unable to find edges. The waveform may be noisy or Check the probes and test
the hysteresis level may be low. fixture connections. Increase the
hysteresis band level.
172 Not enough edges. Number of edges found on Decrease the horizontal scale to

the waveform is less than the
minimum number of edges that is
required for the test.

have more complete cycles of the
waveform. Adjust the hysteresis
level of the signal to find the edge
at the required level.

358
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173 Unable to calculate Could not find the mid of the Check the probes and test fixture
skew. waveform. connections.
174 CTL pattern not found. The CTL pattern (see page 233) Ensure that the appropriate
was not found on the waveform. pattern is present on the source
waveform. Change the polarity of
the waveform.
175 Option ST is not installed Option ST is not available on the Install Option ST.
on the oscilloscope. oscilloscope.
178 Unable to calculate Signal is not probed at the proper Follow the instructions in the
Vswing. test points. setup diagram and probe the
proper signal.
181 Check the DTG DTG connection has failed. This = Switch on the DTG and wait
connection. could happen if: for the DTG software to load.
®  The DTG is not switched on. = Check GPIB connections.
B There is a mismatch in the B Ensure that the primary and
GPIB-ENET configuration, secondary addresses of DTG
software GPIB configuration, in the remote control match
or DTG remote control the GPIB-ENET configuration
configuration. of the oscilloscope.
®m The GPIB cable is not ®m  Ensure that the GPIB-ENET
connected properly. configuration on your
oscilloscope matches the
signal sources configuration
in the software.
182 File not found in the The configured file is not found in Ensure that the specified file in
DTG. the DTG. the software is present in the
DTG. Specify a file name that is
present in the DTG.
183 Invalid logical channel. The logical channel is invalid. Provide a proper logical channel.
184 Conflict in selection of The same physical channel (A1, Select different physical channels
outputs from the DTG. A2, B1, B2, C1, C2, D1, D2) (A1, A2, B1,B2, C1, C2,D1,D2)
is selected for any two logical for a given logical channel (Clock,
channels (Clock, Data0, Dataf, Data0, Data1, Data2).
Data2).
191 Check the AWG AWG connection has failed. This Switch on the AWG and wait for

connection.

could happen if:
= The AWG is not switched on.

®  There is a mismatch
in the GPIB-ENET
configuration, application
GPIB configuration, and AWG
remote control configuration.

B The GPIB cable is not
connected properly.

the AWG software to load. Check
GPIB connections. Ensure
that the primary address of
AWG in the Utility > Network
> Address matches with the
GPIB-ENET configuration of the
oscilloscope. Ensure that the
GPIB-ENET configuration on
your oscilloscope matches the
signal sources configuration in
the software.
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Error code Error message Description Possible solution
192 File not found in the File is not present in the AWG. Ensure that the required file is
AWG. present in the AWG.
193 Check the Signal Signal sources connection has For the DTG connection failure:
Sources connection. failed. It may be due to DTG or ] )
AWG connection failure. DTG = Switch on the DTG and wait
connection has failed. This could for the DTG software to load.
happen if: ®m  Check the GPIB connections.
m The DTG is not switched on. = Ensure that the primary
= There is a mismatch in the address of DTG in the
GPIB-ENET configuration, remote control mgtcheg the
software GPIB configuration, GPIB-ENET configuration of
and DTG remote control the oscilloscope.
configuration. = Ensure that the GPIB-ENET
= If the GPIB cable is not configuration on your
connected properly. oscilloscope matches the
. . . signal sources configuration
AWG connectpn has failed. This in the software.
could happen if: _ _

For AWG connection failure:

m  The AWG is not switched on. ) )

m  Switch on the AWG and wait

®  There is a mismatch in the for the AWG software to load.
GPIB-ENET configuration, )
software GPIB configuration, m  Check the GPIB connections.
andflAWG.remote control = Ensure that the primary
configuration. address of AWG in

= If the GPIB cable is not the Utility > Network >
connected properly. Address matches with the

GPIB-ENET configuration of

= Primary addresses of DTG the oscilloscope.
and AWG are same.

B Ensure that the GPIB-ENET
configuration on your
oscilloscope and signal
sources configuration in the
software match.

Select distinct primary addresses

for the DTG and AWG.

194 Jitter value is Signal is not probed at the proper Follow the instructions in the
unavailable. test points. setup diagram and probe the
proper signal.
196 Invalid DUT frequency. The frequency of the DUT Load the required pattern on the

configured in Configure > Setup >
DUT Freq (MHz) does not match
with the frequency of the signal
generated from the DTG.

DTG and check the frequency of
the signal. Ensure that the same
frequency has been configured in
the DUT Freq (MHz).
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Error code Error message Description Possible solution

201 Edges on the Wfm Deskew number of edges set by Ensure that the edges in the
are lesser than the the user to perform the deskew is waveform and the display
configured number of not available on the waveform. in the numeric input are the
edges. same. Adjust the horizontal

scale to increase the number
of transitions that is required to
adjust the deskew.

202 Calculated skew is The calculated skew value is The deskew will be done to the
greater than the greater than the oscilloscope maximum deskew value that is
oscilloscope skew deskew range. applicable to the oscilloscope.
range.

203 Cycle has less than Insufficient number of samples in Increase the sampling rate.

20 sample points. a complete cycle. The number of
data points in the identified cycle
is less than 20.

21 Select the test point(s) No test points are selected. Select any one or both of the test
to continue. points in cable configuration.

221 Mask cannot be moved Upper and lower masks have Change the Mask Movement
beyond this position. exceeded their boundary values. mode from Coarse to Fine. After

The mask co-ordinates are changing to Fine, you will be able

beyond the plottable area. to move a bit further. If you are
already in Fine mode, and this
message appears, you are in
the maximum/minimum possible
position.

222 Unable to calculate An error occurred while calculating The signal may be wrong (noise,

mask margins.

the mask margins.

invalid pattern). Connection

to the probe tip may be loose.
Recheck the connection and run
the test again.
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Error Codes

Error code Error message Description Possible solution

251 Check the AFG Connection to AFG has failed. Perform the following:
connection. This could happen if: ) )

= Switch on the AFG and wait
= The AFG is not switched on. for the AFG software to load.
E  There is a mismatch in the E  Check the GPIB connections.
GPIB-ENET configuration, )
software GPIB configuration, " Ensure that the primary
and AFG remote control address of AFG in the
configuration. remote control matches the
GPIB-ENET configuration of
= [f the GPIB cable is not the oscilloscope.
connected properly.
m  Ensure that the GPIB-ENET
B Primary addresses of the configuration on your
signal sources are same. oscilloscope matches the
signal sources configuration
in the software.
B Select distinct primary
addresses for the signal
Sources.

252 Four DTGM30 modules An error occurs when any of the Connect four DTGM30 modules
are required to run this four connected modules is not to the DTG and run the test.
measurement. DTGM30.

401 AWG pattern directory The required directory is not Reinstall the AWG pattern files.
not found. present in the AWG.

402 Unable to turn on the Invalid/missing external clock. Ensure that the correct external
AWG output due to clock is connected before turning
invalid external input ON the outputs.
clock. Connect the
external clock and
turn ON the outputs to
proceed.

412 Unable to calibrate. The Calibration has failed. This could Perform the following:
measured jitter value is happen if:
high. B Check the cable and test

®  The cable and test fixture fixture connections.
connections are not correct.
B Reinstall the base pattern.
E  Base pattern on which the
calibration is performed is not
correct.
413 Unable to calibrate. The Calibration has failed. This could Perform the following:

measured jitter value is
zero.

happen if:

B The cable and test fixture
connections are not correct.

B Base pattern on which the
calibration is performed is not
correct.

m  Check the cable and test
fixture connections.

B Reinstall the base pattern.
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Symbols and Numbers

3D Video
Configure, 302
Connect, 304
Connect sink device, 306
DTG output, 303
GPIB, 305
Input, 302
Report configuration, 307
Result details, 307
Result Summary, 306
Select, 302
Setup, 303
Signal sources for DDS
method, 304
Test Conn, 305
4-channel feature, 10
4kx2K Video
Input, 308
4Kx2K Video
Configure, 308
Connect, 310
Connect sink device, 312
DTG output, 309
GPIB, 311
Report configuration, 312
Result details, 312
Result Summary, 312
Select, 308
Setup, 308
Signal sources for DDS
method, 310
Test Conn, 311

A

Acquisition Alert Message, 22
Audio Clock Regeneration
Configure, 274
Connect, 276
Connect sink device, 277
DTG output, 274
GPIB, 276
Input, 274

Report configuration, 278
Result details, 278
Result Summary, 277
Setup, 274
Signal sources for DDS
method, 276
Test Conn, 276
Audio Formats
Configure, 285
Connect, 287
Connect sink device, 288
DTG output, 285
GPIB, 287
Report configuration, 289
Result details, 289
Result Summary, 288
Select, 285
Setup, 285
Signal sources for DDS
method, 287
Test Conn, 287
Audio Sample Packet Jitter
Configure, 280
Connect, 281
Connect sink device, 282
DTG output, 280
GPIB, 282
Input, 280
Report configuration, 283
Result details, 283
Result Summary, 283
Select, 279
Setup, 280
Signal sources for DDS
method, 281
Test Conn, 282
Automation Explorer, 33

C

Cable, 27
Differential tests, 51
Eye Diagram, 51
Differential Tests, 1
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Cable Eye Diagram

Cable equalizer, 331
Configure, 327
Connect, 332
DDS method, 330
DTG method, 329
GPIB, 333
Input, 328
Report configuration, 334
Result, 334
Result details, 334
Result statistics, 336
Rise time filter, 332
Select, 327
Setup, 328
Signal sources, 333
Test conn, 333
Test points
DDS method, 328
DDS method with
Type-E, 328
DTG method, 328

Cable Inter-Pair Skew

Configure, 339
Connect, 341
Horiz/Acq, 341
Input, 341
Reference levels, 341
Report configuration, 343
Result, 342

Result details, 343
Select, 339

Setup, 340

Signal, 340

Tbit, 341

Clock Jitter

Configure, 222

Connect, 222

CRU, 222

Horiz/acq, 222

Input, 222

Reference levels, 222
Report configuration, 227
Result, 223
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Result details, 227
Result statistics, 227
Result summary, 226
Select, 221
Configure, 20
Cable, 58
DTG pattern list, 45
Sink, 53
Source, 52
Connect
Cable
Eye Diagram, 172
Eye Diagram,
4-channel, 179
Eye Diagram, 4-channel
with AFG jitter
insertion, 180
Sink
Cable Eye Diagram for
DDS method, 184
Cable Eye Diagram
for DDS method,
Type-E, 183
Cable Inter-Pair Skew for
DDS method, 185
Deep Color for DDS
method, 130
Intra-Pair Skew, 158
Intra-Pair Skew for DDS
method, 164
Jitter Tolerance for DDS
method, 125
Jitter Tolerance for DDS
method to calibrate
the jitter values, 129
Jitter Tolerance for DDS
method, Type-E, 128
Jitter Tolerance for DTG
method, 115
Min/Max differential
swing for DDS
method, 111
Min/Max-Diff Swing
Tolerance, 105
Sink Intra-Pair Skew
Skew on all channels, 170
To measure Thit, 164

364

Source, 59
Clock litter, 74
Differential Tests Select
All, 83
Differential Tests Select
All, 4-channel, 86
Duty Cycle, 64
Eye Diagram, 61
Eye Diagram,
4-channel, 63
Fall Time, 70
Fall Time, 4-channel, 73
Inter-Pair Skew, 77
Inter-Pair Skew,
4-channel, 82
Intra-Pair Skew, 87
Intra-Pair Skew,
4-channel, 92
Low Amplitude +, 93
Low Amplitude -, 99
Low Amplitude +,
4-channel, 98
Low Amplitude -,
4-channel, 104
Rise Time, 67
Rise Time, 4-channel, 69
Connectivity, 9
CRU, 355
CTL patterns, 233
10-bit, 233
20-bit, 233

D

Deep Color

Configure, 268

Connect, 269

Connect sink device for DDS
method, 271

GPIB, 270

Input, 269

Report configuration, 272

Result details, 272

Result Summary, 271

Select, 268

Setup, 269

Signal sources for DDS
method, 270

Test Conn, 270
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Deskew, 356
Differential Tests Select All
Configure, 234
Connect, 236
CRU, 236
Horiz/acq, 235
Input, 235
Reference levels, 236
Report configuration, 237
Result details, 237
Result statistics, 237
Results, 236
Select, 234
View waveform, 236
DTG, 172
Duty Cycle, 41
Configure, 209
Connect, 209
Horiz/acq, 209
Input, 209
Report configuration, 210
Result details, 211
Result summary, 210
Select, 208
Tbit, 209
View waveform, 210
DVI Interoperability
Configure, 296
Connect, 298
Connect sink device, 300
DTG output, 297
GPIB, 299
Input, 296
Report configuration, 301
Result details, 301
Result Summary, 300
Select, 296
Setup, 297
Signal sources for DDS
method, 298
Test Conn, 299

E

Error codes, 357
Configure, 357
Deskew, 357
DTG, 357
GPIB, 357



Hysteresis, 357
Mask Movement, 357
Option ST, 357
Signal Sources, 357
Tbit, 357
View Waveform, 357
Error Message, 357
Ethernet, 33
GPIB-ENET/100, 33
Execution pane, 24
Existing Tbit, 99
Exit, 19
Extended Colors and Contents
Configure, 314
Connect, 316
Connect sink device, 317
DTG output, 314
GPIB, 316
Input, 315
Report configuration, 318
Result details, 318
Result Summary, 317
Select, 314
Setup, 314
Signal sources for DDS
method, 316
Test Conn, 316
External, 44
Eye Diagram, 207

F

Fail, 301
Fall time
Result details, 219
Fall Time, 41
Configure, 217
Connect, 218
Horiz/acq, 217
Input, 217
Reference level, 218
Report configuration, 219
Result, 218
Result statistics, 219
Select, 217
Thit, 218
View waveform, 218
Features, 2
Field, 17

File Names, 14
Find, 220
Fine button, 26

G

General Purpose Knob, 26
GPIB, 27

H
HDMI, 295
Help, 21

High Definition Multimedia

Interface, 1
HTML/MHT Reports, 351
Hysteresis, 44

Input, 345
Install, 27
Measurement, 27
Install NI-488.2, 27
Windows, 27
Instruments, 27
Scan, 27
Inter-Pair Skew, 41
Differential Tests, 41
Interfaces, 33
GPIB, 27
Interfaces list, 33
Internal, 44
Intra-Pair Skew, 41
Invalid Signal, 9

J

Jitter calibration, 256

Jitter Tolerance, 27
AWG output, 260
Configure, 257
Connect, 260

Connect sink device for DDS

method, 263

Connect sink device for DTG

method, 263
DDS method, 259
DTG method, 258
DTG output, 259
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GPIB, 262

Input, 257

Input for DDS method, 258

Input for DTG method, 257

Report configuration, 265

Result details, 265

Result for DDS method, 264

Result for DTG method, 264

Select, 257

Setup, 258

Signal sources for DDS
method, 261

Signal sources for DTG
method, 261

Test Conn, 262

L

Low Amplitude, 41

Low Amplitude +
Configure, 242
Connect, 243
Horiz/acq, 243
Input, 243
Report configuration, 244
Result, 244
Result details, 244
Select, 242
Thit, 243
View waveform, 244
Voltage, 243

Low Amplitude -
Configure, 246
Connect, 247
Horiz/acq, 246
Input, 246
Result details, 247
Results, 247
Select, 245
Tbit, 246
View waveform, 247
Voltage, 246

Low Pass Filter, 345

MATLAB Runtime, 9
Max, 50
Mean, 50
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Meas Value, 49

Menu bar, 17

Min, 50

Min/Max-Diff Swing
Tolerance, 355
Configure, 249
Connect, 251
DDS method, 249
DTG method, 249
Report configuration, 253
Result, 253
Result details, 253
Select, 249
Signal sources, 252
Test Conn, 248

N

National Instruments, 33
NI-488.2, 27
NI-VISA, 27

0]

One Bit Audio
Configure, 290
Connect, 292
Connect sink device, 294
DTG output, 291
GPIB, 293
Input, 290
Report configuration, 295
Result details, 295
Result Summary, 294
Select, 290
Setup, 291
Signal sources for DDS
method, 292
Test Conn, 293
Ordering fixtures, 8
Over/Undershoot V-H, 41
Over/Undershoot V-L, 41

P

Pass, 207
Phase Detector, 345
Phase Locked Loop, 345

Pinging, 33
Pk-Pk, 50
366

Plug, 33

Population, 49
Position Eye Mask, 22
Preferences, 19
Primary Address, 27
Probe Control, 22
Properties, 33

Pulse Width, 22

Q

Query, 39

Query Form, 39

Quit, 14
Software, 14

R

Re-calculate, 41
Recall, 19
Recommended Accessories, 7
Ref Level Units, 355
Remarks/Comments, 49
Remote GPIB Commands, 39
Report Configuration, 47
Auto Increment, 48
Clear Report, 48
Device Details, 48
Refresh Rate, 48
Report File, 48
Resolution, 48
Save As, 48
Report Generator, 21
Report Viewer, 24
Reports
formats, 351
Requirements, 9
Restore Application, 10
Result Details, 355
Result Statistics, 49
View Eye Plot, 49
View litter Plot, 49
Result pane, 47
Result Statistics, 355
Result Summary, 47
Data Lane, 47
Result Details, 47
View Eye Plot, 47
View lJitter Plot, 47
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Results menu, 20
Return, 13
Rise Time, 41
Configure, 213
Connect, 214
Horiz/acq, 213
Input, 213
Reference levels, 213
Report configuration, 214
Result, 214
Result details, 214
Result statistics, 215
Select, 212
Thit, 213
View waveform, 214
Rise/Fall Time, 19

S

Sample report, 352
Save/Recall, 39
Scroll bar, 17
Secondary Address, 27
Select
Cable, 23
Sink, 51
Source, 50
Select Pulse Width, 22
Selection pane, 23
Configure, 23
Connect, 23
View waveform, 23
Shortcut Keys
set probe control to
internal, 15
Signal Sources, 27
Sink, 20
Differential tests, 51
Jitter Tolerance, 51
Min/Max-Diff Swing
Tolerance, 51
Differential Tests, 1
Min/Max-Diff Swing
Tolerance, 248
Single-Ended tests, 51
Intra-Pair Skew, 51
Single-Ended Tests, 1
Sink Configuration, 355



Sink Intra-Pair Skew
Configure, 320
Connect, 322
DDS method, 321
DTG method, 321
GPIB, 319
Input, 320
Report configuration, 324
Result, 323
Result details, 324
Select, 319
Signal sources, 322
Skew Configuration, 320
Tbit, 320

Software CRU Technology, 345

Software Folders, 14
Source, 20
Differential tests, 50
Clock Jitter, 50
Duty Cycle, 50
Eye Diagram, 50
Fall Time, 50
Inter-Pair Skew, 50
Rise Time, 50
Differential Tests, 1
Duty Cycle, 208
Eye Diagram, 202
Single-Ended tests, 50
Intra-Pair Skew, 50
Low Amplitude—, 50
Low Amplitude+, 50
Single-Ended Tests, 1
Source Configuration, 355
Source DUT, 74
Source Eye Diagram
Configure, 202
Connect, 203
CRU, 203
Horz/acq, 203
Hysteresis, 202
Input, 203
Rec Length, 202
Record Length, 202
Report configuration, 206
Result, 204
Result details, 207
Result statistics, 207
Result summary, 206

Select, 202
View waveform, 204
Source Inter-Pair Skew
Configure, 229
Connect, 231
Input, 230
Reference levels, 230
Report configuration, 232
Result, 231
Result details, 232
Select, 229
Thit, 230
View waveform, 231
Source Intra-Pair Skew
Configure, 239
Connect, 240
Horiz/acq, 239
Input, 239
Report configuration, 241
Result, 240
Result details, 241
Select, 238
Thit, 240
View waveform, 240
Source Test, 355
Spec Range, 49
Status bar, 24
Std Dev, 50
Supported Oscilloscopes, 7
Supported Probes, 7
Supported Test Fixtures, 7

T

Thit, 318
Calculate, 325
Duty Cycle, 41
TekVISA, 9
Test
3D Video, 302
4Kx2K Video, 308
Audio Clock
Regeneration, 273
Audio Formats, 284
Audio Sample Packet
Jitter, 279
Cable Eye Diagram, 327

Cable Inter-Pair Skew, 339

Clock Jitter, 221
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Deep Color, 268

Differential Tests Select
All, 234

Duty Cycle, 208

DVI Interoperability, 296

Extended Colors and
Contents, 313

Fall Time, 216

Jitter Tolerance, 256

Low Amplitude +, 242

Low Amplitude -, 245

Min/Max-Diff Swing
Tolerance, 248

One Bit Audio, 290

Rise Time, 212

Sink Intra-Pair Skew, 319

Source Eye Diagram, 202

Source Inter-Pair Skew, 228

Source Intra-Pair Skew, 238

Test Conn, 319
Test Methods

3D Video, 307

4Kx2K Video, 313

Audio Clock
Regeneration, 278

Audio Formats, 289

Audio Sample Packet
Jitter, 283

Cable Eye Diagram, 337

Clock lJitter, 228

Deep Color, 272

Duty Cycle, 211

DVI Interoperability, 301

Extended Colors and
Contents, 318

Fall Time, 220

Jitter Tolerance, 266

Jitter Tolerance for DDS
method, 266

Min/Max-Diff Swing
Tolerance, 254

One Bit Audio, 295

Rise Time, 215

Sink Intra-Pair Skew, 325

Source Eye Diagram, 207

Source Inter-Pair Skew, 232

Source Intra-Pair Skew, 241

Test Name, 49
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Tests menu, 20

U

Utilities menu, 21

vV

View Eye Plot, 355
View litter Plot, 355
View waveform, 20
3D Video, 201
4Kx2K Video, 201
Audio Clock
Regeneration, 200

368

Audio Formats, 200

Audio Sample Packet
Jitter, 200

Clock Jitter, 194

Deep Color, 200

Differential Tests Select
All, 196

Duty Cycle, 191

DVI Interoperability, 201

Extended Colors and
Contents, 201

Eye Diagram (Cable), 201

Eye Diagram (Source), 190

Fall Time, 193

Inter-Pair Skew, 195

Inter-Pair Skew (Cable), 201

Intra-Pair Skew (Sink), 201

Intra-Pair Skew (Source), 197

Jitter Tolerance, 200

Low Amplitude +, 198

Low Amplitude -, 199

Min/Max-Diff Swing
Tolerance, 199

One Bit Audio, 200

Rise Time, 192

View Waveform, 355
Virtual Keyboard, 24
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